]> git.pld-linux.org Git - packages/kodi.git/blob - xbmc.spec
fb6ba416fd91f93f46e782ea5d01c1726798712f
[packages/kodi.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - add and/or fix users/groups permissions
6 #  - split to subpackages?
7 #
8 # Conditional build:
9 %bcond_without  cec     # build without cec support
10 %bcond_without  goom    # build without goom visualisation
11 %bcond_with     hal     # build with HAL
12
13 %define codename Frodo
14
15 Summary:        XBMC is a free and open source media-player and entertainment hub
16 Name:           xbmc
17 Version:        12.3
18 Release:        1
19 License:        GPL v2+ and GPL v3+
20 Group:          Applications/Multimedia
21 Source0:        http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
22 # Source0-md5:  7ae385ebf8e5cfcb917393235e6efbdb
23 Patch0:         ffmpeg2.patch
24 Patch1:         jpeglib-boolean.patch
25 URL:            http://xbmc.org/
26 BuildRequires:  Mesa-libGLU-devel
27 BuildRequires:  OpenGL-devel
28 BuildRequires:  SDL_image-devel
29 BuildRequires:  SDL_mixer-devel
30 BuildRequires:  alsa-lib-devel
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  avahi-devel
34 BuildRequires:  bluez-libs-devel >= 4.99
35 BuildRequires:  boost-devel
36 BuildRequires:  bzip2-devel
37 BuildRequires:  cmake
38 BuildRequires:  curl-devel
39 BuildRequires:  dbus-devel
40 BuildRequires:  ffmpeg-devel
41 BuildRequires:  flac-devel
42 BuildRequires:  fontconfig-devel
43 BuildRequires:  freetype-devel
44 BuildRequires:  fribidi-devel
45 BuildRequires:  gawk
46 BuildRequires:  gettext-autopoint
47 BuildRequires:  gettext-devel
48 BuildRequires:  glew-devel
49 BuildRequires:  gperf
50 %{?with_hal:BuildRequires:      hal-devel}
51 BuildRequires:  jasper-devel
52 BuildRequires:  jre
53 BuildRequires:  libass-devel
54 BuildRequires:  libbluray-devel >= 0.2.1
55 BuildRequires:  libcap-devel
56 BuildRequires:  libcdio-devel
57 %{?with_cec:BuildRequires:      libcec-devel}
58 %ifarch i686 pentium4 athlon %{x8664}
59 BuildRequires:  libcrystalhd-devel
60 %endif
61 BuildRequires:  libgcrypt-devel
62 BuildRequires:  libjpeg-devel
63 BuildRequires:  libltdl-devel
64 BuildRequires:  libmad-devel
65 BuildRequires:  libmicrohttpd-devel
66 BuildRequires:  libmodplug-devel
67 BuildRequires:  libmpeg2-devel
68 BuildRequires:  libogg-devel
69 BuildRequires:  libplist-devel
70 BuildRequires:  libpng-devel
71 BuildRequires:  librtmp-devel
72 BuildRequires:  libsamplerate-devel
73 BuildRequires:  libsmbclient-devel
74 BuildRequires:  libssh-devel
75 BuildRequires:  libtiff-devel
76 BuildRequires:  libtool
77 BuildRequires:  libva-devel
78 BuildRequires:  libva-glx-devel
79 BuildRequires:  libvdpau-devel
80 BuildRequires:  libvorbis-devel
81 BuildRequires:  lzo-devel
82 BuildRequires:  mysql-devel
83 %ifarch %{ix86}
84 BuildRequires:  nasm
85 %endif
86 BuildRequires:  openssl-devel
87 BuildRequires:  pcre-cxx-devel
88 BuildRequires:  pkgconfig
89 BuildRequires:  pulseaudio-devel
90 BuildRequires:  python-devel >= 2.4
91 BuildRequires:  rpm-pythonprov
92 BuildRequires:  rpmbuild(macros) >= 1.566
93 # used internally
94 BuildRequires:  sed >= 4.0
95 BuildRequires:  sqlite3-devel
96 BuildRequires:  swig
97 BuildRequires:  taglib-devel >= 1.8
98 BuildRequires:  tinyxml-devel
99 BuildRequires:  udev-devel
100 BuildRequires:  unzip
101 BuildRequires:  xorg-lib-libX11-devel
102 BuildRequires:  xorg-lib-libXext-devel
103 BuildRequires:  xorg-lib-libXinerama-devel
104 BuildRequires:  xorg-lib-libXmu-devel
105 BuildRequires:  xorg-lib-libXrandr-devel
106 BuildRequires:  xorg-lib-libXt-devel
107 BuildRequires:  xorg-lib-libXtst-devel
108 BuildRequires:  yajl-devel
109 BuildRequires:  zip
110 BuildRequires:  zlib-devel
111 #https://github.com/sahlberg/libnfs
112 #BuildRequires: libnfs-devel
113 #http://sites.google.com/site/alexthepuffin/home
114 #BuildRequires: afpfs-ng-devel
115 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
116 #https://github.com/albertz/shairport
117 #BuildRequires: libshairport
118 Requires:       /usr/bin/glxinfo
119 Requires:       SDL >= 1.2.14-5
120 Requires:       lsb-release
121 Requires:       xorg-app-xdpyinfo
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %description
125 XBMC media center is a free cross-platform media-player jukebox and
126 entertainment hub. XBMC can play a spectrum of of multimedia formats,
127 and featuring playlist, audio visualizations, slideshow, and weather
128 forecast functions, together third-party plugins.
129
130 %prep
131 %setup -q -n %{name}-%{version}-%{codename}
132 %patch0 -p1
133 %patch1 -p1
134
135 %build
136 ./bootstrap
137 %configure \
138         --disable-debug \
139         --enable-external-libraries \
140         --enable-pulse \
141         --enable-udev \
142         --disable-libusb \
143         --disable-nfs \
144         --disable-afpclient \
145         --disable-airtunes \
146         %{__enable_disable goom} \
147         %{__enable_disable hal} \
148         %{__enable_disable libcec}
149
150 LIBS="-lpthread"
151 %{__make} V=1
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %files
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/*
164 %{_datadir}/%{name}
165 %attr(755,root,root) %{_libdir}/%{name}
166 %{_docdir}/%{name}
167 %{_desktopdir}/%{name}.desktop
168 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
169 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
170 %{_datadir}/xsessions/XBMC.desktop
This page took 0.070983 seconds and 3 git commands to generate.