]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
6edd8ac7bf8fcb305a2597ef9fbdb39f89cec0ba
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - add and/or fix users/groups permissions
6 #  - split to subpackages?
7 #
8 # Conditional build:
9 %bcond_without  cec     # build without cec support
10 %bcond_without  goom    # build without goom visualisation
11 %bcond_with     hal     # build with HAL
12
13 %define codename Frodo
14
15 Summary:        XBMC is a free and open source media-player and entertainment hub
16 Name:           xbmc
17 Version:        12.3
18 Release:        1
19 License:        GPL v2+ and GPL v3+
20 Group:          Applications/Multimedia
21 Source0:        http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
22 # Source0-md5:  7ae385ebf8e5cfcb917393235e6efbdb
23 Patch0:         ffmpeg2.patch
24 Patch1:         jpeglib-boolean.patch
25 Patch2:         %{name}-vdpau.patch
26 URL:            http://xbmc.org/
27 BuildRequires:  Mesa-libGLU-devel
28 BuildRequires:  OpenGL-devel
29 BuildRequires:  SDL_image-devel
30 BuildRequires:  SDL_mixer-devel
31 BuildRequires:  alsa-lib-devel
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  avahi-devel
35 BuildRequires:  bluez-libs-devel >= 4.99
36 BuildRequires:  boost-devel
37 BuildRequires:  bzip2-devel
38 BuildRequires:  cmake
39 BuildRequires:  curl-devel
40 BuildRequires:  dbus-devel
41 BuildRequires:  ffmpeg-devel
42 BuildRequires:  flac-devel
43 BuildRequires:  fontconfig-devel
44 BuildRequires:  freetype-devel
45 BuildRequires:  fribidi-devel
46 BuildRequires:  gawk
47 BuildRequires:  gettext-autopoint
48 BuildRequires:  gettext-devel
49 BuildRequires:  glew-devel
50 BuildRequires:  gperf
51 %{?with_hal:BuildRequires:      hal-devel}
52 BuildRequires:  jasper-devel
53 BuildRequires:  jre
54 BuildRequires:  libass-devel
55 BuildRequires:  libbluray-devel >= 0.2.1
56 BuildRequires:  libcap-devel
57 BuildRequires:  libcdio-devel
58 %{?with_cec:BuildRequires:      libcec-devel}
59 %ifarch i686 pentium4 athlon %{x8664}
60 BuildRequires:  libcrystalhd-devel
61 %endif
62 BuildRequires:  libgcrypt-devel
63 BuildRequires:  libjpeg-devel
64 BuildRequires:  libltdl-devel
65 BuildRequires:  libmad-devel
66 BuildRequires:  libmicrohttpd-devel
67 BuildRequires:  libmodplug-devel
68 BuildRequires:  libmpeg2-devel
69 BuildRequires:  libogg-devel
70 BuildRequires:  libplist-devel
71 BuildRequires:  libpng-devel
72 BuildRequires:  librtmp-devel
73 BuildRequires:  libsamplerate-devel
74 BuildRequires:  libsmbclient-devel
75 BuildRequires:  libssh-devel
76 BuildRequires:  libtiff-devel
77 BuildRequires:  libtool
78 BuildRequires:  libva-devel
79 BuildRequires:  libva-glx-devel
80 BuildRequires:  libvdpau-devel
81 BuildRequires:  libvorbis-devel
82 BuildRequires:  lzo-devel
83 BuildRequires:  mysql-devel
84 %ifarch %{ix86}
85 BuildRequires:  nasm
86 %endif
87 BuildRequires:  openssl-devel
88 BuildRequires:  pcre-cxx-devel
89 BuildRequires:  pkgconfig
90 BuildRequires:  pulseaudio-devel
91 BuildRequires:  python-devel >= 2.4
92 BuildRequires:  rpm-pythonprov
93 BuildRequires:  rpmbuild(macros) >= 1.566
94 # used internally
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  sqlite3-devel
97 BuildRequires:  swig
98 BuildRequires:  taglib-devel >= 1.8
99 BuildRequires:  tinyxml-devel
100 BuildRequires:  udev-devel
101 BuildRequires:  unzip
102 BuildRequires:  xorg-lib-libX11-devel
103 BuildRequires:  xorg-lib-libXext-devel
104 BuildRequires:  xorg-lib-libXinerama-devel
105 BuildRequires:  xorg-lib-libXmu-devel
106 BuildRequires:  xorg-lib-libXrandr-devel
107 BuildRequires:  xorg-lib-libXt-devel
108 BuildRequires:  xorg-lib-libXtst-devel
109 BuildRequires:  yajl-devel
110 BuildRequires:  zip
111 BuildRequires:  zlib-devel
112 #https://github.com/sahlberg/libnfs
113 #BuildRequires: libnfs-devel
114 #http://sites.google.com/site/alexthepuffin/home
115 #BuildRequires: afpfs-ng-devel
116 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
117 #https://github.com/albertz/shairport
118 #BuildRequires: libshairport
119 Requires:       /usr/bin/glxinfo
120 Requires:       SDL >= 1.2.14-5
121 Requires:       lsb-release
122 Requires:       xorg-app-xdpyinfo
123 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125 %description
126 XBMC media center is a free cross-platform media-player jukebox and
127 entertainment hub. XBMC can play a spectrum of of multimedia formats,
128 and featuring playlist, audio visualizations, slideshow, and weather
129 forecast functions, together third-party plugins.
130
131 %prep
132 %setup -q -n %{name}-%{version}-%{codename}
133 %patch0 -p1
134 %patch1 -p1
135 %patch2 -p1
136
137 %build
138 ./bootstrap
139 %configure \
140         --disable-debug \
141         --enable-external-libraries \
142         --enable-pulse \
143         --enable-udev \
144         --disable-libusb \
145         --disable-nfs \
146         --disable-afpclient \
147         --disable-airtunes \
148         %{__enable_disable goom} \
149         %{__enable_disable hal} \
150         %{__enable_disable libcec}
151
152 LIBS="-lpthread"
153 %{__make} V=1
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 %{__make} install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %files
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/*
166 %{_datadir}/%{name}
167 %attr(755,root,root) %{_libdir}/%{name}
168 %{_docdir}/%{name}
169 %{_desktopdir}/%{name}.desktop
170 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
171 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
172 %{_datadir}/xsessions/XBMC.desktop
This page took 0.091112 seconds and 3 git commands to generate.