]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
1a5222a85add353aebabb4e215548de945f949bb
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6 #    only libXrandr 1.1 - with no gamma support; it causes application crash
7 #    on XRRSetCrtcGamma function called by SDL_SetVideoMode)
8 #  - add and/or fix users/groups permissions
9 #  - split to subpackages?
10 #  - check how it works with external python libraries
11 #
12 # Conditional build:
13 %bcond_with     external_python
14
15 Summary:        XBMC
16 Name:           xbmc
17 Version:        10.0
18 Release:        0.1
19 License:        GPL v3
20 Group:          Applications/Multimedia
21 Source0:        http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
22 # Source0-md5:  728fb514e5f43f27bb880305061b4e72
23 URL:            http://xbmc.org
24 Patch0:         %{name}-nobash.patch
25 Patch1:         %{name}-python27.patch
26 Patch2:         %{name}-libpng14.patch
27 BuildRequires:  SDL_image-devel
28 BuildRequires:  SDL_mixer-devel
29 BuildRequires:  a52dec-libs-devel
30 BuildRequires:  alsa-lib-devel
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  avahi-devel
34 BuildRequires:  boost-devel
35 BuildRequires:  bzip2-devel
36 BuildRequires:  cmake
37 BuildRequires:  curl-devel
38 BuildRequires:  dbus-devel
39 BuildRequires:  enca
40 BuildRequires:  enca-devel
41 BuildRequires:  faac-devel
42 BuildRequires:  faad2-devel
43 BuildRequires:  ffmpeg-devel
44 BuildRequires:  flac-devel
45 BuildRequires:  fontconfig-devel
46 BuildRequires:  freetype-devel
47 BuildRequires:  fribidi-devel
48 BuildRequires:  gawk
49 BuildRequires:  gettext-autopoint
50 BuildRequires:  gettext-devel
51 BuildRequires:  glew-devel
52 BuildRequires:  gperf
53 BuildRequires:  gtk+-devel
54 BuildRequires:  hal-devel
55 BuildRequires:  jasper-devel
56 BuildRequires:  libao-devel
57 BuildRequires:  libcdio-devel
58 BuildRequires:  libdts-devel
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libmad-devel
61 BuildRequires:  libmicrohttpd-devel
62 BuildRequires:  libmms-devel
63 BuildRequires:  libmodplug-devel
64 BuildRequires:  libmpeg2-devel
65 BuildRequires:  libogg-devel
66 BuildRequires:  libpng-devel
67 BuildRequires:  libsamplerate-devel
68 BuildRequires:  libsmbclient-devel
69 BuildRequires:  libtiff-devel
70 BuildRequires:  libtool
71 BuildRequires:  libvdpau-devel
72 BuildRequires:  libvorbis-devel
73 BuildRequires:  lzo-devel
74 BuildRequires:  mysql-devel
75 %ifarch %{ix86}
76 BuildRequires:  nasm
77 %endif
78 BuildRequires:  openssl-devel
79 BuildRequires:  pcre-cxx-devel
80 BuildRequires:  pkgconfig
81 BuildRequires:  pulseaudio-devel
82 BuildRequires:  python-devel
83 BuildRequires:  rpm-pythonprov
84 # used internally
85 BuildRequires:  sed >= 4.0
86 BuildRequires:  sqlite3-devel
87 BuildRequires:  unzip
88 BuildRequires:  wavpack-devel
89 BuildRequires:  xmms-devel
90 BuildRequires:  xorg-lib-libXinerama-devel
91 BuildRequires:  xorg-lib-libXrandr-devel
92 BuildRequires:  xorg-lib-libXtst-devel
93 BuildRequires:  zip
94 BuildRequires:  zlib-devel
95 Requires:       /usr/bin/glxinfo
96 Requires:       lsb-release
97 Requires:       xorg-app-xdpyinfo
98 Conflicts:      xorg-driver-video-nvidia <= 260.19.29
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %description
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 enca -L none -x ISO8859-1 xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
107 %patch1 -p1
108 #%patch2 -p1
109
110 %build
111 ./bootstrap
112 %configure \
113         --disable-debug \
114         --enable-external-libraries \
115         --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 #doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
130
131 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
132 %attr(755,root,root) %{_bindir}/*
133 %{_datadir}/%{name}
134 %attr(755,root,root) %{_libdir}/%{name}
135 %{_docdir}/%{name}
136 %{_desktopdir}/%{name}.desktop
137 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
138 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
139 %{_datadir}/xsessions/XBMC.desktop
This page took 0.069229 seconds and 3 git commands to generate.