]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- added pangox patch (needed for gtk+ 2.8.x compatibility); release 2
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8
9 Summary:        wxWidgets library
10 Summary(pl):    Biblioteka wxWidgets
11 Name:           wxWidgets
12 Version:        2.6.1
13 Release:        2
14 License:        wxWidgets Licence (LGPL with exception)
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}.tar.bz2
17 # Source0-md5:  045f0edad0988620a4aa36096bb16e28
18 Patch0:         %{name}-samples.patch
19 Patch1:         %{name}-ogl.patch
20 Patch2:         %{name}-ac.patch
21 Patch3:         %{name}-gif0delay.patch
22 Patch4:         %{name}-pangox.patch
23 URL:            http://www.wxWidgets.org/
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  SDL-devel
26 BuildRequires:  autoconf >= 2.58
27 BuildRequires:  automake
28 BuildRequires:  bakefile >= 0.1.8
29 BuildRequires:  cppunit-devel
30 BuildRequires:  esound-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  flex
33 BuildRequires:  gettext-devel
34 BuildRequires:  gtk+2-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libmng-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtiff-devel
40 BuildRequires:  libtool
41 BuildRequires:  pkgconfig
42 # these are not supported by wxWidgets
43 Obsoletes:      LDAPExplorerTool <= 0.6-1
44 Obsoletes:      abridge <= 0.4.0-1
45 # and these are replaced
46 Obsoletes:      wxGTK
47 Obsoletes:      wxGTK-devel
48 Obsoletes:      wxGTK-gl
49 Obsoletes:      wxGTK-gl-devel
50 Obsoletes:      wxGTK-univ
51 Obsoletes:      wxGTK-univ-devel
52 Obsoletes:      wxGTK-univ-gl
53 Obsoletes:      wxGTK-univ-gl-devel
54 Obsoletes:      wxGTK2-univ
55 Obsoletes:      wxGTK2-univ-devel
56 Obsoletes:      wxGTK2-univ-gl
57 Obsoletes:      wxGTK2-univ-gl-devel
58 Obsoletes:      wxGTK2-univ-unicode
59 Obsoletes:      wxGTK2-univ-unicode-devel
60 Obsoletes:      wxGTK2-univ-unicode-gl
61 Obsoletes:      wxGTK2-univ-unicode-gl-devel
62 Obsoletes:      wxMotif
63 Obsoletes:      wxMotif-devel
64 Obsoletes:      wxMotif-gl
65 Obsoletes:      wxMotif-gl-devel
66 Obsoletes:      wxWidgets-afm
67 Obsoletes:      wxWindows
68 Obsoletes:      wxWindows-afm
69 Obsoletes:      wxwin-afm
70 Obsoletes:      wxwin-common
71 Conflicts:      wxGTK2 < 2.6.0
72 Conflicts:      wxGTK2-unicode < 2.6.0
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     %{_datadir}
76
77 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
78
79 %description
80 wxWidgets is a free C++ library for cross-platform GUI development.
81 With wxWidgets, you can create applications for different GUIs (GTK+,
82 Motif/LessTif, MS Windows, Mac) from the same source code.
83
84 %description -l pl
85 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
86 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
87 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
88 Windows, Mac) z tego samego kodu ¼ród³owego.
89
90 %package devel
91 Summary:        wxWidgets header files and development documentation
92 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
93 Group:          X11/Development/Libraries
94 Requires:       libstdc++-devel
95 Obsoletes:      wxWindows-devel
96
97 %description devel
98 Header files and development documentation for the wxWidgets
99 libraries.
100
101 %description devel -l pl
102 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
103
104 %package examples
105 Summary:        wxWidgets example programs
106 Summary(pl):    Przyk³adowe programy wxWidgets
107 Group:          X11/Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109 Obsoletes:      wxWindows-examples
110
111 %description examples
112 wxWidgets example programs.
113
114 %description examples -l pl
115 Przyk³adowe programy wxWidgets.
116
117 %package HelpGen
118 Summary:        Help file generator for wxWidgets programs
119 Summary(pl):    Generator plików pomocy dla programów wxWidgets
120 Group:          Development/Tools
121 Requires:       wxBase = %{version}-%{release}
122 Obsoletes:      wxWindows-HelpGen
123
124 %description HelpGen
125 Help file generator for wxWidgets programs.
126
127 %description HelpGen -l pl
128 Generator plików pomocy dla programów wxWidgets.
129
130 %package -n wxBase
131 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
132 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
133 Group:          X11/Libraries
134 Requires:       %{name} = %{version}-%{release}
135
136 %description -n wxBase
137 wxBase is a collection of C++ classes providing basic data structures
138 (strings, lists, arrays), powerful wxDateTime class for date
139 manipulations, portable wrappers around many OS-specific functions
140 allowing to build the same program under all supported folders,
141 wxThread class for writing multithreaded programs using either Win32
142 or POSIX threads and much more. wxBase currently supports the
143 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
144 HP-UX, ...) and BeOS.
145
146 %description -n wxBase -l pl
147 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
148 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
149 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
150 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
151 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
152 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
153 platformy: Win32, Unix i BeOS.
154
155 %package -n wxBase-devel
156 Summary:        wxBase headers needed for developping with wxBase
157 Summary(pl):    Pliki nag³ówkowe do wxBase
158 Group:          X11/Development/Libraries
159 Requires:       %{name}-devel = %{version}-%{release}
160 Requires:       wxBase = %{version}-%{release}
161
162 %description -n wxBase-devel
163 Header files for wxBase. You need them to develop programs using
164 wxBase.
165
166 %description -n wxBase-devel -l pl
167 Pliki nag³ówkowe do biblioteki wxBase.
168
169 %package -n wxBase-unicode
170 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
171 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
172 Group:          X11/Libraries
173 Requires:       %{name} = %{version}-%{release}
174
175 %description -n wxBase-unicode
176 wxBase is a collection of C++ classes providing basic data structures
177 (strings, lists, arrays), powerful wxDateTime class for date
178 manipulations, portable wrappers around many OS-specific functions
179 allowing to build the same program under all supported folders,
180 wxThread class for writing multithreaded programs using either Win32
181 or POSIX threads and much more. wxBase currently supports the
182 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
183 HP-UX, ...) and BeOS. This version is build with UNICODE support.
184
185 %description -n wxBase-unicode -l pl
186 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
187 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
188 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
189 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
190 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
191 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
192 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
193 UNICODE.
194
195 %package -n wxBase-unicode-devel
196 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
197 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
198 Group:          X11/Development/Libraries
199 Requires:       %{name}-devel = %{version}-%{release}
200 Requires:       wxBase-unicode = %{version}-%{release}
201
202 %description -n wxBase-unicode-devel
203 Header files for wxBase. You need them to develop programs using
204 UNICODE-enabled wxBase.
205
206 %description -n wxBase-unicode-devel -l pl
207 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
208
209 %package -n wxGTK2
210 Summary:        wxGTK2 library
211 Summary(pl):    Biblioteka wxGTK2
212 Group:          X11/Libraries
213 Requires:       %{name} = %{version}-%{release}
214 Obsoletes:      wxGTK2-univ
215
216 %description -n wxGTK2
217 wxWidgets library using GTK2 widgets.
218
219 %description -n wxGTK2 -l pl
220 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
221
222 %package -n wxGTK2-devel
223 Summary:        Header files for wxGTK2 library
224 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
225 Group:          X11/Development/Libraries
226 Requires:       wxBase-devel = %{version}-%{release}
227 Requires:       wxGTK2 = %{version}-%{release}
228 Obsoletes:      wxGTK2-univ-devel
229
230 %description -n wxGTK2-devel
231 Header files for wxWidgets library using GTK2 widgets.
232
233 %description -n wxGTK2-devel -l pl
234 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
235
236 %package -n wxGTK2-gl
237 Summary:        GL canvas library for wxGTK2
238 Summary(pl):    Biblioteka GL dla wxGTK2
239 Group:          X11/Libraries
240 Requires:       wxGTK2 = %{version}-%{release}
241 Requires:       OpenGL
242 Obsoletes:      wxGTK2-univ-gl
243
244 %description -n wxGTK2-gl
245 wxGTK2 GL canvas library.
246
247 %description -n wxGTK2-gl -l pl
248 Biblioteka GL dla wxGTK2.
249
250 %package -n wxGTK2-gl-devel
251 Summary:        Development files for GL canvas library for wxGTK2
252 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
253 Group:          X11/Development/Libraries
254 Requires:       wxGTK2-devel = %{version}-%{release}
255 Requires:       wxGTK2-gl = %{version}-%{release}
256 Requires:       OpenGL-devel
257 Obsoletes:      wxGTK2-univ-gl-devel
258
259 %description -n wxGTK2-gl-devel
260 Development files for wxGTK2 GL canvas library.
261
262 %description -n wxGTK2-gl-devel -l pl
263 Pliki programistyczne biblioteki GL dla wxGTK2.
264
265 %package -n wxGTK2-unicode
266 Summary:        wxGTK2 library with UNICODE support
267 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
268 Group:          X11/Libraries
269 Requires:       %{name} = %{version}-%{release}
270 Obsoletes:      wxGTK2-univ-unicode
271
272 %description -n wxGTK2-unicode
273 wxWidgets library using GTK2 widgets with UNICODE support.
274
275 %description -n wxGTK2-unicode -l pl
276 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
277
278 %package -n wxGTK2-unicode-devel
279 Summary:        Header files for wxGTK2 library with UNICODE support
280 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
281 Group:          X11/Development/Libraries
282 Requires:       wxBase-unicode-devel = %{version}-%{release}
283 Requires:       wxGTK2-unicode = %{version}-%{release}
284 Obsoletes:      wxGTK2-univ-unicode-devel
285
286 %description -n wxGTK2-unicode-devel
287 Header files for wxWidgets library using GTK2 widgets with UNICODE
288 support.
289
290 %description -n wxGTK2-unicode-devel -l pl
291 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
292 obs³ug± UNICODE.
293
294 %package -n wxGTK2-unicode-gl
295 Summary:        GL canvas library for wxGTK2 with UNICODE support
296 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
297 Group:          X11/Libraries
298 Requires:       wxGTK2-unicode = %{version}-%{release}
299 Requires:       OpenGL
300 Obsoletes:      wxGTK2-univ-unicode-gl
301
302 %description -n wxGTK2-unicode-gl
303 GL canvas library for wxGTK2 with UNICODE support.
304
305 %description -n wxGTK2-unicode-gl -l pl
306 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
307
308 %package -n wxGTK2-unicode-gl-devel
309 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
310 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
311 Group:          X11/Development/Libraries
312 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
313 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
314 Requires:       OpenGL-devel
315 Obsoletes:      wxGTK2-univ-unicode-gl-devel
316
317 %description -n wxGTK2-unicode-gl-devel
318 Development files for GL canvas library for wxGTK2 with UNICODE
319 support.
320
321 %description -n wxGTK2-unicode-gl-devel -l pl
322 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
323
324 %package utils
325 Summary:        Misc utils from wxWidgets project
326 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
327 Group:          X11/Development/Tools
328 Requires:       wxX11 = %{version}-%{release}
329 Obsoletes:      wxWindows-utils
330
331 %description utils
332 Misc utils from wxWidgets project: helpviewer, makegen, etc.
333
334 %description utils -l pl
335 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
336
337 %package -n wxX11
338 Summary:        wxUniversal-based wxX11 library
339 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
340 Group:          X11/Libraries
341 Requires:       %{name} = %{version}-%{release}
342 Obsoletes:      wxX11-univ
343
344 %description -n wxX11
345 wxUniversal-based wxX11 library.
346
347 %description -n wxX11 -l pl
348 Oparta na wxUniversal biblioteka wxX11.
349
350 %package -n wxX11-devel
351 Summary:        Header files for wxUniversal-based wxX11 library
352 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
353 Group:          X11/Libraries
354 Requires:       %{name}-devel = %{version}-%{release}
355 Requires:       wxX11 = %{version}-%{release}
356 Obsoletes:      wxX11-univ-devel
357
358 %description -n wxX11-devel
359 Header files for wxUniversal-based wxX11 library.
360
361 %description -n wxX11-devel -l pl
362 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
363
364 %package -n wxX11-gl
365 Summary:        GL canvas library for wxUniversal-based wxX11
366 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
367 Group:          X11/Libraries
368 Requires:       wxX11 = %{version}-%{release}
369 Requires:       OpenGL
370 Obsoletes:      wxX11-univ-gl
371
372 %description -n wxX11-gl
373 GL canvas library for wxUniversal-based wxX11.
374
375 %description -n wxX11-gl -l pl
376 Biblioteka GL dla opartej na wxUniversal wxX11.
377
378 %package -n wxX11-gl-devel
379 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
380 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
381 Group:          X11/Development/Libraries
382 Requires:       wxX11-gl = %{version}-%{release}
383 Requires:       wxX11-devel = %{version}-%{release}
384 Requires:       OpenGL-devel
385 Obsoletes:      wxX11-univ-gl-devel
386
387 %description -n wxX11-gl-devel
388 Development files for GL canvas library for wxUniversal-based wxX11.
389
390 %description -n wxX11-gl-devel -l pl
391 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
392
393 %package -n wxX11-unicode
394 Summary:        wxUniversal-based wxX11 library with UNICODE support
395 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
396 Group:          X11/Libraries
397 Requires:       %{name} = %{version}-%{release}
398 Obsoletes:      wxX11-univ-unicode
399
400 %description -n wxX11-unicode
401 wxUniversal-based wxX11 library with UNICODE support.
402
403 %description -n wxX11-unicode -l pl
404 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
405
406 %package -n wxX11-unicode-devel
407 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
408 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
409 Group:          X11/Development/Libraries
410 Requires:       %{name}-devel = %{version}-%{release}
411 Requires:       wxX11-unicode = %{version}-%{release}
412 Obsoletes:      wxX11-univ-unicode-devel
413
414 %description -n wxX11-unicode-devel
415 Header files for wxUniversal-based wxX11 library with UNICODE support.
416
417 %description -n wxX11-unicode-devel -l pl
418 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
419
420 %package -n wxX11-unicode-gl
421 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
422 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
423 Group:          X11/Libraries
424 Requires:       wxX11-unicode = %{version}-%{release}
425 Requires:       OpenGL
426 Obsoletes:      wxX11-univ-unicode-gl
427
428 %description -n wxX11-unicode-gl
429 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
430
431 %description -n wxX11-unicode-gl -l pl
432 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
433
434 %package -n wxX11-unicode-gl-devel
435 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
436 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
437 Group:          X11/Development/Libraries
438 Requires:       wxX11-unicode-gl = %{version}-%{release}
439 Requires:       wxX11-unicode-devel = %{version}-%{release}
440 Requires:       OpenGL-devel
441 Obsoletes:      wxX11-univ-unicode-gl-devel
442
443 %description -n wxX11-unicode-gl-devel
444 Development files for GL canvas library for wxUniversal-based wxX11
445 with UNICODE support.
446
447 %description -n wxX11-unicode-gl-devel -l pl
448 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
449 obs³ug± UNICODE.
450
451 %prep
452 %setup -q
453 %patch0 -p1
454 %patch1 -p1
455 %patch2 -p1
456 %patch3 -p1
457 %patch4 -p1
458
459 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
460
461 # bakefile.m4 from 0.1.8
462 tail -n +1518 aclocal.m4 | head -n 1397 > bakefile.m4
463 # AC_BAKEFILE_PROG_* macros
464 tail -n +721 aclocal.m4 | head -n 142 >> bakefile.m4
465
466 %build
467 # if bakefiles rebuild is needed:
468 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.8"
469 #cd build/bakefiles
470 #bakefile_gen -f autoconf
471 #cd ../..
472 #%endif
473 cp -f /usr/share/automake/config.sub .
474 %{__aclocal} -I .
475 %{__autoconf}
476
477 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
478 # avoid adding -s to LDFLAGS
479 LDFLAGS=" "; export LDFLAGS
480 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
481         --enable-plugins \
482         --enable-std_iostreams \
483         --without-sdl \
484         --with-opengl \
485         --enable-calendar \
486         --enable-controls \
487         --enable-tabdialog"
488
489 gui='--with-gtk'
490 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
491         '--enable-unicode' ; do
492         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
493         mkdir $objdir
494         cd $objdir
495         ../%configure \
496                 ${args} \
497                 ${gui} \
498                 --disable-universal \
499                 ${unicode}
500         %{__make}
501         %{__make} -C contrib/src
502         cd ..
503 done
504
505 %if %{with x11}
506 gui='--with-x11'
507 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
508         '--enable-unicode' ; do
509         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
510         mkdir $objdir
511         cd $objdir
512         ../%configure \
513                 ${args} \
514                 ${gui} \
515                 --enable-universal \
516                 ${unicode}
517         %{__make}
518         %{__make} -C contrib/src
519         if echo $objdir| grep -q disable-unicode ; then
520                 %{__make} -C utils
521                 %{__make} -C utils/emulator
522                 %{__make} -C utils/hhp2cached
523                 %{__make} -C contrib/utils
524         fi
525         cd ..
526 done
527 %endif
528
529 cd locale
530 %{__make} allmo
531
532 %install
533 rm -rf $RPM_BUILD_ROOT
534 install -d $RPM_BUILD_ROOT%{_bindir}
535
536 gui='--with-gtk'
537 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
538         '--enable-unicode' ; do
539         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
540         cd $objdir
541         %{__make} install \
542                 prefix=$RPM_BUILD_ROOT%{_prefix} \
543                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
544                 bindir=$RPM_BUILD_ROOT%{_bindir} \
545                 datadir=$RPM_BUILD_ROOT%{_datadir} \
546                 libdir=$RPM_BUILD_ROOT%{_libdir} \
547                 mandir=$RPM_BUILD_ROOT%{_mandir} \
548                 includedir=$RPM_BUILD_ROOT%{_includedir}
549
550         %{__make} -C contrib/src install \
551                 prefix=$RPM_BUILD_ROOT%{_prefix} \
552                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
553                 bindir=$RPM_BUILD_ROOT%{_bindir} \
554                 datadir=$RPM_BUILD_ROOT%{_datadir} \
555                 libdir=$RPM_BUILD_ROOT%{_libdir} \
556                 mandir=$RPM_BUILD_ROOT%{_mandir} \
557                 includedir=$RPM_BUILD_ROOT%{_includedir}
558         cd ..
559 done
560
561 %if %{with x11}
562 gui='--with-x11'
563 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
564         '--enable-unicode' ; do
565         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
566         cd $objdir
567         %{__make} install \
568                 prefix=$RPM_BUILD_ROOT%{_prefix} \
569                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
570                 bindir=$RPM_BUILD_ROOT%{_bindir} \
571                 datadir=$RPM_BUILD_ROOT%{_datadir} \
572                 libdir=$RPM_BUILD_ROOT%{_libdir} \
573                 mandir=$RPM_BUILD_ROOT%{_mandir} \
574                 includedir=$RPM_BUILD_ROOT%{_includedir}
575         if echo $objdir| grep -q disable-unicode ; then
576 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
577                 # TODO: install default config files and default backgrouds
578                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
579                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
580                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
581                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
582 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
583                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
584 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
585 #               install -m644 utils/makegen/templates/* \
586 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
587 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
588 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
589 #               install contrib/utils/wxrcedit/df/* \
590 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
591         fi
592
593         %{__make} -C contrib/src install \
594                 prefix=$RPM_BUILD_ROOT%{_prefix} \
595                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
596                 bindir=$RPM_BUILD_ROOT%{_bindir} \
597                 datadir=$RPM_BUILD_ROOT%{_datadir} \
598                 libdir=$RPM_BUILD_ROOT%{_libdir} \
599                 mandir=$RPM_BUILD_ROOT%{_mandir} \
600                 includedir=$RPM_BUILD_ROOT%{_includedir}
601
602         cd ..
603 done
604 %endif
605
606 set -x
607
608 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
609 do
610         b=`basename $i`
611         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
612 done
613
614 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
615 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
616 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
617
618 %find_lang wxstd
619
620 %clean
621 rm -rf $RPM_BUILD_ROOT
622
623 %post   -n wxBase -p /sbin/ldconfig
624 %postun -n wxBase -p /sbin/ldconfig
625
626 %post   -n wxBase-unicode -p /sbin/ldconfig
627 %postun -n wxBase-unicode -p /sbin/ldconfig
628
629 %post   -n wxGTK2 -p /sbin/ldconfig
630 %postun -n wxGTK2 -p /sbin/ldconfig
631
632 %post   -n wxGTK2-gl -p /sbin/ldconfig
633 %postun -n wxGTK2-gl -p /sbin/ldconfig
634
635 %post   -n wxGTK2-unicode -p /sbin/ldconfig
636 %postun -n wxGTK2-unicode -p /sbin/ldconfig
637
638 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
639 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
640
641 %post   -n wxX11 -p /sbin/ldconfig
642 %postun -n wxX11 -p /sbin/ldconfig
643
644 %post   -n wxX11-unicode -p /sbin/ldconfig
645 %postun -n wxX11-unicode -p /sbin/ldconfig
646
647 %define _libf %{?with_debug:d}
648 %define _configf %{?with_debug:-debug-2.6}
649
650
651 %files -f wxstd.lang
652 %defattr(644,root,root,755)
653 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
654
655 %files devel
656 %defattr(644,root,root,755)
657 %doc docs/html
658 %doc docs/tech docs/univ
659 %{_includedir}/wx*
660 %dir %{_libdir}/wx
661 %dir %{_libdir}/wx/include
662 %dir %{_libdir}/wx/config
663 %{_aclocaldir}/*.m4
664
665 %files examples
666 %defattr(644,root,root,755)
667 %{_examplesdir}/%{name}-%{version}
668
669 %if %{with x11}
670 %files HelpGen
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_bindir}/HelpGen
673 %endif
674
675 %if %{with ansi}
676 %files -n wxBase
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
679 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
680 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
681
682 %files -n wxBase-devel
683 %defattr(644,root,root,755)
684 %{_libdir}/libwx_base%{_libf}-*.so
685 %{_libdir}/libwx_base%{_libf}_*.so
686 %endif
687
688 %files -n wxBase-unicode
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
691 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
692 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
693
694 %files -n wxBase-unicode-devel
695 %defattr(644,root,root,755)
696 %{_libdir}/libwx_baseu%{_libf}-*.so
697 %{_libdir}/libwx_baseu%{_libf}_*.so
698
699 %if %{with ansi}
700 %files -n wxGTK2
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
703 %exclude %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so.*.*
704
705 %files -n wxGTK2-devel
706 %defattr(644,root,root,755)
707 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
708 %exclude %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so
709 %{_libdir}/wx/config/gtk2-ansi-*
710 %{_libdir}/wx/include/gtk2-ansi-*
711 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
712
713 %files -n wxGTK2-gl
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so.*.*
716
717 %files -n wxGTK2-gl-devel
718 %defattr(644,root,root,755)
719 %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so
720 %endif
721
722 %files -n wxGTK2-unicode
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
725 %exclude %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so.*.*
726
727 %files -n wxGTK2-unicode-devel
728 %defattr(644,root,root,755)
729 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
730 %exclude %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so
731 %{_libdir}/wx/config/gtk2-unicode-*
732 %{_libdir}/wx/include/gtk2-unicode-*
733 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
734
735 %files -n wxGTK2-unicode-gl
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so.*.*
738
739 %files -n wxGTK2-unicode-gl-devel
740 %defattr(644,root,root,755)
741 %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so
742
743 %if %{with x11}
744 %if %{with ansi}
745 %files utils
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_bindir}/*
748 %exclude %{_bindir}/HelpGen
749 %exclude %{_bindir}/wx*-config
750
751 %files -n wxX11
752 %defattr(644,root,root,755)
753 %doc docs/wxX11-readme.txt
754 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
755 %exclude %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so.*.*
756
757 %files -n wxX11-devel
758 %defattr(644,root,root,755)
759 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
760 %exclude %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so
761 %{_libdir}/wx/config/x11univ-ansi-*
762 %{_libdir}/wx/include/x11univ-ansi-*
763 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
764
765 %files -n wxX11-gl
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so.*.*
768
769 %files -n wxX11-gl-devel
770 %defattr(644,root,root,755)
771 %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so
772 %endif
773
774 %files -n wxX11-unicode
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
777 %exclude %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so.*.*
778
779 %files -n wxX11-unicode-devel
780 %defattr(644,root,root,755)
781 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
782 %exclude %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so
783 %{_libdir}/wx/config/x11univ-unicode-*
784 %{_libdir}/wx/include/x11univ-unicode-*
785 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
786
787 %files -n wxX11-unicode-gl
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so.*.*
790
791 %files -n wxX11-unicode-gl-devel
792 %defattr(644,root,root,755)
793 %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so
794 %endif
This page took 0.077559 seconds and 3 git commands to generate.