]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
576e242e8d9dd1a9208630853e70355d12bc0138
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8
9 Summary:        wxWidgets library
10 Summary(pl):    Biblioteka wxWidgets
11 Name:           wxWidgets
12 Version:        2.6.2
13 Release:        1
14 License:        wxWidgets Licence (LGPL with exception)
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}.tar.bz2
17 # Source0-md5:  ee0aa211febd992c8540e6c9df749b51
18 Patch0:         %{name}-samples.patch
19 Patch1:         %{name}-ogl.patch
20 Patch2:         %{name}-ac.patch
21 Patch3:         %{name}-gif0delay.patch
22 Patch4:         %{name}-x11unicode.patch
23 URL:            http://www.wxWidgets.org/
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  SDL-devel
26 BuildRequires:  autoconf >= 2.58
27 BuildRequires:  automake
28 #BuildRequires: bakefile >= 0.1.9
29 BuildRequires:  cppunit-devel
30 BuildRequires:  esound-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  flex
33 BuildRequires:  gettext-devel
34 BuildRequires:  gtk+2-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libmng-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtiff-devel
40 BuildRequires:  libtool
41 BuildRequires:  pkgconfig
42 # these are not supported by wxWidgets
43 Obsoletes:      LDAPExplorerTool <= 0.6-1
44 Obsoletes:      abridge <= 0.4.0-1
45 # and these are replaced
46 Obsoletes:      wxGTK
47 Obsoletes:      wxGTK-devel
48 Obsoletes:      wxGTK-gl
49 Obsoletes:      wxGTK-gl-devel
50 Obsoletes:      wxGTK-univ
51 Obsoletes:      wxGTK-univ-devel
52 Obsoletes:      wxGTK-univ-gl
53 Obsoletes:      wxGTK-univ-gl-devel
54 Obsoletes:      wxGTK2-univ
55 Obsoletes:      wxGTK2-univ-devel
56 Obsoletes:      wxGTK2-univ-gl
57 Obsoletes:      wxGTK2-univ-gl-devel
58 Obsoletes:      wxGTK2-univ-unicode
59 Obsoletes:      wxGTK2-univ-unicode-devel
60 Obsoletes:      wxGTK2-univ-unicode-gl
61 Obsoletes:      wxGTK2-univ-unicode-gl-devel
62 Obsoletes:      wxMotif
63 Obsoletes:      wxMotif-devel
64 Obsoletes:      wxMotif-gl
65 Obsoletes:      wxMotif-gl-devel
66 Obsoletes:      wxWidgets-afm
67 Obsoletes:      wxWindows
68 Obsoletes:      wxWindows-afm
69 Obsoletes:      wxwin-afm
70 Obsoletes:      wxwin-common
71 Conflicts:      wxGTK2 < 2.6.0
72 Conflicts:      wxGTK2-unicode < 2.6.0
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     %{_datadir}
76
77 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
78
79 %description
80 wxWidgets is a free C++ library for cross-platform GUI development.
81 With wxWidgets, you can create applications for different GUIs (GTK+,
82 Motif/LessTif, MS Windows, Mac) from the same source code.
83
84 %description -l pl
85 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
86 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
87 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
88 Windows, Mac) z tego samego kodu ¼ród³owego.
89
90 %package devel
91 Summary:        wxWidgets header files and development documentation
92 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
93 Group:          X11/Development/Libraries
94 Requires:       libstdc++-devel
95 Obsoletes:      wxWindows-devel
96
97 %description devel
98 Header files and development documentation for the wxWidgets
99 libraries.
100
101 %description devel -l pl
102 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
103
104 %package examples
105 Summary:        wxWidgets example programs
106 Summary(pl):    Przyk³adowe programy wxWidgets
107 Group:          X11/Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109 Obsoletes:      wxWindows-examples
110
111 %description examples
112 wxWidgets example programs.
113
114 %description examples -l pl
115 Przyk³adowe programy wxWidgets.
116
117 %package HelpGen
118 Summary:        Help file generator for wxWidgets programs
119 Summary(pl):    Generator plików pomocy dla programów wxWidgets
120 Group:          Development/Tools
121 Requires:       wxBase = %{version}-%{release}
122 Obsoletes:      wxWindows-HelpGen
123
124 %description HelpGen
125 Help file generator for wxWidgets programs.
126
127 %description HelpGen -l pl
128 Generator plików pomocy dla programów wxWidgets.
129
130 %package -n wxBase
131 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
132 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
133 Group:          X11/Libraries
134 Requires:       %{name} = %{version}-%{release}
135
136 %description -n wxBase
137 wxBase is a collection of C++ classes providing basic data structures
138 (strings, lists, arrays), powerful wxDateTime class for date
139 manipulations, portable wrappers around many OS-specific functions
140 allowing to build the same program under all supported folders,
141 wxThread class for writing multithreaded programs using either Win32
142 or POSIX threads and much more. wxBase currently supports the
143 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
144 HP-UX, ...) and BeOS.
145
146 %description -n wxBase -l pl
147 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
148 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
149 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
150 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
151 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
152 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
153 platformy: Win32, Unix i BeOS.
154
155 %package -n wxBase-devel
156 Summary:        wxBase headers needed for developping with wxBase
157 Summary(pl):    Pliki nag³ówkowe do wxBase
158 Group:          X11/Development/Libraries
159 Requires:       %{name}-devel = %{version}-%{release}
160 Requires:       wxBase = %{version}-%{release}
161
162 %description -n wxBase-devel
163 Header files for wxBase. You need them to develop programs using
164 wxBase.
165
166 %description -n wxBase-devel -l pl
167 Pliki nag³ówkowe do biblioteki wxBase.
168
169 %package -n wxBase-unicode
170 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
171 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
172 Group:          X11/Libraries
173 Requires:       %{name} = %{version}-%{release}
174
175 %description -n wxBase-unicode
176 wxBase is a collection of C++ classes providing basic data structures
177 (strings, lists, arrays), powerful wxDateTime class for date
178 manipulations, portable wrappers around many OS-specific functions
179 allowing to build the same program under all supported folders,
180 wxThread class for writing multithreaded programs using either Win32
181 or POSIX threads and much more. wxBase currently supports the
182 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
183 HP-UX, ...) and BeOS. This version is build with UNICODE support.
184
185 %description -n wxBase-unicode -l pl
186 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
187 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
188 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
189 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
190 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
191 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
192 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
193 UNICODE.
194
195 %package -n wxBase-unicode-devel
196 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
197 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
198 Group:          X11/Development/Libraries
199 Requires:       %{name}-devel = %{version}-%{release}
200 Requires:       wxBase-unicode = %{version}-%{release}
201
202 %description -n wxBase-unicode-devel
203 Header files for wxBase. You need them to develop programs using
204 UNICODE-enabled wxBase.
205
206 %description -n wxBase-unicode-devel -l pl
207 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
208
209 %package -n wxGTK2
210 Summary:        wxGTK2 library
211 Summary(pl):    Biblioteka wxGTK2
212 Group:          X11/Libraries
213 Requires:       %{name} = %{version}-%{release}
214 Obsoletes:      wxGTK2-univ
215
216 %description -n wxGTK2
217 wxWidgets library using GTK2 widgets.
218
219 %description -n wxGTK2 -l pl
220 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
221
222 %package -n wxGTK2-devel
223 Summary:        Header files for wxGTK2 library
224 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
225 Group:          X11/Development/Libraries
226 Requires:       wxBase-devel = %{version}-%{release}
227 Requires:       wxGTK2 = %{version}-%{release}
228 Obsoletes:      wxGTK2-univ-devel
229
230 %description -n wxGTK2-devel
231 Header files for wxWidgets library using GTK2 widgets.
232
233 %description -n wxGTK2-devel -l pl
234 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
235
236 %package -n wxGTK2-gl
237 Summary:        GL canvas library for wxGTK2
238 Summary(pl):    Biblioteka GL dla wxGTK2
239 Group:          X11/Libraries
240 Requires:       wxGTK2 = %{version}-%{release}
241 Requires:       OpenGL
242 Obsoletes:      wxGTK2-univ-gl
243
244 %description -n wxGTK2-gl
245 wxGTK2 GL canvas library.
246
247 %description -n wxGTK2-gl -l pl
248 Biblioteka GL dla wxGTK2.
249
250 %package -n wxGTK2-gl-devel
251 Summary:        Development files for GL canvas library for wxGTK2
252 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
253 Group:          X11/Development/Libraries
254 Requires:       wxGTK2-devel = %{version}-%{release}
255 Requires:       wxGTK2-gl = %{version}-%{release}
256 Requires:       OpenGL-devel
257 Obsoletes:      wxGTK2-univ-gl-devel
258
259 %description -n wxGTK2-gl-devel
260 Development files for wxGTK2 GL canvas library.
261
262 %description -n wxGTK2-gl-devel -l pl
263 Pliki programistyczne biblioteki GL dla wxGTK2.
264
265 %package -n wxGTK2-unicode
266 Summary:        wxGTK2 library with UNICODE support
267 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
268 Group:          X11/Libraries
269 Requires:       %{name} = %{version}-%{release}
270 Obsoletes:      wxGTK2-univ-unicode
271
272 %description -n wxGTK2-unicode
273 wxWidgets library using GTK2 widgets with UNICODE support.
274
275 %description -n wxGTK2-unicode -l pl
276 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
277
278 %package -n wxGTK2-unicode-devel
279 Summary:        Header files for wxGTK2 library with UNICODE support
280 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
281 Group:          X11/Development/Libraries
282 Requires:       wxBase-unicode-devel = %{version}-%{release}
283 Requires:       wxGTK2-unicode = %{version}-%{release}
284 Obsoletes:      wxGTK2-univ-unicode-devel
285
286 %description -n wxGTK2-unicode-devel
287 Header files for wxWidgets library using GTK2 widgets with UNICODE
288 support.
289
290 %description -n wxGTK2-unicode-devel -l pl
291 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
292 obs³ug± UNICODE.
293
294 %package -n wxGTK2-unicode-gl
295 Summary:        GL canvas library for wxGTK2 with UNICODE support
296 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
297 Group:          X11/Libraries
298 Requires:       wxGTK2-unicode = %{version}-%{release}
299 Requires:       OpenGL
300 Obsoletes:      wxGTK2-univ-unicode-gl
301
302 %description -n wxGTK2-unicode-gl
303 GL canvas library for wxGTK2 with UNICODE support.
304
305 %description -n wxGTK2-unicode-gl -l pl
306 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
307
308 %package -n wxGTK2-unicode-gl-devel
309 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
310 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
311 Group:          X11/Development/Libraries
312 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
313 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
314 Requires:       OpenGL-devel
315 Obsoletes:      wxGTK2-univ-unicode-gl-devel
316
317 %description -n wxGTK2-unicode-gl-devel
318 Development files for GL canvas library for wxGTK2 with UNICODE
319 support.
320
321 %description -n wxGTK2-unicode-gl-devel -l pl
322 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
323
324 %package utils
325 Summary:        Misc utils from wxWidgets project
326 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
327 Group:          X11/Development/Tools
328 Requires:       wxX11 = %{version}-%{release}
329 Obsoletes:      wxWindows-utils
330
331 %description utils
332 Misc utils from wxWidgets project: helpviewer, makegen, etc.
333
334 %description utils -l pl
335 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
336
337 %package -n wxX11
338 Summary:        wxUniversal-based wxX11 library
339 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
340 Group:          X11/Libraries
341 Requires:       %{name} = %{version}-%{release}
342 Obsoletes:      wxX11-univ
343
344 %description -n wxX11
345 wxUniversal-based wxX11 library.
346
347 %description -n wxX11 -l pl
348 Oparta na wxUniversal biblioteka wxX11.
349
350 %package -n wxX11-devel
351 Summary:        Header files for wxUniversal-based wxX11 library
352 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
353 Group:          X11/Libraries
354 Requires:       %{name}-devel = %{version}-%{release}
355 Requires:       wxX11 = %{version}-%{release}
356 Obsoletes:      wxX11-univ-devel
357
358 %description -n wxX11-devel
359 Header files for wxUniversal-based wxX11 library.
360
361 %description -n wxX11-devel -l pl
362 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
363
364 %package -n wxX11-gl
365 Summary:        GL canvas library for wxUniversal-based wxX11
366 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
367 Group:          X11/Libraries
368 Requires:       wxX11 = %{version}-%{release}
369 Requires:       OpenGL
370 Obsoletes:      wxX11-univ-gl
371
372 %description -n wxX11-gl
373 GL canvas library for wxUniversal-based wxX11.
374
375 %description -n wxX11-gl -l pl
376 Biblioteka GL dla opartej na wxUniversal wxX11.
377
378 %package -n wxX11-gl-devel
379 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
380 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
381 Group:          X11/Development/Libraries
382 Requires:       wxX11-gl = %{version}-%{release}
383 Requires:       wxX11-devel = %{version}-%{release}
384 Requires:       OpenGL-devel
385 Obsoletes:      wxX11-univ-gl-devel
386
387 %description -n wxX11-gl-devel
388 Development files for GL canvas library for wxUniversal-based wxX11.
389
390 %description -n wxX11-gl-devel -l pl
391 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
392
393 %package -n wxX11-unicode
394 Summary:        wxUniversal-based wxX11 library with UNICODE support
395 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
396 Group:          X11/Libraries
397 Requires:       %{name} = %{version}-%{release}
398 Obsoletes:      wxX11-univ-unicode
399
400 %description -n wxX11-unicode
401 wxUniversal-based wxX11 library with UNICODE support.
402
403 %description -n wxX11-unicode -l pl
404 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
405
406 %package -n wxX11-unicode-devel
407 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
408 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
409 Group:          X11/Development/Libraries
410 Requires:       %{name}-devel = %{version}-%{release}
411 Requires:       wxX11-unicode = %{version}-%{release}
412 Obsoletes:      wxX11-univ-unicode-devel
413
414 %description -n wxX11-unicode-devel
415 Header files for wxUniversal-based wxX11 library with UNICODE support.
416
417 %description -n wxX11-unicode-devel -l pl
418 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
419
420 %package -n wxX11-unicode-gl
421 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
422 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
423 Group:          X11/Libraries
424 Requires:       wxX11-unicode = %{version}-%{release}
425 Requires:       OpenGL
426 Obsoletes:      wxX11-univ-unicode-gl
427
428 %description -n wxX11-unicode-gl
429 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
430
431 %description -n wxX11-unicode-gl -l pl
432 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
433
434 %package -n wxX11-unicode-gl-devel
435 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
436 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
437 Group:          X11/Development/Libraries
438 Requires:       wxX11-unicode-gl = %{version}-%{release}
439 Requires:       wxX11-unicode-devel = %{version}-%{release}
440 Requires:       OpenGL-devel
441 Obsoletes:      wxX11-univ-unicode-gl-devel
442
443 %description -n wxX11-unicode-gl-devel
444 Development files for GL canvas library for wxUniversal-based wxX11
445 with UNICODE support.
446
447 %description -n wxX11-unicode-gl-devel -l pl
448 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
449 obs³ug± UNICODE.
450
451 %prep
452 %setup -q
453 %patch0 -p1
454 %patch1 -p1
455 %patch2 -p1
456 %patch3 -p1
457 %patch4 -p1
458
459 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
460
461 %build
462 # if bakefiles rebuild is needed:
463 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.9"
464 #cd build/bakefiles
465 #bakefile_gen -f autoconf
466 #cd ../..
467 #%endif
468 cp -f /usr/share/automake/config.sub .
469 %{__aclocal} -I build/aclocal
470 %{__autoconf}
471
472 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
473 # avoid adding -s to LDFLAGS
474 LDFLAGS=" "; export LDFLAGS
475 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
476         --enable-plugins \
477         --enable-std_iostreams \
478         --without-sdl \
479         --with-opengl \
480         --enable-calendar \
481         --enable-controls \
482         --enable-tabdialog"
483
484 gui='--with-gtk'
485 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
486         '--enable-unicode' ; do
487         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
488         mkdir $objdir
489         cd $objdir
490         ../%configure \
491                 ${args} \
492                 ${gui} \
493                 --disable-universal \
494                 ${unicode}
495         %{__make}
496         %{__make} -C contrib/src
497         cd ..
498 done
499
500 %if %{with x11}
501 gui='--with-x11'
502 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
503         '--enable-unicode' ; do
504         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
505         mkdir $objdir
506         cd $objdir
507         ../%configure \
508                 ${args} \
509                 ${gui} \
510                 --enable-universal \
511                 ${unicode}
512         %{__make}
513         %{__make} -C contrib/src
514         if echo $objdir| grep -q disable-unicode ; then
515                 %{__make} -C utils
516                 %{__make} -C utils/emulator
517                 %{__make} -C utils/hhp2cached
518                 %{__make} -C contrib/utils
519         fi
520         cd ..
521 done
522 %endif
523
524 cd locale
525 %{__make} allmo
526
527 %install
528 rm -rf $RPM_BUILD_ROOT
529 install -d $RPM_BUILD_ROOT%{_bindir}
530
531 gui='--with-gtk'
532 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
533         '--enable-unicode' ; do
534         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
535         cd $objdir
536         %{__make} install \
537                 prefix=$RPM_BUILD_ROOT%{_prefix} \
538                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
539                 bindir=$RPM_BUILD_ROOT%{_bindir} \
540                 datadir=$RPM_BUILD_ROOT%{_datadir} \
541                 libdir=$RPM_BUILD_ROOT%{_libdir} \
542                 mandir=$RPM_BUILD_ROOT%{_mandir} \
543                 includedir=$RPM_BUILD_ROOT%{_includedir}
544
545         %{__make} -C contrib/src install \
546                 prefix=$RPM_BUILD_ROOT%{_prefix} \
547                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
548                 bindir=$RPM_BUILD_ROOT%{_bindir} \
549                 datadir=$RPM_BUILD_ROOT%{_datadir} \
550                 libdir=$RPM_BUILD_ROOT%{_libdir} \
551                 mandir=$RPM_BUILD_ROOT%{_mandir} \
552                 includedir=$RPM_BUILD_ROOT%{_includedir}
553         cd ..
554 done
555
556 %if %{with x11}
557 gui='--with-x11'
558 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
559         '--enable-unicode' ; do
560         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
561         cd $objdir
562         %{__make} install \
563                 prefix=$RPM_BUILD_ROOT%{_prefix} \
564                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
565                 bindir=$RPM_BUILD_ROOT%{_bindir} \
566                 datadir=$RPM_BUILD_ROOT%{_datadir} \
567                 libdir=$RPM_BUILD_ROOT%{_libdir} \
568                 mandir=$RPM_BUILD_ROOT%{_mandir} \
569                 includedir=$RPM_BUILD_ROOT%{_includedir}
570         if echo $objdir| grep -q disable-unicode ; then
571 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
572                 # TODO: install default config files and default backgrouds
573                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
574                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
575                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
576                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
577 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
578                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
579 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
580 #               install -m644 utils/makegen/templates/* \
581 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
582 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
583 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
584 #               install contrib/utils/wxrcedit/df/* \
585 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
586         fi
587
588         %{__make} -C contrib/src install \
589                 prefix=$RPM_BUILD_ROOT%{_prefix} \
590                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
591                 bindir=$RPM_BUILD_ROOT%{_bindir} \
592                 datadir=$RPM_BUILD_ROOT%{_datadir} \
593                 libdir=$RPM_BUILD_ROOT%{_libdir} \
594                 mandir=$RPM_BUILD_ROOT%{_mandir} \
595                 includedir=$RPM_BUILD_ROOT%{_includedir}
596
597         cd ..
598 done
599 %endif
600
601 set -x
602
603 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
604 do
605         b=`basename $i`
606         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
607 done
608
609 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
610 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
611 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
612
613 %find_lang wxstd
614
615 %clean
616 rm -rf $RPM_BUILD_ROOT
617
618 %post   -n wxBase -p /sbin/ldconfig
619 %postun -n wxBase -p /sbin/ldconfig
620
621 %post   -n wxBase-unicode -p /sbin/ldconfig
622 %postun -n wxBase-unicode -p /sbin/ldconfig
623
624 %post   -n wxGTK2 -p /sbin/ldconfig
625 %postun -n wxGTK2 -p /sbin/ldconfig
626
627 %post   -n wxGTK2-gl -p /sbin/ldconfig
628 %postun -n wxGTK2-gl -p /sbin/ldconfig
629
630 %post   -n wxGTK2-unicode -p /sbin/ldconfig
631 %postun -n wxGTK2-unicode -p /sbin/ldconfig
632
633 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
634 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
635
636 %post   -n wxX11 -p /sbin/ldconfig
637 %postun -n wxX11 -p /sbin/ldconfig
638
639 %post   -n wxX11-unicode -p /sbin/ldconfig
640 %postun -n wxX11-unicode -p /sbin/ldconfig
641
642 %define _libf %{?with_debug:d}
643 %define _configf %{?with_debug:-debug-2.6}
644
645
646 %files -f wxstd.lang
647 %defattr(644,root,root,755)
648 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
649
650 %files devel
651 %defattr(644,root,root,755)
652 %doc docs/html
653 %doc docs/tech docs/univ
654 %{_includedir}/wx*
655 %dir %{_libdir}/wx
656 %dir %{_libdir}/wx/include
657 %dir %{_libdir}/wx/config
658 %{_aclocaldir}/*.m4
659
660 %files examples
661 %defattr(644,root,root,755)
662 %{_examplesdir}/%{name}-%{version}
663
664 %if %{with x11}
665 %files HelpGen
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/HelpGen
668 %endif
669
670 %if %{with ansi}
671 %files -n wxBase
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
674 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
675 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
676
677 %files -n wxBase-devel
678 %defattr(644,root,root,755)
679 %{_libdir}/libwx_base%{_libf}-*.so
680 %{_libdir}/libwx_base%{_libf}_*.so
681 %endif
682
683 %files -n wxBase-unicode
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
686 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
687 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
688
689 %files -n wxBase-unicode-devel
690 %defattr(644,root,root,755)
691 %{_libdir}/libwx_baseu%{_libf}-*.so
692 %{_libdir}/libwx_baseu%{_libf}_*.so
693
694 %if %{with ansi}
695 %files -n wxGTK2
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
698 %exclude %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so.*.*
699
700 %files -n wxGTK2-devel
701 %defattr(644,root,root,755)
702 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
703 %exclude %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so
704 %{_libdir}/wx/config/gtk2-ansi-*
705 %{_libdir}/wx/include/gtk2-ansi-*
706 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
707
708 %files -n wxGTK2-gl
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so.*.*
711
712 %files -n wxGTK2-gl-devel
713 %defattr(644,root,root,755)
714 %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so
715 %endif
716
717 %files -n wxGTK2-unicode
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
720 %exclude %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so.*.*
721
722 %files -n wxGTK2-unicode-devel
723 %defattr(644,root,root,755)
724 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
725 %exclude %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so
726 %{_libdir}/wx/config/gtk2-unicode-*
727 %{_libdir}/wx/include/gtk2-unicode-*
728 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
729
730 %files -n wxGTK2-unicode-gl
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so.*.*
733
734 %files -n wxGTK2-unicode-gl-devel
735 %defattr(644,root,root,755)
736 %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so
737
738 %if %{with x11}
739 %if %{with ansi}
740 %files utils
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_bindir}/*
743 %exclude %{_bindir}/HelpGen
744 %exclude %{_bindir}/wx*-config
745
746 %files -n wxX11
747 %defattr(644,root,root,755)
748 %doc docs/wxX11-readme.txt
749 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
750 %exclude %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so.*.*
751
752 %files -n wxX11-devel
753 %defattr(644,root,root,755)
754 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
755 %exclude %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so
756 %{_libdir}/wx/config/x11univ-ansi-*
757 %{_libdir}/wx/include/x11univ-ansi-*
758 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
759
760 %files -n wxX11-gl
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so.*.*
763
764 %files -n wxX11-gl-devel
765 %defattr(644,root,root,755)
766 %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so
767 %endif
768
769 %files -n wxX11-unicode
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
772 %exclude %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so.*.*
773
774 %files -n wxX11-unicode-devel
775 %defattr(644,root,root,755)
776 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
777 %exclude %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so
778 %{_libdir}/wx/config/x11univ-unicode-*
779 %{_libdir}/wx/include/x11univ-unicode-*
780 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
781
782 %files -n wxX11-unicode-gl
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so.*.*
785
786 %files -n wxX11-unicode-gl-devel
787 %defattr(644,root,root,755)
788 %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so
789 %endif
This page took 0.07873 seconds and 3 git commands to generate.