]> git.pld-linux.org Git - packages/wvstreams.git/blob - wvstreams.spec
- release 4
[packages/wvstreams.git] / wvstreams.spec
1 #
2 # TODO:
3 #   - check and/or package files:
4 #
5 #   /etc/uniconf.conf
6 #   /usr/bin/uni
7 #   /usr/lib64/pkgconfig/liboggspeex.pc
8 #   /usr/lib64/pkgconfig/liboggvorbis.pc
9 #   /usr/lib64/pkgconfig/libuniconf.pc
10 #   /usr/lib64/pkgconfig/libwvbase.pc
11 #   /usr/lib64/pkgconfig/libwvfft.pc
12 #   /usr/lib64/pkgconfig/libwvqt.pc
13 #   /usr/lib64/pkgconfig/libwvstreams.pc
14 #   /usr/lib64/pkgconfig/libwvutils.pc
15 #   /usr/lib64/pkgconfig/wvxplc.pc
16 #   /usr/sbin/uniconfd
17 #   /usr/share/man/man8/uni.8.gz
18 #   /usr/share/man/man8/uniconfd.8.gz
19 #   /var/lib/uniconf/uniconfd.ini
20 #
21 # Conditional build:
22 %bcond_without  doc     # don't build documentation
23 %bcond_without  slp     # build without openslp
24 #
25 Summary:        A network programming library written in C++
26 Summary(pl.UTF-8):      Biblioteka programowania sieciowego napisana w C++
27 Name:           wvstreams
28 Version:        4.0.2
29 Release:        4
30 License:        LGPL
31 Group:          Libraries
32 Source0:        http://www.csclub.uwaterloo.ca/~ja2morri/%{name}-%{version}.tar.gz
33 # Source0-md5:  ecb4e74ebaa1f45206f5d88eb34c5623
34 Patch0:         %{name}-cflags.patch
35 Patch1:         %{name}-gcc4.patch
36 Patch2:         %{name}-unresolved_symbols.patch
37 Patch3:         %{name}-mk.patch
38 URL:            http://open.nit.ca/wvstreams/
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 %{?with_doc:BuildRequires:      doxygen}
42 BuildRequires:  libstdc++-devel
43 %{?with_slp:BuildRequires:      openslp-devel}
44 BuildRequires:  openssl-devel >= 0.9.7i
45 Obsoletes:      libwvstreams
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 WvStreams aims to be an efficient, secure, and easy-to-use library for
50 doing network applications development.
51
52 %description -l pl.UTF-8
53 WvStreams próbuje być wydajną, bezpieczną i łatwą w użyciu biblioteką
54 do tworzenia aplikacji sieciowych.
55
56 %package devel
57 Summary:        Development files for WvStreams
58 Summary(pl.UTF-8):      Pliki developerskie dla WvStreams
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       libstdc++-devel
62 Obsoletes:      libwvstreams-devel
63
64 %description devel
65 WvStreams aims to be an efficient, secure, and easy-to-use library for
66 doing network applications development. This package contains the
67 files needed for developing applications which use WvStreams.
68
69 %description devel -l pl.UTF-8
70 WvStreams próbuje być wydajną, bezpieczną i łatwą w użyciu biblioteką
71 do tworzenia aplikacji sieciowych. Pakiet ten zawiera pliki niezbędne
72 do tworzenia aplikacji używających WvStreams.
73
74 %package static
75 Summary:        Static wvstreams library
76 Summary(pl.UTF-8):      Statyczna biblioteka wvstreams
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static wvstreams library.
82
83 %description static -l pl.UTF-8
84 Statyczna wersja biblioteki wvstreams.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92 #ugly hack - fix it
93 cp include/wvsslhacks.h crypto
94 cp include/wvtelephony.h telephony
95
96 %build
97 cd xplc
98 cp -f /usr/share/automake/config.sub .
99 %{__aclocal}
100 %{__autoconf}
101 %{__autoheader}
102 %configure
103 cd ..
104
105 # despite .fpic rules the same .o files are used for .a and .so - need -fPIC
106 %{__aclocal}
107 %{__autoconf}
108 %{__autoheader}
109 %configure \
110         --with%{!?with_slp:out}-openslp \
111         --without-vorbis
112
113 %{__make} -j1 \
114         VPATH=%{_libdir} \
115         DEBUG=%{?debug:1}%{!?debug:0} \
116         CXX="%{__cxx}" \
117         CFLAGS="%{rpmcflags} -fPIC -DDEBUG=0 \$(OSDEFINE)"
118
119 %if %{with doc}
120 %{__make} doxygen
121 %endif
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc README ChangeLog
138 %attr(755,root,root) %{_libdir}/lib*.so.*.*
139
140 %files devel
141 %defattr(644,root,root,755)
142 %if %{with doc}
143 %doc Docs/doxy-html/*
144 %endif
145 %attr(755,root,root) %{_libdir}/lib*.so
146 %{_includedir}/wvstreams
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/lib*.a
This page took 0.05951 seconds and 4 git commands to generate.