]> git.pld-linux.org Git - packages/wvstreams.git/blob - wvstreams.spec
- make -j1
[packages/wvstreams.git] / wvstreams.spec
1 Summary:        A network programming library written in C++
2 Summary(pl):    Biblioteka programowania sieciowego napisana w C++
3 Name:           wvstreams
4 Version:        3.70
5 Release:        3
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://open.nit.ca/download/%{name}-%{version}.tar.gz
9 # Source0-md5:  6fd341edd65d248f92338ba9e91a2875
10 Patch0:         %{name}-rsapublickey.patch
11 Patch1:         %{name}-gcc3.patch
12 URL:            http://open.nit.ca/wvstreams/
13 BuildRequires:  doxygen
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  openssl-devel >= 0.9.7d
16 Obsoletes:      libwvstreams
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 WvStreams aims to be an efficient, secure, and easy-to-use library for
21 doing network applications development.
22
23 %description -l pl
24 WvStreams próbuje byæ wydajn±, bezpieczn± i ³atw± w u¿yciu bibliotek±
25 do tworzenia aplikacji sieciowych.
26
27 %package devel
28 Summary:        Development files for WvStreams
29 Summary(pl):    Pliki developerskie dla WvStreams
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       libstdc++-devel
33 Obsoletes:      libwvstreams-devel
34
35 %description devel
36 WvStreams aims to be an efficient, secure, and easy-to-use library for
37 doing network applications development. This package contains the
38 files needed for developing applications which use WvStreams.
39
40 %description devel -l pl
41 WvStreams próbuje byæ wydajn±, bezpieczn± i ³atw± w u¿yciu bibliotek±
42 do tworzenia aplikacji sieciowych. Pakiet ten zawiera pliki niezbêdne
43 do tworzenia aplikacji u¿ywaj±cych WvStreams.
44
45 %package static
46 Summary:        Static wvstreams library
47 Summary(pl):    Statyczna biblioteka wvstreams
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static wvstreams library.
53
54 %description static -l pl
55 Statyczna wersja biblioteki wvstreams.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61
62 %build
63 # despite .fpic rules the same .o files are used for .a and .so - need -fPIC
64 %{__make} -j1 \
65         DEBUG=%{?debug:1}%{!?debug:0} \
66         CXX="%{__cxx}" \
67         CFLAGS="%{rpmcflags} -fPIC -DDEBUG=0 \$(OSDEFINE)"
68         
69 %{__make} doxygen
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
76         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc src/README
87 %attr(755,root,root) %{_libdir}/lib*.so.*.*
88
89 %files devel
90 %defattr(644,root,root,755)
91 %doc dox/html/*
92 %attr(755,root,root) %{_libdir}/lib*.so
93 %{_includedir}/wvstreams
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/lib*.a
This page took 0.036723 seconds and 4 git commands to generate.