]> git.pld-linux.org Git - packages/wpa_supplicant.git/blob - wpa_supplicant.spec
- 0.5.8
[packages/wpa_supplicant.git] / wpa_supplicant.spec
1 # TODO:
2 # - wpa_gui can be built with qt4 - bcond?
3 # - icon for wpa_gui
4 # - reverse madwifi bcond when appropriate packages will be available on ftp
5 #       / as of madwifi-ng > r1499 and kernel > 2.6.14 wext driver could be 
6 #       used instead of madwifi - so madwifi bcond will become obsolete soon /
7 #
8 # Conditional build
9 %bcond_with     madwifi         # with madwifi support
10 %bcond_without  gui             # don't build gui
11 #
12 # sync archlist with madwifi.spec
13 %ifnarch %{x8664} arm %{ix86} mips ppc xscale
14 %undefine       with_madwifi
15 %endif
16 #
17 Summary:        Linux WPA/WPA2/RSN/IEEE 802.1X supplicant
18 Summary(pl.UTF-8):      Suplikant WPA/WPA2/RSN/IEEE 802.1X dla Linuksa
19 Name:           wpa_supplicant
20 Version:        0.5.8
21 Release:        1
22 License:        GPL v2
23 Group:          Networking
24 Source0:        http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
25 # Source0-md5:  7bb22f2bcdeed54b3fb5407d6d8bc9bb
26 Source1:        %{name}.config
27 Source2:        %{name}-wpa_gui.desktop
28 Patch0:         %{name}-makefile.patch
29 Patch1:         %{name}-0.4.7_dscape-02.patch
30 Patch2:         %{name}-OPTCFLAGS.patch
31 URL:            http://hostap.epitest.fi/wpa_supplicant/
32 %{?with_madwifi:BuildRequires:  madwifi-devel}
33 BuildRequires:  ncurses-devel
34 BuildRequires:  openssl-devel
35 %if %{with gui}
36 BuildRequires:  qmake
37 BuildRequires:  qt-devel
38 %endif
39 BuildRequires:  readline-devel
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 wpa_supplicant is a WPA Supplicant with support for WPA and WPA2 (IEEE
44 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA component that is
45 used in the client stations. It implements key negotiation with a WPA
46 Authenticator and it controls the roaming and IEEE 802.11
47 authentication/association of the wlan driver.
48
49 wpa_supplicant is designed to be a "daemon" program that runs in the
50 background and acts as the backend component controlling the wireless
51 connection. Support for separate frontend programs is included and an
52 example text-based frontend, wpa_cli, is included with wpa_supplicant.
53
54 Supported WPA/IEEE 802.11i features:
55 - WPA-PSK ("WPA-Personal")
56 - WPA with EAP (e.g., with RADIUS authentication server)
57   ("WPA-Enterprise") (currently, EAP-TLS and EAP-PEAP/MSCHAPv2 are
58   supported with an integrated IEEE 802.1X Supplicant; other EAP types
59   may be used with an external program, Xsupplicant)
60 - key management for CCMP, TKIP, WEP104, WEP40
61 - RSN/WPA2 (IEEE 802.11i)
62
63 %description -l pl.UTF-8
64 wpa_supplicant to suplikant WPA z obsługą WPA oraz WPA2 (IEEE 802.11i
65 / RSN). Suplikant to element IEEE 802.1X/WPA używany na stacjach
66 klienckich. Implementuje negocjację kluczy z elementem
67 uwierzytelniającym WPA (WPA Authenticator) i kontroluje roaming oraz
68 uwierzytelnianie/kojarzenie sterownika wlan zgodnie z IEEE 802.11.
69
70 wpa_supplicant jest zaprojektowany tak, by był wspólnym programem
71 działającym w tle i działa jako element backendu sterujący połączeniem
72 bezprzewodowym. Dostępna jest obsługa oddzielnych programów
73 frontendowych, a w pakiecie wpa_supplicant załączony jest prosty
74 frontend tekstowy - wpa_cli.
75
76 Obsługiwane możliwości WPA/IEEE 802.11i:
77 - WPA-PSK ("WPA-Personal")
78 - WPA z EAP (np. z serwerem uwierzytleniającym RADIUS)
79   ("WPA-Enterprise") (aktualnie EAP-TLS i EAP-PEAP/MSCHAPv2 są
80   obsługiwane przez załączonego suplikanta IEEE 802.1X; inne rodzaje EAP
81   mogą być używane przez zewnętrzny program - Xsupplicant)
82 - zarządzanie kluczy dla CCMP, TKIP, WEP104, WEP40
83 - RSN/WPA2 (IEEE 802.11i)
84
85 %package -n wpa_gui
86 Summary:        Linux WPA/WPA2/RSN/IEEE 802.1X supplicant GUI
87 Summary(pl.UTF-8):      Graficzny interfejs suplikanta WPA/WPA2/RSN/IEEE 802.1X dla Linuksa
88 Group:          X11/Applications/Networking
89 Requires:       %{name} = %{version}-%{release}
90
91 %description -n wpa_gui
92 Linux WPA/WPA2/RSN/IEEE 802.1X supplicant GUI.
93
94 %description -n wpa_gui -l pl.UTF-8
95 Graficzny interfejs suplikanta WPA/WPA2/RSN/IEEE 802.1X dla Linuksa.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102
103 install %{SOURCE1} .config
104
105 %if %{with madwifi}
106 echo 'CONFIG_DRIVER_MADWIFI=y' >> .config
107 %endif
108
109 %build
110 %{__make} \
111         CC="%{__cc}" \
112         LDFLAGS="%{rpmldflags}" \
113         OPTCFLAGS="%{rpmcflags}"
114
115 %if %{with gui}
116 %{__make} wpa_gui \
117         QTDIR=/usr \
118         UIC=%{_bindir}/uic \
119         CC="%{__cc}" \
120         CXX="%{__cxx}" \
121         LDFLAGS="%{rpmldflags}" \
122         OPTCFLAGS="%{rpmcflags}"
123 %endif
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_mandir}/man{5,8},%{_bindir},%{_desktopdir},/var/run/%{name}}
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install doc/docbook/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
132 install doc/docbook/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
133
134 %if %{with gui}
135 install wpa_gui/wpa_gui $RPM_BUILD_ROOT%{_bindir}
136 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/wpa_gui.desktop
137 %endif
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files
143 %defattr(644,root,root,755)
144 %doc ChangeLog README eap_testing.txt todo.txt
145 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
146 %attr(755,root,root) %{_sbindir}/*
147 %attr(750,root,root) %dir /var/run/%{name}
148 %{_mandir}/man[58]/*
149
150 %if %{with gui}
151 %files -n wpa_gui
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/wpa_gui
154 %{_desktopdir}/wpa_gui.desktop
155 %endif
This page took 0.063476 seconds and 3 git commands to generate.