]> git.pld-linux.org Git - packages/wlroots.git/blob - wlroots.spec
- pl
[packages/wlroots.git] / wlroots.spec
1 Summary:        A modular Wayland compositor library
2 Summary(pl.UTF-8):      Modularna biblioteka kompozytora Wayland
3 Name:           wlroots
4 Version:        0.16.2
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 Source0:        https://gitlab.freedesktop.org/wlroots/wlroots/-/releases/%{version}/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  cea876a8833d60ab65548ef60aae14b7
10 Patch0:         x32.patch
11 URL:            https://gitlab.freedesktop.org/wlroots/wlroots
12 BuildRequires:  EGL-devel
13 BuildRequires:  Mesa-libgbm-devel >= 21.1.0
14 BuildRequires:  OpenGLESv2-devel
15 BuildRequires:  Vulkan-Loader-devel >= 1.2.182
16 BuildRequires:  glslang >= 11.0.0
17 BuildRequires:  hwdata >= 0.364
18 BuildRequires:  libdrm-devel >= 2.4.113
19 BuildRequires:  libinput-devel >= 1.19.0
20 BuildRequires:  libseat-devel >= 0.2.0
21 BuildRequires:  libxcb-devel
22 BuildRequires:  meson >= 0.59.0
23 BuildRequires:  ninja
24 BuildRequires:  pixman-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpmbuild(macros) >= 1.736
27 BuildRequires:  udev-devel
28 BuildRequires:  wayland-devel >= 1.21
29 BuildRequires:  wayland-protocols >= 1.27
30 BuildRequires:  xcb-util-errors-devel
31 BuildRequires:  xcb-util-renderutil-devel
32 BuildRequires:  xcb-util-wm-devel
33 BuildRequires:  xorg-lib-libxkbcommon-devel
34 BuildRequires:  xorg-xserver-Xwayland-devel
35 Requires:       Mesa-libgbm >= 21.1.0
36 Requires:       Vulkan-Loader >= 1.2.182
37 Requires:       libdrm >= 2.4.113
38 Requires:       libinput >= 1.19.0
39 Requires:       libseat >= 0.2.0
40 Requires:       wayland >= 1.21
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Pluggable, composable, unopinionated modules for building a Wayland
45 compositor; or about 50,000 lines of code you were going to write
46 anyway.
47 - wlroots provides backends that abstract the underlying display and
48   input hardware, including KMS/DRM, libinput, Wayland, X11, and
49   headless backends, plus any custom backends you choose to write, which
50   can all be created or destroyed at runtime and used in concert with
51   each other.
52 - wlroots provides unopinionated, mostly standalone implementations of
53   many Wayland interfaces, both from wayland.xml and various protocol
54   extensions. We also promote the standardization of portable extensions
55   across many compositors.
56 - wlroots provides several powerful, standalone, and optional tools
57   that implement components common to many compositors, such as the
58   arrangement of outputs in physical space.
59 - wlroots provides an Xwayland abstraction that allows you to have
60   excellent Xwayland support without worrying about writing your own X11
61   window manager on top of writing your compositor.
62 - wlroots provides a renderer abstraction that simple compositors can
63   use to avoid writing GL code directly, but which steps out of the way
64   when your needs demand custom rendering code.
65
66 %description -l pl.UTF-8
67 Dołączalne, składalne moduły do tworzenia kompozytora Wayland; albo
68 około 50000 linii kodu, który i tak trzeba by napisać. Udostępnia
69 m.in.:
70 - backendy będące abstrakcją sprzętu wyświetlającego i wejściowego - w
71   tym KMS/DRM, libinput, Wayland, X11 oraz samodzielne, oraz dowolne
72   inne własne backendy, które można tworzyć i niszczyć w czasie
73   działania programu, i wykorzystywać wraz z innymi
74 - w większości samodzielne implementacje wielu interfejsów Wayland,
75   zarówno z wayland.xml, jak i różnych rozszerzeń protokołu
76 - kilka samodzielnych, opcjonalnych narzędzi, będących implementacją
77   komponentów wspólnych dla wielu kompozytorów, takich jak układanie
78   wyjść w przestrzeni fizycznej
79 - abstrakcję Xwayland
80 - abstrakcję renderowania, pozwalającą pominąć pisanie bezpośrednio
81   kodu GL
82
83 %package devel
84 Summary:        Header files for wlroots library
85 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki wlroots
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       EGL-devel
89 Requires:       Mesa-libgbm-devel >= 21.1.0
90 Requires:       OpenGLESv2-devel
91 Requires:       Vulkan-Loader-devel >= 1.2.182
92 Requires:       libdrm-devel >= 2.4.113
93 Requires:       libinput-devel >= 1.19.0
94 Requires:       libseat-devel >= 0.2.0
95 Requires:       libxcb-devel
96 Requires:       pixman-devel
97 Requires:       systemd-devel >= 1:237
98 Requires:       udev-devel
99 Requires:       wayland-devel >= 1.21
100 Requires:       wayland-protocols >= 1.27
101 Requires:       xcb-util-errors-devel
102 Requires:       xcb-util-renderutil-devel
103 Requires:       xcb-util-wm-devel
104 Requires:       xorg-lib-libxkbcommon-devel
105
106 %description devel
107 Header files for wlroots library.
108
109 %description devel -l pl.UTF-8
110 Pliki nagłówkowe biblioteki wlroots.
111
112 %package static
113 Summary:        Static wlroots library
114 Summary(pl.UTF-8):      Statyczna biblioteka wlroots
115 Group:          Development/Libraries
116 Requires:       %{name}-devel = %{version}-%{release}
117
118 %description static
119 Static wlroots library.
120
121 %description static -l pl.UTF-8
122 Statyczna biblioteka wlroots.
123
124 %prep
125 %setup -q
126 %patch0 -p1
127
128 %build
129 %meson build \
130         -Dexamples=false \
131         -Dxwayland=enabled
132
133 %ninja_build -C build
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 %ninja_install -C build
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc CONTRIBUTING.md README.md
148 %attr(755,root,root) %{_libdir}/libwlroots.so.11
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libwlroots.so
153 %{_includedir}/wlr
154 %{_pkgconfigdir}/wlroots.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libwlroots.a
This page took 0.068573 seconds and 4 git commands to generate.