]> git.pld-linux.org Git - packages/wireshark.git/blob - wireshark.spec
- build and package randpktdump, androiddump, *idl2wrs, dpauxmon, sdjournal
[packages/wireshark.git] / wireshark.spec
1 # TODO
2 # - use policykit to gain root
3 # - use %caps when rpm supports it: %attr(750,root,wireshark) %caps(cap_net_raw,cap_net_admin=eip) %{_sbindir}/dumpcap
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # Kerberos V support
7 %bcond_without  snmp            # SNMP support
8 %bcond_without  gui             # without QT GUI
9
10 Summary:        Network traffic and protocol analyzer
11 Summary(es.UTF-8):      Analizador de tráfico de red
12 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych
13 Summary(pt_BR.UTF-8):   Analisador de tráfego de rede
14 Summary(ru.UTF-8):      Анализатор сетевого траффика
15 Summary(uk.UTF-8):      Аналізатор мережевого трафіку
16 Name:           wireshark
17 Version:        3.0.0
18 Release:        0.1
19 License:        GPL v2+
20 Group:          Networking/Utilities
21 Source0:        https://www.wireshark.org/download/src/%{name}-%{version}.tar.xz
22 # Source0-md5:  258d62ac7434d126dc497303c8f7961b
23 Patch0:         %{name}-desktop.patch
24 URL:            https://www.wireshark.org/
25 BuildRequires:  GeoIP-devel
26 BuildRequires:  asciidoc
27 BuildRequires:  bison
28 BuildRequires:  cmake
29 BuildRequires:  c-ares-devel
30 BuildRequires:  doxygen
31 BuildRequires:  flex
32 BuildRequires:  gcc >= 5:3.2
33 BuildRequires:  glib2-devel >= 1:2.32
34 BuildRequires:  gnutls-devel >= 3.2.0
35 %{?with_kerberos5:BuildRequires:        heimdal-devel}
36 BuildRequires:  libcap-devel
37 BuildRequires:  libgcrypt-devel >= 1.4.2
38 BuildRequires:  libmaxminddb-devel
39 BuildRequires:  libnl-devel >= 3.2
40 BuildRequires:  libpcap-devel >= 2:1.0.0-4
41 BuildRequires:  libssh-devel >= 0.6.0
42 BuildRequires:  libsmi-devel
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool >= 2:2.2.2
45 BuildRequires:  libxml2-devel >= 2.0
46 BuildRequires:  libxslt-progs
47 BuildRequires:  lua52-devel
48 BuildRequires:  lz4-devel
49 %{?with_snmp:BuildRequires:     net-snmp-devel}
50 BuildRequires:  nghttp2-devel
51 BuildRequires:  perl-tools-pod
52 BuildRequires:  pkgconfig >= 1:0.7
53 %{?with_gui:BuildRequires:      portaudio-devel}
54 BuildRequires:  python3 >= 1:3.4
55 BuildRequires:  rpmbuild(macros) >= 1.527
56 %{?with_gui:BuildRequires:      sbc-devel >= 1.0}
57 %{?with_qt:BuildRequires:       speexdsp-devel}
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  snappy-devel
60 BuildRequires:  spandsp-devel
61 BuildRequires:  tar >= 1:1.22
62 BuildRequires:  w3m
63 BuildRequires:  xz
64 BuildRequires:  zlib-devel
65 %if %{with qt}
66 BuildRequires:  Qt5Core-devel >= 5.2
67 BuildRequires:  Qt5Multimedia-devel >= 5.2
68 BuildRequires:  Qt5PrintSupport-devel >= 5.2
69 BuildRequires:  Qt5Widgets-devel >= 5.2
70 BuildRequires:  libstdc++-devel >= 5
71 BuildRequires:  qt5-build >= 5.2
72 BuildRequires:  qt5-linguist >= 5.2
73 %endif
74 Requires:       %{name}-gui-common = %{version}-%{release}
75 Requires:       gdk-pixbuf2 >= 2.26
76 %if %{with gtk2}
77 Requires:       gtk+2 >= 2:2.12.0
78 %else
79 Requires:       gtk+3 >= 3.0.0
80 %endif
81 Suggests:       xdg-utils
82 Provides:       ethereal
83 Provides:       ethereal-gnome
84 Obsoletes:      ethereal
85 Obsoletes:      ethereal-gnome
86 Obsoletes:      wireshark-gui-common
87 Obsoletes:      wireshark-qt
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %description
91 Wireshark is the name for powerful graphical network sniffer, traffic
92 and protocol analyzer based on GTK+ and libpcap libraries. It lets you
93 capture and interactively browse the contents of network frames with
94 vast knowledge of more than 100 network protocols. Wireshark has
95 severeal useful features, including a rich display filter language,
96 the ability to view the ASCII contents of a TCP connection and plug-in
97 capabilities.
98
99 %description -l es.UTF-8
100 Analizador de tráfico de red.
101
102 %description -l pl.UTF-8
103 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
104 protokołów sieciowych opartym na bibliotekach GTK+ oraz libpcap.
105 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
106 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
107 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
108 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
109 wtyczek (plug-ins).
110
111 %description -l pt_BR.UTF-8
112 O Wireshark é um analisador de protocolo de rede baseado no GTK+.
113
114 %description -l ru.UTF-8
115 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
116 базируется на GTK+ и libpcap.
117
118 %description -l uk.UTF-8
119 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
120 базується на GTK+ та libpcap.
121
122 %package common
123 Summary:        Network traffic and protocol analyzer - common files
124 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych - wspólne pliki
125 Group:          Networking
126 Requires:       %{name}-libs = %{version}-%{release}
127 Requires:       gnutls >= 3.1.10
128 Requires:       libpcap >= 0.4
129 Requires:       libssh >= 0.6.0
130 Provides:       ethereal-common
131 Provides:       group(wireshark)
132 Provides:       wireshark-tools
133 Obsoletes:      ethereal-common
134 Obsoletes:      wireshark-tools
135 Requires(post,postun):  /sbin/setcap
136
137 %description common
138 Wireshark is the name for powerful graphical network sniffer, traffic
139 and protocol analyzer based on GTK+ and libpcap libraries. It lets you
140 capture and interactively browse the contents of network frames with
141 vast knowledge of more than 100 network protocols. Wireshark has
142 severeal useful features, including a rich display filter language,
143 the ability to view the ASCII contents of a TCP connection and plug-in
144 capabilities.
145
146 This package provides the shared library, plugins, data and a set of
147 tools for manipulating capture files. It contains:
148 - capinfos - prints informatio about binary capture files,
149 - captype - prints the file types of capture files,
150 - dftest - shows display filter byte-code,
151 - dumpcap - dumps network traffic to a file,
152 - editcap - edit and/or translate the format of capture files,
153 - mergecap - merges two capture files into one,
154 - randpkt - generates libpcap trace file full of random packets,
155 - rawshark - dumps and analyzes raw libpcap data,
156 - text2cap - generate a capture file from an ASCII hexdump of packets.
157
158 %description common -l es.UTF-8
159 Analizador de tráfico de red.
160
161 %description common -l pl.UTF-8
162 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
163 protokołów sieciowych opartym na bibliotekach GTK+ oraz libpcap.
164 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
165 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
166 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
167 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
168 wtyczek (plug-ins).
169
170 Ten pakiet ten zawiera bibliotekę współdzieloną, wtyczki, dane oraz
171 zestaw narzędzi do obróbki plików z przechwyconymi pakietami,
172 obejmujący:
173 - capinfos - do wyświetlania informacji o binarnych plikach zrzutu,
174 - captype - do wyświetlania rodzaju plików zrzutu,
175 - dftest - do pokazywania bajtkodu filtrów wyświetlania,
176 - dumpcap - do zrzucania ruchu sieciowego do pliku,
177 - editcap - do edycji plików i tłumaczenia ich na inne formaty,
178 - mergecap - do łączenia dwóch plików w jeden,
179 - randpkt - do generowania plikow cap z losowymi danymi,
180 - rawshark - do obróbki plików cap,
181 - text2cap - do generowania pliku cap z szesnastkowego zrzutu ASCII
182   pakietów.
183
184 %description common -l pt_BR.UTF-8
185 O Wireshark é um analisador de protocolo de rede baseado no GTK+.
186
187 %description common -l ru.UTF-8
188 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
189 базируется на GTK+ и libpcap.
190
191 %description common -l uk.UTF-8
192 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
193 базується на GTK+ та libpcap.
194
195 %package -n twireshark
196 Summary:        Text-mode network traffic and protocol analyzer
197 Summary(pl.UTF-8):      Tekstowy analizator ruchu i protokołów sieciowych
198 Summary(pt_BR.UTF-8):   Analisador modo texto de tráfego de rede (sniffer)
199 Group:          Networking
200 Requires:       %{name}-common = %{version}-%{release}
201 Requires:       libpcap >= 0.4
202 Provides:       tethereal
203 Obsoletes:      tethereal
204
205 %description -n twireshark
206 Twireshark is a network protocol analyzer. It lets you capture packet
207 data from a live network, or read packets from a previously saved
208 capture file, either printing a decoded form of those packets to the
209 standard output or writing the packets to a file. Twireshark's native
210 capture file format is libpcap format, which is also the format used
211 by tcpdump and various other tools.
212
213 %description -n twireshark -l pl.UTF-8
214 Twireshark jest analizatorem protokołów sieciowych. Pozwala na
215 przechwytywanie pakietów z sieci lub wczytywanie danych z pliku.
216 Zdekodowany wynik (a twireshark zna ponad 100 rozmaitych protokołów
217 sieciowych!) jest wyświetlony na ekranie. Natywnym formatem plików
218 tetherala jest format libpcap, tak więc jest on kompatybilny z
219 tcpdumpem i innymi podobnymi narzędziami.
220
221 %description -n twireshark -l pt_BR.UTF-8
222 Esta é uma versão para modo texto do analisador de tráfego de rede
223 Wireshark.
224
225 %package libs
226 Summary:        Wireshark packet capture and dissection libraries
227 Summary(pl.UTF-8):      Biblioteki Wiresharka do przechwytywania i sekcji pakietów
228 Group:          Libraries
229 Requires:       glib2 >= 1:2.32
230 Requires:       libgcrypt >= 1.4.2
231 Requires:       libnl >= 3.2
232 Obsoletes:      libwiretap < 2.4.0
233
234 %description libs
235 Wireshark packet capture and dissection libraries.
236
237 %description libs -l pl.UTF-8
238 Biblioteki Wiresharka do przechwytywania i sekcji pakietów.
239
240 %package devel
241 Summary:        Header files for Wireshark libraries
242 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wiresharka
243 Group:          Development/Libraries
244 Requires:       %{name}-libs = %{version}-%{release}
245 Requires:       glib2-devel >= 1:2.32
246 Requires:       libgcrypt-devel >= 1.4.2
247 Requires:       libnl-devel >= 3.2
248 Obsoletes:      libwiretap-devel < 2.4.0
249
250 %description devel
251 Header files for Wireshark libraries.
252
253 %description devel -l pl.UTF-8
254 Pliki nagłówkowe bibliotek Wiresharka.
255
256 %prep
257 %setup -q
258 %patch0 -p1
259
260 %build
261 %cmake -G "Unix Makefiles" \
262   -DDISABLE_WERROR=ON \
263   -DBUILD_wireshark=ON \
264   -DENABLE_QT5=ON \
265   -DENABLE_LUA=ON \
266   -DBUILD_mmdbresolve=ON \
267   -DBUILD_randpktdump=ON \
268   -DBUILD_androiddump=ON \
269   -DBUILD_tfshark=OFF \
270   -DBUILD_corbaidl2wrs=ON \
271   -DBUILD_dcerpcidl2wrs=ON \
272   -DBUILD_xxx2deb=ON \
273   -DENABLE_SMI=ON \
274   -DENABLE_PORTAUDIO=ON \
275   -DENABLE_PLUGINS=ON \
276   -DENABLE_NETLINK=ON
277
278 %{__make}
279
280 %install
281 rm -rf $RPM_BUILD_ROOT
282 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_includedir}/wireshark}
283
284 %{__make} install \
285         DESTDIR=$RPM_BUILD_ROOT
286
287 cp -p image/wsicon48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
288
289 %{?with_gui:cp -p wireshark.desktop $RPM_BUILD_ROOT%{_desktopdir}/wireshark.desktop}
290
291 # headers (from Fedora, inspired by debian/wireshark-dev.header-files)
292 install -d $RPM_BUILD_ROOT%{_includedir}/wireshark/{epan/{crypt,ftypes,dfilter,dissectors,wmem},wiretap,wsutil}
293 install config.h            $RPM_BUILD_ROOT%{_includedir}/wireshark
294 install cfile.h file.h      $RPM_BUILD_ROOT%{_includedir}/wireshark
295 install ws_diag_control.h   $RPM_BUILD_ROOT%{_includedir}/wireshark
296 install ws_symbol_export.h  $RPM_BUILD_ROOT%{_includedir}/wireshark
297 install epan/*.h            $RPM_BUILD_ROOT%{_includedir}/wireshark/epan
298 install epan/crypt/*.h      $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/crypt
299 install epan/ftypes/*.h     $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/ftypes
300 install epan/dfilter/*.h    $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/dfilter
301 install epan/dissectors/*.h $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/dissectors
302 install epan/wmem/*.h       $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/wmem
303 install wiretap/*.h         $RPM_BUILD_ROOT%{_includedir}/wireshark/wiretap
304 install wsutil/*.h          $RPM_BUILD_ROOT%{_includedir}/wireshark/wsutil
305
306 # plugins *.la are useless - *.so are loaded through gmodule
307 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*/*/*.la
308
309 %clean
310 rm -rf $RPM_BUILD_ROOT
311
312 %pre
313 %update_mime_database
314
315 %postun
316 %update_mime_database
317
318 %pre    common
319 %groupadd -P %{name}-common -g 104 wireshark
320
321 %post   common
322 /sbin/setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' %{_bindir}/dumpcap
323 exit 0
324
325 %postun common
326 if [ "$1" = "0" ]; then
327         %groupremove wireshark
328 fi
329
330 %post   libs -p /sbin/ldconfig
331 %postun libs -p /sbin/ldconfig
332
333 %if %{with gui}
334 %files
335 %defattr(644,root,root,755)
336 %attr(755,root,root) %{_bindir}/wireshark
337 %{_desktopdir}/wireshark.desktop
338 #%{_datadir}/%{name}
339 %{_datadir}/appdata/wireshark.appdata.xml
340 %{_datadir}/mime/packages/wireshark.xml
341 %{_pixmapsdir}/%{name}.png
342 %{_iconsdir}/hicolor/16x16/apps/%{name}.png
343 %{_iconsdir}/hicolor/16x16/mimetypes/application-%{name}-doc.png
344 %{_iconsdir}/hicolor/24x24/apps/%{name}.png
345 %{_iconsdir}/hicolor/24x24/mimetypes/application-%{name}-doc.png
346 %{_iconsdir}/hicolor/32x32/apps/%{name}.png
347 %{_iconsdir}/hicolor/32x32/mimetypes/application-%{name}-doc.png
348 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
349 %{_iconsdir}/hicolor/48x48/mimetypes/application-%{name}-doc.png
350 %{_iconsdir}/hicolor/64x64/apps/%{name}.png
351 %{_iconsdir}/hicolor/64x64/mimetypes/application-%{name}-doc.png
352 %{_iconsdir}/hicolor/128x128/apps/%{name}.png
353 %{_iconsdir}/hicolor/128x128/mimetypes/application-%{name}-doc.png
354 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
355 %{_iconsdir}/hicolor/256x256/mimetypes/application-%{name}-doc.png
356 %{_iconsdir}/hicolor/scalable/apps/%{name}.svg
357 %{_mandir}/man1/wireshark.1*
358 %endif
359
360 %files common
361 %defattr(644,root,root,755)
362 %doc AUTHORS* ChangeLog NEWS README.md README.linux doc/README.*
363 %dir %{_libdir}/%{name}
364 %dir %{_libdir}/%{name}/extcap
365 %dir %{_libdir}/%{name}/plugins
366 %dir %{_libdir}/%{name}/plugins/3.0
367 %dir %{_libdir}/%{name}/plugins/3.0/codecs
368 %dir %{_libdir}/%{name}/plugins/3.0/epan
369 %dir %{_libdir}/%{name}/plugins/3.0/wiretap
370 %attr(755,root,root) %{_libdir}/%{name}/extcap/androiddump
371 %attr(755,root,root) %{_libdir}/%{name}/extcap/ciscodump
372 %attr(755,root,root) %{_libdir}/%{name}/extcap/dpauxmon
373 %attr(755,root,root) %{_libdir}/%{name}/extcap/randpktdump
374 %attr(755,root,root) %{_libdir}/%{name}/extcap/sshdump
375 %attr(755,root,root) %{_libdir}/%{name}/extcap/sdjournal
376 %attr(755,root,root) %{_libdir}/%{name}/extcap/udpdump
377 %attr(755,root,root) %{_libdir}/%{name}/plugins/3.0/codecs/*.so
378 %attr(755,root,root) %{_libdir}/%{name}/plugins/3.0/epan/*.so
379 %attr(755,root,root) %{_libdir}/%{name}/plugins/3.0/wiretap/*.so
380 %attr(755,root,root) %{_bindir}/capinfos
381 %attr(755,root,root) %{_bindir}/captype
382 #%attr(755,root,root) %{_bindir}/dftest
383 %attr(750,root,wireshark) %{_bindir}/dumpcap
384 %attr(755,root,root) %{_bindir}/editcap
385 %attr(755,root,root) %{_bindir}/idl2wrs
386 %attr(755,root,root) %{_bindir}/mergecap
387 %attr(755,root,root) %{_bindir}/mmdbresolve
388 %attr(755,root,root) %{_bindir}/randpkt
389 %attr(755,root,root) %{_bindir}/rawshark
390 %attr(755,root,root) %{_bindir}/reordercap
391 %attr(755,root,root) %{_bindir}/sharkd
392 %attr(755,root,root) %{_bindir}/text2pcap
393 #%attr(755,root,root) %{_bindir}/tfshark
394 %{_mandir}/man1/androiddump.1*
395 %{_mandir}/man1/capinfos.1*
396 %{_mandir}/man1/captype.1*
397 %{_mandir}/man1/ciscodump.1*
398 %{_mandir}/man1/dftest.1*
399 %{_mandir}/man1/dumpcap.1*
400 %{_mandir}/man1/editcap.1*
401 %{_mandir}/man1/mergecap.1*
402 %{_mandir}/man1/mmdbresolve.1*
403 %{_mandir}/man1/rawshark.1*
404 %{_mandir}/man1/randpkt.1*
405 %{_mandir}/man1/randpktdump.1*
406 %{_mandir}/man1/reordercap.1*
407 %{_mandir}/man1/sshdump.1*
408 %{_mandir}/man1/text2pcap.1*
409 %{_mandir}/man1/udpdump.1*
410 %{_mandir}/man4/extcap.4*
411 %{_mandir}/man4/wireshark-filter.4*
412
413 %files -n twireshark
414 %defattr(644,root,root,755)
415 %attr(755,root,root) %{_bindir}/tshark
416 %{_mandir}/man1/tshark*.1*
417
418 %files libs
419 %defattr(644,root,root,755)
420 #%doc wiretap/README*
421 %attr(755,root,root) %{_libdir}/libwireshark.so.*.*.*
422 %attr(755,root,root) %ghost %{_libdir}/libwireshark.so.12
423 %attr(755,root,root) %{_libdir}/libwiretap.so.*.*.*
424 %attr(755,root,root) %ghost %{_libdir}/libwiretap.so.9
425 %attr(755,root,root) %{_libdir}/libwscodecs.so.*.*.*
426 %attr(755,root,root) %ghost %{_libdir}/libwscodecs.so.2
427 %attr(755,root,root) %{_libdir}/libwsutil.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libwsutil.so.10
429
430 %files devel
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_libdir}/libwireshark.so
433 %attr(755,root,root) %{_libdir}/libwiretap.so
434 %attr(755,root,root) %{_libdir}/libwscodecs.so
435 %attr(755,root,root) %{_libdir}/libwsutil.so
436 #%{_libdir}/libwireshark.la
437 #%{_libdir}/libwiretap.la
438 #%{_libdir}/libwscodecs.la
439 #%{_libdir}/libwsutil.la
440 %{_includedir}/wireshark
441 %{_pkgconfigdir}/wireshark.pc
This page took 0.071042 seconds and 4 git commands to generate.