]> git.pld-linux.org Git - packages/wireshark.git/blob - wireshark.spec
- updated dependencies (including recommended versions)
[packages/wireshark.git] / wireshark.spec
1 # TODO
2 # - use policykit to gain root
3 # - use %caps when rpm supports it: %attr(750,root,wireshark) %caps(cap_net_raw,cap_net_admin=eip) %{_sbindir}/dumpcap
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # Kerberos V support
7 %bcond_without  snmp            # SNMP support
8 %bcond_without  gui             # without QT GUI
9
10 %define         branch_ver      3.6
11 %define         qt_ver          5.6
12 Summary:        Network traffic and protocol analyzer
13 Summary(es.UTF-8):      Analizador de tráfico de red
14 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych
15 Summary(pt_BR.UTF-8):   Analisador de tráfego de rede
16 Summary(ru.UTF-8):      Анализатор сетевого траффика
17 Summary(uk.UTF-8):      Аналізатор мережевого трафіку
18 Name:           wireshark
19 Version:        3.6.6
20 Release:        1
21 License:        GPL v2+
22 Group:          Networking/Utilities
23 Source0:        https://www.wireshark.org/download/src/%{name}-%{version}.tar.xz
24 # Source0-md5:  f81b515660d496543af50a06048d8c4d
25 URL:            https://www.wireshark.org/
26 BuildRequires:  bcg729-devel
27 BuildRequires:  bison
28 BuildRequires:  c-ares-devel >= 1.5.0
29 BuildRequires:  cmake >= 3.5
30 BuildRequires:  doxygen
31 BuildRequires:  flex
32 BuildRequires:  gcc >= 5:3.2
33 BuildRequires:  gettext-tools
34 BuildRequires:  glib2-devel >= 1:2.38
35 BuildRequires:  gnutls-devel >= 3.4.0
36 %{?with_kerberos5:BuildRequires:        heimdal-devel}
37 BuildRequires:  libbrotli-devel
38 BuildRequires:  libcap-devel
39 BuildRequires:  libgcrypt-devel >= 1.8.0
40 BuildRequires:  libmaxminddb-devel
41 BuildRequires:  libnl-devel >= 3.2
42 BuildRequires:  libpcap-devel >= 2:1.0.0-4
43 BuildRequires:  libsmi-devel
44 BuildRequires:  libssh-devel >= 0.6.0
45 BuildRequires:  libstdc++-devel >= 6:4.7
46 BuildRequires:  libtool >= 2:2.2.2
47 BuildRequires:  libxml2-devel >= 2.0
48 BuildRequires:  libxslt-progs
49 BuildRequires:  lua52-devel
50 BuildRequires:  lz4-devel
51 BuildRequires:  minizip-devel
52 %{?with_snmp:BuildRequires:     net-snmp-devel}
53 BuildRequires:  nghttp2-devel
54 BuildRequires:  opus-devel
55 BuildRequires:  perl-tools-pod
56 BuildRequires:  pkgconfig >= 1:0.7
57 BuildRequires:  python3 >= 1:3.4
58 BuildRequires:  rpmbuild(macros) >= 1.527
59 BuildRequires:  ruby-asciidoctor >= 1.5
60 %{?with_gui:BuildRequires:      sbc-devel >= 1.0}
61 BuildRequires:  sed >= 4.0
62 BuildRequires:  snappy-devel
63 BuildRequires:  spandsp-devel
64 %{?with_gui:BuildRequires:      speexdsp-devel}
65 BuildRequires:  systemd-devel
66 BuildRequires:  tar >= 1:1.22
67 BuildRequires:  webrtc-libilbc-devel
68 BuildRequires:  w3m
69 BuildRequires:  xz
70 BuildRequires:  zlib-devel
71 BuildRequires:  zstd-devel >= 1.0.0
72 %if %{with gui}
73 BuildRequires:  Qt5Core-devel >= %{qt_ver}
74 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
75 BuildRequires:  Qt5Multimedia-devel >= %{qt_ver}
76 BuildRequires:  Qt5PrintSupport-devel >= %{qt_ver}
77 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
78 BuildRequires:  libstdc++-devel >= 6:5
79 BuildRequires:  qt5-build >= %{qt_ver}
80 BuildRequires:  qt5-linguist >= %{qt_ver}
81 %endif
82 Requires(post,postun):  gtk-update-icon-cache
83 Requires(post,postun):  shared-mime-info
84 Requires:       Qt5Core >= %{qt_ver}
85 Requires:       Qt5Gui >= %{qt_ver}
86 Requires:       Qt5Multimedia >= %{qt_ver}
87 Requires:       Qt5PrintSupport >= %{qt_ver}
88 Requires:       Qt5Widgets >= %{qt_ver}
89 Requires:       gdk-pixbuf2 >= 2.26
90 Requires:       hicolor-icon-theme
91 Suggests:       xdg-utils
92 Provides:       ethereal
93 Provides:       ethereal-gnome
94 Obsoletes:      ethereal < 1
95 Obsoletes:      ethereal-gnome < 1
96 Obsoletes:      wireshark-gui-common < 3
97 Obsoletes:      wireshark-qt < 3
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101 Wireshark is the name for powerful graphical network sniffer, traffic
102 and protocol analyzer based on QT and libpcap libraries. It lets you
103 capture and interactively browse the contents of network frames with
104 vast knowledge of more than 100 network protocols. Wireshark has
105 severeal useful features, including a rich display filter language,
106 the ability to view the ASCII contents of a TCP connection and plug-in
107 capabilities.
108
109 %description -l es.UTF-8
110 Analizador de tráfico de red.
111
112 %description -l pl.UTF-8
113 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
114 protokołów sieciowych opartym na bibliotekach QT oraz libpcap.
115 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
116 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
117 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
118 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
119 wtyczek (plug-ins).
120
121 %description -l pt_BR.UTF-8
122 O Wireshark é um analisador de protocolo de rede baseado no QT.
123
124 %description -l ru.UTF-8
125 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
126 базируется на QT и libpcap.
127
128 %description -l uk.UTF-8
129 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
130 базується на QT та libpcap.
131
132 %package common
133 Summary:        Network traffic and protocol analyzer - common files
134 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych - wspólne pliki
135 Group:          Networking
136 Requires(post,postun):  /sbin/setcap
137 Requires:       %{name}-libs = %{version}-%{release}
138 Requires:       gnutls >= 3.4.0
139 Requires:       libpcap >= 0.4
140 Requires:       libssh >= 0.6.0
141 Provides:       ethereal-common
142 Provides:       group(wireshark)
143 Provides:       wireshark-tools
144 Obsoletes:      ethereal-common < 1
145 Obsoletes:      wireshark-tools < 1.0.3-3
146
147 %description common
148 Wireshark is the name for powerful graphical network sniffer, traffic
149 and protocol analyzer based on QT and libpcap libraries. It lets you
150 capture and interactively browse the contents of network frames with
151 vast knowledge of more than 100 network protocols. Wireshark has
152 severeal useful features, including a rich display filter language,
153 the ability to view the ASCII contents of a TCP connection and plug-in
154 capabilities.
155
156 This package provides the shared library, plugins, data and a set of
157 tools for manipulating capture files. It contains:
158 - capinfos - prints informatio about binary capture files,
159 - captype - prints the file types of capture files,
160 - dftest - shows display filter byte-code,
161 - dumpcap - dumps network traffic to a file,
162 - editcap - edit and/or translate the format of capture files,
163 - mergecap - merges two capture files into one,
164 - randpkt - generates libpcap trace file full of random packets,
165 - rawshark - dumps and analyzes raw libpcap data,
166 - text2cap - generate a capture file from an ASCII hexdump of packets.
167
168 %description common -l es.UTF-8
169 Analizador de tráfico de red.
170
171 %description common -l pl.UTF-8
172 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
173 protokołów sieciowych opartym na bibliotekach QT oraz libpcap.
174 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
175 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
176 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
177 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
178 wtyczek (plug-ins).
179
180 Ten pakiet ten zawiera bibliotekę współdzieloną, wtyczki, dane oraz
181 zestaw narzędzi do obróbki plików z przechwyconymi pakietami,
182 obejmujący:
183 - capinfos - do wyświetlania informacji o binarnych plikach zrzutu,
184 - captype - do wyświetlania rodzaju plików zrzutu,
185 - dftest - do pokazywania bajtkodu filtrów wyświetlania,
186 - dumpcap - do zrzucania ruchu sieciowego do pliku,
187 - editcap - do edycji plików i tłumaczenia ich na inne formaty,
188 - mergecap - do łączenia dwóch plików w jeden,
189 - randpkt - do generowania plikow cap z losowymi danymi,
190 - rawshark - do obróbki plików cap,
191 - text2cap - do generowania pliku cap z szesnastkowego zrzutu ASCII
192   pakietów.
193
194 %description common -l pt_BR.UTF-8
195 O Wireshark é um analisador de protocolo de rede baseado no QT.
196
197 %description common -l ru.UTF-8
198 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
199 базируется на QT и libpcap.
200
201 %description common -l uk.UTF-8
202 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
203 базується на QT та libpcap.
204
205 %package -n twireshark
206 Summary:        Text-mode network traffic and protocol analyzer
207 Summary(pl.UTF-8):      Tekstowy analizator ruchu i protokołów sieciowych
208 Summary(pt_BR.UTF-8):   Analisador modo texto de tráfego de rede (sniffer)
209 Group:          Networking
210 Requires:       %{name}-common = %{version}-%{release}
211 Requires:       libpcap >= 0.4
212 Provides:       tethereal
213 Obsoletes:      tethereal < 1
214
215 %description -n twireshark
216 Twireshark is a network protocol analyzer. It lets you capture packet
217 data from a live network, or read packets from a previously saved
218 capture file, either printing a decoded form of those packets to the
219 standard output or writing the packets to a file. Twireshark's native
220 capture file format is libpcap format, which is also the format used
221 by tcpdump and various other tools.
222
223 %description -n twireshark -l pl.UTF-8
224 Twireshark jest analizatorem protokołów sieciowych. Pozwala na
225 przechwytywanie pakietów z sieci lub wczytywanie danych z pliku.
226 Zdekodowany wynik (a twireshark zna ponad 100 rozmaitych protokołów
227 sieciowych!) jest wyświetlony na ekranie. Natywnym formatem plików
228 tetherala jest format libpcap, tak więc jest on kompatybilny z
229 tcpdumpem i innymi podobnymi narzędziami.
230
231 %description -n twireshark -l pt_BR.UTF-8
232 Esta é uma versão para modo texto do analisador de tráfego de rede
233 Wireshark.
234
235 %package libs
236 Summary:        Wireshark packet capture and dissection libraries
237 Summary(pl.UTF-8):      Biblioteki Wiresharka do przechwytywania i sekcji pakietów
238 Group:          Libraries
239 Requires:       c-ares >= 1.5.0
240 Requires:       glib2 >= 1:2.38
241 Requires:       libgcrypt >= 1.8.0
242 Requires:       libnl >= 3.2
243 Requires:       zstd >= 1.0.0
244 Obsoletes:      libwiretap < 2.4.0
245
246 %description libs
247 Wireshark packet capture and dissection libraries.
248
249 %description libs -l pl.UTF-8
250 Biblioteki Wiresharka do przechwytywania i sekcji pakietów.
251
252 %package devel
253 Summary:        Header files for Wireshark libraries
254 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wiresharka
255 Group:          Development/Libraries
256 Requires:       %{name}-libs = %{version}-%{release}
257 Requires:       glib2-devel >= 1:2.38
258 Requires:       libgcrypt-devel >= 1.8.0
259 Requires:       libnl-devel >= 3.2
260 Obsoletes:      libwiretap-devel < 2.4.0
261
262 %description devel
263 Header files for Wireshark libraries.
264
265 %description devel -l pl.UTF-8
266 Pliki nagłówkowe bibliotek Wiresharka.
267
268 %prep
269 %setup -q
270
271 %build
272 install -d build
273 cd build
274 %cmake .. \
275         -DBUILD_androiddump=ON \
276         -DBUILD_corbaidl2wrs=ON \
277         -DBUILD_dcerpcidl2wrs=ON \
278         -DBUILD_mmdbresolve=ON \
279         -DBUILD_randpktdump=ON \
280         -DBUILD_tfshark=OFF \
281         -DBUILD_wireshark=ON \
282         -DCMAKE_INSTALL_DATADIR:PATH=share/wireshark \
283         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
284         -DDISABLE_WERROR=ON \
285         -DENABLE_LUA=ON \
286         -DENABLE_NETLINK=ON \
287         -DENABLE_PLUGINS=ON \
288         -DENABLE_PORTAUDIO=ON \
289         -DENABLE_QT5=ON \
290         -DENABLE_SMI=ON
291
292 %{__make}
293
294 %install
295 rm -rf $RPM_BUILD_ROOT
296
297 %{__make} -C build install \
298         DESTDIR=$RPM_BUILD_ROOT
299
300 # used by installed headers, but not installed by cmake
301 cp -p build/config.h $RPM_BUILD_ROOT%{_includedir}/wireshark
302
303 %clean
304 rm -rf $RPM_BUILD_ROOT
305
306 %pre
307 %update_icon_cache hicolor
308 %update_mime_database
309
310 %postun
311 %update_icon_cache hicolor
312 %update_mime_database
313
314 %pre    common
315 %groupadd -P %{name}-common -g 104 wireshark
316
317 %post   common
318 /sbin/setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' %{_bindir}/dumpcap
319 exit 0
320
321 %postun common
322 if [ "$1" = "0" ]; then
323         %groupremove wireshark
324 fi
325
326 %post   libs -p /sbin/ldconfig
327 %postun libs -p /sbin/ldconfig
328
329 %if %{with gui}
330 %files
331 %defattr(644,root,root,755)
332 %attr(755,root,root) %{_bindir}/wireshark
333 %{_desktopdir}/org.wireshark.Wireshark.desktop
334 %{_datadir}/%{name}
335 %{_datadir}/metainfo/org.wireshark.Wireshark.metainfo.xml
336 %{_datadir}/mime/packages/org.wireshark.Wireshark.xml
337 %{_iconsdir}/hicolor/16x16/apps/org.wireshark.Wireshark.png
338 %{_iconsdir}/hicolor/16x16/mimetypes/org.wireshark.Wireshark-mimetype.png
339 %{_iconsdir}/hicolor/24x24/apps/org.wireshark.Wireshark.png
340 %{_iconsdir}/hicolor/24x24/mimetypes/org.wireshark.Wireshark-mimetype.png
341 %{_iconsdir}/hicolor/32x32/apps/org.wireshark.Wireshark.png
342 %{_iconsdir}/hicolor/32x32/mimetypes/org.wireshark.Wireshark-mimetype.png
343 %{_iconsdir}/hicolor/48x48/apps/org.wireshark.Wireshark.png
344 %{_iconsdir}/hicolor/48x48/mimetypes/org.wireshark.Wireshark-mimetype.png
345 %{_iconsdir}/hicolor/64x64/apps/org.wireshark.Wireshark.png
346 %{_iconsdir}/hicolor/64x64/mimetypes/org.wireshark.Wireshark-mimetype.png
347 %{_iconsdir}/hicolor/128x128/apps/org.wireshark.Wireshark.png
348 %{_iconsdir}/hicolor/128x128/mimetypes/org.wireshark.Wireshark-mimetype.png
349 %{_iconsdir}/hicolor/256x256/apps/org.wireshark.Wireshark.png
350 %{_iconsdir}/hicolor/256x256/mimetypes/org.wireshark.Wireshark-mimetype.png
351 %{_iconsdir}/hicolor/scalable/apps/org.wireshark.Wireshark.svg
352 %{_mandir}/man1/wireshark.1*
353 %endif
354
355 %files common
356 %defattr(644,root,root,755)
357 %doc AUTHORS* ChangeLog NEWS README.md README.linux doc/README.*
358 %dir %{_libdir}/%{name}/extcap
359 %dir %{_libdir}/%{name}/plugins
360 %dir %{_libdir}/%{name}/plugins/%{branch_ver}
361 %dir %{_libdir}/%{name}/plugins/%{branch_ver}/codecs
362 %dir %{_libdir}/%{name}/plugins/%{branch_ver}/epan
363 %dir %{_libdir}/%{name}/plugins/%{branch_ver}/wiretap
364 %attr(755,root,root) %{_libdir}/%{name}/extcap/androiddump
365 %attr(755,root,root) %{_libdir}/%{name}/extcap/ciscodump
366 %attr(755,root,root) %{_libdir}/%{name}/extcap/dpauxmon
367 %attr(755,root,root) %{_libdir}/%{name}/extcap/randpktdump
368 %attr(755,root,root) %{_libdir}/%{name}/extcap/sshdump
369 %attr(755,root,root) %{_libdir}/%{name}/extcap/sdjournal
370 %attr(755,root,root) %{_libdir}/%{name}/extcap/udpdump
371 %attr(755,root,root) %{_libdir}/%{name}/plugins/%{branch_ver}/codecs/*.so
372 %attr(755,root,root) %{_libdir}/%{name}/plugins/%{branch_ver}/epan/*.so
373 %attr(755,root,root) %{_libdir}/%{name}/plugins/%{branch_ver}/wiretap/*.so
374 %attr(755,root,root) %{_bindir}/capinfos
375 %attr(755,root,root) %{_bindir}/captype
376 %attr(750,root,wireshark) %{_bindir}/dumpcap
377 %attr(755,root,root) %{_bindir}/editcap
378 %attr(755,root,root) %{_bindir}/idl2wrs
379 %attr(755,root,root) %{_bindir}/mergecap
380 %attr(755,root,root) %{_bindir}/mmdbresolve
381 %attr(755,root,root) %{_bindir}/randpkt
382 %attr(755,root,root) %{_bindir}/rawshark
383 %attr(755,root,root) %{_bindir}/reordercap
384 %attr(755,root,root) %{_bindir}/sharkd
385 %attr(755,root,root) %{_bindir}/text2pcap
386 %{_mandir}/man1/androiddump.1*
387 %{_mandir}/man1/capinfos.1*
388 %{_mandir}/man1/captype.1*
389 %{_mandir}/man1/ciscodump.1*
390 %{_mandir}/man1/dftest.1*
391 %{_mandir}/man1/dpauxmon.1*
392 %{_mandir}/man1/dumpcap.1*
393 %{_mandir}/man1/editcap.1*
394 %{_mandir}/man1/etwdump.1.*
395 %{_mandir}/man1/idl2wrs.1*
396 %{_mandir}/man1/mergecap.1*
397 %{_mandir}/man1/mmdbresolve.1*
398 %{_mandir}/man1/rawshark.1*
399 %{_mandir}/man1/randpkt.1*
400 %{_mandir}/man1/randpktdump.1*
401 %{_mandir}/man1/reordercap.1*
402 %{_mandir}/man1/sdjournal.1*
403 %{_mandir}/man1/sshdump.1*
404 %{_mandir}/man1/text2pcap.1*
405 %{_mandir}/man1/udpdump.1*
406 %{_mandir}/man4/extcap.4*
407 %{_mandir}/man4/wireshark-filter.4*
408
409 %files -n twireshark
410 %defattr(644,root,root,755)
411 %attr(755,root,root) %{_bindir}/tshark
412 %{_mandir}/man1/tshark*.1*
413
414 %files libs
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_libdir}/libwireshark.so.*.*.*
417 %attr(755,root,root) %ghost %{_libdir}/libwireshark.so.15
418 %attr(755,root,root) %{_libdir}/libwiretap.so.*.*.*
419 %attr(755,root,root) %ghost %{_libdir}/libwiretap.so.12
420 %attr(755,root,root) %{_libdir}/libwsutil.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/libwsutil.so.13
422 %dir %{_libdir}/%{name}
423
424 %files devel
425 %defattr(644,root,root,755)
426 %doc wiretap/{README,README.airmagnet}
427 %attr(755,root,root) %{_libdir}/libwireshark.so
428 %attr(755,root,root) %{_libdir}/libwiretap.so
429 %attr(755,root,root) %{_libdir}/libwsutil.so
430 %{_includedir}/wireshark
431 %{_pkgconfigdir}/wireshark.pc
432 %{_libdir}/%{name}/cmake
This page took 0.178213 seconds and 4 git commands to generate.