]> git.pld-linux.org Git - packages/wireshark.git/blob - wireshark.spec
R: -common in gui
[packages/wireshark.git] / wireshark.spec
1 # TODO
2 # - use policykit to gain root
3 # - use %caps when rpm supports it: %attr(750,root,wireshark) %caps(cap_net_raw,cap_net_admin=eip) %{_sbindir}/dumpcap
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # Kerberos V support
7 %bcond_without  snmp            # SNMP support
8 %bcond_without  gui             # without QT GUI
9
10 %define         branch_ver      4.0
11 %define         qt_ver          5.12
12 Summary:        Network traffic and protocol analyzer
13 Summary(es.UTF-8):      Analizador de tráfico de red
14 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych
15 Summary(pt_BR.UTF-8):   Analisador de tráfego de rede
16 Summary(ru.UTF-8):      Анализатор сетевого траффика
17 Summary(uk.UTF-8):      Аналізатор мережевого трафіку
18 Name:           wireshark
19 Version:        4.0.6
20 Release:        1
21 License:        GPL v2+
22 Group:          Networking/Utilities
23 Source0:        https://2.na.dl.wireshark.org/src/%{name}-%{version}.tar.xz
24 # Source0-md5:  0994f7f327e0562f7a69bb4fa956dc7f
25 URL:            https://www.wireshark.org/
26 BuildRequires:  bcg729-devel
27 BuildRequires:  bison
28 BuildRequires:  c-ares-devel >= 1.13.0
29 BuildRequires:  cmake >= 3.10
30 BuildRequires:  doxygen
31 BuildRequires:  flex
32 BuildRequires:  gcc >= 5:3.2
33 BuildRequires:  gettext-tools
34 BuildRequires:  glib2-devel >= 1:2.50.0
35 BuildRequires:  gnutls-devel >= 3.5.8
36 %{?with_kerberos5:BuildRequires:        heimdal-devel}
37 BuildRequires:  libbrotli-devel
38 # libcap-devel doesn't pull libcap, but only libcap-libs
39 BuildRequires:  libcap
40 BuildRequires:  libcap-devel
41 BuildRequires:  libgcrypt-devel >= 1.8.0
42 BuildRequires:  libmaxminddb-devel
43 BuildRequires:  libnl-devel >= 3.2
44 BuildRequires:  libpcap-devel >= 2:1.0.0-4
45 BuildRequires:  libsmi-devel
46 BuildRequires:  libssh-devel >= 0.6.0
47 BuildRequires:  libstdc++-devel >= 6:4.7
48 BuildRequires:  libtool >= 2:2.2.2
49 BuildRequires:  libxml2-devel >= 2.0
50 BuildRequires:  libxslt-progs
51 BuildRequires:  lua52-devel
52 BuildRequires:  lz4-devel
53 BuildRequires:  minizip-devel
54 %{?with_snmp:BuildRequires:     net-snmp-devel}
55 BuildRequires:  nghttp2-devel >= 1.11.0
56 BuildRequires:  opus-devel
57 BuildRequires:  perl-tools-pod
58 BuildRequires:  pkgconfig >= 1:0.7
59 BuildRequires:  python3 >= 1:3.6
60 BuildRequires:  rpmbuild(macros) >= 1.605
61 BuildRequires:  ruby-asciidoctor >= 1.5
62 %{?with_gui:BuildRequires:      sbc-devel >= 1.0}
63 BuildRequires:  sed >= 4.0
64 BuildRequires:  snappy-devel
65 BuildRequires:  spandsp-devel
66 %{?with_gui:BuildRequires:      speexdsp-devel}
67 BuildRequires:  systemd-devel
68 BuildRequires:  tar >= 1:1.22
69 BuildRequires:  webrtc-libilbc-devel
70 BuildRequires:  w3m
71 BuildRequires:  xz
72 BuildRequires:  zlib-devel
73 BuildRequires:  zstd-devel >= 1.0.0
74 %if %{with gui}
75 BuildRequires:  Qt5Concurrent-devel >= %{qt_ver}
76 BuildRequires:  Qt5Core-devel >= %{qt_ver}
77 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
78 BuildRequires:  Qt5Multimedia-devel >= %{qt_ver}
79 BuildRequires:  Qt5PrintSupport-devel >= %{qt_ver}
80 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
81 BuildRequires:  libstdc++-devel >= 6:5
82 BuildRequires:  qt5-build >= %{qt_ver}
83 BuildRequires:  qt5-linguist >= %{qt_ver}
84 %endif
85 Requires(post,postun):  desktop-file-utils
86 Requires(post,postun):  gtk-update-icon-cache
87 Requires(post,postun):  shared-mime-info
88 Requires:       %{name}-common = %{version}-%{release}
89 Requires:       Qt5Core >= %{qt_ver}
90 Requires:       Qt5Gui >= %{qt_ver}
91 Requires:       Qt5Multimedia >= %{qt_ver}
92 Requires:       Qt5PrintSupport >= %{qt_ver}
93 Requires:       Qt5Widgets >= %{qt_ver}
94 Requires:       gdk-pixbuf2 >= 2.26
95 Requires:       hicolor-icon-theme
96 Suggests:       xdg-utils
97 Provides:       ethereal
98 Provides:       ethereal-gnome
99 Obsoletes:      ethereal < 1
100 Obsoletes:      ethereal-gnome < 1
101 Obsoletes:      wireshark-gui-common < 3
102 Obsoletes:      wireshark-qt < 3
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %description
106 Wireshark is the name for powerful graphical network sniffer, traffic
107 and protocol analyzer based on QT and libpcap libraries. It lets you
108 capture and interactively browse the contents of network frames with
109 vast knowledge of more than 100 network protocols. Wireshark has
110 severeal useful features, including a rich display filter language,
111 the ability to view the ASCII contents of a TCP connection and plug-in
112 capabilities.
113
114 %description -l es.UTF-8
115 Analizador de tráfico de red.
116
117 %description -l pl.UTF-8
118 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
119 protokołów sieciowych opartym na bibliotekach QT oraz libpcap.
120 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
121 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
122 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
123 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
124 wtyczek (plug-ins).
125
126 %description -l pt_BR.UTF-8
127 O Wireshark é um analisador de protocolo de rede baseado no QT.
128
129 %description -l ru.UTF-8
130 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
131 базируется на QT и libpcap.
132
133 %description -l uk.UTF-8
134 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
135 базується на QT та libpcap.
136
137 %package common
138 Summary:        Network traffic and protocol analyzer - common files
139 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych - wspólne pliki
140 Group:          Networking
141 Requires(post,postun):  /sbin/setcap
142 Requires:       %{name}-libs = %{version}-%{release}
143 Requires:       gnutls >= 3.5.8
144 Requires:       libpcap >= 0.4
145 Requires:       libssh >= 0.6.0
146 Provides:       ethereal-common
147 Provides:       group(wireshark)
148 Provides:       wireshark-tools
149 Obsoletes:      ethereal-common < 1
150 Obsoletes:      wireshark-tools < 1.0.3-3
151
152 %description common
153 Wireshark is the name for powerful graphical network sniffer, traffic
154 and protocol analyzer based on QT and libpcap libraries. It lets you
155 capture and interactively browse the contents of network frames with
156 vast knowledge of more than 100 network protocols. Wireshark has
157 severeal useful features, including a rich display filter language,
158 the ability to view the ASCII contents of a TCP connection and plug-in
159 capabilities.
160
161 This package provides the shared library, plugins, data and a set of
162 tools for manipulating capture files. It contains:
163 - capinfos - prints informatio about binary capture files,
164 - captype - prints the file types of capture files,
165 - dftest - shows display filter byte-code,
166 - dumpcap - dumps network traffic to a file,
167 - editcap - edit and/or translate the format of capture files,
168 - mergecap - merges two capture files into one,
169 - randpkt - generates libpcap trace file full of random packets,
170 - rawshark - dumps and analyzes raw libpcap data,
171 - text2cap - generate a capture file from an ASCII hexdump of packets.
172
173 %description common -l es.UTF-8
174 Analizador de tráfico de red.
175
176 %description common -l pl.UTF-8
177 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
178 protokołów sieciowych opartym na bibliotekach QT oraz libpcap.
179 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
180 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
181 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
182 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
183 wtyczek (plug-ins).
184
185 Ten pakiet ten zawiera bibliotekę współdzieloną, wtyczki, dane oraz
186 zestaw narzędzi do obróbki plików z przechwyconymi pakietami,
187 obejmujący:
188 - capinfos - do wyświetlania informacji o binarnych plikach zrzutu,
189 - captype - do wyświetlania rodzaju plików zrzutu,
190 - dftest - do pokazywania bajtkodu filtrów wyświetlania,
191 - dumpcap - do zrzucania ruchu sieciowego do pliku,
192 - editcap - do edycji plików i tłumaczenia ich na inne formaty,
193 - mergecap - do łączenia dwóch plików w jeden,
194 - randpkt - do generowania plikow cap z losowymi danymi,
195 - rawshark - do obróbki plików cap,
196 - text2cap - do generowania pliku cap z szesnastkowego zrzutu ASCII
197   pakietów.
198
199 %description common -l pt_BR.UTF-8
200 O Wireshark é um analisador de protocolo de rede baseado no QT.
201
202 %description common -l ru.UTF-8
203 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
204 базируется на QT и libpcap.
205
206 %description common -l uk.UTF-8
207 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
208 базується на QT та libpcap.
209
210 %package -n twireshark
211 Summary:        Text-mode network traffic and protocol analyzer
212 Summary(pl.UTF-8):      Tekstowy analizator ruchu i protokołów sieciowych
213 Summary(pt_BR.UTF-8):   Analisador modo texto de tráfego de rede (sniffer)
214 Group:          Networking
215 Requires:       %{name}-common = %{version}-%{release}
216 Requires:       libpcap >= 0.4
217 Provides:       tethereal
218 Obsoletes:      tethereal < 1
219
220 %description -n twireshark
221 Twireshark is a network protocol analyzer. It lets you capture packet
222 data from a live network, or read packets from a previously saved
223 capture file, either printing a decoded form of those packets to the
224 standard output or writing the packets to a file. Twireshark's native
225 capture file format is libpcap format, which is also the format used
226 by tcpdump and various other tools.
227
228 %description -n twireshark -l pl.UTF-8
229 Twireshark jest analizatorem protokołów sieciowych. Pozwala na
230 przechwytywanie pakietów z sieci lub wczytywanie danych z pliku.
231 Zdekodowany wynik (a twireshark zna ponad 100 rozmaitych protokołów
232 sieciowych!) jest wyświetlony na ekranie. Natywnym formatem plików
233 tetherala jest format libpcap, tak więc jest on kompatybilny z
234 tcpdumpem i innymi podobnymi narzędziami.
235
236 %description -n twireshark -l pt_BR.UTF-8
237 Esta é uma versão para modo texto do analisador de tráfego de rede
238 Wireshark.
239
240 %package libs
241 Summary:        Wireshark packet capture and dissection libraries
242 Summary(pl.UTF-8):      Biblioteki Wiresharka do przechwytywania i sekcji pakietów
243 Group:          Libraries
244 Requires:       c-ares >= 1.13.0
245 Requires:       glib2 >= 1:2.50.0
246 Requires:       libgcrypt >= 1.8.0
247 Requires:       libnl >= 3.2
248 Requires:       zstd >= 1.0.0
249 Obsoletes:      libwiretap < 2.4.0
250
251 %description libs
252 Wireshark packet capture and dissection libraries.
253
254 %description libs -l pl.UTF-8
255 Biblioteki Wiresharka do przechwytywania i sekcji pakietów.
256
257 %package devel
258 Summary:        Header files for Wireshark libraries
259 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wiresharka
260 Group:          Development/Libraries
261 Requires:       %{name}-libs = %{version}-%{release}
262 Requires:       glib2-devel >= 1:2.50.0
263 Requires:       libgcrypt-devel >= 1.8.0
264 Requires:       libnl-devel >= 3.2
265 Obsoletes:      libwiretap-devel < 2.4.0
266
267 %description devel
268 Header files for Wireshark libraries.
269
270 %description devel -l pl.UTF-8
271 Pliki nagłówkowe bibliotek Wiresharka.
272
273 %prep
274 %setup -q
275
276 %build
277 install -d build
278 cd build
279 %cmake .. \
280         -DBUILD_androiddump=ON \
281         -DBUILD_corbaidl2wrs=ON \
282         -DBUILD_dcerpcidl2wrs=ON \
283         -DBUILD_mmdbresolve=ON \
284         -DBUILD_randpktdump=ON \
285         -DBUILD_tfshark=OFF \
286         -DBUILD_wireshark=ON \
287         -DCMAKE_INSTALL_DATADIR:PATH=share/wireshark \
288         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
289         -DDISABLE_WERROR=ON \
290         -DENABLE_LUA=ON \
291         -DENABLE_NETLINK=ON \
292         -DENABLE_PLUGINS=ON \
293         -DENABLE_PORTAUDIO=ON \
294         -DENABLE_QT5=ON \
295         -DENABLE_SMI=ON
296
297 %{__make}
298
299 %install
300 rm -rf $RPM_BUILD_ROOT
301
302 %{__make} -C build install \
303         DESTDIR=$RPM_BUILD_ROOT
304
305 # used by installed headers, but not installed by cmake
306 cp -p build/config.h $RPM_BUILD_ROOT%{_includedir}/wireshark
307
308 %clean
309 rm -rf $RPM_BUILD_ROOT
310
311 %post
312 %update_icon_cache hicolor
313 %update_desktop_database_post
314 %update_mime_database
315
316 %postun
317 %update_icon_cache hicolor
318 %update_desktop_database_postun
319 %update_mime_database
320
321 %pre    common
322 %groupadd -P %{name}-common -g 104 wireshark
323
324 %post   common
325 /sbin/setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' %{_bindir}/dumpcap
326 exit 0
327
328 %postun common
329 if [ "$1" = "0" ]; then
330         %groupremove wireshark
331 fi
332
333 %post   libs -p /sbin/ldconfig
334 %postun libs -p /sbin/ldconfig
335
336 %if %{with gui}
337 %files
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_bindir}/wireshark
340 %{_desktopdir}/org.wireshark.Wireshark.desktop
341 %{_datadir}/%{name}
342 %{_datadir}/metainfo/org.wireshark.Wireshark.metainfo.xml
343 %{_datadir}/mime/packages/org.wireshark.Wireshark.xml
344 %{_iconsdir}/hicolor/16x16/apps/org.wireshark.Wireshark.png
345 %{_iconsdir}/hicolor/16x16/mimetypes/org.wireshark.Wireshark-mimetype.png
346 %{_iconsdir}/hicolor/24x24/apps/org.wireshark.Wireshark.png
347 %{_iconsdir}/hicolor/24x24/mimetypes/org.wireshark.Wireshark-mimetype.png
348 %{_iconsdir}/hicolor/32x32/apps/org.wireshark.Wireshark.png
349 %{_iconsdir}/hicolor/32x32/mimetypes/org.wireshark.Wireshark-mimetype.png
350 %{_iconsdir}/hicolor/48x48/apps/org.wireshark.Wireshark.png
351 %{_iconsdir}/hicolor/48x48/mimetypes/org.wireshark.Wireshark-mimetype.png
352 %{_iconsdir}/hicolor/64x64/apps/org.wireshark.Wireshark.png
353 %{_iconsdir}/hicolor/64x64/mimetypes/org.wireshark.Wireshark-mimetype.png
354 %{_iconsdir}/hicolor/128x128/apps/org.wireshark.Wireshark.png
355 %{_iconsdir}/hicolor/128x128/mimetypes/org.wireshark.Wireshark-mimetype.png
356 %{_iconsdir}/hicolor/256x256/apps/org.wireshark.Wireshark.png
357 %{_iconsdir}/hicolor/256x256/mimetypes/org.wireshark.Wireshark-mimetype.png
358 %{_iconsdir}/hicolor/scalable/apps/org.wireshark.Wireshark.svg
359 %{_mandir}/man1/wireshark.1*
360 %endif
361
362 %files common
363 %defattr(644,root,root,755)
364 %doc AUTHORS* ChangeLog NEWS README.md README.linux doc/README.*
365 %dir %{_libdir}/%{name}/extcap
366 %dir %{_libdir}/%{name}/plugins
367 %dir %{_libdir}/%{name}/plugins/%{branch_ver}
368 %dir %{_libdir}/%{name}/plugins/%{branch_ver}/codecs
369 %dir %{_libdir}/%{name}/plugins/%{branch_ver}/epan
370 %dir %{_libdir}/%{name}/plugins/%{branch_ver}/wiretap
371 %attr(755,root,root) %{_libdir}/%{name}/extcap/androiddump
372 %attr(755,root,root) %{_libdir}/%{name}/extcap/ciscodump
373 %attr(755,root,root) %{_libdir}/%{name}/extcap/dpauxmon
374 %attr(755,root,root) %{_libdir}/%{name}/extcap/randpktdump
375 %attr(755,root,root) %{_libdir}/%{name}/extcap/sshdump
376 %attr(755,root,root) %{_libdir}/%{name}/extcap/sdjournal
377 %attr(755,root,root) %{_libdir}/%{name}/extcap/udpdump
378 %attr(755,root,root) %{_libdir}/%{name}/extcap/wifidump
379 %attr(755,root,root) %{_libdir}/%{name}/plugins/%{branch_ver}/codecs/*.so
380 %attr(755,root,root) %{_libdir}/%{name}/plugins/%{branch_ver}/epan/*.so
381 %attr(755,root,root) %{_libdir}/%{name}/plugins/%{branch_ver}/wiretap/*.so
382 %attr(755,root,root) %{_bindir}/capinfos
383 %attr(755,root,root) %{_bindir}/captype
384 %attr(750,root,wireshark) %{_bindir}/dumpcap
385 %attr(755,root,root) %{_bindir}/editcap
386 %attr(755,root,root) %{_bindir}/idl2wrs
387 %attr(755,root,root) %{_bindir}/mergecap
388 %attr(755,root,root) %{_bindir}/mmdbresolve
389 %attr(755,root,root) %{_bindir}/randpkt
390 %attr(755,root,root) %{_bindir}/rawshark
391 %attr(755,root,root) %{_bindir}/reordercap
392 %attr(755,root,root) %{_bindir}/sharkd
393 %attr(755,root,root) %{_bindir}/text2pcap
394 %{_mandir}/man1/androiddump.1*
395 %{_mandir}/man1/capinfos.1*
396 %{_mandir}/man1/captype.1*
397 %{_mandir}/man1/ciscodump.1*
398 %{_mandir}/man1/dftest.1*
399 %{_mandir}/man1/dpauxmon.1*
400 %{_mandir}/man1/dumpcap.1*
401 %{_mandir}/man1/editcap.1*
402 %{_mandir}/man1/etwdump.1.*
403 %{_mandir}/man1/idl2wrs.1*
404 %{_mandir}/man1/mergecap.1*
405 %{_mandir}/man1/mmdbresolve.1*
406 %{_mandir}/man1/rawshark.1*
407 %{_mandir}/man1/randpkt.1*
408 %{_mandir}/man1/randpktdump.1*
409 %{_mandir}/man1/reordercap.1*
410 %{_mandir}/man1/sdjournal.1*
411 %{_mandir}/man1/sshdump.1*
412 %{_mandir}/man1/text2pcap.1*
413 %{_mandir}/man1/udpdump.1*
414 %{_mandir}/man1/wifidump.1*
415 %{_mandir}/man4/extcap.4*
416 %{_mandir}/man4/wireshark-filter.4*
417
418 %files -n twireshark
419 %defattr(644,root,root,755)
420 %attr(755,root,root) %{_bindir}/tshark
421 %{_mandir}/man1/tshark*.1*
422
423 %files libs
424 %defattr(644,root,root,755)
425 %attr(755,root,root) %{_libdir}/libwireshark.so.*.*.*
426 %attr(755,root,root) %ghost %{_libdir}/libwireshark.so.16
427 %attr(755,root,root) %{_libdir}/libwiretap.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libwiretap.so.13
429 %attr(755,root,root) %{_libdir}/libwsutil.so.*.*.*
430 %attr(755,root,root) %ghost %{_libdir}/libwsutil.so.14
431 %dir %{_libdir}/%{name}
432
433 %files devel
434 %defattr(644,root,root,755)
435 %doc wiretap/{README,README.airmagnet}
436 %attr(755,root,root) %{_libdir}/libwireshark.so
437 %attr(755,root,root) %{_libdir}/libwiretap.so
438 %attr(755,root,root) %{_libdir}/libwsutil.so
439 %{_includedir}/wireshark
440 %{_pkgconfigdir}/wireshark.pc
441 %{_libdir}/%{name}/cmake
This page took 0.073158 seconds and 4 git commands to generate.