]> git.pld-linux.org Git - packages/wireshark.git/blob - wireshark.spec
- use setcaps instead of .desktop file hacks
[packages/wireshark.git] / wireshark.spec
1 # TODO
2 # - use policykit to gain root
3 # - use %caps when rpm supports it: %attr(750,root,wireshark) %caps(cap_net_raw,cap_net_admin=eip) %{_sbindir}/dumpcap
4 # - think of loosing dependency loop:
5 #   Executing rpm --upgrade -vh --root /...
6 #   error: LOOP:
7 #   error: removing libwiretap-1.2.4-1.i686 "Requires(auto): libwsutil.so.0" from tsort relations.
8 #   error:     libwiretap-1.2.4-1.i686                  Requires(auto): libwsutil.so.0
9 #   error: removing wireshark-common-1.2.4-1.i686 "Requires: libwiretap = 1.2.4-1" from tsort relations.
10 #   error:     wireshark-common-1.2.4-1.i686            Requires: libwiretap = 1.2.4-1
11 #   error: LOOP:
12 #   error: removing libwiretap-1.2.3-1.i686 "Requires: libwiretap = 1.2.3-1" from tsort relations.
13 #   error:     libwiretap-1.2.3-1.i686                  Requires: libwiretap = 1.2.3-1
14 #   error: removing wireshark-common-1.2.3-1.i686 "Requires(auto): libwsutil.so.0" from tsort relations.
15 #   error:     wireshark-common-1.2.3-1.i686            Requires(auto): libwsutil.so.0
16 #
17 # Conditional build:
18 %bcond_without  kerberos5       # build without Kerberos V support
19 %bcond_without  snmp            # build without snmp support
20
21 Summary:        Network traffic and protocol analyzer
22 Summary(es.UTF-8):      Analizador de tráfico de red
23 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych
24 Summary(pt_BR.UTF-8):   Analisador de tráfego de rede
25 Summary(ru.UTF-8):      Анализатор сетевого траффика
26 Summary(uk.UTF-8):      Аналізатор мережевого трафіку
27 Name:           wireshark
28 Version:        1.6.7
29 Release:        2
30 License:        GPL
31 Group:          Networking/Utilities
32 Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
33 # Source0-md5:  7e39f1c0ea4abd8bffa5122df800ca5d
34 Patch0:         %{name}-Werror.patch
35 Patch1:         %{name}-gcc43.patch
36 Patch2:         %{name}-ac.patch
37 Patch3:         %{name}-desktop.patch
38 URL:            http://www.wireshark.org/
39 BuildRequires:  autoconf >= 2.52
40 BuildRequires:  automake
41 BuildRequires:  bison
42 BuildRequires:  elfutils-devel
43 BuildRequires:  flex
44 BuildRequires:  gnutls-devel >= 1.0.0
45 BuildRequires:  gtk+2-devel >= 1:2.0.0
46 %{?with_kerberos5:BuildRequires:        heimdal-devel}
47 BuildRequires:  libcap-devel
48 BuildRequires:  libgcrypt-devel >= 1.1.42
49 BuildRequires:  libpcap-devel >= 2:1.0.0-4
50 BuildRequires:  libsmi-devel
51 BuildRequires:  libtool
52 BuildRequires:  libxslt-progs
53 BuildRequires:  lua51-devel
54 %{?with_snmp:BuildRequires:     net-snmp-devel}
55 BuildRequires:  pcre-devel
56 BuildRequires:  perl-tools-pod
57 BuildRequires:  pkgconfig
58 BuildRequires:  portaudio-devel
59 BuildRequires:  sed >= 4.0
60 BuildRequires:  zlib-devel
61 Requires:       %{name}-common = %{version}-%{release}
62 Requires:       libpcap >= 0.4
63 Provides:       ethereal
64 Provides:       ethereal-gnome
65 Obsoletes:      ethereal
66 Obsoletes:      ethereal-gnome
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Wireshark is the name for powerful graphical network sniffer, traffic
71 and protocol analyzer based on GTK+ and libpcap libraries. It lets you
72 capture and interactively browse the contents of network frames with
73 vast knowledge of more than 100 network protocols. Wireshark has
74 severeal useful features, including a rich display filter language,
75 the ability to view the ASCII contents of a TCP connection and plug-in
76 capabilities.
77
78 %description -l es.UTF-8
79 Analizador de tráfico de red.
80
81 %description -l pl.UTF-8
82 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
83 protokołów sieciowych opartym na bibliotekach GTK+ oraz libpcap.
84 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
85 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
86 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
87 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
88 wtyczek (plug-ins).
89
90 %description -l pt_BR.UTF-8
91 O Wireshark é um analisador de protocolo de rede baseado no GTK+.
92
93 %description -l ru.UTF-8
94 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
95 базируется на GTK+ и libpcap.
96
97 %description -l uk.UTF-8
98 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
99 базується на GTK+ та libpcap.
100
101 %package common
102 Summary:        Network traffic and protocol analyzer - common files
103 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych - wspólne pliki
104 Group:          Networking
105 Requires:       libwiretap = %{version}-%{release}
106 Provides:       %{name}-tools
107 Provides:       ethereal-common
108 Provides:       group(wireshark)
109 Obsoletes:      ethereal-common
110 Obsoletes:      wireshark-tools
111 Requires(post,postun):  /sbin/ldconfig
112 Requires(post,postun):  /sbin/setcap
113
114 %description common
115 Wireshark is the name for powerful graphical network sniffer, traffic
116 and protocol analyzer based on GTK+ and libpcap libraries. It lets you
117 capture and interactively browse the contents of network frames with
118 vast knowledge of more than 100 network protocols. Wireshark has
119 severeal useful features, including a rich display filter language,
120 the ability to view the ASCII contents of a TCP connection and plug-in
121 capabilities.
122
123 This package provides set of tools for manipulating capture files. It
124 contains:
125 - capinfo - prints informatio about binary capture files,
126 - dftest - shows display filter byte-code,
127 - editcap - edit and/or translate the format of capture files,
128 - idl2eth - corba IDL to Wireshark Plugin Generator,
129 - mergecap - merges two capture files into one,
130 - text2cap - generate a capture file from an ASCII hexdump of packets.
131
132 %description common -l es.UTF-8
133 Analizador de tráfico de red.
134
135 %description common -l pl.UTF-8
136 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
137 protokołów sieciowych opartym na bibliotekach GTK+ oraz libpcap.
138 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
139 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
140 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
141 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
142 wtyczek (plug-ins).
143
144 Pakiet ten dostarcza także zestaw narzędzi do obróbki plików z
145 przechwyconymi pakietami, obejmujący:
146 - capinfo - do wyświetlania informacji o binarnych plikach zrzutu,
147 - dftest - do pokazywania bajtkodu filtrów wyświetlania,
148 - editcap - do edycji plików i tłumaczenia ich na inne formaty,
149 - idl2eth - do konwersji Corba IDL do wtyczek Wireshark,
150 - mergecap - do łączenia dwóch plików w jeden,
151 - text2cap - do generowania pliku cap z szesnastkowego zrzutu ASCII
152   pakietów.
153
154 %description common -l pt_BR.UTF-8
155 O Wireshark é um analisador de protocolo de rede baseado no GTK+.
156
157 %description common -l ru.UTF-8
158 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
159 базируется на GTK+ и libpcap.
160
161 %description common -l uk.UTF-8
162 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
163 базується на GTK+ та libpcap.
164
165 %package -n twireshark
166 Summary:        Text-mode network traffic and protocol analyzer
167 Summary(pl.UTF-8):      Tekstowy analizator ruchu i protokołów sieciowych
168 Summary(pt_BR.UTF-8):   Analisador modo texto de tráfego de rede (sniffer)
169 Group:          Networking
170 Requires:       %{name}-common = %{version}-%{release}
171 Requires:       libpcap >= 0.4
172 Provides:       tethereal
173 Obsoletes:      tethereal
174
175 %description -n twireshark
176 Twireshark is a network protocol analyzer. It lets you capture packet
177 data from a live network, or read packets from a previously saved
178 capture file, either printing a decoded form of those packets to the
179 standard output or writing the packets to a file. Twireshark's native
180 capture file format is libpcap format, which is also the format used
181 by tcpdump and various other tools.
182
183 %description -n twireshark -l pl.UTF-8
184 Twireshark jest analizatorem protokołów sieciowych. Pozwala na
185 przechwytywanie pakietów z sieci lub wczytywanie danych z pliku.
186 Zdekodowany wynik (a twireshark zna ponad 100 rozmaitych protokołów
187 sieciowych!) jest wyświetlony na ekranie. Natywnym formatem plików
188 tetherala jest format libpcap, tak więc jest on kompatybilny z
189 tcpdumpem i innymi podobnymi narzędziami.
190
191 %description -n twireshark -l pt_BR.UTF-8
192 Esta é uma versão para modo texto do analisador de tráfego de rede
193 Wireshark.
194
195 %package -n libwiretap
196 Summary:        Packet capture and analysis library
197 Summary(pl.UTF-8):      Biblioteka do przechwytywania i analizy pakietów
198 Group:          Libraries
199
200 %description -n libwiretap
201 Wiretap is a library that is being developed as a future replacement
202 for libpcap, the current standard Unix library for packet capturing.
203
204 %description -n libwiretap -l pl.UTF-8
205 Biblioteka Wiretap rozwijana jest jako przyszły następca biblioteki
206 libpcap, obecnie standardu przechwytywania pakietów w systemach Unix.
207
208 %package -n libwiretap-devel
209 Summary:        Header files for libwiretap packet capture library
210 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libwiretap do przechwytywania pakietów
211 Group:          Development/Libraries
212 Requires:       gtk+2-devel >= 2.0.0
213 Requires:       libwiretap = %{version}-%{release}
214
215 %description -n libwiretap-devel
216 Header files for libwiretap packet capture library.
217
218 %description -n libwiretap-devel -l pl.UTF-8
219 Pliki nagłówkowe biblioteki libwiretap służącej do przechwytywania
220 pakietów.
221
222 %prep
223 %setup -q
224 %patch0 -p1
225 %patch1 -p1
226 %patch2 -p1
227 %patch3 -p1
228 sed -i -e 's/lua5\.1/lua51/g' acinclude.m4
229 find -name Makefile.am | xargs sed -i -e 's/-Werror//g'
230
231 %build
232 %{__libtoolize}
233 %{__aclocal} -I aclocal-fallback
234 %{__autoconf}
235 %{__automake}
236 %configure \
237         --enable-randpkt \
238         --enable-dftest \
239         --enable-threads \
240         --with-pcre \
241 %if %{with kerberos5}
242         --with-krb5 \
243         --with-ssl \
244 %endif
245         %{!?with_snmp:--without-net-snmp --without-ucdsnmp} \
246         --with-lua=/usr
247
248 %{__make}
249
250 %install
251 rm -rf $RPM_BUILD_ROOT
252 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_includedir}/wiretap}
253
254 %{__make} install \
255         DESTDIR=$RPM_BUILD_ROOT
256
257 cp -p image/hi48-app-wireshark.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
258 cp -p wireshark.desktop $RPM_BUILD_ROOT%{_desktopdir}
259
260 cp -a wiretap/*.h $RPM_BUILD_ROOT%{_includedir}/wiretap
261
262 # plugins *.la are useless - *.so are loaded through gmodule
263 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/%{version}*/*.la
264
265 # no headers installed for this library
266 rm -f $RPM_BUILD_ROOT%{_libdir}/libwireshark.{so,la}
267
268 %clean
269 rm -rf $RPM_BUILD_ROOT
270
271 %pre common
272 %groupadd -P %{name}-common -g 104 wireshark
273
274 %post   common
275 /sbin/ldconfig
276 /sbin/setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' %{_bindir}/dumpcap
277 exit 0
278
279 %postun common
280 /sbin/ldconfig
281 if [ "$1" = "0" ]; then
282         %groupremove wireshark
283 fi
284
285 %post   -n libwiretap -p /sbin/ldconfig
286 %postun -n libwiretap -p /sbin/ldconfig
287
288 %files
289 %defattr(644,root,root,755)
290 %attr(755,root,root) %{_bindir}/wireshark
291 %dir %{_libdir}/%{name}
292 %dir %{_libdir}/%{name}/plugins
293 %dir %{_libdir}/%{name}/plugins/%{version}*
294 %attr(755,root,root) %{_libdir}/%{name}/plugins/%{version}*/*.so
295 %{_datadir}/%{name}
296 %{_desktopdir}/%{name}.desktop
297 %{_pixmapsdir}/*.png
298 %{_mandir}/man1/wireshark.1*
299
300 %files common
301 %defattr(644,root,root,755)
302 %doc AUTHORS* ChangeLog NEWS README{,.[lv]*} doc/{randpkt.txt,README.*}
303 %attr(755,root,root) %{_bindir}/capinfos
304 %attr(755,root,root) %{_bindir}/dftest
305 %attr(750,root,wireshark) %{_bindir}/dumpcap
306 %attr(755,root,root) %{_bindir}/editcap
307 %attr(755,root,root) %{_bindir}/idl2wrs
308 %attr(755,root,root) %{_bindir}/mergecap
309 %attr(755,root,root) %{_bindir}/randpkt
310 %attr(755,root,root) %{_bindir}/rawshark
311 %attr(755,root,root) %{_bindir}/text2pcap
312 %attr(755,root,root) %{_libdir}/libwireshark.so.*.*.*
313 %attr(755,root,root) %ghost %{_libdir}/libwireshark.so.1
314 %attr(755,root,root) %{_libdir}/libwsutil.so.*.*.*
315 %attr(755,root,root) %ghost %{_libdir}/libwsutil.so.1
316 %{_mandir}/man1/capinfos.1*
317 %{_mandir}/man1/dftest.1*
318 %{_mandir}/man1/dumpcap.1*
319 %{_mandir}/man1/editcap.1*
320 %{_mandir}/man1/idl2wrs.1*
321 %{_mandir}/man1/mergecap.1*
322 %{_mandir}/man1/rawshark.1*
323 %{_mandir}/man1/randpkt.1*
324 %{_mandir}/man1/text2pcap.1*
325 %{_mandir}/man4/wireshark-filter.4*
326
327 %files -n twireshark
328 %defattr(644,root,root,755)
329 %attr(755,root,root) %{_bindir}/tshark
330 %{_mandir}/man1/tshark*.1*
331
332 %files -n libwiretap
333 %defattr(644,root,root,755)
334 %doc wiretap/{README*,AUTHORS}
335 %attr(755,root,root) %{_libdir}/libwiretap.so.*.*.*
336 %attr(755,root,root) %ghost %{_libdir}/libwiretap.so.1
337
338 %files -n libwiretap-devel
339 %defattr(644,root,root,755)
340 %attr(755,root,root) %{_libdir}/libwiretap.so
341 %attr(755,root,root) %{_libdir}/libwsutil.so
342 %{_libdir}/libwiretap.la
343 %{_libdir}/libwsutil.la
344 %{_includedir}/wiretap
This page took 0.076337 seconds and 4 git commands to generate.