]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- commented out wine.sym
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications.
2 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows.
3 Name:           wine
4 Version:        20000430
5 Release:        1
6 Copyright:      distributable
7 Group:          Applications/Emulators
8 Group(pl):      Aplikacje/Emulatory
9 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
10 Url:            http://www.winehq.com
11 Exclusivearch:  %{ix86}
12 BuildRequires:  XFree86-devel
13 BuildRequires:  xpm-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _prefix         /usr/X11R6
17
18 %description
19 Wine is a program which allows running Microsoft Windows programs
20 (including DOS, Windows 3.x and Win32 executables) on Unix. It consists of
21 a program loader which loads and executes a Microsoft Windows binary, and a
22 library that implements Windows API calls using their Unix or X11
23 equivalents. The library may also be used for porting Win32 code into
24 native Unix executables.
25
26 %description -l pl
27 Wine iest programem dziêki któremu mo¿na uruchamiaæ programy napisane dla
28 Microsoft Windows pod systemami unixowymi. Sk³ada siê on z loadera, który
29 pozwala wczytywaæ i uruchamiaæ programy w formacie Microsoft Windows oraz z
30 biblioteki, która implementuje API Windows przy u¿yciu odpowiedników
31 Unixowych oraz z X11. Biblioteka mo¿e byæ tak¿e wykorzystana do
32 przenoszenia aplikacji Win32 do Unixa.
33
34 %package devel
35 Summary:        Wine - header files
36 Summary(pl):    Wine - pliki nag³owkowe
37 Group:          Development/Libraries
38 Group(fr):      Development/Librairies
39 Group(pl):      Programowanie/Biblioteki
40 Requires:       %{name} = %{version}
41  
42 %description devel
43 Wine - header files.
44
45 %description -l pl devel
46 Wine - pliki nag³ówkowe.
47
48 %prep
49 %setup -q
50
51 %build
52 LDFLAGS="-s"; export LDFLAGS
53 %configure \
54     --disable-debug \
55     --disable-trace \
56     --with-x
57
58 make depend
59 make
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_mandir}/man1
64
65 make install \
66         prefix=$RPM_BUILD_ROOT%{_prefix} \
67         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
68         bindir=$RPM_BUILD_ROOT%{_bindir} \
69         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
70         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
71         datadir=$RPM_BUILD_ROOT%{_datadir} \
72         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
73         libdir=$RPM_BUILD_ROOT%{_libdir} \
74         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
75         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
76         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
77         mandir=$RPM_BUILD_ROOT%{_mandir} \
78         infodir=$RPM_BUILD_ROOT%{_infodir} 
79         
80 # there is something broken with make install 
81 # it expects root privileges, and if invoked by user, makes some stupid link
82 # instead of libs installation /by klakier
83
84 rm -f $RPM_BUILD_ROOT%{_libdir}/*.so
85 cp -dp libwine.so* $RPM_BUILD_ROOT%{_libdir}
86
87 cp wine.ini wine.conf.example
88 install -d $RPM_BUILD_ROOT%{_sysconfdir}
89 cat <<EOF >$RPM_BUILD_ROOT%{_sysconfdir}/wine.conf
90 ;
91 ; You can find example wine.conf file in %{_docdir}/%{name}-%{version}/wine.conf.example
92 ; More information: 'man wine.conf' or http://www.winehq.com
93
94 ; Przyk³adowy plik konfiguracyjny jest w %{_docdir}/%{name}-%{version}/wine.conf.example
95 ; Wiêcej informacji: 'man wine.conf' lub na stronach WINE: http://www.winehq.com
96 ;
97 EOF
98
99 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/*.so.*.*
100 strip $RPM_BUILD_ROOT%{_bindir}/*
101
102 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
103         README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc {README,WARRANTY,LICENSE,DEVELOPERS-HINTS,ChangeLog,BUGS,AUTHORS,ANNOUNCE}.gz
114 %doc documentation wine.conf.example
115 %attr(755,root,root) %{_bindir}/*
116 %{_mandir}/man[15]/*
117 %attr(755,root,root) %{_libdir}/lib*.so.*.*
118 #%{_libdir}/wine.sym
119 %config %{_sysconfdir}/wine.conf
120
121 %files devel
122 %defattr(644,root,root,755)
123 %{_includedir}/wine
124 %attr(755,root,root) %{_libdir}/lib*.so
This page took 0.265616 seconds and 4 git commands to generate.