]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- Rel 0.3 STBR
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications
2 Summary(es):    Ejecuta programas Windows en Linux
3 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows
4 Summary(pt_BR): Executa programas Windows no Linux
5 Name:           wine
6 Version:        20020509
7 Release:        0.3
8 License:        GPL
9 Group:          Applications/Emulators
10 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.reg
13 Source3:        %{name}.systemreg
14 Source4:        %{name}.userreg
15 Patch0:         %{name}-fontcache.patch
16 URL:            http://www.winehq.com/
17 ExclusiveArch:  %{ix86}
18 BuildRequires:  arts-devel
19 BuildRequires:  bison
20 BuildRequires:  chpax
21 BuildRequires:  cups-devel
22 BuildRequires:  docbook-dtd31-sgml
23 BuildRequires:  docbook-utils
24 BuildRequires:  flex
25 BuildRequires:  freetype-devel >= 2.0.5
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  ncurses-devel
28 BuildRequires:  OpenGL-devel
29 BuildRequires:  openjade
30 BuildRequires:  sane-backends-devel
31 BuildRequires:  XFree86-devel
32 Requires:       OpenGL
33 Requires(post): ldconfig
34 Requires(post,preun): chkconfig
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
38 %define         no_install_post_strip   1
39
40 %define         _prefix                 /usr/X11R6
41 %define         _mandir                 %{_prefix}/man
42 %define         _winedir                %{_datadir}/%{name}
43
44 %description
45 Wine is a program which allows running Microsoft Windows programs
46 (including DOS, Windows 3.x and Win32 executables) on Unix. It
47 consists of a program loader which loads and executes a Microsoft
48 Windows binary, and a library that implements Windows API calls using
49 their Unix or X11 equivalents. The library may also be used for
50 porting Win32 code into native Unix executables.
51
52 %description -l es
53 Ejecuta programas Windows en Linux.
54
55 %description -l pl
56 Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
57 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z
58 loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
59 Microsoft Windows oraz z biblioteki, która implementuje API Windows
60 przy u¿yciu odpowiedników Unixowych oraz z X11. Biblioteka mo¿e byæ
61 tak¿e wykorzystana do przenoszenia aplikacji Win32 do Unixa.
62
63 %description -l pt_BR
64 O Wine é um programa que permite rodar programas MS-Windows no X11.
65 Ele consiste de um carregador de programa, que carrega e executa um
66 binário MS-Windows, e de uma biblioteca de emulação que traduz as
67 chamadas da API para as equivalentes Unix/X11.
68
69 %package devel
70 Summary:        Wine - header files
71 Summary(es):    Biblioteca de desarrollo de wine
72 Summary(pl):    Wine - pliki nag³owkowe
73 Summary(pt_BR): Biblioteca de desenvolvimento do wine
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}
76
77 %description devel
78 Wine - header files.
79
80 %description devel -l es
81 Biblioteca de desarrollo de wine.
82
83 %description devel -l pl
84 Wine - pliki nag³ówkowe.
85
86 %description devel -l pt_BR
87 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
88 WINE.
89
90 %package programs
91 Summary:        Wine - programs
92 Summary(pl):    Wine - programy
93 Group:          Applications
94 Requires:       %{name} = %{version}
95
96 %description programs
97 Wine - programs
98
99 %description programs -l pl
100 Wine - programy
101
102 %prep
103 %setup -q
104 %patch -p1
105
106 # turn off compilation of some tools
107 sed -e "s|winetest||;s|avitools||" programs/Makefile.in > .tmp
108 mv -f .tmp programs/Makefile.in
109
110 %build
111 #aclocal
112 #autoconf
113 CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
114 CFLAGS="%{rpmcflags} $CPPFLAGS"
115 %configure \
116 %{!?debug:      --disable-debug} \
117 %{!?debug:      --disable-trace} \
118         --enable-curses \
119         --enable-opengl \
120         --with-x
121
122 %{__make} depend
123 %{__make}
124 %{__make} -C programs
125
126 (cd documentation
127 ./db2html-winehq wine-user.sgml
128 ./db2html-winehq wine-devel.sgml
129 ./db2html-winehq winelib-user.sgml)
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT%{_mandir}/man1
134
135 %{__make} install \
136         prefix=$RPM_BUILD_ROOT%{_prefix} \
137         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
138         bindir=$RPM_BUILD_ROOT%{_bindir} \
139         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
140         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
141         datadir=$RPM_BUILD_ROOT%{_datadir} \
142         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
143         libdir=$RPM_BUILD_ROOT%{_libdir} \
144         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
145         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
146         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
147         mandir=$RPM_BUILD_ROOT%{_mandir} \
148         infodir=$RPM_BUILD_ROOT%{_infodir} \
149         dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
150
151 %{__make} -C programs install \
152         prefix=$RPM_BUILD_ROOT%{_prefix} \
153         bindir=$RPM_BUILD_ROOT%{_bindir}
154
155 (cd $RPM_BUILD_ROOT%{_bindir}
156 find -name '*.so' | sed 's|^.|%attr(755,root,root) %{_bindir}|; s|.so$||') > programs.list
157
158 install programs/winhelp/hlp2sgml $RPM_BUILD_ROOT%{_bindir}
159
160 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
161         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
162         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
163         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
164         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
165         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
166
167 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/wine
168 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
169 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
170 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
171
172 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
173 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
174 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
175
176 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
177 [mci]
178 cdaudio=mcicda.drv
179 sequencer=mciseq.drv
180 waveaudio=mciwave.drv
181 avivideo=mciavi.drv
182 videodisc=mcipionr.drv
183 vcr=mciviscd.drv
184 MPEGVideo=mciqtz.drv
185 EOF
186
187 %if %{?debug:0}%{!?debug:1}
188 echo "Strip executable binaries and shared object files."
189 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
190 elfexelist=`echo $filelist | xargs -r file | \
191         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
192 elfsharedlist=`echo $filelist | xargs -r file | \
193         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
194 if [ -n "$elfexelist" ]; then \
195         strip -R .note -R .comment $elfexelist
196 fi
197 if [ -n "$elfsharedlist" ]; then
198         strip --strip-unneeded -R .note  -R .comment $elfsharedlist
199 fi
200 %endif
201
202 /sbin/chpax -p $RPM_BUILD_ROOT%{_bindir}/wine
203
204 %clean
205 rm -rf $RPM_BUILD_ROOT
206
207 %post
208 /sbin/ldconfig
209 /sbin/chkconfig --add wine
210 if [ ! -f /var/lock/subsys/wine ]; then
211         echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
212 fi
213
214 %preun
215 if [ "$1" = "0" ]; then
216         if [ -f /var/lock/subsys/wine ]; then
217                 /etc/rc.d/init.d/wine stop >&2
218         fi
219         /sbin/chkconfig --del wine
220 fi
221
222 %postun -p /sbin/ldconfig
223
224 %files
225 %defattr(644,root,root,755)
226 %doc README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
227 %doc documentation/wine-user
228 %attr(755,root,root) %{_bindir}/wine
229 %attr(755,root,root) %{_bindir}/winebuild
230 %attr(755,root,root) %{_bindir}/winemaker
231 %attr(755,root,root) %{_bindir}/wineserver
232 %attr(755,root,root) %{_bindir}/wineclipsrv
233 %attr(755,root,root) %{_bindir}/winelauncher
234 %attr(755,root,root) %{_bindir}/wineshelllink
235 %attr(755,root,root) %{_bindir}/winedump
236 %attr(755,root,root) %{_bindir}/wrc
237 %attr(755,root,root) %{_bindir}/wmc
238 %attr(755,root,root) %{_bindir}/fnt2bdf
239 %attr(755,root,root) %{_bindir}/function_grep.pl
240 %attr(755,root,root) %{_libdir}/*.so*
241 %{_libdir}/wine
242 %{_mandir}/man[15]/*
243 %config(noreplace) %{_sysconfdir}/wine.reg
244 %config(missingok) %{_sysconfdir}/wine.systemreg
245 %config(missingok) %{_sysconfdir}/wine.userreg
246 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
247 %{_winedir}
248
249 %files programs -f programs.list
250 %defattr(644,root,root,755)
251 %attr (755,root,root) %{_bindir}/hlp2sgml
252 %{_bindir}/*.so
253
254 %files devel
255 %defattr(644,root,root,755)
256 %doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
257 %{_includedir}/wine
258 %{_libdir}/*.a
This page took 0.056371 seconds and 4 git commands to generate.