]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- Updated to 20000326.
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications.
2 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows.
3 Name:           wine
4 Version:        20000326
5 Release:        1
6 Copyright:      distributable
7 Group:          Applications/Emulators
8 Group(pl):      Applikacje/Emulatory
9 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
10 Url:            http://www.winehq.com
11 Exclusivearch:  %{ix86}
12 BuildRequires:  XFree86-devel
13 BuildRequires:  xpm-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _prefix         /usr/X11R6
17
18 %description
19 Wine is a program which allows running Microsoft Windows programs
20 (including DOS, Windows 3.x and Win32 executables) on Unix.  It
21 consists of a program loader which loads and executes a Microsoft
22 Windows binary, and a library that implements Windows API calls using
23 their Unix or X11 equivalents. The library may also be used for
24 porting Win32 code into native Unix executables.
25
26 %description -l pl
27 Wine iest programem dziêki któremu mo¿na uruchamiaæ programy napisane
28 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z loadera, który
29 pozwala wczytywaæ i uruchamiaæ programy w formacie Microsoft Windows oraz z
30 biblioteki, która implementuje API Windows przy u¿yciu odpowiedników Unixowych
31 oraz z X11. Biblioteka mo¿e byæ tak¿e wykorzystana do przenoszenia aplikacji
32 Win32 do Unixa.
33
34 %package devel
35 Summary:        Wine - header files
36 Summary(pl):    Wine - pliki nag³owkowe
37 Group:          Development/Libraries
38 Group(pl):      Programowanie/Biblioteki
39 Requires:       %{name} = %{version}
40  
41 %description devel
42 Wine - header files.
43
44 %description -l pl devel
45 Wine - pliki nag³ówkowe.
46
47 %prep
48 %setup -q
49
50 %build
51
52 #automake
53 LDFLAGS="-s"; export LDFLAGS
54 %configure \
55     --disable-debug \
56     --disable-trace \
57     --with-x
58
59 make depend
60 make
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT%{_mandir}/man1
65
66 make install \
67         prefix=$RPM_BUILD_ROOT%{_prefix} \
68         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
69         bindir=$RPM_BUILD_ROOT%{_bindir} \
70         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
71         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
72         datadir=$RPM_BUILD_ROOT%{_datadir} \
73         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
74         libdir=$RPM_BUILD_ROOT%{_libdir} \
75         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
76         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
77         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
78         mandir=$RPM_BUILD_ROOT%{_mandir} \
79         infodir=$RPM_BUILD_ROOT%{_infodir} 
80         
81 # there is something broken with make install 
82 # it expects root privileges, and if invoked by user, makes some stupid link
83 # instead of libs installation /by klakier
84
85 rm -f $RPM_BUILD_ROOT%{_libdir}/*.so
86 cp -dp libwine.so* $RPM_BUILD_ROOT%{_libdir}
87
88 cp wine.ini wine.conf.example
89 install -d $RPM_BUILD_ROOT%{_sysconfdir}
90 cat <<EOF >$RPM_BUILD_ROOT%{_sysconfdir}/wine.conf
91 ;
92 ; You can find example wine.conf file in %{_docdir}/%{name}-%{version}/wine.conf.example
93 ; More information: 'man wine.conf' or http://www.winehq.com
94
95 ; Przyk³adowy plik konfiguracyjny jest w %{_docdir}/%{name}-%{version}/wine.conf.example
96 ; Wiêcej informacji: 'man wine.conf' lub na stronach WINE: http://www.winehq.com
97 ;
98 EOF
99
100 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
101 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man5/*
102
103 gzip -9nf README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc {README,WARRANTY,LICENSE,DEVELOPERS-HINTS,ChangeLog,BUGS,AUTHORS,ANNOUNCE}.gz
114 %doc documentation wine.conf.example
115 %attr(755,root,root) %{_bindir}/*
116 %{_mandir}/man1/*
117 %{_mandir}/man5/*
118 %attr(755,root,root) %{_libdir}/*.so*
119 %{_libdir}/wine.sym
120 %config %{_sysconfdir}/wine.conf
121
122 %files devel
123 %defattr(644,root,root,755)
124 %{_includedir}/wine
This page took 0.036795 seconds and 4 git commands to generate.