]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- missing dir (%%{_libdir}/wine)
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications
2 Summary(es):    Ejecuta programas Windows en Linux
3 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows
4 Summary(pt_BR): Executa programas Windows no Linux
5 Name:           wine
6 Version:        20030115
7 Release:        1
8 License:        GPL
9 Group:          Applications/Emulators
10 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.reg
13 Source3:        %{name}.systemreg
14 Source4:        %{name}.userreg
15 Patch0:         %{name}-fontcache.patch
16 Patch1:         %{name}-destdir.patch
17 Patch2:         %{name}-ncurses.patch
18 Patch3:         %{name}-ac-ksh.patch
19 URL:            http://www.winehq.com/
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  XFree86-devel
22 %{!?_without_arts:BuildRequires:        arts-devel}
23 BuildRequires:  bison
24 BuildRequires:  chpax >= 0.20020901-2
25 %{!?_without_cups:BuildRequires:        cups-devel}
26 BuildRequires:  docbook-dtd31-sgml
27 BuildRequires:  docbook-utils
28 BuildRequires:  flex
29 BuildRequires:  freetype-devel >= 2.0.5
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  ncurses-devel
32 BuildRequires:  openjade
33 %{!?_without_sane:BuildRequires:        sane-backends-devel}
34 Requires:       OpenGL
35 Requires(post): /sbin/ldconfig
36 Requires(post,preun):/sbin/chkconfig
37 ExclusiveArch:  %{ix86}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
41 %define         no_install_post_strip   1
42
43 %define         _winedir                %{_datadir}/%{name}
44
45 %description
46 Wine is a program which allows running Microsoft Windows programs
47 (including DOS, Windows 3.x and Win32 executables) on Unix. It
48 consists of a program loader which loads and executes a Microsoft
49 Windows binary, and a library that implements Windows API calls using
50 their Unix or X11 equivalents. The library may also be used for
51 porting Win32 code into native Unix executables.
52
53 %description -l es
54 Ejecuta programas Windows en Linux.
55
56 %description -l pl
57 Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
58 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z
59 loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
60 Microsoft Windows oraz z biblioteki, która implementuje API Windows
61 przy u¿yciu odpowiedników Unixowych oraz z X11. Biblioteka mo¿e byæ
62 tak¿e wykorzystana do przenoszenia aplikacji Win32 do Unixa.
63
64 %description -l pt_BR
65 O Wine é um programa que permite rodar programas MS-Windows no X11.
66 Ele consiste de um carregador de programa, que carrega e executa um
67 binário MS-Windows, e de uma biblioteca de emulação que traduz as
68 chamadas da API para as equivalentes Unix/X11.
69
70 %package devel
71 Summary:        Wine - header files
72 Summary(es):    Biblioteca de desarrollo de wine
73 Summary(pl):    Wine - pliki nag³owkowe
74 Summary(pt_BR): Biblioteca de desenvolvimento do wine
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}
77
78 %description devel
79 Wine - header files.
80
81 %description devel -l es
82 Biblioteca de desarrollo de wine.
83
84 %description devel -l pl
85 Wine - pliki nag³ówkowe.
86
87 %description devel -l pt_BR
88 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
89 WINE.
90
91 %package programs
92 Summary:        Wine - programs
93 Summary(pl):    Wine - programy
94 Group:          Applications
95 Requires:       %{name} = %{version}
96
97 %description programs
98 Wine - programs
99
100 %description programs -l pl
101 Wine - programy
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %patch3 -p1
109
110 # turn off compilation of some tools
111 #sed -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in > .tmp
112 sed -e "s|avitools||" programs/Makefile.in > .tmp
113 mv -f .tmp programs/Makefile.in
114
115 %build
116 %{__aclocal}
117 %{__autoconf}
118 CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
119 CFLAGS="%{rpmcflags} $CPPFLAGS"
120 %configure \
121 %{!?debug:      --disable-debug} \
122 %{!?debug:      --disable-trace} \
123         --enable-curses \
124         --enable-opengl \
125         --with-x
126
127 %{__make} depend
128 %{__make}
129 %{__make} -C programs
130 %{__make} -C programs/regapi
131
132 cd documentation
133 ./db2html-winehq wine-user.sgml
134 ./db2html-winehq wine-devel.sgml
135 ./db2html-winehq winelib-user.sgml
136 cd -
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
141
142 %{__make} install DESTDIR=$RPM_BUILD_ROOT
143 %{__make} -C programs install DESTDIR=$RPM_BUILD_ROOT
144
145 install programs/winhelp/hlp2sgml       $RPM_BUILD_ROOT%{_bindir}
146 install tools/fnt2bdf                   $RPM_BUILD_ROOT%{_bindir}
147
148 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
149 #mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
150
151 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
152         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
153         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
154         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
155         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
156         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
157
158 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wine
159 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
160 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
161 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
162
163 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
164 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
165 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
166
167 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
168 [mci]
169 cdaudio=mcicda.drv
170 sequencer=mciseq.drv
171 waveaudio=mciwave.drv
172 avivideo=mciavi.drv
173 videodisc=mcipionr.drv
174 vcr=mciviscd.drv
175 MPEGVideo=mciqtz.drv
176 EOF
177
178 %if %{?debug:0}%{!?debug:1}
179 echo "Strip executable binaries and shared object files."
180 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
181 elfexelist=`echo $filelist | xargs -r file | \
182         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
183 elfsharedlist=`echo $filelist | xargs -r file | \
184         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
185 if [ -n "$elfexelist" ]; then \
186         strip -R .note -R .comment $elfexelist
187 fi
188 if [ -n "$elfsharedlist" ]; then
189         strip --strip-unneeded -R .note  -R .comment $elfsharedlist
190 fi
191 %endif
192
193 /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
194
195 programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp wcmd"
196
197 BZZZ=`pwd`
198 rm -f files.so;         touch files.so
199 rm -f files.programs;   touch files.programs
200 cd $RPM_BUILD_ROOT%{_libdir}/wine
201 for f in *.so; do
202         echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
203 done
204 cd -
205 for p in $programs; do 
206         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
207         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
208         grep -v "$p\.exe\.so$" files.so > files.so.
209         mv -f files.so. files.so
210 done
211
212 %clean
213 rm -rf $RPM_BUILD_ROOT
214
215 %post
216 /sbin/ldconfig
217 /sbin/chkconfig --add wine
218 if [ ! -f /var/lock/subsys/wine ]; then
219         echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
220 fi
221
222 %preun
223 if [ "$1" = "0" ]; then
224         if [ -f /var/lock/subsys/wine ]; then
225                 /etc/rc.d/init.d/wine stop >&2
226         fi
227         /sbin/chkconfig --del wine
228 fi
229
230 %postun -p /sbin/ldconfig
231
232 %files -f files.so
233 %defattr(644,root,root,755)
234 %doc README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
235 %doc documentation/{wine-user,samples,status}
236 %attr(755,root,root) %{_bindir}/wine
237 %attr(755,root,root) %{_bindir}/winedbg
238 %attr(755,root,root) %{_bindir}/wineserver
239 %attr(755,root,root) %{_bindir}/wineclipsrv
240 %attr(755,root,root) %{_bindir}/wineshelllink
241 %attr(755,root,root) %{_bindir}/wineboot
242 %attr(755,root,root) %{_libdir}/*.so*
243 %dir %{_libdir}/wine
244 %{_mandir}/man1/wine.*
245 %{_mandir}/man5/wine.conf.*
246 %config(noreplace) %{_sysconfdir}/wine.reg
247 %config(missingok) %{_sysconfdir}/wine.systemreg
248 %config(missingok) %{_sysconfdir}/wine.userreg
249 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
250 %{_winedir}
251
252 %files programs -f files.programs
253 %defattr(644,root,root,755)
254
255 %files devel
256 %defattr(644,root,root,755)
257 %doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
258 %attr(755,root,root) %{_bindir}/winebuild
259 %attr(755,root,root) %{_bindir}/winemaker
260 %attr(755,root,root) %{_bindir}/winedump
261 %attr(755,root,root) %{_bindir}/wrc
262 %attr(755,root,root) %{_bindir}/wmc
263 #%attr(755,root,root) %{_bindir}/widl
264 %attr(755,root,root) %{_bindir}/hlp2sgml
265 %attr(755,root,root) %{_bindir}/fnt2bdf
266 %attr(755,root,root) %{_bindir}/function_grep.pl
267 %{_includedir}/wine
268 %{_libdir}/*.a
269 %{_mandir}/man1/winemaker.*
270 #%{_mandir}/man1/winebuild.*
271 %{_mandir}/man1/wmc.*
272 %{_mandir}/man1/wrc.*
273 %{_aclocaldir}/*.m4
This page took 0.056439 seconds and 4 git commands to generate.