]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- 20020710
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications
2 Summary(es):    Ejecuta programas Windows en Linux
3 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows
4 Summary(pt_BR): Executa programas Windows no Linux
5 Name:           wine
6 Version:        20020710
7 Release:        1
8 License:        GPL
9 Group:          Applications/Emulators
10 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.reg
13 Source3:        %{name}.systemreg
14 Source4:        %{name}.userreg
15 Patch0:         %{name}-fontcache.patch
16 URL:            http://www.winehq.com/
17 ExclusiveArch:  %{ix86}
18 BuildRequires:  arts-devel
19 BuildRequires:  bison
20 BuildRequires:  chpax
21 BuildRequires:  cups-devel
22 BuildRequires:  docbook-dtd31-sgml
23 BuildRequires:  docbook-utils
24 BuildRequires:  flex
25 BuildRequires:  freetype-devel >= 2.0.5
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  ncurses-devel
28 BuildRequires:  OpenGL-devel
29 BuildRequires:  openjade
30 BuildRequires:  XFree86-devel
31 Requires:       OpenGL
32 Requires(post): ldconfig
33 Requires(post,preun): chkconfig
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
37 %define         no_install_post_strip   1
38
39 %define         _prefix                 /usr/X11R6
40 %define         _mandir                 %{_prefix}/man
41 %define         _winedir                %{_datadir}/%{name}
42
43 %description
44 Wine is a program which allows running Microsoft Windows programs
45 (including DOS, Windows 3.x and Win32 executables) on Unix. It
46 consists of a program loader which loads and executes a Microsoft
47 Windows binary, and a library that implements Windows API calls using
48 their Unix or X11 equivalents. The library may also be used for
49 porting Win32 code into native Unix executables.
50
51 %description -l es
52 Ejecuta programas Windows en Linux.
53
54 %description -l pl
55 Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
56 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z
57 loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
58 Microsoft Windows oraz z biblioteki, która implementuje API Windows
59 przy u¿yciu odpowiedników Unixowych oraz z X11. Biblioteka mo¿e byæ
60 tak¿e wykorzystana do przenoszenia aplikacji Win32 do Unixa.
61
62 %description -l pt_BR
63 O Wine é um programa que permite rodar programas MS-Windows no X11.
64 Ele consiste de um carregador de programa, que carrega e executa um
65 binário MS-Windows, e de uma biblioteca de emulação que traduz as
66 chamadas da API para as equivalentes Unix/X11.
67
68 %package devel
69 Summary:        Wine - header files
70 Summary(es):    Biblioteca de desarrollo de wine
71 Summary(pl):    Wine - pliki nag³owkowe
72 Summary(pt_BR): Biblioteca de desenvolvimento do wine
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}
75
76 %description devel
77 Wine - header files.
78
79 %description devel -l es
80 Biblioteca de desarrollo de wine.
81
82 %description devel -l pl
83 Wine - pliki nag³ówkowe.
84
85 %description devel -l pt_BR
86 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
87 WINE.
88
89 %package programs
90 Summary:        Wine - programs
91 Summary(pl):    Wine - programy
92 Group:          Applications
93 Requires:       %{name} = %{version}
94
95 %description programs
96 Wine - programs
97
98 %description programs -l pl
99 Wine - programy
100
101 %prep
102 %setup -q
103 %patch -p1
104
105 # turn off compilation of some tools
106 sed -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in > .tmp
107 mv -f .tmp programs/Makefile.in
108
109 %build
110 #aclocal
111 #autoconf
112 CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
113 CFLAGS="%{rpmcflags} $CPPFLAGS"
114 %configure \
115 %{!?debug:      --disable-debug} \
116 %{!?debug:      --disable-trace} \
117         --enable-curses \
118         --enable-opengl \
119         --with-x
120
121 %{__make} depend
122 %{__make}
123 %{__make} -C programs
124
125 (cd documentation
126 ./db2html-winehq wine-user.sgml
127 ./db2html-winehq wine-devel.sgml
128 ./db2html-winehq winelib-user.sgml)
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT%{_mandir}/man1
133
134 %{__make} install \
135         prefix=$RPM_BUILD_ROOT%{_prefix} \
136         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
137         bindir=$RPM_BUILD_ROOT%{_bindir} \
138         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
139         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
140         datadir=$RPM_BUILD_ROOT%{_datadir} \
141         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
142         libdir=$RPM_BUILD_ROOT%{_libdir} \
143         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
144         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
145         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
146         mandir=$RPM_BUILD_ROOT%{_mandir} \
147         infodir=$RPM_BUILD_ROOT%{_infodir} \
148         dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
149
150 %{__make} -C programs install \
151         prefix=$RPM_BUILD_ROOT%{_prefix} \
152         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
153         bindir=$RPM_BUILD_ROOT%{_bindir} \
154         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
155         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
156         datadir=$RPM_BUILD_ROOT%{_datadir} \
157         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
158         libdir=$RPM_BUILD_ROOT%{_libdir} \
159         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
160         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
161         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
162         mandir=$RPM_BUILD_ROOT%{_mandir} \
163         infodir=$RPM_BUILD_ROOT%{_infodir} \
164         dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
165
166 (cd $RPM_BUILD_ROOT%{_bindir}
167 find -name '*.so' | sed 's|^.|%attr(755,root,root) %{_bindir}|; s|.so$||') > programs.list
168
169 install programs/winhelp/hlp2sgml       $RPM_BUILD_ROOT%{_bindir}
170 install tools/fnt2bdf                   $RPM_BUILD_ROOT%{_bindir}
171
172 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
173         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
174         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
175         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
176         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
177         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
178
179 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/wine
180 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
181 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
182 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
183
184 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
185 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
186 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
187
188 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
189 [mci]
190 cdaudio=mcicda.drv
191 sequencer=mciseq.drv
192 waveaudio=mciwave.drv
193 avivideo=mciavi.drv
194 videodisc=mcipionr.drv
195 vcr=mciviscd.drv
196 MPEGVideo=mciqtz.drv
197 EOF
198
199 %if %{?debug:0}%{!?debug:1}
200 echo "Strip executable binaries and shared object files."
201 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
202 elfexelist=`echo $filelist | xargs -r file | \
203         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
204 elfsharedlist=`echo $filelist | xargs -r file | \
205         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
206 if [ -n "$elfexelist" ]; then \
207         strip -R .note -R .comment $elfexelist
208 fi
209 if [ -n "$elfsharedlist" ]; then
210         strip --strip-unneeded -R .note  -R .comment $elfsharedlist
211 fi
212 %endif
213
214 /sbin/chpax -p $RPM_BUILD_ROOT%{_bindir}/wine
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %post
220 /sbin/ldconfig
221 /sbin/chkconfig --add wine
222 if [ ! -f /var/lock/subsys/wine ]; then
223         echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
224 fi
225
226 %preun
227 if [ "$1" = "0" ]; then
228         if [ -f /var/lock/subsys/wine ]; then
229                 /etc/rc.d/init.d/wine stop >&2
230         fi
231         /sbin/chkconfig --del wine
232 fi
233
234 %postun -p /sbin/ldconfig
235
236 %files
237 %defattr(644,root,root,755)
238 %doc README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
239 %doc documentation/wine-user
240 %attr(755,root,root) %{_bindir}/wine
241 %attr(755,root,root) %{_bindir}/winebuild
242 %attr(755,root,root) %{_bindir}/winemaker
243 %attr(755,root,root) %{_bindir}/wineserver
244 %attr(755,root,root) %{_bindir}/wineclipsrv
245 %attr(755,root,root) %{_bindir}/winelauncher
246 %attr(755,root,root) %{_bindir}/wineshelllink
247 %attr(755,root,root) %{_bindir}/winedump
248 %attr(755,root,root) %{_bindir}/wrc
249 %attr(755,root,root) %{_bindir}/wmc
250 %attr(755,root,root) %{_bindir}/fnt2bdf
251 %attr(755,root,root) %{_bindir}/function_grep.pl
252 %attr(755,root,root) %{_libdir}/*.so*
253 %{_libdir}/wine
254 %{_mandir}/man[15]/*
255 %config(noreplace) %{_sysconfdir}/wine.reg
256 %config(missingok) %{_sysconfdir}/wine.systemreg
257 %config(missingok) %{_sysconfdir}/wine.userreg
258 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
259 %{_winedir}
260
261 %files programs -f programs.list
262 %defattr(644,root,root,755)
263 %attr (755,root,root) %{_bindir}/hlp2sgml
264 #%{_bindir}/*.so
265
266 %files devel
267 %defattr(644,root,root,755)
268 %doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
269 %{_includedir}/wine
270 %{_libdir}/*.a
This page took 0.052595 seconds and 4 git commands to generate.