]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- updated to 20000227
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications.
2 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows.
3 Name:           wine
4 Version:        20000227
5 Release:        1
6 Copyright:      distributable
7 Group:          Applications/Emulators
8 Group(pl):      Applikacje/Emulatory
9 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
10 Url:            http://www.winehq.com
11 Exclusivearch:  %{ix86}
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %define         _prefix         /usr/X11R6
15
16 %description
17 Wine is a program which allows running Microsoft Windows programs
18 (including DOS, Windows 3.x and Win32 executables) on Unix.  It
19 consists of a program loader which loads and executes a Microsoft
20 Windows binary, and a library that implements Windows API calls using
21 their Unix or X11 equivalents. The library may also be used for
22 porting Win32 code into native Unix executables.
23
24 %description -l pl
25 Wine iest programem dziêki któremu mo¿na uruchamiaæ programy napisane
26 dla Microsoft Windows pod systemami unixowymi.
27
28 %package devel
29 Summary:        Wine - header files
30 Summary(pl):    Wine - pliki nag³owkowe
31 Group:          Development/Libraries
32 Group(pl):      Programowanie/Biblioteki
33 Requires:       %{name} = %{version}
34  
35 %description devel
36 Wine - header files.
37
38 %description -l pl devel
39 Wine - pliki nag³ówkowe.
40
41 %prep
42 %setup -q
43
44 %build
45
46 #automake
47 LDFLAGS="-s"; export LDFLAGS
48 %configure \
49     --disable-debug \
50     --disable-trace \
51     --with-x
52
53 make depend
54 make
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_mandir}/man1
59
60 make install \
61         prefix=$RPM_BUILD_ROOT%{_prefix} \
62         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
63         bindir=$RPM_BUILD_ROOT%{_bindir} \
64         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
65         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
66         datadir=$RPM_BUILD_ROOT%{_datadir} \
67         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
68         libdir=$RPM_BUILD_ROOT%{_libdir} \
69         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
70         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
71         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
72         mandir=$RPM_BUILD_ROOT%{_mandir} \
73         infodir=$RPM_BUILD_ROOT%{_infodir} 
74         
75 # there is something broken with make install 
76 # it expects root privileges, and if invoked by user, makes some stupid link
77 # instead of libs installation /by klakier
78
79 rm -f $RPM_BUILD_ROOT%{_libdir}/*.so
80 cp -dp libwine.so* $RPM_BUILD_ROOT%{_libdir}
81
82 cp wine.ini wine.conf.example
83 install -d $RPM_BUILD_ROOT%{_sysconfdir}
84 cat <<EOF >$RPM_BUILD_ROOT%{_sysconfdir}/wine.conf
85 ;
86 ; You can find example wine.conf file in %{_docdir}/%{name}-%{version}/wine.conf.example
87 ; More information: 'man wine.conf' or http://www.winehq.com
88
89 ; Przyk³adowy plik konfiguracyjny jest w %{_docdir}/%{name}-%{version}/wine.conf.example
90 ; Wiêcej informacji: 'man wine.conf' lub na stronach WINE: http://www.winehq.com
91 ;
92 EOF
93
94 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
95 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man5/*
96
97 gzip -9nf README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc {README,WARRANTY,LICENSE,DEVELOPERS-HINTS,ChangeLog,BUGS,AUTHORS,ANNOUNCE}.gz
108 %doc documentation wine.conf.example
109 %attr(755,root,root) %{_bindir}/*
110 %{_mandir}/man1/*
111 %{_mandir}/man5/*
112 %attr(755,root,root) %{_libdir}/*.so*
113 %{_libdir}/wine.sym
114 %config %{_sysconfdir}/wine.conf
115
116 %files devel
117 %defattr(644,root,root,755)
118 %{_includedir}/wine
This page took 0.043627 seconds and 4 git commands to generate.