]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- completed & sorted BuildReqs
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications
2 Summary(es):    Ejecuta programas Windows en Linux
3 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows
4 Summary(pt_BR): Executa programas Windows no Linux
5 Name:           wine
6 Version:        20020411
7 Release:        2
8 License:        GPL
9 Group:          Applications/Emulators
10 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.reg
13 Source3:        %{name}.systemreg
14 Source4:        %{name}.userreg
15 Patch0:         %{name}-fontcache.patch
16 URL:            http://www.winehq.com/
17 ExclusiveArch:  %{ix86}
18 BuildRequires:  arts-devel
19 BuildRequires:  bison
20 BuildRequires:  chpax
21 BuildRequires:  cups-devel
22 BuildRequires:  flex
23 BuildRequires:  freetype-devel >= 2.0.5
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  ncurses-devel
26 BuildRequires:  OpenGL-devel
27 BuildRequires:  sane-backends-devel
28 BuildRequires:  XFree86-devel
29 Requires:       OpenGL
30 Requires(post): ldconfig
31 Requires(post,preun): chkconfig
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
35 %define         no_install_post_strip   1
36
37 %define         _prefix                 /usr/X11R6
38 %define         _mandir                 %{_prefix}/man
39 %define         _winedir                %{_datadir}/%{name}
40
41 %description
42 Wine is a program which allows running Microsoft Windows programs
43 (including DOS, Windows 3.x and Win32 executables) on Unix. It
44 consists of a program loader which loads and executes a Microsoft
45 Windows binary, and a library that implements Windows API calls using
46 their Unix or X11 equivalents. The library may also be used for
47 porting Win32 code into native Unix executables.
48
49 %description -l es
50 Ejecuta programas Windows en Linux.
51
52 %description -l pl
53 Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
54 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z
55 loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
56 Microsoft Windows oraz z biblioteki, która implementuje API Windows
57 przy u¿yciu odpowiedników Unixowych oraz z X11. Biblioteka mo¿e byæ
58 tak¿e wykorzystana do przenoszenia aplikacji Win32 do Unixa.
59
60 %description -l pt_BR
61 O Wine é um programa que permite rodar programas MS-Windows no X11.
62 Ele consiste de um carregador de programa, que carrega e executa um
63 binário MS-Windows, e de uma biblioteca de emulação que traduz as
64 chamadas da API para as equivalentes Unix/X11.
65
66 %package devel
67 Summary:        Wine - header files
68 Summary(es):    Biblioteca de desarrollo de wine
69 Summary(pl):    Wine - pliki nag³owkowe
70 Summary(pt_BR): Biblioteca de desenvolvimento do wine
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}
73
74 %description devel
75 Wine - header files.
76
77 %description devel -l es
78 Biblioteca de desarrollo de wine.
79
80 %description devel -l pl
81 Wine - pliki nag³ówkowe.
82
83 %description devel -l pt_BR
84 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
85 WINE.
86
87 %package programs
88 Summary:        Wine - programs
89 Summary(pl):    Wine - programy
90 Group:          Applications
91 Requires:       %{name} = %{version}
92
93 %description programs
94 Wine - programs
95
96 %description programs -l pl
97 Wine - programy
98
99 %prep
100 %setup -q
101 %patch -p1
102
103 # turn off compilation of some tools
104 sed -e "s|winetest||;s|avitools||" programs/Makefile.in > .tmp
105 mv -f .tmp programs/Makefile.in
106
107 %build
108 #aclocal
109 #autoconf
110 CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
111 CFLAGS="%{rpmcflags} $CPPFLAGS"
112 %configure \
113 %{!?debug:      --disable-debug} \
114 %{!?debug:      --disable-trace} \
115         --enable-curses \
116         --enable-opengl \
117         --with-x
118
119 %{__make} depend
120 %{__make}
121 %{__make} -C programs
122
123 (cd documentation
124 ./db2html-winehq wine-user.sgml
125 ./db2html-winehq wine-devel.sgml
126 ./db2html-winehq winelib-user.sgml)
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT%{_mandir}/man1
131
132 %{__make} install \
133         prefix=$RPM_BUILD_ROOT%{_prefix} \
134         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
135         bindir=$RPM_BUILD_ROOT%{_bindir} \
136         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
137         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
138         datadir=$RPM_BUILD_ROOT%{_datadir} \
139         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
140         libdir=$RPM_BUILD_ROOT%{_libdir} \
141         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
142         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
143         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
144         mandir=$RPM_BUILD_ROOT%{_mandir} \
145         infodir=$RPM_BUILD_ROOT%{_infodir} \
146         dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
147
148 %{__make} -C programs install \
149         prefix=$RPM_BUILD_ROOT%{_prefix} \
150         bindir=$RPM_BUILD_ROOT%{_bindir}
151
152 (cd $RPM_BUILD_ROOT%{_bindir}
153 find -name '*.so' | sed 's|^.|%attr(755,root,root) %{_bindir}|; s|.so$||') > programs.list
154
155 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
156         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
157         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
158         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
159         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
160         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
161
162 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/wine
163 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
164 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
165 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
166
167 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
168 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
169 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
170
171 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
172 [mci]
173 cdaudio=mcicda.drv
174 sequencer=mciseq.drv
175 waveaudio=mciwave.drv
176 avivideo=mciavi.drv
177 videodisc=mcipionr.drv
178 vcr=mciviscd.drv
179 MPEGVideo=mciqtz.drv
180 EOF
181
182 gzip -9nf README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
183
184 %if %{?debug:0}%{!?debug:1}
185 echo "Strip executable binaries and shared object files."
186 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
187 elfexelist=`echo $filelist | xargs -r file | \
188         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
189 elfsharedlist=`echo $filelist | xargs -r file | \
190         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
191 if [ -n "$elfexelist" ]; then \
192         strip -R .note -R .comment $elfexelist
193 fi
194 if [ -n "$elfsharedlist" ]; then
195         strip --strip-unneeded -R .note  -R .comment $elfsharedlist
196 fi
197 %endif
198
199 /sbin/chpax -p $RPM_BUILD_ROOT%{_bindir}/wine
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %post
205 /sbin/ldconfig
206 /sbin/chkconfig --add wine
207 if [ ! -f /var/lock/subsys/wine ]; then
208         echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
209 fi
210
211 %preun
212 if [ "$1" = "0" ]; then
213         if [ -f /var/lock/subsys/wine ]; then
214                 /etc/rc.d/init.d/wine stop >&2
215         fi
216         /sbin/chkconfig --del wine
217 fi
218
219 %postun -p /sbin/ldconfig
220
221 %files
222 %defattr(644,root,root,755)
223 %doc *.gz
224 %doc documentation/wine-user
225 %attr(755,root,root) %{_bindir}/wine
226 %attr(755,root,root) %{_bindir}/winebuild
227 %attr(755,root,root) %{_bindir}/winemaker
228 %attr(755,root,root) %{_bindir}/wineserver
229 %attr(755,root,root) %{_bindir}/wineclipsrv
230 %attr(755,root,root) %{_bindir}/winelauncher
231 %attr(755,root,root) %{_bindir}/wineshelllink
232 %attr(755,root,root) %{_bindir}/winedump
233 %attr(755,root,root) %{_bindir}/wrc
234 %attr(755,root,root) %{_bindir}/wmc
235 %attr(755,root,root) %{_bindir}/fnt2bdf
236 %attr(755,root,root) %{_bindir}/function_grep.pl
237 %attr(755,root,root) %{_libdir}/*.so*
238 %{_libdir}/wine
239 %{_mandir}/man[15]/*
240 %config(noreplace) %{_sysconfdir}/wine.reg
241 %config(missingok) %{_sysconfdir}/wine.systemreg
242 %config(missingok) %{_sysconfdir}/wine.userreg
243 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
244 %{_winedir}
245
246 %files programs -f programs.list
247 %defattr(644,root,root,755)
248 %attr (755,root,root) %{_bindir}/hlp2sgml
249 %{_bindir}/*.so
250
251 %files devel
252 %defattr(644,root,root,755)
253 %doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
254 %{_includedir}/wine
255 %{_libdir}/*.a
This page took 0.056428 seconds and 4 git commands to generate.