]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- initial working wersion
[packages/wine.git] / wine.spec
1
2 Summary:        Program that lets you launch Win applications.
3 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows.
4 Name:           wine
5 Version:        20000130
6 Release:        1
7 Copyright:      distributable
8 Group:          Applications/Emulators
9 Group(pl):      Applikacje/Emulatory
10 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
11 Url:            http://www.winehq.com
12 Exclusivearch:  %{ix86}
13 Buildroot:      /tmp/%{name}-%{version}-root
14
15 %description
16
17 %description -l pl
18
19
20
21 %package devel
22 Summary:        Wine - header files
23 Summary(pl):    Wine - pliki nag³owkowe
24 Group:          Development/Libraries
25 Group(pl):      Programowanie/Biblioteki
26 Requires:       %{name} = %{version}
27  
28 %description devel
29 Wine - header files.
30
31 %description -l pl devel
32 Wine - pliki nag³ówkowe.
33
34
35 %prep
36 %setup -q
37
38 %build
39
40 #automake
41 LDFLAGS="-s"; export LDFLAGS
42 %configure
43 make depend
44 make
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{_mandir}/man1
49
50 make install \
51         prefix=$RPM_BUILD_ROOT%{_prefix} \
52         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
53         bindir=$RPM_BUILD_ROOT%{_bindir} \
54         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
55         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
56         datadir=$RPM_BUILD_ROOT%{_datadir} \
57         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
58         libdir=$RPM_BUILD_ROOT%{_libdir} \
59         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
60         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
61         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
62         mandir=$RPM_BUILD_ROOT%{_mandir} \
63         infodir=$RPM_BUILD_ROOT%{_infodir} 
64         
65 # there is something broken with make install 
66 # it expects root privileges, and if invoked by user, makes some stupid link
67 # instead of libs installation /by klakier
68
69 rm -f $RPM_BUILD_ROOT%{_libdir}/*.so
70 cp -dp libwine.so* $RPM_BUILD_ROOT%{_libdir}
71
72 cp wine.ini wine.conf.example
73 install -d $RPM_BUILD_ROOT%{_sysconfdir}
74 cat <<EOF >$RPM_BUILD_ROOT%{_sysconfdir}/wine.conf
75 ;
76 ; You can find example wine.conf file in %{_docdir}/%{name}-%{version}/wine.conf.example
77 ; More information: 'man wine.conf' or http://www.winehq.com
78
79 ; Przyk³adowy plik konfiguracyjny jest w %{_docdir}/%{name}-%{version}/wine.conf.example
80 ; Wiêcej informacji: 'man wine.conf' lub na stronach WINE: http://www.winehq.com
81 ;
82 EOF
83
84
85 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
86 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man5/*
87
88 gzip -9nf README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
89
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97     
98 %files
99 %defattr(644,root,root,755)
100 %doc {README,WARRANTY,LICENSE,DEVELOPERS-HINTS,ChangeLog,BUGS,AUTHORS,ANNOUNCE}.gz
101 %doc documentation wine.conf.example
102 %attr(755,root,root) %{_bindir}/*
103 %{_mandir}/man1/*
104 %{_mandir}/man5/*
105 %attr(755,root,root) %{_libdir}/*.so*
106 %{_libdir}/wine.sym
107 %config %{_sysconfdir}/wine.conf
108
109 %files devel
110 %defattr(644,root,root,755)
111 %{_includedir}/wine
This page took 0.055274 seconds and 4 git commands to generate.