]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- disable debuginfocflags - it somehow breaks build in this version
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  arts            # don't build aRts mm driver
5 %bcond_without  jack            # don't build JACK mm driver
6 %bcond_without  nas             # don't build NAS mm driver
7 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 #
10 # NOTE: wine detects the following SONAMES for dlopen at build time:
11 #   libcrypto,libssl (wininet.dll)
12 #   libcups (winspool.dll.so,wineps.dll.so)
13 #   libcurses/libncurses (wineconsole program)
14 #   libfontconfig (gdi32.dll.so)
15 #   libfreetype (wineps.dll.so,gdi32.dll.so)
16 #   libGL (x11drv.dll.so,ddraw.dll.so)
17 #   libjack (winejack.drv.so - explicit dependency in subpackage)
18 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
19 # thus requires rebuild after change of any of the above.
20 #
21 # JACK requires ALSA
22 %if !%{with alsa}
23 %undefine       with_jack
24 %endif
25 Summary:        Program that lets you launch Win applications
26 Summary(es):    Ejecuta programas Windows en Linux
27 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows
28 Summary(pt_BR): Executa programas Windows no Linux
29 Name:           wine
30 Version:        0.9.29
31 Release:        2
32 Epoch:          1
33 License:        LGPL
34 Group:          Applications/Emulators
35 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
36 # Source0-md5:  4f6270a0828e0f8e524cf360b7fd58ee
37 Patch0:         %{name}-fontcache.patch
38 Patch1:         %{name}-makedep.patch
39 Patch2:         %{name}-alsa.patch
40 Patch3:         %{name}-ncurses.patch
41 #PatchX:                %{name}-dga.patch
42 URL:            http://www.winehq.org/
43 BuildRequires:  OpenGL-GLU-devel
44 %{?with_alsa:BuildRequires:     alsa-lib-devel}
45 %{?with_arts:BuildRequires:     artsc-devel}
46 BuildRequires:  autoconf
47 BuildRequires:  automake
48 BuildRequires:  bison
49 # BuildRequires:        chpax >= 0.20020901-2
50 %{?with_cups:BuildRequires:     cups-devel}
51 BuildRequires:  docbook-dtd31-sgml
52 BuildRequires:  docbook-utils
53 BuildRequires:  flex
54 BuildRequires:  fontconfig-devel
55 BuildRequires:  fontforge
56 BuildRequires:  freetype-devel >= 2.0.5
57 BuildRequires:  giflib-devel
58 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libtool
61 %{?with_nas:BuildRequires:      nas-devel}
62 BuildRequires:  ncurses-devel
63 # db2* failed previously - probably openjade or opensp bug
64 BuildRequires:  openjade >= 1:1.3.3-0.pre1
65 BuildRequires:  opensp >= 1:1.5.1
66 BuildRequires:  openssl-devel >= 0.9.7d
67 %{?with_sane:BuildRequires:     sane-backends-devel}
68 BuildRequires:  valgrind
69 BuildRequires:  xorg-lib-libXi-devel
70 BuildRequires:  xorg-lib-libXmu-devel
71 BuildRequires:  xorg-lib-libXrender-devel
72 BuildRequires:  xorg-lib-libXxf86dga-devel
73 BuildRequires:  xorg-lib-libXxf86vm-devel
74 Requires:       binfmt-detector
75 # link to wine/ntdll.dll.so, without any SONAME
76 Provides:       libntdll.dll.so
77 ExclusiveArch:  %{ix86}
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
81 %define         no_install_post_strip   1
82
83 %define         _winedir                %{_datadir}/%{name}
84
85 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
86
87 %undefine       debuginfocflags
88
89 %description
90 Wine is a program which allows running Microsoft Windows programs
91 (including DOS, Windows 3.x and Win32 executables) on Unix. It
92 consists of a program loader which loads and executes a Microsoft
93 Windows binary, and a library that implements Windows API calls using
94 their Unix or X11 equivalents. The library may also be used for
95 porting Win32 code into native Unix executables.
96
97 %description -l es
98 Ejecuta programas Windows en Linux.
99
100 %description -l pl
101 Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
102 dla Microsoft Windows pod systemami uniksowymi. Sk³ada siê on z
103 loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
104 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
105 przy u¿yciu odpowiedników uniksowych oraz z X11. Biblioteka mo¿e byæ
106 tak¿e wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
107
108 %description -l pt_BR
109 O Wine é um programa que permite rodar programas MS-Windows no X11.
110 Ele consiste de um carregador de programa, que carrega e executa um
111 binário MS-Windows, e de uma biblioteca de emulação que traduz as
112 chamadas da API para as equivalentes Unix/X11.
113
114 %package devel
115 Summary:        Wine - header files
116 Summary(es):    Biblioteca de desarrollo de wine
117 Summary(pl):    Wine - pliki nag³owkowe
118 Summary(pt_BR): Biblioteca de desenvolvimento do wine
119 Group:          Development/Libraries
120 Requires:       %{name} = %{epoch}:%{version}-%{release}
121
122 %description devel
123 Wine - header files.
124
125 %description devel -l es
126 Biblioteca de desarrollo de wine.
127
128 %description devel -l pl
129 Wine - pliki nag³ówkowe.
130
131 %description devel -l pt_BR
132 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
133 WINE.
134
135 %package programs
136 Summary:        Wine - programs
137 Summary(pl):    Wine - programy
138 Group:          Applications
139 Requires:       %{name} = %{epoch}:%{version}-%{release}
140
141 %description programs
142 Wine - programs.
143
144 %description programs -l pl
145 Wine - programy.
146
147 %package dll-d3d
148 Summary:        Direct3D implementation DLLs for Wine
149 Summary(pl):    Biblioteki DLL z implementacj± Direct3D dla Wine
150 Group:          Applications/Emulators
151 Requires:       %{name} = %{epoch}:%{version}-%{release}
152 Requires:       OpenGL
153
154 %description dll-d3d
155 Direct3D implementation DLLs for Wine (through OpenGL).
156
157 %description dll-d3d -l pl
158 Biblioteki DLL z implementacj± Direct3D dla Wine (poprzez OpenGL).
159
160 %package dll-gl
161 Summary:        OpenGL implementation DLLs for Wine
162 Summary(pl):    Biblioteki DLL z implementacj± OpenGL dla Wine
163 Group:          Applications/Emulators
164 Requires:       %{name} = %{epoch}:%{version}-%{release}
165 Requires:       OpenGL
166
167 %description dll-gl
168 OpenGL implementation DLLs for Wine.
169
170 %description dll-gl -l pl
171 Biblioteki DLL z implementacj± OpenGL dla Wine.
172
173 %package dll-twain
174 Summary:        TWAIN implementation DLL for Wine
175 Summary(pl):    Biblioteka DLL z implementacj± TWAIN dla Wine
176 Group:          Applications/Emulators
177 Requires:       %{name} = %{epoch}:%{version}-%{release}
178
179 %description dll-twain
180 TWAIN implementation DLL for Wine (through SANE).
181
182 %description dll-twain -l pl
183 Biblioteka DLL z implementacj± TWAIN dla Wine (poprzez SANE).
184
185 %package drv-alsa
186 Summary:        ALSA driver for WINE mm.dll implementation
187 Summary(pl):    Sterownik ALSA dla implementacji mm.dll w Wine
188 Group:          Applications/Emulators
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190
191 %description drv-alsa
192 ALSA driver for WINE mm.dll (multimedia system) implementation.
193
194 %description drv-alsa -l pl
195 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
196
197 %package drv-arts
198 Summary:        aRts driver for WINE mm.dll implementation
199 Summary(pl):    Sterownik aRts dla implementacji mm.dll w Wine
200 Group:          Applications/Emulators
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202
203 %description drv-arts
204 aRts driver for WINE mm.dll (multimedia system) implementation.
205
206 %description drv-arts -l pl
207 Sterownik aRts dla implementacji mm.dll (systemu multimediów) w Wine.
208
209 %package drv-jack
210 Summary:        JACK driver for WINE mm.dll implementation
211 Summary(pl):    Sterownik JACK-a dla implementacji mm.dll w Wine
212 Group:          Applications/Emulators
213 Requires:       %{name} = %{epoch}:%{version}-%{release}
214 Requires:       jack-audio-connection-kit
215 # dlopened by SONAME detected at build time
216 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
217
218 %description drv-jack
219 JACK driver for WINE mm.dll (multimedia system) implementation.
220
221 %description drv-jack -l pl
222 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
223 Wine.
224
225 %package drv-nas
226 Summary:        NAS driver for WINE mm.dll implementation
227 Summary(pl):    Sterownik NAS dla implementacji mm.dll w Wine
228 Group:          Applications/Emulators
229 Requires:       %{name} = %{epoch}:%{version}-%{release}
230
231 %description drv-nas
232 NAS driver for WINE mm.dll (multimedia system) implementation.
233
234 %description drv-nas -l pl
235 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
236
237 %prep
238 %setup -q
239 %patch0 -p1
240 %patch1 -p1
241 %patch2 -p1
242 %patch3 -p1
243
244 # turn off compilation of some tools
245 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
246 #sed -i -e "s|avitools||" programs/Makefile.in
247
248 %build
249 %{__autoconf}
250 %{__autoheader}
251 %configure \
252         %{!?debug:--disable-debug} \
253         %{!?debug:--disable-trace} \
254         --enable-curses \
255         --enable-opengl \
256         --with-x
257 %{__make} depend
258 %{__make}
259 %{__make} -C programs
260 #%{__make} -C programs/regapi
261
262 %install
263 rm -rf $RPM_BUILD_ROOT
264 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
265
266 %{__make} install \
267         DESTDIR=$RPM_BUILD_ROOT
268
269 %{__make} -C programs install \
270         DESTDIR=$RPM_BUILD_ROOT
271
272 install tools/fnt2bdf                   $RPM_BUILD_ROOT%{_bindir}
273
274 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
275 #mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
276
277 install -d \
278         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
279         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
280         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
281         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
282         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
283
284 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
285 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
286 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
287
288 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
289 [mci]
290 cdaudio=mcicda.drv
291 sequencer=mciseq.drv
292 waveaudio=mciwave.drv
293 avivideo=mciavi.drv
294 videodisc=mcipionr.drv
295 vcr=mciviscd.drv
296 MPEGVideo=mciqtz.drv
297 EOF
298
299 %if %{?debug:0}%{!?debug:1}
300 echo "Strip executable binaries and shared object files."
301 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
302 elfexelist=`echo $filelist | xargs -r file | \
303         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
304 elfsharedlist=`echo $filelist | xargs -r file | \
305         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
306 if [ -n "$elfexelist" ]; then \
307         strip -R .note -R .comment $elfexelist
308 fi
309 if [ -n "$elfsharedlist" ]; then
310         strip --strip-unneeded -R .note -R .comment $elfsharedlist
311 fi
312 %endif
313
314 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
315
316 programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
317
318 BZZZ=`pwd`
319 rm -f files.so;         touch files.so
320 rm -f files.programs;   touch files.programs
321 cd $RPM_BUILD_ROOT%{_libdir}/wine
322 for f in *.so; do
323         case $f in
324                 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winearts.drv.so|winejack.drv.so|winenas.drv.so)
325                         ;;
326                 *)
327                         echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
328         esac
329 done
330 cd -
331 for p in $programs; do
332         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
333         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
334         grep -v "$p\.exe\.so$" files.so > files.so.
335         mv -f files.so. files.so
336 done
337
338 %clean
339 rm -rf $RPM_BUILD_ROOT
340
341 %post   -p /sbin/ldconfig
342 %postun -p /sbin/ldconfig
343
344 %triggerpostun -- wine < 1:0.9.12-1.9
345 rm -f /var/lock/subsys/wine
346 if [ -x /sbin/chkconfig ]; then
347         /sbin/chkconfig --del wine
348 fi
349
350 %files -f files.so
351 %defattr(644,root,root,755)
352 %doc README ChangeLog AUTHORS ANNOUNCE
353 %lang(de) %doc documentation/README.de
354 %lang(es) %doc documentation/README.es
355 %lang(fr) %doc documentation/README.fr
356 %lang(it) %doc documentation/README.it
357 %lang(ko) %doc documentation/README.ko
358 %lang(nb) %doc documentation/README.no
359 %lang(pt) %doc documentation/README.pt
360 %lang(pt_BR) %doc documentation/README.pt_br
361 %attr(755,root,root) %{_bindir}/msiexec
362 %attr(755,root,root) %{_bindir}/wine
363 %attr(755,root,root) %{_bindir}/wineboot
364 %attr(755,root,root) %{_bindir}/winebrowser
365 %attr(755,root,root) %{_bindir}/winecfg
366 %attr(755,root,root) %{_bindir}/winedbg
367 %attr(755,root,root) %{_bindir}/wine-kthread
368 %attr(755,root,root) %{_bindir}/winelauncher
369 %attr(755,root,root) %{_bindir}/wineprefixcreate
370 %attr(755,root,root) %{_bindir}/wine-preloader
371 %attr(755,root,root) %{_bindir}/wine-pthread
372 %attr(755,root,root) %{_bindir}/wineserver
373 %attr(755,root,root) %{_bindir}/wineshelllink
374 %attr(755,root,root) %{_libdir}/*.so*
375 %dir %{_libdir}/wine
376 %{_libdir}/wine/*.dll16
377 %{_libdir}/wine/*.drv16
378 %{_libdir}/wine/*.exe16
379 %{_mandir}/man1/wine.1*
380 %{_mandir}/man1/winedbg.1*
381 %{_mandir}/man1/wineprefixcreate.1*
382 %{_mandir}/man1/wineserver.1*
383 %{_winedir}
384 %{_desktopdir}/wine.desktop
385
386 %files programs -f files.programs
387 %defattr(644,root,root,755)
388
389 %files devel
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_bindir}/fnt2bdf
392 %attr(755,root,root) %{_bindir}/function_grep.pl
393 %attr(755,root,root) %{_bindir}/widl
394 %attr(755,root,root) %{_bindir}/winebuild
395 %attr(755,root,root) %{_bindir}/winedump
396 %attr(755,root,root) %{_bindir}/wineg++
397 %attr(755,root,root) %{_bindir}/winegcc
398 %attr(755,root,root) %{_bindir}/winemaker
399 #%attr(755,root,root) %{_bindir}/winewrap
400 %attr(755,root,root) %{_bindir}/wmc
401 %attr(755,root,root) %{_bindir}/wrc
402 %{_libdir}/wine/lib*.def
403 # no shared variants, so not separated
404 %{_libdir}/wine/lib*.def.a
405 %{_libdir}/wine/libdx*.a
406 %{_libdir}/wine/libstrmiids.a
407 %{_libdir}/wine/libuuid.a
408 %{_libdir}/wine/libwinecrt0.a
409 %{_includedir}/wine
410 %{_mandir}/man1/widl.1*
411 %{_mandir}/man1/winedump.1*
412 %{_mandir}/man1/winegcc.1*
413 %{_mandir}/man1/winemaker.1*
414 %{_mandir}/man1/winebuild.1*
415 %{_mandir}/man1/wmc.1*
416 %{_mandir}/man1/wrc.1*
417 %{_aclocaldir}/*.m4
418
419 %files dll-d3d
420 %defattr(644,root,root,755)
421 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
422 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
423 %attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
424 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
425
426 %files dll-gl
427 %defattr(644,root,root,755)
428 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
429 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
430
431 %if %{with sane}
432 %files dll-twain
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
435 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
436 %endif
437
438 %if %{with alsa}
439 %files drv-alsa
440 %defattr(644,root,root,755)
441 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
442 %endif
443
444 %if %{with arts}
445 %files drv-arts
446 %defattr(644,root,root,755)
447 %attr(755,root,root) %{_libdir}/wine/winearts.drv.so
448 %endif
449
450 %if %{with jack}
451 %files drv-jack
452 %defattr(644,root,root,755)
453 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
454 %endif
455
456 %if %{with nas}
457 %files drv-nas
458 %defattr(644,root,root,755)
459 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
460 %endif
461
462 # additional dependencies in *.so not separated (yet?) from main package
463 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
464 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
465 #   ttydrv.dll.so depends on ncurses
This page took 0.094928 seconds and 4 git commands to generate.