]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- Updated to 20000430.
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications.
2 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows.
3 Name:           wine
4 Version:        20000430
5 Release:        1
6 Copyright:      distributable
7 Group:          Applications/Emulators
8 Group(pl):      Aplikacje/Emulatory
9 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
10 Url:            http://www.winehq.com
11 Exclusivearch:  %{ix86}
12 BuildRequires:  XFree86-devel
13 BuildRequires:  xpm-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _prefix         /usr/X11R6
17
18 %description
19 Wine is a program which allows running Microsoft Windows programs
20 (including DOS, Windows 3.x and Win32 executables) on Unix.  It
21 consists of a program loader which loads and executes a Microsoft
22 Windows binary, and a library that implements Windows API calls using
23 their Unix or X11 equivalents. The library may also be used for
24 porting Win32 code into native Unix executables.
25
26 %description -l pl
27 Wine iest programem dziêki któremu mo¿na uruchamiaæ programy napisane
28 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z loadera, który
29 pozwala wczytywaæ i uruchamiaæ programy w formacie Microsoft Windows oraz z
30 biblioteki, która implementuje API Windows przy u¿yciu odpowiedników Unixowych
31 oraz z X11. Biblioteka mo¿e byæ tak¿e wykorzystana do przenoszenia aplikacji
32 Win32 do Unixa.
33
34 %package devel
35 Summary:        Wine - header files
36 Summary(pl):    Wine - pliki nag³owkowe
37 Group:          Development/Libraries
38 Group(pl):      Programowanie/Biblioteki
39 Requires:       %{name} = %{version}
40  
41 %description devel
42 Wine - header files.
43
44 %description -l pl devel
45 Wine - pliki nag³ówkowe.
46
47 %prep
48 %setup -q
49
50 %build
51 LDFLAGS="-s"; export LDFLAGS
52 %configure \
53     --disable-debug \
54     --disable-trace \
55     --with-x
56
57 make depend
58 make
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_mandir}/man1
63
64 make install \
65         prefix=$RPM_BUILD_ROOT%{_prefix} \
66         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
67         bindir=$RPM_BUILD_ROOT%{_bindir} \
68         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
69         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
70         datadir=$RPM_BUILD_ROOT%{_datadir} \
71         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
72         libdir=$RPM_BUILD_ROOT%{_libdir} \
73         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
74         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
75         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
76         mandir=$RPM_BUILD_ROOT%{_mandir} \
77         infodir=$RPM_BUILD_ROOT%{_infodir} 
78         
79 # there is something broken with make install 
80 # it expects root privileges, and if invoked by user, makes some stupid link
81 # instead of libs installation /by klakier
82
83 rm -f $RPM_BUILD_ROOT%{_libdir}/*.so
84 cp -dp libwine.so* $RPM_BUILD_ROOT%{_libdir}
85
86 cp wine.ini wine.conf.example
87 install -d $RPM_BUILD_ROOT%{_sysconfdir}
88 cat <<EOF >$RPM_BUILD_ROOT%{_sysconfdir}/wine.conf
89 ;
90 ; You can find example wine.conf file in %{_docdir}/%{name}-%{version}/wine.conf.example
91 ; More information: 'man wine.conf' or http://www.winehq.com
92
93 ; Przyk³adowy plik konfiguracyjny jest w %{_docdir}/%{name}-%{version}/wine.conf.example
94 ; Wiêcej informacji: 'man wine.conf' lub na stronach WINE: http://www.winehq.com
95 ;
96 EOF
97
98 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/*.so.*.*
99 strip $RPM_BUILD_ROOT%{_bindir}/*
100
101 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
102         README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc {README,WARRANTY,LICENSE,DEVELOPERS-HINTS,ChangeLog,BUGS,AUTHORS,ANNOUNCE}.gz
113 %doc documentation wine.conf.example
114 %attr(755,root,root) %{_bindir}/*
115 %{_mandir}/man[15]/*
116 %attr(755,root,root) %{_libdir}/lib*.so.*.*
117 %{_libdir}/wine.sym
118 %config %{_sysconfdir}/wine.conf
119
120 %files devel
121 %defattr(644,root,root,755)
122 %{_includedir}/wine
123 %attr(755,root,root) %{_libdir}/lib*.so
This page took 0.045573 seconds and 4 git commands to generate.