]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- version to ntlm_auth
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  jack            # don't build JACK mm driver
5 %bcond_without  nas             # don't build NAS mm driver
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
8 #
9 # NOTE: wineconsole is a bit broken: try wineconsole cmd to see what will happen
10 #       As a workaroound use `wineconsole --backend=user cmd' (works fine)
11 #       ref: http://bugs.winehq.org/show_bug.cgi?id=8069
12 #
13 # NOTE: wine detects the following SONAMES for dlopen at build time:
14 #   libcrypto,libssl (wininet.dll)
15 #   libcups (winspool.dll.so,wineps.dll.so)
16 #   libcurses/libncurses (wineconsole program)
17 #   libfontconfig (gdi32.dll.so)
18 #   libfreetype (wineps.dll.so,gdi32.dll.so)
19 #   libGL (x11drv.dll.so,ddraw.dll.so)
20 #   libjack (winejack.drv.so - explicit dependency in subpackage)
21 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
22 # thus requires rebuild after change of any of the above.
23 #
24 # JACK requires ALSA
25 %if %{without alsa}
26 %undefine       with_jack
27 %endif
28 Summary:        Program that lets you launch Win applications
29 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
30 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
31 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
32 Name:           wine
33 Version:        0.9.60
34 Release:        1
35 Epoch:          1
36 License:        LGPL
37 Group:          Applications/Emulators
38 Source0:        http://dl.sourceforge.net/wine/%{name}-%{version}.tar.bz2
39 # Source0-md5:  4960869defb2d93daff6fe74da334463
40 Patch0:         %{name}-fontcache.patch
41 Patch1:         %{name}-makedep.patch
42 Patch2:         %{name}-ncurses.patch
43 Patch3:         %{name}-bug9177_workaround.patch
44 Patch4:         %{name}-disable-valgrind.patch
45 #PatchX:                %{name}-dga.patch
46 URL:            http://www.winehq.org/
47 BuildRequires:  OpenGL-GLU-devel
48 %{?with_alsa:BuildRequires:     alsa-lib-devel}
49 %{?with_arts:BuildRequires:     artsc-devel}
50 BuildRequires:  autoconf
51 BuildRequires:  automake
52 BuildRequires:  bison
53 %{?with_cups:BuildRequires:     cups-devel}
54 BuildRequires:  docbook-dtd31-sgml
55 BuildRequires:  docbook-utils
56 BuildRequires:  flex
57 BuildRequires:  fontconfig-devel
58 BuildRequires:  fontforge
59 BuildRequires:  freetype-devel >= 2.0.5
60 BuildRequires:  giflib-devel
61 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
62 BuildRequires:  libjpeg-devel
63 BuildRequires:  libtool
64 %{?with_nas:BuildRequires:      nas-devel}
65 BuildRequires:  ncurses-devel
66 # db2* failed previously - probably openjade or opensp bug
67 BuildRequires:  openjade >= 1:1.3.3-0.pre1
68 BuildRequires:  openldap-devel >= 2.4.6
69 BuildRequires:  opensp >= 1:1.5.1
70 BuildRequires:  openssl-devel >= 0.9.7d
71 %{?with_sane:BuildRequires:     sane-backends-devel}
72 #BuildRequires: valgrind
73 BuildRequires:  xorg-lib-libXi-devel
74 BuildRequires:  xorg-lib-libXmu-devel
75 BuildRequires:  xorg-lib-libXrender-devel
76 BuildRequires:  xorg-lib-libXxf86dga-devel
77 BuildRequires:  xorg-lib-libXxf86vm-devel
78 Suggests:       binfmt-detector
79 # for winelauncher
80 Suggests:       xorg-app-xmessage
81 # for ntlm_auth
82 Suggests:       samba-common >= 1:3.0.25
83 # link to wine/ntdll.dll.so, without any SONAME
84 Provides:       libntdll.dll.so
85 Obsoletes:      wine-doc-pdf
86 Obsoletes:      wine-drv-arts
87 ExclusiveArch:  %{ix86}
88 ExcludeArch:    i386
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
92 %define         no_install_post_strip   1
93
94 %define         _winedir                %{_datadir}/%{name}
95
96 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
97
98 %undefine       debuginfocflags
99
100 %description
101 Wine is a program which allows running Microsoft Windows programs
102 (including DOS, Windows 3.x and Win32 executables) on Unix. It
103 consists of a program loader which loads and executes a Microsoft
104 Windows binary, and a library that implements Windows API calls using
105 their Unix or X11 equivalents. The library may also be used for
106 porting Win32 code into native Unix executables.
107
108 %description -l es.UTF-8
109 Ejecuta programas Windows en Linux.
110
111 %description -l pl.UTF-8
112 Wine jest programem dzięki któremu można uruchamiać programy napisane
113 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
114 loadera, który pozwala wczytywać i uruchamiać programy w formacie
115 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
116 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
117 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
118
119 %description -l pt_BR.UTF-8
120 O Wine é um programa que permite rodar programas MS-Windows no X11.
121 Ele consiste de um carregador de programa, que carrega e executa um
122 binário MS-Windows, e de uma biblioteca de emulação que traduz as
123 chamadas da API para as equivalentes Unix/X11.
124
125 %package devel
126 Summary:        Wine - header files
127 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
128 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
129 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
130 Group:          Development/Libraries
131 Requires:       %{name} = %{epoch}:%{version}-%{release}
132
133 %description devel
134 Wine - header files.
135
136 %description devel -l es.UTF-8
137 Biblioteca de desarrollo de wine.
138
139 %description devel -l pl.UTF-8
140 Wine - pliki nagłówkowe.
141
142 %description devel -l pt_BR.UTF-8
143 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
144 WINE.
145
146 %package programs
147 Summary:        Wine - programs
148 Summary(pl.UTF-8):      Wine - programy
149 Group:          Applications
150 Requires:       %{name} = %{epoch}:%{version}-%{release}
151
152 %description programs
153 Wine - programs.
154
155 %description programs -l pl.UTF-8
156 Wine - programy.
157
158 %package dll-d3d
159 Summary:        Direct3D implementation DLLs for Wine
160 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
161 Group:          Applications/Emulators
162 Requires:       %{name} = %{epoch}:%{version}-%{release}
163 Requires:       OpenGL
164
165 %description dll-d3d
166 Direct3D implementation DLLs for Wine (through OpenGL).
167
168 %description dll-d3d -l pl.UTF-8
169 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
170
171 %package dll-gl
172 Summary:        OpenGL implementation DLLs for Wine
173 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
174 Group:          Applications/Emulators
175 Requires:       %{name} = %{epoch}:%{version}-%{release}
176 Requires:       OpenGL
177
178 %description dll-gl
179 OpenGL implementation DLLs for Wine.
180
181 %description dll-gl -l pl.UTF-8
182 Biblioteki DLL z implementacją OpenGL dla Wine.
183
184 %package dll-twain
185 Summary:        TWAIN implementation DLL for Wine
186 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
187 Group:          Applications/Emulators
188 Requires:       %{name} = %{epoch}:%{version}-%{release}
189
190 %description dll-twain
191 TWAIN implementation DLL for Wine (through SANE).
192
193 %description dll-twain -l pl.UTF-8
194 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
195
196 %package drv-alsa
197 Summary:        ALSA driver for WINE mm.dll implementation
198 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
199 Group:          Applications/Emulators
200 Requires:       %{name} = %{epoch}:%{version}-%{release}
201
202 %description drv-alsa
203 ALSA driver for WINE mm.dll (multimedia system) implementation.
204
205 %description drv-alsa -l pl.UTF-8
206 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
207
208 %package drv-jack
209 Summary:        JACK driver for WINE mm.dll implementation
210 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
211 Group:          Applications/Emulators
212 Requires:       %{name} = %{epoch}:%{version}-%{release}
213 Requires:       jack-audio-connection-kit
214 # dlopened by SONAME detected at build time
215 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
216
217 %description drv-jack
218 JACK driver for WINE mm.dll (multimedia system) implementation.
219
220 %description drv-jack -l pl.UTF-8
221 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
222 Wine.
223
224 %package drv-nas
225 Summary:        NAS driver for WINE mm.dll implementation
226 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
227 Group:          Applications/Emulators
228 Requires:       %{name} = %{epoch}:%{version}-%{release}
229
230 %description drv-nas
231 NAS driver for WINE mm.dll (multimedia system) implementation.
232
233 %description drv-nas -l pl.UTF-8
234 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
235
236 %prep
237 %setup -q
238 %patch0 -p1
239 %patch1 -p1
240 %patch2 -p1
241 %patch3 -p1
242 %patch4 -p1
243
244 # turn off compilation of some tools
245 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
246 #sed -i -e "s|avitools||" programs/Makefile.in
247
248 %build
249 %{__autoconf}
250 %{__autoheader}
251 %configure \
252         %{!?debug:--disable-debug} \
253         %{!?debug:--disable-trace} \
254         --enable-curses \
255         --enable-opengl \
256         --with-x
257 %{__make} depend
258 %{__make}
259 %{__make} -C programs
260 #%{__make} -C programs/regapi
261
262 %install
263 rm -rf $RPM_BUILD_ROOT
264 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
265
266 %{__make} install \
267         DESTDIR=$RPM_BUILD_ROOT
268
269 %{__make} -C programs install \
270         DESTDIR=$RPM_BUILD_ROOT
271
272 install tools/fnt2bdf                   $RPM_BUILD_ROOT%{_bindir}
273
274 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
275 #mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
276
277 install -d \
278         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
279         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
280         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
281         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
282         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
283
284 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
285 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
286 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
287
288 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
289 [mci]
290 cdaudio=mcicda.drv
291 sequencer=mciseq.drv
292 waveaudio=mciwave.drv
293 avivideo=mciavi.drv
294 videodisc=mcipionr.drv
295 vcr=mciviscd.drv
296 MPEGVideo=mciqtz.drv
297 EOF
298
299 %if %{?debug:0}%{!?debug:1}
300 echo "Strip executable binaries and shared object files."
301 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
302 elfexelist=`echo $filelist | xargs -r file | \
303         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
304 elfsharedlist=`echo $filelist | xargs -r file | \
305         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
306 if [ -n "$elfexelist" ]; then \
307         strip -R .note -R .comment $elfexelist
308 fi
309 if [ -n "$elfsharedlist" ]; then
310         strip --strip-unneeded -R .note -R .comment $elfsharedlist
311 fi
312 %endif
313
314 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
315
316 programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
317
318 BZZZ=`pwd`
319 rm -f files.so;         touch files.so
320 rm -f files.programs;   touch files.programs
321 cd $RPM_BUILD_ROOT%{_libdir}/wine
322 for f in *.so; do
323         case $f in
324                 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
325                         ;;
326                 *)
327                         echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
328         esac
329 done
330 cd -
331 for p in $programs; do
332         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
333         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
334         grep -v "$p\.exe\.so$" files.so > files.so.
335         mv -f files.so. files.so
336 done
337
338 %clean
339 rm -rf $RPM_BUILD_ROOT
340
341 %post   -p /sbin/ldconfig
342 %postun -p /sbin/ldconfig
343
344 %triggerpostun -- wine < 1:0.9.12-1.9
345 rm -f /var/lock/subsys/wine
346 if [ -x /sbin/chkconfig ]; then
347         /sbin/chkconfig --del wine
348 fi
349
350 %files -f files.so
351 %defattr(644,root,root,755)
352 %doc README ChangeLog AUTHORS ANNOUNCE
353 %lang(de) %doc documentation/README.de
354 %lang(es) %doc documentation/README.es
355 %lang(fr) %doc documentation/README.fr
356 %lang(it) %doc documentation/README.it
357 %lang(ko) %doc documentation/README.ko
358 %lang(nb) %doc documentation/README.no
359 %lang(pt) %doc documentation/README.pt
360 %lang(pt_BR) %doc documentation/README.pt_br
361 %attr(755,root,root) %{_bindir}/msiexec
362 %attr(755,root,root) %{_bindir}/wine
363 %attr(755,root,root) %{_bindir}/wineboot
364 %attr(755,root,root) %{_bindir}/winebrowser
365 %attr(755,root,root) %{_bindir}/winecfg
366 %attr(755,root,root) %{_bindir}/winedbg
367 %attr(755,root,root) %{_bindir}/wine-kthread
368 #%attr(755,root,root) %{_bindir}/winelauncher
369 %attr(755,root,root) %{_bindir}/wineprefixcreate
370 %attr(755,root,root) %{_bindir}/wine-preloader
371 %attr(755,root,root) %{_bindir}/wine-pthread
372 %attr(755,root,root) %{_bindir}/wineserver
373 %attr(755,root,root) %{_bindir}/wineshelllink
374 %attr(755,root,root) %{_libdir}/*.so*
375 %dir %{_libdir}/wine
376 %{_libdir}/wine/*.dll16
377 %{_libdir}/wine/*.drv16
378 %{_libdir}/wine/*.exe16
379 %{_libdir}/wine/*.mod16
380 %{_mandir}/man1/wine.1*
381 %{_mandir}/man1/winedbg.1*
382 %{_mandir}/man1/wineprefixcreate.1*
383 %{_mandir}/man1/wineserver.1*
384 %{_winedir}
385 %{_desktopdir}/wine.desktop
386
387 %files programs -f files.programs
388 %defattr(644,root,root,755)
389
390 %files devel
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_bindir}/fnt2bdf
393 %attr(755,root,root) %{_bindir}/function_grep.pl
394 %attr(755,root,root) %{_bindir}/widl
395 %attr(755,root,root) %{_bindir}/winebuild
396 %attr(755,root,root) %{_bindir}/winedump
397 %attr(755,root,root) %{_bindir}/wineg++
398 %attr(755,root,root) %{_bindir}/winegcc
399 %attr(755,root,root) %{_bindir}/winemaker
400 %attr(755,root,root) %{_bindir}/winecpp
401 #%attr(755,root,root) %{_bindir}/winewrap
402 %attr(755,root,root) %{_bindir}/wmc
403 %attr(755,root,root) %{_bindir}/wrc
404 %{_libdir}/wine/lib*.def
405 # no shared variants, so not separated
406 %{_libdir}/wine/lib*.def.a
407 %{_libdir}/wine/libadsiid.a
408 %{_libdir}/wine/libdx*.a
409 %{_libdir}/wine/libstrmiids.a
410 %{_libdir}/wine/libuuid.a
411 %{_libdir}/wine/libwinecrt0.a
412 %{_includedir}/wine
413 %{_mandir}/man1/widl.1*
414 %{_mandir}/man1/winedump.1*
415 %{_mandir}/man1/winegcc.1*
416 %{_mandir}/man1/wineg++.1*
417 %{_mandir}/man1/winemaker.1*
418 %{_mandir}/man1/winebuild.1*
419 %{_mandir}/man1/wmc.1*
420 %{_mandir}/man1/wrc.1*
421 %{_aclocaldir}/*.m4
422
423 %files dll-d3d
424 %defattr(644,root,root,755)
425 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
426 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
427 %attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
428 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
429
430 %files dll-gl
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
433 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
434
435 %if %{with sane}
436 %files dll-twain
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
439 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
440 %endif
441
442 %if %{with alsa}
443 %files drv-alsa
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
446 %endif
447
448 %if %{with jack}
449 %files drv-jack
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
452 %endif
453
454 %if %{with nas}
455 %files drv-nas
456 %defattr(644,root,root,755)
457 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
458 %endif
459
460 # additional dependencies in *.so not separated (yet?) from main package
461 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
462 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
463 #   ttydrv.dll.so depends on ncurses
This page took 0.06387 seconds and 4 git commands to generate.