]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
compholio patches added for Silverlight / Pipelight
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  ldap            # don't build LDAP DLL
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 %bcond_without  netapi          # don't use the Samba NetAPI library
10 %bcond_without  compholio       # don't use the compholio patches for Silverlight
11 #
12 # NOTE: wine detects the following SONAMES for dlopen at build time:
13 #   libcrypto,libssl (wininet.dll)
14 #   libcups (winspool.dll.so,wineps.dll.so)
15 #   libcurses/libncurses (wineconsole program)
16 #   libfontconfig (gdi32.dll.so)
17 #   libfreetype (wineps.dll.so,gdi32.dll.so)
18 #   libGL (x11drv.dll.so,ddraw.dll.so)
19 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
20 #   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
21 # thus requires rebuild after change of any of the above.
22
23 # library qualifier in rpm generated deps
24 %ifarch %{x8664} ia64 ppc64 s390x sparc64
25 %define libqual ()(64bit)
26 %else
27 %define libqual %{nil}
28 %endif
29
30 %define         gecko_ver       2.24
31 %define         compholio_ver   %{version}
32 Summary:        Program that lets you launch Win applications
33 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
34 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
35 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
36 Name:           wine
37 # 1.6.x – stable
38 # 1.7.x – development (DEVEL branch)
39 Version:        1.7.18
40 Release:        0.1
41 Epoch:          1
42 License:        LGPL
43 Group:          Applications/Emulators
44 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
45 # Source0-md5:  b13c19ef69a99f2aa6c0b3fd08ae8d90
46 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
47 # Source1-md5:  766bb034172f7f0a97443951a02a0df8
48 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
49 # Source2-md5:  1912fd191872c72d5f562283e44e8ab4
50 Source3:        %{name}-uninstaller.desktop
51 Source4:        https://github.com/compholio/wine-compholio-daily/archive/v%{compholio_ver}/wine-compholio-%{compholio_ver}.tar.gz
52 # Source4-md5:  7e5b25b732415112f6d4b9418a2e5945
53 Patch0:         %{name}-gphoto2_bool.patch
54 Patch1:         %{name}-makedep.patch
55 Patch2:         %{name}-ncurses.patch
56 Patch4:         %{name}-disable-valgrind.patch
57 Patch5:         %{name}-ca_certificates.patch
58 Patch6:         desktop.patch
59 Patch7:         %{name}-wine64_man.patch
60 URL:            http://www.winehq.org/
61 BuildRequires:  OpenAL-devel >= 1.1
62 BuildRequires:  ocl-icd-libOpenCL-devel
63 BuildRequires:  OpenGL-GLU-devel
64 BuildRequires:  Mesa-libOSMesa-devel
65 %{?with_alsa:BuildRequires:     alsa-lib-devel}
66 %{?with_arts:BuildRequires:     artsc-devel}
67 %{?with_compholio:BuildRequires:        attr-devel}
68 BuildRequires:  autoconf
69 BuildRequires:  automake
70 BuildRequires:  bison
71 %{?with_capi:BuildRequires:     capi4k-utils-devel}
72 %{?with_cups:BuildRequires:     cups-devel}
73 BuildRequires:  dbus-devel
74 BuildRequires:  docbook-dtd31-sgml
75 BuildRequires:  docbook-utils
76 BuildRequires:  flex
77 BuildRequires:  fontconfig-devel
78 BuildRequires:  fontforge
79 BuildRequires:  freetype-devel >= 2.0.5
80 BuildRequires:  fslint
81 BuildRequires:  gettext-devel
82 BuildRequires:  giflib-devel
83 BuildRequires:  gnutls-devel
84 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel}
85 BuildRequires:  icoutils
86 BuildRequires:  lcms2-devel
87 BuildRequires:  libgphoto2-devel
88 BuildRequires:  libgsm-devel
89 BuildRequires:  libjpeg-devel
90 BuildRequires:  libmpg123-devel >= 1.5.0
91 BuildRequires:  libtool
92 BuildRequires:  libv4l-devel
93 BuildRequires:  libxslt-devel
94 BuildRequires:  ncurses-devel
95 # db2* failed previously - probably openjade or opensp bug
96 BuildRequires:  libpng-devel >= 1.5
97 BuildRequires:  openjade >= 1:1.3.3-0.pre1
98 %{?with_ldap:BuildRequires:     openldap-devel}
99 BuildRequires:  opensp >= 1:1.5.1
100 BuildRequires:  openssl-devel >= 0.9.7d
101 BuildRequires:  pkgconfig
102 BuildRequires:  prelink
103 BuildRequires:  samba-devel
104 %{?with_sane:BuildRequires:     sane-backends-devel}
105 BuildRequires:  unixODBC-devel >= 2.2.12-2
106 #BuildRequires: valgrind
107 BuildRequires:  xorg-lib-libXcomposite-devel
108 BuildRequires:  xorg-lib-libXcursor-devel
109 BuildRequires:  xorg-lib-libXi-devel
110 BuildRequires:  xorg-lib-libXinerama-devel
111 BuildRequires:  xorg-lib-libXmu-devel
112 BuildRequires:  xorg-lib-libXrandr-devel
113 BuildRequires:  xorg-lib-libXrender-devel
114 BuildRequires:  xorg-lib-libXxf86dga-devel
115 BuildRequires:  xorg-lib-libXxf86vm-devel
116 Requires:       libfreetype.so.6%{libqual}
117 Requires:       libpng16.so.16%{libqual}
118 Requires(post): /sbin/ldconfig
119 Suggests:       binfmt-detector
120 Suggests:       ca-certificates
121 Suggests:       cabextract
122 Conflicts:      ca-certificates < 20080809-4
123 # for printing needs lpr
124 Suggests:       cups-clients
125 # for winelauncher
126 Suggests:       xorg-app-xmessage
127 # for ntlm_auth
128 Suggests:       samba-common >= 1:3.0.25
129 # link to wine/ntdll.dll.so, without any SONAME
130 Provides:       libntdll.dll.so
131 %if %{with compholio}
132 Provides:       wine(compholio) = %{compholio_ver}
133 %ifarch %{ix86}
134 # Pipelight dependency on x86_64
135 Provides:       wine(compholio)(32bit) = %{compholio_ver}
136 %endif
137 %endif
138 Obsoletes:      wine-doc-pdf
139 Obsoletes:      wine-drv-arts
140 Obsoletes:      wine-drv-jack
141 Obsoletes:      wine-drv-nas
142 ExclusiveArch:  %{ix86} %{x8664}
143 ExcludeArch:    i386
144 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
145
146 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
147 %define         no_install_post_strip   1
148
149 %define         _winedir                %{_datadir}/%{name}
150
151 %description
152 Wine is a program which allows running Microsoft Windows programs
153 (including DOS, Windows 3.x and Win32 executables) on Unix. It
154 consists of a program loader which loads and executes a Microsoft
155 Windows binary, and a library that implements Windows API calls using
156 their Unix or X11 equivalents. The library may also be used for
157 porting Win32 code into native Unix executables.
158
159 %description -l es.UTF-8
160 Ejecuta programas Windows en Linux.
161
162 %description -l pl.UTF-8
163 Wine jest programem dzięki któremu można uruchamiać programy napisane
164 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
165 loadera, który pozwala wczytywać i uruchamiać programy w formacie
166 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
167 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
168 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
169
170 %description -l pt_BR.UTF-8
171 O Wine é um programa que permite rodar programas MS-Windows no X11.
172 Ele consiste de um carregador de programa, que carrega e executa um
173 binário MS-Windows, e de uma biblioteca de emulação que traduz as
174 chamadas da API para as equivalentes Unix/X11.
175
176 %package devel
177 Summary:        Wine - header files
178 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
179 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
180 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
181 Group:          Development/Libraries
182 Requires:       %{name} = %{epoch}:%{version}-%{release}
183
184 %description devel
185 Wine - header files.
186
187 %description devel -l es.UTF-8
188 Biblioteca de desarrollo de wine.
189
190 %description devel -l pl.UTF-8
191 Wine - pliki nagłówkowe.
192
193 %description devel -l pt_BR.UTF-8
194 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
195 WINE.
196
197 %package programs
198 Summary:        Wine - programs
199 Summary(pl.UTF-8):      Wine - programy
200 Group:          Applications
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202
203 %description programs
204 Wine - programs.
205
206 %description programs -l pl.UTF-8
207 Wine - programy.
208
209 %package dll-capi
210 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
211 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
212 Group:          Applications/Emulators
213 Requires:       %{name} = %{epoch}:%{version}-%{release}
214
215 %description dll-capi
216 CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
217
218 %description dll-capi -l pl.UTF-8
219 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
220 OpenGL).
221
222 %package dll-d3d
223 Summary:        Direct3D implementation DLLs for Wine
224 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
225 Group:          Applications/Emulators
226 Requires:       %{name} = %{epoch}:%{version}-%{release}
227 Requires:       OpenGL
228
229 %description dll-d3d
230 Direct3D implementation DLLs for Wine (through OpenGL).
231
232 %description dll-d3d -l pl.UTF-8
233 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
234
235 %package dll-gl
236 Summary:        OpenGL implementation DLLs for Wine
237 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
238 Group:          Applications/Emulators
239 Requires:       %{name} = %{epoch}:%{version}-%{release}
240 Requires:       OpenGL
241
242 %description dll-gl
243 OpenGL implementation DLLs for Wine.
244
245 %description dll-gl -l pl.UTF-8
246 Biblioteki DLL z implementacją OpenGL dla Wine.
247
248 %package dll-twain
249 Summary:        TWAIN implementation DLL for Wine
250 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
251 Group:          Applications/Emulators
252 Requires:       %{name} = %{epoch}:%{version}-%{release}
253
254 %description dll-twain
255 TWAIN implementation DLL for Wine (through SANE).
256
257 %description dll-twain -l pl.UTF-8
258 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
259
260 %package dll-ldap
261 Summary:        Win32 LDAP API DLL for Wine
262 Group:          Applications/Emulators
263 Requires:       %{name} = %{epoch}:%{version}-%{release}
264
265 %description dll-ldap
266 Lightweight Directory Access Protocol Library.
267
268 %package drv-alsa
269 Summary:        ALSA driver for WINE mm.dll implementation
270 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
271 Group:          Applications/Emulators
272 Requires:       %{name} = %{epoch}:%{version}-%{release}
273
274 %description drv-alsa
275 ALSA driver for WINE mm.dll (multimedia system) implementation.
276
277 %description drv-alsa -l pl.UTF-8
278 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
279
280 %prep
281 %setup -q -a4
282 %patch0 -p1
283 %patch1 -p1
284 %patch2 -p1
285 %patch4 -p1
286 %patch5 -p1
287 %patch6 -p1
288 %ifarch %{x8664}
289 %patch7 -p1
290 %endif
291
292 %if %{with compholio}
293 # binary patch that doesn't apply
294 # and real Arial may be installed through fonts-TTF-microsoft
295 rm -r wine-compholio-*/patches/10-Missing_Fonts
296
297 for patch in wine-compholio-*/patches/*/*.patch ; do
298         patch -N -p0 --strip=1 < "${patch}"
299 #       wine-compholio-*/debian/tools/gitapply.sh < "${patch}"
300 done
301 %endif
302
303 %build
304 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
305 mv -f oic_winlogo_*.png %{name}.png
306
307 %if %{with compholio}
308 tools/make_requests
309 %endif
310
311 %{__autoconf}
312 %{__autoheader}
313 %configure \
314 %ifarch %{x8664}
315         --enable-win64 \
316 %endif
317         --with%{!?with_alsa:out}-alsa \
318         --with%{!?with_capi:out}-capi \
319         --with-cms \
320         --with-coreaudio \
321         --with%{!?with_cups:out}-cups \
322         --with-curses \
323         --with-dbus \
324         --with-fontconfig \
325         --with-freetype \
326         --with-gphoto \
327         --with-glu \
328         --with-gnutls \
329         --with-gsm \
330         --with%{!?with_gstreamer:out}-gstreamer \
331         --without-hal \
332         --with-jpeg \
333         --with%{!?with_ldap:out}-ldap \
334         --with-mpg123 \
335         --with%{!?with_netapi:out}-netapi \
336         --with-openal \
337         --with-opencl \
338         --with-opengl \
339         --with-openssl \
340         --with-osmesa \
341         --with-oss \
342         --with-png \
343         --with-pthread \
344         --with%{!?with_sane:out}-sane \
345         --with-tiff \
346         --with-v4l \
347         --with-xcomposite \
348         --with-xcursor \
349         --with-xinerama \
350         --with-xinput \
351         --with-xinput2 \
352         --with-xml \
353         --with-xrandr \
354         --with-xrender \
355         --with-xshape \
356         --with-xshm \
357         --with-xslt \
358         --with-xxf86vm \
359         --with-x \
360         --with-zlib
361 %{__make} depend
362 %{__make}
363
364 %install
365 rm -rf $RPM_BUILD_ROOT
366 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
367 %{__make} install \
368         DESTDIR=$RPM_BUILD_ROOT
369
370 install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
371 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
372
373 install -d \
374         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
375         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
376         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
377         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
378         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
379
380 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
381 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
382 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
383
384 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
385 [mci]
386 cdaudio=mcicda.drv
387 sequencer=mciseq.drv
388 waveaudio=mciwave.drv
389 avivideo=mciavi.drv
390 videodisc=mcipionr.drv
391 vcr=mciviscd.drv
392 MPEGVideo=mciqtz.drv
393 EOF
394
395 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
396
397 dir=$(pwd)
398 > files.so
399 > files.programs
400 cd $RPM_BUILD_ROOT%{_libdir}/wine
401 for f in *.so; do
402         case $f in
403         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
404                 ;;
405         *)
406                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
407         esac
408 done
409 cd -
410
411 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
412 for p in $programs; do
413         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
414         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
415         echo "%{_mandir}/man1/$p.1*" >> files.programs
416         grep -v "$p\.exe\.so$" files.so > files.so.
417         mv -f files.so. files.so
418 done
419
420 for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
421         mv "$dir" "${dir%.UTF-8}"
422 done
423
424 %ifarch %{x8664}
425 for langdir in "" de/ fr/ pl/ ; do
426 mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
427 done
428 %endif
429
430 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
431 %ifnarch %{x8664}
432 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
433 %else
434 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
435 %endif
436
437 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
438 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
439 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
440
441 %clean
442 rm -rf $RPM_BUILD_ROOT
443
444 %post
445 /sbin/ldconfig
446 %update_desktop_database
447
448 %postun -p /sbin/ldconfig
449
450 %triggerpostun -- wine < 1:0.9.12-1.9
451 rm -f /var/lock/subsys/wine
452 if [ -x /sbin/chkconfig ]; then
453         /sbin/chkconfig --del wine
454 fi
455
456 %files -f files.so
457 %defattr(644,root,root,755)
458 %doc README AUTHORS ANNOUNCE
459 %lang(de) %doc documentation/README.de
460 %lang(es) %doc documentation/README.es
461 %lang(fr) %doc documentation/README.fr
462 %lang(hu) %doc documentation/README.hu
463 %lang(it) %doc documentation/README.it
464 %lang(ko) %doc documentation/README.ko
465 %lang(nb) %doc documentation/README.no
466 %lang(pt) %doc documentation/README.pt
467 %lang(pt_BR) %doc documentation/README.pt_br
468 %lang(ru) %doc documentation/README.ru
469 %lang(sv) %doc documentation/README.sv
470 %lang(tr) %doc documentation/README.tr
471 %attr(755,root,root) %{_bindir}/msiexec
472 %ifnarch %{x8664}
473 %attr(755,root,root) %{_bindir}/wine
474 %else
475 %attr(755,root,root) %{_bindir}/wine64
476 %endif
477 %attr(755,root,root) %{_bindir}/wineboot
478 %attr(755,root,root) %{_bindir}/winedbg
479 %attr(755,root,root) %{_bindir}/winecfg
480 %ifnarch %{x8664}
481 %attr(755,root,root) %{_bindir}/wine-preloader
482 %else
483 %attr(755,root,root) %{_bindir}/wine64-preloader
484 %endif
485 %attr(755,root,root) %{_bindir}/wineserver
486 %attr(755,root,root) %{_libdir}/*.so*
487 %dir %{_libdir}/wine
488 %dir %{_libdir}/wine/fakedlls
489 %{_libdir}/wine/fakedlls/*.acm
490 %{_libdir}/wine/fakedlls/*.cpl
491 %{_libdir}/wine/fakedlls/*.dll
492 %ifarch %{ix86}
493 %{_libdir}/wine/fakedlls/*.dll16
494 %endif
495 %{_libdir}/wine/fakedlls/*.drv
496 %ifarch %{ix86}
497 %{_libdir}/wine/fakedlls/*.drv16
498 %endif
499 %{_libdir}/wine/fakedlls/*.ds
500 %{_libdir}/wine/fakedlls/*.exe
501 %ifarch %{ix86}
502 %{_libdir}/wine/fakedlls/*.exe16
503 %{_libdir}/wine/fakedlls/*.mod16
504 %endif
505 %{_libdir}/wine/fakedlls/*.ocx
506 %{_libdir}/wine/fakedlls/*.sys
507 %{_libdir}/wine/fakedlls/*.tlb
508 %ifarch %{ix86}
509 %{_libdir}/wine/fakedlls/*.vxd
510 %endif
511 %ifnarch %{x8664}
512 %{_mandir}/man1/wine.1*
513 %lang(de) %{_mandir}/de/man1/wine.1*
514 %lang(fr) %{_mandir}/fr/man1/wine.1*
515 %lang(pl) %{_mandir}/pl/man1/wine.1*
516 %else
517 %{_mandir}/man1/wine64.1*
518 %lang(de) %{_mandir}/de/man1/wine64.1*
519 %lang(fr) %{_mandir}/fr/man1/wine64.1*
520 %lang(pl) %{_mandir}/pl/man1/wine64.1*
521 %endif
522 %{_mandir}/man1/msiexec.1*
523 %{_mandir}/man1/wineboot.1*
524 %{_mandir}/man1/winecfg.1*
525 %{_mandir}/man1/winedbg.1*
526 %{_mandir}/man1/wineserver.1*
527 %lang(de) %{_mandir}/de/man1/wineserver.1*
528 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
529 %{_winedir}
530 %{_desktopdir}/wine.desktop
531 %{_desktopdir}/wine-uninstaller.desktop
532 %{_pixmapsdir}/%{name}.png
533
534 %files programs -f files.programs
535 %defattr(644,root,root,755)
536
537 %files devel
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_bindir}/sfnt2fon
540 %attr(755,root,root) %{_bindir}/function_grep.pl
541 %attr(755,root,root) %{_bindir}/widl
542 %attr(755,root,root) %{_bindir}/winebuild
543 %attr(755,root,root) %{_bindir}/winedump
544 %attr(755,root,root) %{_bindir}/wineg++
545 %attr(755,root,root) %{_bindir}/winegcc
546 %attr(755,root,root) %{_bindir}/winemaker
547 %attr(755,root,root) %{_bindir}/winecpp
548 %attr(755,root,root) %{_bindir}/wmc
549 %attr(755,root,root) %{_bindir}/wrc
550 %{_libdir}/wine/lib*.def
551 # no shared variants, so not separated
552 %{_libdir}/wine/lib*.def.a
553 %{_libdir}/wine/libadsiid.a
554 %{_libdir}/wine/libdx*.a
555 %{_libdir}/wine/libstrmbase.a
556 %{_libdir}/wine/libstrmiids.a
557 %{_libdir}/wine/libuuid.a
558 %{_libdir}/wine/libwinecrt0.a
559 %{_includedir}/wine
560 %{_mandir}/man1/widl.1*
561 %{_mandir}/man1/winebuild.1*
562 %{_mandir}/man1/winecpp.1*
563 %{_mandir}/man1/winedump.1*
564 %{_mandir}/man1/winegcc.1*
565 %{_mandir}/man1/wineg++.1*
566 %{_mandir}/man1/winemaker.1*
567 %lang(de) %{_mandir}/de/man1/winemaker.1*
568 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
569 %{_mandir}/man1/wmc.1*
570 %{_mandir}/man1/wrc.1*
571 %{_aclocaldir}/*.m4
572
573 %files dll-capi
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
576
577 %files dll-d3d
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
580 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
581 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
582
583 %files dll-gl
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
586 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
587
588 %if %{with sane}
589 %files dll-twain
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
592 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
593 %endif
594
595 %if %{with ldap}
596 %files dll-ldap
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
599 %endif
600
601 %if %{with alsa}
602 %files drv-alsa
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
605 %endif
606
607 # additional dependencies in *.so not separated (yet?) from main package
608 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
609 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
610 #   ttydrv.dll.so depends on ncurses
This page took 0.111892 seconds and 3 git commands to generate.