]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
aa2a74be7fcf34f92647d7a666fbf70d448358b7
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  jack            # don't build JACK mm driver
5 %bcond_without  nas             # don't build NAS mm driver
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
8 #
9 # TODO:
10 # - support for CAPI (ISDN support; --with-capi)
11 #
12 # NOTE: wine detects the following SONAMES for dlopen at build time:
13 #   libcrypto,libssl (wininet.dll)
14 #   libcups (winspool.dll.so,wineps.dll.so)
15 #   libcurses/libncurses (wineconsole program)
16 #   libfontconfig (gdi32.dll.so)
17 #   libfreetype (wineps.dll.so,gdi32.dll.so)
18 #   libGL (x11drv.dll.so,ddraw.dll.so)
19 #   libjack (winejack.drv.so - explicit dependency in subpackage)
20 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
21 # thus requires rebuild after change of any of the above.
22 #
23 # JACK requires ALSA
24 %if %{without alsa}
25 %undefine       with_jack
26 %endif
27 Summary:        Program that lets you launch Win applications
28 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
29 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
30 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
31 Name:           wine
32 Version:        1.1.9
33 Release:        1
34 Epoch:          1
35 License:        LGPL
36 Group:          Applications/Emulators
37 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
38 # Source0-md5:  c3975c66640c1efaf2717ffa2260b6c7
39 Source1:        %{name}-uninstaller.desktop
40 Patch0:         %{name}-fontcache.patch
41 Patch1:         %{name}-makedep.patch
42 Patch2:         %{name}-ncurses.patch
43 Patch3:         %{name}-bug9177_workaround.patch
44 Patch4:         %{name}-disable-valgrind.patch
45 Patch5:         %{name}-ca_certificates.patch
46 #PatchX:        %{name}-dga.patch
47 URL:            http://www.winehq.org/
48 BuildRequires:  OpenGL-GLU-devel
49 %{?with_alsa:BuildRequires:     alsa-lib-devel}
50 %{?with_arts:BuildRequires:     artsc-devel}
51 BuildRequires:  autoconf
52 BuildRequires:  automake
53 BuildRequires:  bison
54 %{?with_cups:BuildRequires:     cups-devel}
55 BuildRequires:  docbook-dtd31-sgml
56 BuildRequires:  docbook-utils
57 BuildRequires:  flex
58 BuildRequires:  fontconfig-devel
59 BuildRequires:  fontforge
60 BuildRequires:  freetype-devel >= 2.0.5
61 BuildRequires:  giflib-devel
62 BuildRequires:  gnutls-devel
63 BuildRequires:  hal-devel
64 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
65 BuildRequires:  lcms-devel
66 BuildRequires:  libgphoto2-devel
67 BuildRequires:  libjpeg-devel
68 BuildRequires:  libtool
69 BuildRequires:  libxslt-devel
70 %{?with_nas:BuildRequires:      nas-devel}
71 BuildRequires:  ncurses-devel
72 # db2* failed previously - probably openjade or opensp bug
73 BuildRequires:  openjade >= 1:1.3.3-0.pre1
74 BuildRequires:  openldap-devel
75 BuildRequires:  opensp >= 1:1.5.1
76 BuildRequires:  openssl-devel >= 0.9.7d
77 BuildRequires:  pkgconfig
78 %{?with_sane:BuildRequires:     sane-backends-devel}
79 #BuildRequires: valgrind
80 BuildRequires:  xorg-lib-libXcomposite-devel
81 BuildRequires:  xorg-lib-libXcursor-devel
82 BuildRequires:  xorg-lib-libXi-devel
83 BuildRequires:  xorg-lib-libXinerama-devel
84 BuildRequires:  xorg-lib-libXmu-devel
85 BuildRequires:  xorg-lib-libXrandr-devel
86 BuildRequires:  xorg-lib-libXrender-devel
87 BuildRequires:  xorg-lib-libXxf86dga-devel
88 BuildRequires:  xorg-lib-libXxf86vm-devel
89 Conflicts:      ca-certificates < 20080809-4
90 Suggests:       binfmt-detector
91 Suggests:       ca-certificates
92 # for winelauncher
93 Suggests:       xorg-app-xmessage
94 # for ntlm_auth
95 Suggests:       samba-common >= 1:3.0.25
96 # link to wine/ntdll.dll.so, without any SONAME
97 Provides:       libntdll.dll.so
98 Obsoletes:      wine-doc-pdf
99 Obsoletes:      wine-drv-arts
100 ExclusiveArch:  %{ix86}
101 ExcludeArch:    i386
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
105 %define         no_install_post_strip   1
106
107 %define         _winedir                %{_datadir}/%{name}
108
109 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
110
111 %undefine       debuginfocflags
112
113 %description
114 Wine is a program which allows running Microsoft Windows programs
115 (including DOS, Windows 3.x and Win32 executables) on Unix. It
116 consists of a program loader which loads and executes a Microsoft
117 Windows binary, and a library that implements Windows API calls using
118 their Unix or X11 equivalents. The library may also be used for
119 porting Win32 code into native Unix executables.
120
121 %description -l es.UTF-8
122 Ejecuta programas Windows en Linux.
123
124 %description -l pl.UTF-8
125 Wine jest programem dzięki któremu można uruchamiać programy napisane
126 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
127 loadera, który pozwala wczytywać i uruchamiać programy w formacie
128 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
129 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
130 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
131
132 %description -l pt_BR.UTF-8
133 O Wine é um programa que permite rodar programas MS-Windows no X11.
134 Ele consiste de um carregador de programa, que carrega e executa um
135 binário MS-Windows, e de uma biblioteca de emulação que traduz as
136 chamadas da API para as equivalentes Unix/X11.
137
138 %package devel
139 Summary:        Wine - header files
140 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
141 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
142 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
143 Group:          Development/Libraries
144 Requires:       %{name} = %{epoch}:%{version}-%{release}
145
146 %description devel
147 Wine - header files.
148
149 %description devel -l es.UTF-8
150 Biblioteca de desarrollo de wine.
151
152 %description devel -l pl.UTF-8
153 Wine - pliki nagłówkowe.
154
155 %description devel -l pt_BR.UTF-8
156 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
157 WINE.
158
159 %package programs
160 Summary:        Wine - programs
161 Summary(pl.UTF-8):      Wine - programy
162 Group:          Applications
163 Requires:       %{name} = %{epoch}:%{version}-%{release}
164
165 %description programs
166 Wine - programs.
167
168 %description programs -l pl.UTF-8
169 Wine - programy.
170
171 %package dll-d3d
172 Summary:        Direct3D implementation DLLs for Wine
173 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
174 Group:          Applications/Emulators
175 Requires:       %{name} = %{epoch}:%{version}-%{release}
176 Requires:       OpenGL
177
178 %description dll-d3d
179 Direct3D implementation DLLs for Wine (through OpenGL).
180
181 %description dll-d3d -l pl.UTF-8
182 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
183
184 %package dll-gl
185 Summary:        OpenGL implementation DLLs for Wine
186 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
187 Group:          Applications/Emulators
188 Requires:       %{name} = %{epoch}:%{version}-%{release}
189 Requires:       OpenGL
190
191 %description dll-gl
192 OpenGL implementation DLLs for Wine.
193
194 %description dll-gl -l pl.UTF-8
195 Biblioteki DLL z implementacją OpenGL dla Wine.
196
197 %package dll-twain
198 Summary:        TWAIN implementation DLL for Wine
199 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
200 Group:          Applications/Emulators
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202
203 %description dll-twain
204 TWAIN implementation DLL for Wine (through SANE).
205
206 %description dll-twain -l pl.UTF-8
207 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
208
209 %package drv-alsa
210 Summary:        ALSA driver for WINE mm.dll implementation
211 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
212 Group:          Applications/Emulators
213 Requires:       %{name} = %{epoch}:%{version}-%{release}
214
215 %description drv-alsa
216 ALSA driver for WINE mm.dll (multimedia system) implementation.
217
218 %description drv-alsa -l pl.UTF-8
219 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
220
221 %package drv-jack
222 Summary:        JACK driver for WINE mm.dll implementation
223 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
224 Group:          Applications/Emulators
225 Requires:       %{name} = %{epoch}:%{version}-%{release}
226 Requires:       jack-audio-connection-kit
227 # dlopened by SONAME detected at build time
228 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
229
230 %description drv-jack
231 JACK driver for WINE mm.dll (multimedia system) implementation.
232
233 %description drv-jack -l pl.UTF-8
234 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
235 Wine.
236
237 %package drv-nas
238 Summary:        NAS driver for WINE mm.dll implementation
239 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
240 Group:          Applications/Emulators
241 Requires:       %{name} = %{epoch}:%{version}-%{release}
242
243 %description drv-nas
244 NAS driver for WINE mm.dll (multimedia system) implementation.
245
246 %description drv-nas -l pl.UTF-8
247 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
248
249 %prep
250 %setup -q
251 %patch0 -p1
252 %patch1 -p1
253 %patch2 -p1
254 %patch3 -p1
255 %patch4 -p1
256 %patch5 -p1
257
258 # turn off compilation of some tools
259 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
260 #sed -i -e "s|avitools||" programs/Makefile.in
261
262 %build
263 %{__autoconf}
264 %{__autoheader}
265 %configure \
266         --with%{!?with_alsa:out}-alsa \
267         --with-cms \
268         --with%{!?with_cups:out}-cups \
269         --with-cups \
270         --with-curses \
271         --with-esd \
272         --with-fontconfig \
273         --with-freetype \
274         --with-glu \
275         --with-gphoto \
276         --with-hal \
277         --with%{!?with_jack:out}-jack \
278         --with-jpeg \
279         --with-ldap \
280         --with%{!?with_nas:out}-nas \
281         --with-opengl \
282         --with-openssl \
283         --with-oss \
284         --with-png \
285         --with%{!?with_sane:out}-sane \
286         --with-xcomposite \
287         --with-xcursor \
288         --with-xinerama \
289         --with-xinput \
290         --with-xml \
291         --with-xrandr \
292         --with-xrender \
293         --with-xshape \
294         --with-xshm \
295         --with-xslt \
296         --with-xxf86vm \
297         --with-x
298 %{__make} depend
299 %{__make}
300 %{__make} -C programs
301
302 %install
303 rm -rf $RPM_BUILD_ROOT
304 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
305
306 %{__make} install \
307         DESTDIR=$RPM_BUILD_ROOT
308
309 %{__make} -C programs install \
310         DESTDIR=$RPM_BUILD_ROOT
311
312 install tools/fnt2bdf                   $RPM_BUILD_ROOT%{_bindir}
313
314 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
315
316 install -d \
317         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
318         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
319         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
320         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
321         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
322
323 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
324 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
325 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
326
327 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
328 [mci]
329 cdaudio=mcicda.drv
330 sequencer=mciseq.drv
331 waveaudio=mciwave.drv
332 avivideo=mciavi.drv
333 videodisc=mcipionr.drv
334 vcr=mciviscd.drv
335 MPEGVideo=mciqtz.drv
336 EOF
337
338 %if %{?debug:0}%{!?debug:1}
339 echo "Strip executable binaries and shared object files."
340 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
341 elfexelist=`echo $filelist | xargs -r file | \
342         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
343 elfsharedlist=`echo $filelist | xargs -r file | \
344         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
345 if [ -n "$elfexelist" ]; then \
346         strip -R .note -R .comment $elfexelist
347 fi
348 if [ -n "$elfsharedlist" ]; then
349         strip --strip-unneeded -R .note -R .comment $elfsharedlist
350 fi
351 %endif
352
353 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
354
355 programs="msiexec notepad progman regedit regsvr32 uninstaller wineboot winebrowser winecfg wineconsole winedbg winefile winemine winepath"
356
357 BZZZ=`pwd`
358 rm -f files.so;         touch files.so
359 rm -f files.programs;   touch files.programs
360 cd $RPM_BUILD_ROOT%{_libdir}/wine
361 for f in *.so; do
362         case $f in
363                 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
364                         ;;
365                 *)
366                         echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
367         esac
368 done
369 cd -
370 for p in $programs; do
371         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
372         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
373         grep -v "$p\.exe\.so$" files.so > files.so.
374         mv -f files.so. files.so
375 done
376
377 install -d $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
378 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
379 install programs/winetest/winetest.svg $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %post   -p /sbin/ldconfig
385 %postun -p /sbin/ldconfig
386
387 %triggerpostun -- wine < 1:0.9.12-1.9
388 rm -f /var/lock/subsys/wine
389 if [ -x /sbin/chkconfig ]; then
390         /sbin/chkconfig --del wine
391 fi
392
393 %files -f files.so
394 %defattr(644,root,root,755)
395 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
396 %lang(de) %doc documentation/README.de
397 %lang(es) %doc documentation/README.es
398 %lang(fr) %doc documentation/README.fr
399 %lang(it) %doc documentation/README.it
400 %lang(ko) %doc documentation/README.ko
401 %lang(nb) %doc documentation/README.no
402 %lang(pt) %doc documentation/README.pt
403 %lang(pt_BR) %doc documentation/README.pt_br
404 %attr(755,root,root) %{_bindir}/msiexec
405 %attr(755,root,root) %{_bindir}/wine
406 %attr(755,root,root) %{_bindir}/wineboot
407 %attr(755,root,root) %{_bindir}/winebrowser
408 %attr(755,root,root) %{_bindir}/winecfg
409 %attr(755,root,root) %{_bindir}/winedbg
410 %attr(755,root,root) %{_bindir}/wine-kthread
411 #%attr(755,root,root) %{_bindir}/winelauncher
412 %attr(755,root,root) %{_bindir}/wineprefixcreate
413 %attr(755,root,root) %{_bindir}/wine-preloader
414 %attr(755,root,root) %{_bindir}/wine-pthread
415 %attr(755,root,root) %{_bindir}/wineserver
416 %attr(755,root,root) %{_libdir}/*.so*
417 %dir %{_libdir}/wine
418 %{_libdir}/wine/*.dll16
419 %{_libdir}/wine/*.drv16
420 %{_libdir}/wine/*.exe16
421 %{_libdir}/wine/*.mod16
422 %{_mandir}/man1/wine.1*
423 %{_mandir}/man1/winedbg.1*
424 %{_mandir}/man1/wineprefixcreate.1*
425 %{_mandir}/man1/wineserver.1*
426 %{_winedir}
427 %{_desktopdir}/wine.desktop
428 %{_desktopdir}/wine-uninstaller.desktop
429 %{_pixmapsdir}/wine.svg
430
431 %files programs -f files.programs
432 %defattr(644,root,root,755)
433
434 %files devel
435 %defattr(644,root,root,755)
436 %attr(755,root,root) %{_bindir}/fnt2bdf
437 %attr(755,root,root) %{_bindir}/function_grep.pl
438 %attr(755,root,root) %{_bindir}/widl
439 %attr(755,root,root) %{_bindir}/winebuild
440 %attr(755,root,root) %{_bindir}/winedump
441 %attr(755,root,root) %{_bindir}/wineg++
442 %attr(755,root,root) %{_bindir}/winegcc
443 %attr(755,root,root) %{_bindir}/winemaker
444 %attr(755,root,root) %{_bindir}/winecpp
445 #%attr(755,root,root) %{_bindir}/winewrap
446 %attr(755,root,root) %{_bindir}/wmc
447 %attr(755,root,root) %{_bindir}/wrc
448 %{_libdir}/wine/lib*.def
449 # no shared variants, so not separated
450 %{_libdir}/wine/lib*.def.a
451 %{_libdir}/wine/libadsiid.a
452 %{_libdir}/wine/libdx*.a
453 %{_libdir}/wine/libstrmiids.a
454 %{_libdir}/wine/libuuid.a
455 %{_libdir}/wine/libwinecrt0.a
456 %{_includedir}/wine
457 %{_mandir}/man1/widl.1*
458 %{_mandir}/man1/winedump.1*
459 %{_mandir}/man1/winegcc.1*
460 %{_mandir}/man1/wineg++.1*
461 %{_mandir}/man1/winemaker.1*
462 %{_mandir}/man1/winebuild.1*
463 %{_mandir}/man1/wmc.1*
464 %{_mandir}/man1/wrc.1*
465 %{_aclocaldir}/*.m4
466
467 %files dll-d3d
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
470 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
471 %attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
472 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
473
474 %files dll-gl
475 %defattr(644,root,root,755)
476 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
477 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
478
479 %if %{with sane}
480 %files dll-twain
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
483 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
484 %endif
485
486 %if %{with alsa}
487 %files drv-alsa
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
490 %endif
491
492 %if %{with jack}
493 %files drv-jack
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
496 %endif
497
498 %if %{with nas}
499 %files drv-nas
500 %defattr(644,root,root,755)
501 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
502 %endif
503
504 # additional dependencies in *.so not separated (yet?) from main package
505 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
506 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
507 #   ttydrv.dll.so depends on ncurses
This page took 0.084276 seconds and 3 git commands to generate.