]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
70c26b5393ae2a9e4e2c2e71fb1ba2a1e6de9652
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  jack            # don't build JACK mm driver
5 %bcond_without  nas             # don't build NAS mm driver
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
8 #
9 # TODO:
10 # - support for CAPI (ISDN support; --with-capi)
11 #
12 # NOTE: wine detects the following SONAMES for dlopen at build time:
13 #   libcrypto,libssl (wininet.dll)
14 #   libcups (winspool.dll.so,wineps.dll.so)
15 #   libcurses/libncurses (wineconsole program)
16 #   libfontconfig (gdi32.dll.so)
17 #   libfreetype (wineps.dll.so,gdi32.dll.so)
18 #   libGL (x11drv.dll.so,ddraw.dll.so)
19 #   libjack (winejack.drv.so - explicit dependency in subpackage)
20 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
21 # thus requires rebuild after change of any of the above.
22 #
23 # JACK requires ALSA
24 %if %{without alsa}
25 %undefine       with_jack
26 %endif
27 Summary:        Program that lets you launch Win applications
28 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
29 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
30 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
31 Name:           wine
32 Version:        1.1.14
33 Release:        1
34 Epoch:          1
35 License:        LGPL
36 Group:          Applications/Emulators
37 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
38 # Source0-md5:  5becf91455ef1d426e39cda34e6e7e81
39 Source1:        %{name}-uninstaller.desktop
40 Patch0:         %{name}-fontcache.patch
41 Patch1:         %{name}-makedep.patch
42 Patch2:         %{name}-ncurses.patch
43 Patch4:         %{name}-disable-valgrind.patch
44 Patch5:         %{name}-ca_certificates.patch
45 #PatchX:        %{name}-dga.patch
46 URL:            http://www.winehq.org/
47 BuildRequires:  OpenGL-GLU-devel
48 %{?with_alsa:BuildRequires:     alsa-lib-devel}
49 %{?with_arts:BuildRequires:     artsc-devel}
50 BuildRequires:  autoconf
51 BuildRequires:  automake
52 BuildRequires:  bison
53 %{?with_cups:BuildRequires:     cups-devel}
54 BuildRequires:  docbook-dtd31-sgml
55 BuildRequires:  docbook-utils
56 BuildRequires:  flex
57 BuildRequires:  fontconfig-devel
58 BuildRequires:  fontforge
59 BuildRequires:  freetype-devel >= 2.0.5
60 BuildRequires:  giflib-devel
61 BuildRequires:  gnutls-devel
62 BuildRequires:  hal-devel
63 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
64 BuildRequires:  lcms-devel
65 BuildRequires:  libgphoto2-devel
66 BuildRequires:  libjpeg-devel
67 BuildRequires:  libtool
68 BuildRequires:  libxslt-devel
69 %{?with_nas:BuildRequires:      nas-devel}
70 BuildRequires:  ncurses-devel
71 # db2* failed previously - probably openjade or opensp bug
72 BuildRequires:  openjade >= 1:1.3.3-0.pre1
73 BuildRequires:  openldap-devel
74 BuildRequires:  opensp >= 1:1.5.1
75 BuildRequires:  openssl-devel >= 0.9.7d
76 BuildRequires:  pkgconfig
77 %{?with_sane:BuildRequires:     sane-backends-devel}
78 #BuildRequires: valgrind
79 BuildRequires:  xorg-lib-libXcomposite-devel
80 BuildRequires:  xorg-lib-libXcursor-devel
81 BuildRequires:  xorg-lib-libXi-devel
82 BuildRequires:  xorg-lib-libXinerama-devel
83 BuildRequires:  xorg-lib-libXmu-devel
84 BuildRequires:  xorg-lib-libXrandr-devel
85 BuildRequires:  xorg-lib-libXrender-devel
86 BuildRequires:  xorg-lib-libXxf86dga-devel
87 BuildRequires:  xorg-lib-libXxf86vm-devel
88 Requires:       libfreetype.so.6
89 Suggests:       binfmt-detector
90 Suggests:       ca-certificates
91 Conflicts:      ca-certificates < 20080809-4
92 # for winelauncher
93 Suggests:       xorg-app-xmessage
94 # for ntlm_auth
95 Suggests:       samba-common >= 1:3.0.25
96 # link to wine/ntdll.dll.so, without any SONAME
97 Provides:       libntdll.dll.so
98 Obsoletes:      wine-doc-pdf
99 Obsoletes:      wine-drv-arts
100 ExclusiveArch:  %{ix86}
101 ExcludeArch:    i386
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
105 %define         no_install_post_strip   1
106
107 %define         _winedir                %{_datadir}/%{name}
108
109 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
110
111 %undefine       debuginfocflags
112
113 %description
114 Wine is a program which allows running Microsoft Windows programs
115 (including DOS, Windows 3.x and Win32 executables) on Unix. It
116 consists of a program loader which loads and executes a Microsoft
117 Windows binary, and a library that implements Windows API calls using
118 their Unix or X11 equivalents. The library may also be used for
119 porting Win32 code into native Unix executables.
120
121 %description -l es.UTF-8
122 Ejecuta programas Windows en Linux.
123
124 %description -l pl.UTF-8
125 Wine jest programem dzięki któremu można uruchamiać programy napisane
126 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
127 loadera, który pozwala wczytywać i uruchamiać programy w formacie
128 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
129 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
130 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
131
132 %description -l pt_BR.UTF-8
133 O Wine é um programa que permite rodar programas MS-Windows no X11.
134 Ele consiste de um carregador de programa, que carrega e executa um
135 binário MS-Windows, e de uma biblioteca de emulação que traduz as
136 chamadas da API para as equivalentes Unix/X11.
137
138 %package devel
139 Summary:        Wine - header files
140 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
141 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
142 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
143 Group:          Development/Libraries
144 Requires:       %{name} = %{epoch}:%{version}-%{release}
145
146 %description devel
147 Wine - header files.
148
149 %description devel -l es.UTF-8
150 Biblioteca de desarrollo de wine.
151
152 %description devel -l pl.UTF-8
153 Wine - pliki nagłówkowe.
154
155 %description devel -l pt_BR.UTF-8
156 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
157 WINE.
158
159 %package programs
160 Summary:        Wine - programs
161 Summary(pl.UTF-8):      Wine - programy
162 Group:          Applications
163 Requires:       %{name} = %{epoch}:%{version}-%{release}
164
165 %description programs
166 Wine - programs.
167
168 %description programs -l pl.UTF-8
169 Wine - programy.
170
171 %package dll-d3d
172 Summary:        Direct3D implementation DLLs for Wine
173 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
174 Group:          Applications/Emulators
175 Requires:       %{name} = %{epoch}:%{version}-%{release}
176 Requires:       OpenGL
177
178 %description dll-d3d
179 Direct3D implementation DLLs for Wine (through OpenGL).
180
181 %description dll-d3d -l pl.UTF-8
182 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
183
184 %package dll-gl
185 Summary:        OpenGL implementation DLLs for Wine
186 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
187 Group:          Applications/Emulators
188 Requires:       %{name} = %{epoch}:%{version}-%{release}
189 Requires:       OpenGL
190
191 %description dll-gl
192 OpenGL implementation DLLs for Wine.
193
194 %description dll-gl -l pl.UTF-8
195 Biblioteki DLL z implementacją OpenGL dla Wine.
196
197 %package dll-twain
198 Summary:        TWAIN implementation DLL for Wine
199 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
200 Group:          Applications/Emulators
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202
203 %description dll-twain
204 TWAIN implementation DLL for Wine (through SANE).
205
206 %description dll-twain -l pl.UTF-8
207 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
208
209 %package drv-alsa
210 Summary:        ALSA driver for WINE mm.dll implementation
211 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
212 Group:          Applications/Emulators
213 Requires:       %{name} = %{epoch}:%{version}-%{release}
214
215 %description drv-alsa
216 ALSA driver for WINE mm.dll (multimedia system) implementation.
217
218 %description drv-alsa -l pl.UTF-8
219 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
220
221 %package drv-jack
222 Summary:        JACK driver for WINE mm.dll implementation
223 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
224 Group:          Applications/Emulators
225 Requires:       %{name} = %{epoch}:%{version}-%{release}
226 Requires:       jack-audio-connection-kit
227 # dlopened by SONAME detected at build time
228 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
229
230 %description drv-jack
231 JACK driver for WINE mm.dll (multimedia system) implementation.
232
233 %description drv-jack -l pl.UTF-8
234 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
235 Wine.
236
237 %package drv-nas
238 Summary:        NAS driver for WINE mm.dll implementation
239 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
240 Group:          Applications/Emulators
241 Requires:       %{name} = %{epoch}:%{version}-%{release}
242
243 %description drv-nas
244 NAS driver for WINE mm.dll (multimedia system) implementation.
245
246 %description drv-nas -l pl.UTF-8
247 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
248
249 %prep
250 %setup -q
251 %patch0 -p1
252 %patch1 -p1
253 %patch2 -p1
254 %patch4 -p1
255 %patch5 -p1
256
257 # turn off compilation of some tools
258 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
259 #sed -i -e "s|avitools||" programs/Makefile.in
260
261 %build
262 %{__autoconf}
263 %{__autoheader}
264 %configure \
265         --with%{!?with_alsa:out}-alsa \
266         --with-cms \
267         --with%{!?with_cups:out}-cups \
268         --with-cups \
269         --with-curses \
270         --with-esd \
271         --with-fontconfig \
272         --with-freetype \
273         --with-glu \
274         --with-gphoto \
275         --with-hal \
276         --with%{!?with_jack:out}-jack \
277         --with-jpeg \
278         --with-ldap \
279         --with%{!?with_nas:out}-nas \
280         --with-opengl \
281         --with-openssl \
282         --with-oss \
283         --with-png \
284         --with%{!?with_sane:out}-sane \
285         --with-xcomposite \
286         --with-xcursor \
287         --with-xinerama \
288         --with-xinput \
289         --with-xml \
290         --with-xrandr \
291         --with-xrender \
292         --with-xshape \
293         --with-xshm \
294         --with-xslt \
295         --with-xxf86vm \
296         --with-x
297 %{__make} depend
298 %{__make}
299 %{__make} -C programs
300
301 %install
302 rm -rf $RPM_BUILD_ROOT
303 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
304
305 %{__make} install \
306         DESTDIR=$RPM_BUILD_ROOT
307
308 %{__make} -C programs install \
309         DESTDIR=$RPM_BUILD_ROOT
310
311 install tools/fnt2bdf                   $RPM_BUILD_ROOT%{_bindir}
312
313 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
314
315 install -d \
316         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
317         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
318         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
319         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
320         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
321
322 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
323 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
324 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
325
326 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
327 [mci]
328 cdaudio=mcicda.drv
329 sequencer=mciseq.drv
330 waveaudio=mciwave.drv
331 avivideo=mciavi.drv
332 videodisc=mcipionr.drv
333 vcr=mciviscd.drv
334 MPEGVideo=mciqtz.drv
335 EOF
336
337 %if %{?debug:0}%{!?debug:1}
338 echo "Strip executable binaries and shared object files."
339 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
340 elfexelist=`echo $filelist | xargs -r file | \
341         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
342 elfsharedlist=`echo $filelist | xargs -r file | \
343         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
344 if [ -n "$elfexelist" ]; then \
345         strip -R .note -R .comment $elfexelist
346 fi
347 if [ -n "$elfsharedlist" ]; then
348         strip --strip-unneeded -R .note -R .comment $elfsharedlist
349 fi
350 %endif
351
352 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
353
354 programs="msiexec notepad progman regedit regsvr32 uninstaller wineboot winebrowser winecfg wineconsole winedbg winefile winemine winepath"
355
356 BZZZ=`pwd`
357 rm -f files.so;         touch files.so
358 rm -f files.programs;   touch files.programs
359 cd $RPM_BUILD_ROOT%{_libdir}/wine
360 for f in *.so; do
361         case $f in
362                 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
363                         ;;
364                 *)
365                         echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
366         esac
367 done
368 cd -
369 for p in $programs; do
370         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
371         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
372         grep -v "$p\.exe\.so$" files.so > files.so.
373         mv -f files.so. files.so
374 done
375
376 install -d $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
377 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
378 install programs/winetest/winetest.svg $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
379
380 %clean
381 rm -rf $RPM_BUILD_ROOT
382
383 %post   -p /sbin/ldconfig
384 %postun -p /sbin/ldconfig
385
386 %triggerpostun -- wine < 1:0.9.12-1.9
387 rm -f /var/lock/subsys/wine
388 if [ -x /sbin/chkconfig ]; then
389         /sbin/chkconfig --del wine
390 fi
391
392 %files -f files.so
393 %defattr(644,root,root,755)
394 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
395 %lang(de) %doc documentation/README.de
396 %lang(es) %doc documentation/README.es
397 %lang(fr) %doc documentation/README.fr
398 %lang(it) %doc documentation/README.it
399 %lang(ko) %doc documentation/README.ko
400 %lang(nb) %doc documentation/README.no
401 %lang(pt) %doc documentation/README.pt
402 %lang(pt_BR) %doc documentation/README.pt_br
403 %attr(755,root,root) %{_bindir}/msiexec
404 %attr(755,root,root) %{_bindir}/wine
405 %attr(755,root,root) %{_bindir}/wineboot
406 %attr(755,root,root) %{_bindir}/winebrowser
407 %attr(755,root,root) %{_bindir}/winecfg
408 %attr(755,root,root) %{_bindir}/winedbg
409 %attr(755,root,root) %{_bindir}/wine-kthread
410 #%attr(755,root,root) %{_bindir}/winelauncher
411 %attr(755,root,root) %{_bindir}/wineprefixcreate
412 %attr(755,root,root) %{_bindir}/wine-preloader
413 %attr(755,root,root) %{_bindir}/wine-pthread
414 %attr(755,root,root) %{_bindir}/wineserver
415 %attr(755,root,root) %{_libdir}/*.so*
416 %dir %{_libdir}/wine
417 %{_libdir}/wine/*.dll16
418 %{_libdir}/wine/*.drv16
419 %{_libdir}/wine/*.exe16
420 %{_libdir}/wine/*.mod16
421 %{_mandir}/man1/wine.1*
422 %{_mandir}/man1/winedbg.1*
423 %{_mandir}/man1/wineprefixcreate.1*
424 %{_mandir}/man1/wineserver.1*
425 %{_winedir}
426 %{_desktopdir}/wine.desktop
427 %{_desktopdir}/wine-uninstaller.desktop
428 %{_pixmapsdir}/wine.svg
429
430 %files programs -f files.programs
431 %defattr(644,root,root,755)
432
433 %files devel
434 %defattr(644,root,root,755)
435 %attr(755,root,root) %{_bindir}/fnt2bdf
436 %attr(755,root,root) %{_bindir}/function_grep.pl
437 %attr(755,root,root) %{_bindir}/widl
438 %attr(755,root,root) %{_bindir}/winebuild
439 %attr(755,root,root) %{_bindir}/winedump
440 %attr(755,root,root) %{_bindir}/wineg++
441 %attr(755,root,root) %{_bindir}/winegcc
442 %attr(755,root,root) %{_bindir}/winemaker
443 %attr(755,root,root) %{_bindir}/winecpp
444 #%attr(755,root,root) %{_bindir}/winewrap
445 %attr(755,root,root) %{_bindir}/wmc
446 %attr(755,root,root) %{_bindir}/wrc
447 %{_libdir}/wine/lib*.def
448 # no shared variants, so not separated
449 %{_libdir}/wine/lib*.def.a
450 %{_libdir}/wine/libadsiid.a
451 %{_libdir}/wine/libdx*.a
452 %{_libdir}/wine/libstrmiids.a
453 %{_libdir}/wine/libuuid.a
454 %{_libdir}/wine/libwinecrt0.a
455 %{_includedir}/wine
456 %{_mandir}/man1/widl.1*
457 %{_mandir}/man1/winedump.1*
458 %{_mandir}/man1/winegcc.1*
459 %{_mandir}/man1/wineg++.1*
460 %{_mandir}/man1/winemaker.1*
461 %{_mandir}/man1/winebuild.1*
462 %{_mandir}/man1/wmc.1*
463 %{_mandir}/man1/wrc.1*
464 %{_aclocaldir}/*.m4
465
466 %files dll-d3d
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
469 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
470 %attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
471 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
472
473 %files dll-gl
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
476 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
477
478 %if %{with sane}
479 %files dll-twain
480 %defattr(644,root,root,755)
481 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
482 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
483 %endif
484
485 %if %{with alsa}
486 %files drv-alsa
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
489 %endif
490
491 %if %{with jack}
492 %files drv-jack
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
495 %endif
496
497 %if %{with nas}
498 %files drv-nas
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
501 %endif
502
503 # additional dependencies in *.so not separated (yet?) from main package
504 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
505 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
506 #   ttydrv.dll.so depends on ncurses
This page took 0.725682 seconds and 2 git commands to generate.