]> git.pld-linux.org Git - packages/widelands.git/blob - widelands.spec
- missing BRs
[packages/widelands.git] / widelands.spec
1 #
2 # TODO:
3 # - create bcond for ggz
4 #
5 %define         buildver        14
6 Summary:        Game like Settlers II
7 Summary(pl.UTF-8):      Remake gry Settlers II
8 Name:           widelands
9 Version:        0.build%{buildver}
10 Release:        0.6
11 License:        GPL v2+
12 Group:          X11/Applications/Games
13 Source0:        http://dl.sourceforge.net/widelands/Widelands-Build%{buildver}-src.7z
14 # Source0-md5:  06d63783b82b68af7af26198bc0a5afa
15 Source1:        %{name}.desktop
16 #Patch0:                %{name}-syntax.patch
17 URL:            http://widelands.sourceforge.net/
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  SDL-devel >= 1.2.11
21 BuildRequires:  SDL_gfx-devel
22 BuildRequires:  SDL_image-devel
23 BuildRequires:  SDL_mixer-devel >= 1.2.7
24 BuildRequires:  SDL_net-devel
25 BuildRequires:  SDL_ttf-devel >= 2.0.0
26 BuildRequires:  boost-devel >= 1.35
27 BuildRequires:  gettext-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  p7zip
31 BuildRequires:  scons
32 BuildRequires:  sed >= 4.0
33 Requires:       SDL_image >= 1.2.10
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 In Widelands, you are the regent of a small tribe. You start out with
38 nothing but your headquarters, a kind of castle in which all your
39 resources are stored. Every member of your tribe will do his or her
40 part to produce more resources - wood, food, iron, gold and more - to
41 further this growth. But you are not alone in the world, and you will
42 meet other tribes sooner or later. Some of them may be friendly and
43 trade with you. However, if you want to rule the world, you will have
44 to train soldiers and fight.
45
46 %description -l pl.UTF-8
47 W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
48 grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
49 przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
50 wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
51 żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
52 nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
53 spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
54 nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
55 światem, będziesz musiał wyszkolić żołnierzy i walczyć.
56
57 %prep
58 %setup -q -c -T -n %{name}
59 7z x -o.. %{SOURCE0}
60 #%%patch0 -p1
61 #%{__sed} -i 's/framework-mt/framework/' SConstruct
62
63 %{__sed} -i '/env.strip=1/d' build/scons-tools/scons_configure.py
64
65 %build
66 %scons \
67         cxx="%{__cxx}" \
68         cc="%{__cc}" \
69         extra_compile_flags="%{rpmcxxflags} -O0" \
70         extra_link_flags="%{rpmcxxflags} %{rpmldflags}" \
71         build="release" \
72         pretty_compile_output="false" \
73         install_prefix="" \
74         bindir="%{_bindir}" \
75         datadir="%{_datadir}/games/%{name}" \
76         localedir="%{_datadir}/games/%{name}/locale" \
77         enable_ggz="false"
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__scons} install \
83         build="release" \
84         install_prefix="$RPM_BUILD_ROOT%{_prefix}" \
85         bindir="$RPM_BUILD_ROOT%{_bindir}" \
86         datadir="$RPM_BUILD_ROOT%{_datadir}/games/%{name}" \
87         localedir="$RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale" \
88
89 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
90
91 install pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
92 cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc ChangeLog CREDITS
100 %attr(755,root,root) %{_bindir}/%{name}
101 %dir %{_datadir}/games/%{name}
102 %{_datadir}/games/%{name}/VERSION
103 %{_datadir}/games/%{name}/campaigns
104 %{_datadir}/games/%{name}/fonts
105 %{_datadir}/games/%{name}/global
106 %{_datadir}/games/%{name}/maps
107 %{_datadir}/games/%{name}/music
108 %{_datadir}/games/%{name}/pics
109 %{_datadir}/games/%{name}/sound
110 %{_datadir}/games/%{name}/tribes
111 %{_datadir}/games/%{name}/txts
112 %{_datadir}/games/%{name}/worlds
113 %dir %{_datadir}/games/%{name}/locale
114 %lang(cs) %{_datadir}/games/%{name}/locale/cs_CZ
115 %lang(da) %{_datadir}/games/%{name}/locale/da_DK
116 %lang(de) %{_datadir}/games/%{name}/locale/de_DE
117 %lang(es) %{_datadir}/games/%{name}/locale/es_ES
118 %lang(fi) %{_datadir}/games/%{name}/locale/fi_FI
119 %lang(fr) %{_datadir}/games/%{name}/locale/fr_FR
120 %lang(gl) %{_datadir}/games/%{name}/locale/gl_ES
121 %lang(he) %{_datadir}/games/%{name}/locale/he_HE
122 %lang(hu) %{_datadir}/games/%{name}/locale/hu_HU
123 %lang(it) %{_datadir}/games/%{name}/locale/it_IT
124 %lang(nl) %{_datadir}/games/%{name}/locale/nl_NL
125 %lang(pl) %{_datadir}/games/%{name}/locale/pl_PL
126 %lang(ru) %{_datadir}/games/%{name}/locale/ru_RU
127 %lang(sk) %{_datadir}/games/%{name}/locale/sk_SK
128 %lang(sv) %{_datadir}/games/%{name}/locale/sv_SE
129 %{_desktopdir}/%{name}.desktop
130 %{_pixmapsdir}/%{name}.png
This page took 0.052635 seconds and 4 git commands to generate.