]> git.pld-linux.org Git - packages/widelands.git/blob - widelands.spec
- BR: lua51-devel, python, python-modules
[packages/widelands.git] / widelands.spec
1 #
2 # TODO:
3 # - create bcond for ggz
4 #
5 %define         buildver        15
6 Summary:        Game like Settlers II
7 Summary(pl.UTF-8):      Remake gry Settlers II
8 Name:           widelands
9 Version:        0.build%{buildver}
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications/Games
13 Source0:        http://launchpad.net/widelands/build%{buildver}/build%{buildver}/+download/%{name}-build%{buildver}-src.tar.bz2
14 # Source0-md5:  5b2e2d0913272f66055e424f91360b1d
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-locale.patch
17 Patch1:         %{name}-gcc-4.5.patch
18 URL:            http://widelands.sourceforge.net/
19 BuildRequires:  SDL-devel >= 1.2.11
20 BuildRequires:  SDL_gfx-devel
21 BuildRequires:  SDL_image-devel
22 BuildRequires:  SDL_mixer-devel >= 1.2.7
23 BuildRequires:  SDL_net-devel
24 BuildRequires:  SDL_ttf-devel >= 2.0.0
25 BuildRequires:  boost-devel >= 1.35
26 BuildRequires:  cmake
27 BuildRequires:  gettext-devel
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtiff-devel
32 BuildRequires:  lua51-devel
33 BuildRequires:  python
34 BuildRequires:  python-modules
35 Requires:       SDL_image >= 1.2.10
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 In Widelands, you are the regent of a small tribe. You start out with
40 nothing but your headquarters, a kind of castle in which all your
41 resources are stored. Every member of your tribe will do his or her
42 part to produce more resources - wood, food, iron, gold and more - to
43 further this growth. But you are not alone in the world, and you will
44 meet other tribes sooner or later. Some of them may be friendly and
45 trade with you. However, if you want to rule the world, you will have
46 to train soldiers and fight.
47
48 %description -l pl.UTF-8
49 W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
50 grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
51 przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
52 wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
53 żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
54 nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
55 spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
56 nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
57 światem, będziesz musiał wyszkolić żołnierzy i walczyć.
58
59 %prep
60 %setup -q -n %{name}-build%{buildver}-src
61 %patch0 -p1
62 %patch1 -p1
63
64 %build
65 install -d build
66 cd build
67 %cmake \
68         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
69         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
70         -DWL_INSTALL_BINDIR=%{_bindir} \
71         -DWL_INSTALL_DATADIR=%{_datadir}/games/%{name} \
72         -DWL_INSTALL_LOCALEDIR=%{_datadir}/games/%{name}/locale \
73 %if "%{_lib}" == "lib64"
74         -DLIB_SUFFIX=64 \
75 %endif
76         ..
77
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} -C build install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
87
88 install pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
89 cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc ChangeLog CREDITS
97 %attr(755,root,root) %{_bindir}/%{name}
98 %dir %{_datadir}/games/%{name}
99 %{_datadir}/games/%{name}/VERSION
100 %{_datadir}/games/%{name}/campaigns
101 %{_datadir}/games/%{name}/fonts
102 %{_datadir}/games/%{name}/global
103 %{_datadir}/games/%{name}/maps
104 %{_datadir}/games/%{name}/music
105 %{_datadir}/games/%{name}/pics
106 %{_datadir}/games/%{name}/sound
107 %{_datadir}/games/%{name}/tribes
108 %{_datadir}/games/%{name}/txts
109 %{_datadir}/games/%{name}/worlds
110 %dir %{_datadir}/games/%{name}/locale
111 %lang(ar) %{_datadir}/games/%{name}/locale/ar
112 %lang(ca) %{_datadir}/games/%{name}/locale/ca
113 %lang(cs) %{_datadir}/games/%{name}/locale/cs
114 %lang(da) %{_datadir}/games/%{name}/locale/da
115 %lang(de) %{_datadir}/games/%{name}/locale/de
116 %lang(en_GB) %{_datadir}/games/%{name}/locale/en_GB
117 %lang(eo) %{_datadir}/games/%{name}/locale/eo
118 %lang(es) %{_datadir}/games/%{name}/locale/es
119 %lang(eu) %{_datadir}/games/%{name}/locale/eu
120 %lang(fi) %{_datadir}/games/%{name}/locale/fi
121 %lang(fr) %{_datadir}/games/%{name}/locale/fr
122 %lang(gl) %{_datadir}/games/%{name}/locale/gl
123 %lang(he) %{_datadir}/games/%{name}/locale/he
124 %lang(hu) %{_datadir}/games/%{name}/locale/hu
125 %lang(ia) %{_datadir}/games/%{name}/locale/ia
126 %lang(id) %{_datadir}/games/%{name}/locale/id
127 %lang(it) %{_datadir}/games/%{name}/locale/it
128 %lang(ja) %{_datadir}/games/%{name}/locale/ja
129 %lang(la) %{_datadir}/games/%{name}/locale/la
130 %lang(nl) %{_datadir}/games/%{name}/locale/nl
131 %lang(nn) %{_datadir}/games/%{name}/locale/nn
132 %lang(pl) %{_datadir}/games/%{name}/locale/pl
133 %lang(pt_BR) %{_datadir}/games/%{name}/locale/pt_BR
134 %lang(ru) %{_datadir}/games/%{name}/locale/ru
135 %lang(si) %{_datadir}/games/%{name}/locale/si
136 %lang(sk) %{_datadir}/games/%{name}/locale/sk
137 %lang(sl) %{_datadir}/games/%{name}/locale/sl
138 %lang(sr) %{_datadir}/games/%{name}/locale/sr
139 %lang(sv) %{_datadir}/games/%{name}/locale/sv
140 %{_desktopdir}/%{name}.desktop
141 %{_pixmapsdir}/%{name}.png
This page took 0.03533 seconds and 4 git commands to generate.