]> git.pld-linux.org Git - packages/wget.git/blob - wget.spec
ipv6 support readded
[packages/wget.git] / wget.spec
1 %define debug 1
2 Summary:        A utility for retrieving files using the HTTP or FTP protocols
3 Summary(fr):    Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
4 Summary(pl):    Wsadowy klient HTTP/FTP 
5 Name:           wget
6 Version:        1.6
7 Release:        1
8 License:        GPL
9 Group:          Networking/Utilities
10 Group(de):      Netzwerkwesen/Werkzeuge
11 Group(pl):      Sieciowe/Narzêdzia
12 Source0:        ftp://ftp.gnu.org/pub/gnu/wget/%{name}-%{version}.tar.gz
13 Source1:        http://cade.8m.com/away/%{name}-new-percentage-3.0.tar.gz
14 Patch0:         %{name}-man.patch
15 Patch1:         %{name}-info.patch
16 Patch2:         %{name}-DESTDIR.patch
17 Patch3:         %{name}-1.6-ipv6-20010102.patch.gz
18 URL:            http://sunsite.dk/wget/
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define _sysconfdir     /etc
22
23 %description
24 GNU Wget is a file retrieval utility which can use either the HTTP or
25 FTP protocols. Wget features include the ability to work in the
26 background while you're logged out, recursive retrieval of
27 directories, file name wildcard matching, remote file timestamp
28 storage and comparison, use of Rest with FTP servers and Range with
29 HTTP servers to retrieve files over slow or unstable connections,
30 support for Proxy servers, and configurability.
31
32 %description -l fr
33 GNU Wget est un utilitaire pour récupérer des fichiers qui peut
34 utiliser indifféremment les protocoles HTTP ou FTP. Parmi les
35 caractéristiques de Wget, citons la capacité à récupérer des fichiers
36 en arrière-plan alors que vous n'êtes pas connecté, la récupération
37 récursive de répertoires, la capacité de récupérer des fichiers en
38 appliquant un filtre sur le nom ou sur la date, la gestion de Rest
39 avec les serveurs FTP et de Range avec les serveurs HTTP pour
40 récupérer des fichiers avec une connexion lente ou instable, le
41 support des serveurs Proxy... Wget est particulièrement configurable.
42
43 %description -l pl
44 Wget jest klientem FTP/HTTP przeznaczonym do ¶ci±gania zasobów
45 wsadowo. Umo¿liwia ¶ci±ganie zasobów z podkatalogami, a tak¿e ma opcje
46 umo¿liwiaj±ce wykonanie lokalnej kopii zasobów (mirror). W razie
47 niemo¿no¶ci dostania siê do zasobów lub gdy po³±czenie z serwerem
48 FTP/HTTP zostanie zerwane, mo¿e automatycznie ponawiaæ próby
49 kopiowania. Jest tak¿e dobrze przystosowany do tego, ¿eby uruchamiaæ
50 go jako zadanie z cron'a.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57 %patch3 -p1
58 tar xzf %{SOURCE1}
59 cd src
60 mv -f ../wget-new-percentage/wget-new-percentage.c .
61 patch retr.c < ../wget-new-percentage/wget-new-percentage.diff
62
63 %build
64 autoconf
65 autoheader
66 %configure --enable-ipv6
67 %{__make}
68 tail -6 util/README >rmold.README
69
70 (cd doc; makeinfo --force %{name}.texi; touch *)
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install DESTDIR=$RPM_BUILD_ROOT
76
77 install util/rmold.pl $RPM_BUILD_ROOT%{_bindir}/rmold
78
79 mv -f wget-new-percentage/README README-new_percent
80
81 gzip -9nf AUTHORS ChangeLog NEWS TODO README MAILING-LIST rmold.README \
82         README-new_percent
83
84 %find_lang %{name}
85  
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
91
92 %postun
93 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
94
95 %files -f %{name}.lang
96 %defattr(644,root,root,755)
97 %doc *.gz
98 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/%{name}rc
99 %attr(755,root,root) %{_bindir}/*
100 %{_mandir}/man1/*
101 %{_infodir}/*.info*
This page took 0.057508 seconds and 4 git commands to generate.