]> git.pld-linux.org Git - packages/wget.git/blob - wget.spec
3be3144b8f6503f2f94937c69cf8799201a9ba9e
[packages/wget.git] / wget.spec
1 Summary:        Command-line HTTP and FTP client
2 Summary(pl):    Wsadowy klient HTTP/FTP 
3 Name:           wget
4 Version:        1.5.3
5 Release:        6
6 Copyright:      GPL
7 Group:          Networking/Utilities
8 Group(pl):      Sieciowe/Narzêdzia
9 Source:         ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
10 Patch0:         wget-man.patch
11 Patch1:         wget-pl.po.patch
12 Patch2:         wget-info.patch
13 Prereq:         /sbin/install-info
14 URL:            http://sunsite.auc.dk/ftp/pub/infosystems/wget/
15 BuildRoot:      /tmp/%{name}-%{version}-root
16
17 %description
18 wget is a command-line program to fetch files via HTTP or FTP.  It
19 supports recursive retrieval and mirroring options, and it automatically
20 retries several times before giving up, so it is well-suited to running
21 from cron jobs.
22
23 %description -l pl
24 Wget jest klientem FTP/HTTP przeznaczonym do ¶ci±gania zasobów wsadowo. 
25 Umo¿liwia ¶ci±ganie zasobów z podkatalogami, a tak¿e ma opcje umo¿liwiaj±ce 
26 wykonanie lokalnej kopii zasobów (mirror). W razie niemo¿no¶ci dostania siê 
27 do zasobów lub gdy po³±czenie z serwerem FTP/HTTP zostanie zerwane, mo¿e 
28 automatycznie ponawiaæ próby kopiowania. Jest tak¿e dobrze przystosowany do 
29 tego, ¿eby uruchamiaæ go jako zadanie z cron'a.
30
31 %prep
32 %setup -q
33 %patch0 -p1
34 %patch1 -p1
35 %patch2 -p1
36
37 %build
38 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
39 ./configure %{_target} \
40         --prefix=/usr \
41         --sysconfdir=/etc
42 make
43 tail -6 util/README >rmold.README
44
45 (cd doc; makeinfo --force wget.texi; touch *)
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 make prefix=$RPM_BUILD_ROOT/usr sysconfdir=$RPM_BUILD_ROOT/etc install
51 install -c util/rmold.pl $RPM_BUILD_ROOT/usr/bin/rmold
52
53 gzip -9nf $RPM_BUILD_ROOT/usr/{info/wget.info*,man/man1/*} \
54     AUTHORS ChangeLog NEWS TODO README MAILING-LIST rmold.README
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 /sbin/install-info /usr/info/wget.info.gz /etc/info-dir
61
62 %postun
63 if [ "$1" = "0" ]; then
64         /sbin/install-info --delete /usr/info/wget.info.gz /etc/info-dir
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc {AUTHORS,ChangeLog,MAILING-LIST,NEWS,TODO,README,rmold.README}.gz
70
71 %attr(755,root,root) /usr/bin/*
72
73 %lang(cs) /usr/share/locale/cs/LC_MESSAGES/wget.mo
74 %lang(de) /usr/share/locale/de/LC_MESSAGES/wget.mo
75 %lang(hr) /usr/share/locale/hr/LC_MESSAGES/wget.mo
76 %lang(it) /usr/share/locale/it/LC_MESSAGES/wget.mo
77 %lang(no) /usr/share/locale/no/LC_MESSAGES/wget.mo
78 %lang(pl) /usr/share/locale/pl/LC_MESSAGES/wget.mo
79 %lang(pt) /usr/share/locale/pt*/LC_MESSAGES/wget.mo
80
81 /usr/man/man1/*
82 /usr/info/wget.info*
83
84 %verify(not md5 size mtime) %config(noreplace) /etc/wgetrc
85
86 %changelog
87 * Wed Apr 21 1999 Piotr Czerwiñski <pius@pld.org.pl>
88   [1.5.3-6]
89 - replacements in %files,
90 - recompiled on rpm 3,
91 - force making info pages (new makeinfo don't accept @xfer{} without "." or
92   "," after this markup) by Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>.
93
94 * Fri Apr  2 1999 Piotr Czerwiñski <pius@pld.org.pl>
95   [1.5.2-5]
96 - removed man group from man pages,
97 - few typos corrected,
98 - cosmetic changes for common l&f.
99
100 * Thu Feb 10 1999 Micha³ Kuratczyk <kurkens@polbox.com>
101   [1.5.2-4]
102 - added Group(pl)
103 - added gzipping documentation
104
105 * Mon Dec 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
106   [1.5.2-3]
107 - standarized {un}registering info pages (added wget-info.patch),
108 - added URL,
109 - added gzipping man pages.
110
111 * Tue Sep 12 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
112   [1.5.2-2]
113 - fixed pl translation.
114
115 * Mon Sep  7 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
116   [1.5.2-2]
117 - added wget-pl.po.patch patch with polish translation 
118   (Adam Kozubowicz <tapir@interdata.com.pl>,
119 - added wget-man.patch patch with wget man page.
120
121 * Sat Aug  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
122   [1.5.2-1]
123 - added pl translation.
124
125 * Sun May 17 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
126   [1.5.1-2]
127 - %%{version} macro instead %%{PACKAGE_VERSION},
128 - added -q %setup parameter,
129 - added using %%{name} macro in Buildroot and Source,
130 - added %verify(not md5 size mtime) and noreplace parameter for %config,
131 - removed COPYING from %doc (copyright statment is in Copyright
132   field),
133 - added %postun, %post sections with {de}instaling wget info pages,
134 - spec file rewrited for using Buildroot,
135 - added %clean section,
136 - added URL,
137 - removed Packager field from spec (if you want recompile package and
138   redistribute this package later put this in your private .rpmrc). 
139 - Buildroot changed to /tmp/wget-%%{PACKAGE_VERSION}-root,
140 - added %%{PACKAGE_VERSION} to Source url,
141 - replaced "mkdir -p" with "install -d" in %install,
142 - base datadir changed to /usr/share,
143 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/wget.mo files,
144 - added %defattr and %attr macros in %files (allows building package from
145   non-root account).
146
147 * Thu May  7 1998 ??? <root@ricketts.stannes.ox.ac.uk>
148   [1.5.1-1]
149 - previous release in rpm package.
This page took 0.030949 seconds and 2 git commands to generate.