]> git.pld-linux.org Git - packages/weston.git/blob - weston.spec
66be703413d0b91fc66db9fd8f8c055da84935ea
[packages/weston.git] / weston.spec
1 #
2 # Conditional build:
3 %bcond_without  drm             # DRM compositor
4 %bcond_with     rdp             # RDP compositor (needs freerdp 1.1.0)
5 %bcond_without  wayland         # wayland (nested) compositor
6 %bcond_without  x11             # X11 compositor
7 %bcond_without  libinput        # libinput backend
8 %bcond_without  vaapi           # vaapi recorder
9 %bcond_without  wlaunch         # weston launch
10 %bcond_without  xwayland        # X server launcher
11 %bcond_without  sclients        # simple clients
12 %bcond_without  clients         # non-simple + full GL clients
13 #
14 Summary:        Weston - Wayland demos
15 Summary(pl.UTF-8):      Weston - programy demonstracyjne dla protokołu Wayland
16 Name:           weston
17 Version:        1.6.1
18 Release:        1
19 License:        MIT
20 Group:          Applications
21 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
22 # Source0-md5:  08e857668621c930cab239d11c12cf47
23 Patch0:         libinput-0.9.patch
24 URL:            http://wayland.freedesktop.org/
25 BuildRequires:  Mesa-libEGL-devel >= 7.10
26 # GLESv2
27 BuildRequires:  Mesa-libGLES-devel
28 # for wayland and sclients, but also desktop-shell, which is always enabled
29 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0-2
30 BuildRequires:  autoconf >= 2.64
31 BuildRequires:  automake >= 1:1.11
32 BuildRequires:  cairo-devel >= 1.10.0
33 BuildRequires:  colord-devel >= 0.1.27
34 BuildRequires:  dbus-devel >= 1.6
35 %{?with_rdp:BuildRequires:      freerdp-devel >= 1.1.0}
36 BuildRequires:  lcms2-devel >= 2
37 %{?with_libinput:BuildRequires: libinput-devel >= 0.6.0}
38 BuildRequires:  libjpeg-devel
39 BuildRequires:  libpng-devel
40 BuildRequires:  libtool >= 2:2.2
41 BuildRequires:  libunwind-devel
42 BuildRequires:  libwebp-devel
43 BuildRequires:  pixman-devel >= 0.26
44 BuildRequires:  pkgconfig
45 BuildRequires:  tar >= 1:1.22
46 # wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
47 BuildRequires:  wayland-devel >= 1.6.0
48 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
49 BuildRequires:  xz
50 %if %{with drm}
51 BuildRequires:  Mesa-libgbm-devel
52 BuildRequires:  libdrm-devel >= 2.4.30
53 BuildRequires:  mtdev-devel >= 1.1.0
54 BuildRequires:  udev-devel >= 1:136
55 %endif
56 %if %{with vaapi}
57 BuildRequires:  libva-devel >= 1.2.0
58 BuildRequires:  libva-drm-devel >= 1.2.0
59 # API versions
60 BuildRequires:  pkgconfig(libva) >= 0.34.0
61 BuildRequires:  pkgconfig(libva-drm) >= 0.34.0
62 %endif
63 %if %{with x11}
64 BuildRequires:  libxcb-devel
65 BuildRequires:  xorg-lib-libX11-devel
66 %endif
67 %if %{with wlaunch}
68 BuildRequires:  libdrm-devel
69 BuildRequires:  pam-devel
70 # TODO: bump to 1:209 (required at runtime when built with such version)
71 BuildRequires:  systemd-devel >= 1:198
72 %endif
73 %if %{with xwayland}
74 BuildRequires:  libxcb-devel
75 BuildRequires:  pkgconfig(cairo-xcb)
76 BuildRequires:  xorg-lib-libXcursor-devel
77 %endif
78 %if %{with clients}
79 BuildRequires:  OpenGL-GLU-devel
80 BuildRequires:  cairo-devel >= 1.11.3
81 BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
82 BuildRequires:  pkgconfig(cairo-gl)
83 %endif
84 Requires:       Mesa-libEGL >= 7.10
85 Requires:       Mesa-libwayland-egl >= 9.0-2
86 Requires:       cairo >= %{?with_clients:1.11.3}%{!?with_clients:1.10.0}
87 Requires:       colord-libs >= 0.1.27
88 Requires:       dbus-libs >= 1.6
89 %{?with_rdp:Requires:   freerdp >= 1.1.0}
90 %{?with_drm:Requires:   libdrm >= 2.4.30}
91 %{?with_libinput:Requires:      libinput >= 0.6.0}
92 %if %{with vaapi}
93 Requires:       libva >= 1.2.0
94 Requires:       libva-drm >= 1.2.0
95 %endif
96 %{?with_drm:Requires:   mtdev >= 1.1.0}
97 Requires:       pixman >= 0.26
98 %{?with_wlaunch:Requires:       systemd-libs >= 1:198}
99 %{?with_drm:Requires:   udev-libs >= 1:136}
100 Requires:       wayland >= 1.6.0
101 Requires:       xorg-lib-libxkbcommon >= 0.3.0
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %description
105 Weston contains a few demo application for the Wayland project.
106 There's a sample compositor that can run on KMS, under X11 or under
107 another Wayland compositor and there's a handful of simple clients
108 that demonstrate various aspects of Wayland.
109
110 %description -l pl.UTF-8
111 Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
112 Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
113 X11 lub pod innym serwerem składającym Wayland; są także proste
114 programy klienckie demonstrujące różne aspekty protokołu Wayland.
115
116 %package devel
117 Summary:        Header files for Weston plugin development
118 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek dla Westona
119 Group:          Development/Libraries
120 Requires:       Mesa-libEGL-devel >= 7.10
121 # GLESv2
122 Requires:       Mesa-libGLES-devel
123 Requires:       pixman-devel >= 0.26
124 Requires:       wayland-devel >= 1.6.0
125 Requires:       xorg-lib-libxkbcommon-devel >= 0.3.0
126
127 %description devel
128 Header files for Weston plugin development.
129
130 %description devel -l pl.UTF-8
131 Pliki nagłówkowe do tworzenia wtyczek dla Westona.
132
133 %prep
134 %setup -q
135 %patch0 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal} -I m4
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 %configure \
144         %{!?with_clients:--disable-clients} \
145         %{!?with_drm:--disable-drm-compositor} \
146         %{?with_libinput:--enable-libinput-backend} \
147         %{?with_rdp:--enable-rdp-compositor} \
148         %{!?with_sclients:--disable-simple-clients} \
149         --disable-setuid-install \
150         --disable-silent-rules \
151         %{!?with_vaapi:--disable-vaapi-recorder} \
152         %{!?with_wlaunch:--disable-weston-launch} \
153         %{!?with_x11:--disable-x11-compositor} \
154         %{!?with_xwayland:--disable-xwayland} \
155         %{?with_clients:--with-cairo=gl}
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %files
170 %defattr(644,root,root,755)
171 %doc README
172 %attr(755,root,root) %{_bindir}/wcap-decode
173 %attr(755,root,root) %{_bindir}/weston-info
174 # composer
175 %attr(755,root,root) %{_bindir}/weston
176 %if %{with wlaunch}
177 %attr(755,root,root) %{_bindir}/weston-launch
178 %endif
179 %if %{with clients}
180 %attr(755,root,root) %{_bindir}/weston-terminal
181 %attr(755,root,root) %{_libexecdir}/weston-desktop-shell
182 %attr(755,root,root) %{_libexecdir}/weston-keyboard
183 %attr(755,root,root) %{_libexecdir}/weston-screensaver
184 %attr(755,root,root) %{_libexecdir}/weston-screenshooter
185 %endif
186 %attr(755,root,root) %{_libexecdir}/weston-simple-im
187 %dir %{_libdir}/weston
188 %attr(755,root,root) %{_libdir}/weston/cms-colord.so
189 %attr(755,root,root) %{_libdir}/weston/cms-static.so
190 %if %{with drm}
191 %attr(755,root,root) %{_libdir}/weston/drm-backend.so
192 %endif
193 %attr(755,root,root) %{_libdir}/weston/fbdev-backend.so
194 %attr(755,root,root) %{_libdir}/weston/gl-renderer.so
195 %attr(755,root,root) %{_libdir}/weston/headless-backend.so
196 %if %{with rdp}
197 %attr(755,root,root) %{_libdir}/weston/rdp-backend.so
198 %endif
199 %if %{with wayland}
200 %attr(755,root,root) %{_libdir}/weston/wayland-backend.so
201 %endif
202 %if %{with x11}
203 %attr(755,root,root) %{_libdir}/weston/x11-backend.so
204 %endif
205 %if %{with xwayland}
206 %attr(755,root,root) %{_libdir}/weston/xwayland.so
207 %endif
208 %attr(755,root,root) %{_libdir}/weston/desktop-shell.so
209 %attr(755,root,root) %{_libdir}/weston/fullscreen-shell.so
210 %{_datadir}/weston
211 %{_mandir}/man1/weston.1*
212 %{_mandir}/man5/weston.ini.5*
213 %{_mandir}/man7/weston-drm.7*
214
215 # noinst by default - --enable-demo-clients and package in %{name}-demos?
216 # "simple clients"
217 #%attr(755,root,root) %{_bindir}/weston-multi-resource
218 #%attr(755,root,root) %{_bindir}/weston-simple-egl
219 #%attr(755,root,root) %{_bindir}/weston-simple-shm
220 #%attr(755,root,root) %{_bindir}/weston-simple-touch
221 %if %{with clients}
222 #%attr(755,root,root) %{_bindir}/weston-calibrator
223 #%attr(755,root,root) %{_bindir}/weston-clickdot
224 #%attr(755,root,root) %{_bindir}/weston-cliptest
225 #%attr(755,root,root) %{_bindir}/weston-dnd
226 #%attr(755,root,root) %{_bindir}/weston-editor
227 #%attr(755,root,root) %{_bindir}/weston-eventdemo
228 #%attr(755,root,root) %{_bindir}/weston-flower
229 #%attr(755,root,root) %{_bindir}/weston-fullscreen
230 #%attr(755,root,root) %{_bindir}/weston-image
231 #%attr(755,root,root) %{_bindir}/weston-resizor
232 #%attr(755,root,root) %{_bindir}/weston-scaler
233 #%attr(755,root,root) %{_bindir}/weston-smoke
234 #%attr(755,root,root) %{_bindir}/weston-stacking
235 #%attr(755,root,root) %{_bindir}/weston-transformed
236 # "full GL" clients
237 #%attr(755,root,root) %{_bindir}/weston-gears
238 %endif
239
240 %files devel
241 %defattr(644,root,root,755)
242 %{_includedir}/weston
243 %{_pkgconfigdir}/weston.pc
This page took 0.076248 seconds and 2 git commands to generate.