]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
rebuild with openssl 3.0.0
[packages/wesnoth.git] / wesnoth.spec
1 # TODO
2 # - system lua?
3 # - unpackaged language files
4 #
5 # Conditional build
6 %bcond_without  server  # without server
7 %bcond_without  fribidi # without Bidirectional language support
8
9 Summary:        Strategy game with a fantasy theme
10 Summary(hu.UTF-8):      Fantasy környezetben játszódó stratégiai játék
11 Summary(pl.UTF-8):      Gra strategiczna z motywem fantasy
12 Name:           wesnoth
13 Version:        1.14.17
14 Release:        3
15 Epoch:          1
16 License:        GPL v2+
17 Group:          X11/Applications/Games/Strategy
18 Source0:        http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
19 # Source0-md5:  5ef1d8045fd52f17852b726826c5c52a
20 Source1:        %{name}d.init
21 Source2:        %{name}.tmpfiles
22 Source3:        %{name}.sysconfig
23 Source4:        %{name}d.service
24 URL:            http://www.wesnoth.org/
25 BuildRequires:  SDL2-devel >= 2.0.4
26 BuildRequires:  SDL2_image-devel >= 2.0.0
27 BuildRequires:  SDL2_mixer-devel >= 2.0.0
28 BuildRequires:  SDL2_ttf-devel >= 2.0.12
29 BuildRequires:  boost-devel >= 1.50.0
30 BuildRequires:  bzip2-devel
31 BuildRequires:  cairo-devel >= 1.10.0
32 BuildRequires:  cmake >= 2.8.5
33 BuildRequires:  dbus-devel
34 BuildRequires:  fontconfig-devel >= 2.4.1
35 %{?with_fribidi:BuildRequires:  fribidi-devel >= 0.10.9}
36 BuildRequires:  gettext-tools
37 BuildRequires:  libicu-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libstdc++-devel >= 6:4.7
40 BuildRequires:  libvorbis-devel
41 BuildRequires:  openssl-devel >= 1.0
42 BuildRequires:  pango-devel >= 1:1.22.0
43 BuildRequires:  pkgconfig
44 BuildRequires:  readline-devel
45 BuildRequires:  rpm-build >= 4.6
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  rpmbuild(macros) >= 1.605
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  systemd-devel
50 BuildRequires:  xorg-lib-libICE-devel
51 BuildRequires:  xorg-lib-libSM-devel
52 BuildRequires:  xorg-lib-libX11-devel
53 BuildRequires:  xorg-lib-libXext-devel
54 BuildRequires:  zlib-devel
55 Requires(post,postun):  desktop-file-utils
56 Requires(post,postun):  gtk-update-icon-cache
57 Requires:       %{name}-data = %{epoch}:%{version}
58 Requires:       SDL2 >= 2.0.4
59 Requires:       fontconfig >= 2.4.1
60 %{?with_fribidi:Requires:       fribidi >= 0.10.9}
61 Requires:       pango >= 1:1.22.8
62 Obsoletes:      wesnoth-tools < 1:1.14
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Battle for Wesnoth is a fantasy strategy game. Battle for control of
67 villages, using variety of units which have advantages and
68 disadvantages in different types of terrains and against different
69 types of attacks. Units gain experience and advance levels, and are
70 carried over from one scenario to the next campaign.
71
72 %description -l hu.UTF-8
73 Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben játszódó
74 stratégiai játék. Harc a falvak megszerzéséért, különböző egységek
75 felhasználásával, amelyeknek különböző előnyeik és hátrányaik vannak a
76 különféle terepeken és a különböző támadási stílusok ellen. Az
77 egységek tapasztalatot gyűjtenek, és fejlődnek, amelyek átvihetők a
78 következő pályára.
79
80 %description -l pl.UTF-8
81 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
82 wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
83 jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym sposobom
84 ataku. Oddziały zdobywają doświadczenie i poziomy zaawansowania i są
85 przenoszone z jednej scenerii do następnej kampanii.
86
87 %package server
88 Summary:        Network server for Wesnoth
89 Summary(hu.UTF-8):      Hálózati szerver Wesnoth-hoz
90 Summary(pl.UTF-8):      Sieciowy serwer dla Wesnoth
91 Group:          X11/Applications/Games/Strategy
92 Requires(post,preun):   /sbin/chkconfig
93 Requires(postun):       /usr/sbin/groupdel
94 Requires(postun):       /usr/sbin/userdel
95 Requires(pre):  /usr/sbin/groupadd
96 Requires(pre):  /usr/sbin/useradd
97 Requires:       rc-scripts >= 0.4.0.17
98 Provides:       group(wesnothd)
99 Provides:       user(wesnothd)
100
101 %description server
102 Server for playing networked games of Wesnoth.
103
104 %description server -l hu.UTF-8
105 Szerver a Wesnoth hálózati játékához.
106
107 %description server -l pl.UTF-8
108 Serwer do prowadzenia sieciowych gier Wesnoth.
109
110 %package data
111 Summary:        Strategy game with a fantasy theme - data files
112 Summary(pl.UTF-8):      Gra strategiczna z motywem fantasy - pliki danych
113 Group:          Applications/Games
114 BuildArch:      noarch
115
116 %description data
117 This package contains the data files for Wesnoth.
118
119 %description data -l pl.UTF-8
120 Ten pakiet zawiera pliki danych dla gry Wesnoth.
121
122 %prep
123 %setup -q
124
125 # don't install locales in %{_datadir}/%{name}
126 %{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
127
128 %{__sed} -i '1s,/usr/bin/env python3$,%{__python3},' \
129         data/tools/{GUI.pyw,about_cfg_to_wiki,addon_manager/__init__.py,addon_manager/html.py,campaign2wiki.py,extractbindings,hexometer.py,imgcheck,steam-changelog,terrain2wiki.py,unit_tree/TeamColorizer,unit_tree/__init__.py,unit_tree/animations.py,unit_tree/helpers.py,unit_tree/html_output.py,unit_tree/overview.py,unit_tree/wiki_output.py,wesnoth/campaignserver_client.py,wesnoth/libgithub.py,wesnoth/wescamp.py,wesnoth/wmliterator3.py,wesnoth/wmlparser3.py,wesnoth/wmltools3.py,wesnoth_addon_manager,wmlindent,wmllint,wmllint-1.4,wmlscope,wmlunits,wmlxgettext}
130 %{__sed} -i '1s,/usr/bin/env python2$,%{__python},' \
131         data/tools/{expand-terrain-macros.py,journeylifter,rmtrans/rmtrans.py,scoutDefault.py,trackplacer,wesnoth/wmldata.py,wesnoth/wmlgrammar.py,wesnoth/wmliterator.py,wesnoth/wmlparser.py,wesnoth/wmlparser2.py,wesnoth/wmltools.py,wmlflip,wmlvalidator}
132
133 %build
134 install -d build
135 cd build
136 # override *FLAGS to remove -DNDEBUG (wesnoth depends on asserts)
137 CFLAGS="%{rpmcflags}"
138 CXXFLAGS="%{rpmcxxflags}"
139 %cmake .. \
140         -DENABLE_STRICT_COMPILATION=OFF \
141         -DBINDIR="%{_bindir}" \
142         -DMANDIR="%{_mandir}" \
143         -DLOCALEDIR="%{_localedir}" \
144         %{!?with_server:-DENABLE_SERVER=OFF} \
145         %{?with_server:-DENABLE_CAMPAIGN_SERVER=ON} \
146         %{!?with_fribidi:-DENABLE_FRIBIDI=OFF}
147
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,/etc/sysconfig} \
153         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{_docdir}/%{name}-%{version}} \
154         $RPM_BUILD_ROOT%{systemdunitdir}
155
156 %{__make} -C build install \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 %if %{with server}
160 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
161 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
162 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/wesnoth
163 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/wesnothd.service
164 %endif
165
166 %{__mv} $RPM_BUILD_ROOT%{_docdir}/html $RPM_BUILD_ROOT%{_docdir}/%{name}
167
168 # unify
169 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ca_ES@valencia,ca@valencia}
170 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{nb_NO,nb}
171 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fur_IT,fur}
172 %{__mv} $RPM_BUILD_ROOT%{_mandir}/{ca_ES@valencia,ca@valencia}
173
174 # unsupported(?)
175 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ang@latin
176 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/racv
177 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavian
178 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavianlatin
179
180 # the same as manuals from %{_mandir}/man?
181 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/en_GB
182
183 %find_lang %{name} --all-name
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %post
189 %update_desktop_database
190 %update_icon_cache hicolor
191
192 %postun
193 %update_desktop_database
194 %update_icon_cache hicolor
195
196 %pre server
197 %groupadd -P %{name}-server -g 178  wesnothd
198 %useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
199
200 %post server
201 /sbin/chkconfig --add wesnothd
202 %service wesnothd restart
203 %systemd_post wesnothd.service
204
205 %preun server
206 if [ "$1" = "0" ]; then
207         %service wesnothd stop
208         /sbin/chkconfig --del wesnothd
209 fi
210 %systemd_preun wesnothd.service
211
212 %postun server
213 if [ "$1" = "0" ]; then
214         %userremove wesnothd
215         %groupremove wesnothd
216 fi
217 %systemd_reload
218
219 %files -f %{name}.lang
220 %defattr(644,root,root,755)
221 %doc README.md changelog.md
222 %doc %{_docdir}/%{name}
223 %attr(755,root,root) %{_bindir}/wesnoth
224 %{_mandir}/man6/wesnoth.6*
225 %lang(ca) %{_mandir}/ca/man6/wesnoth.6*
226 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
227 %lang(de) %{_mandir}/de/man6/wesnoth.6*
228 %lang(es) %{_mandir}/es/man6/wesnoth.6*
229 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
230 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
231 %lang(it) %{_mandir}/it/man6/wesnoth.6*
232 %lang(ja) %{_mandir}/ja/man6/wesnoth.6*
233 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
234 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
235 %lang(ru) %{_mandir}/ru/man6/wesnoth.6*
236 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
237 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
238 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
239 %{_desktopdir}/wesnoth.desktop
240 %{_iconsdir}/hicolor/*x*/apps/wesnoth-icon.png
241 %{_datadir}/metainfo/wesnoth.appdata.xml
242
243 %if %{with server}
244 %files server
245 %defattr(644,root,root,755)
246 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
247 %attr(755,root,root) %{_bindir}/campaignd
248 %attr(755,root,root) %{_bindir}/wesnothd
249 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
250 %attr(644,root,root) %{systemdunitdir}/wesnothd.service
251 %{_mandir}/man6/wesnothd.6*
252 %lang(ca) %{_mandir}/ca/man6/wesnothd.6*
253 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
254 %lang(de) %{_mandir}/de/man6/wesnothd.6*
255 %lang(es) %{_mandir}/es/man6/wesnothd.6*
256 %lang(et) %{_mandir}/et/man6/wesnothd.6*
257 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
258 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
259 %lang(gl) %{_mandir}/gl/man6/wesnothd.6*
260 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
261 %lang(id) %{_mandir}/id/man6/wesnothd.6*
262 %lang(it) %{_mandir}/it/man6/wesnothd.6*
263 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
264 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
265 %lang(pt) %{_mandir}/pt/man6/wesnothd.6*
266 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
267 %lang(ru) %{_mandir}/ru/man6/wesnothd.6*
268 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
269 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
270 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
271 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
272 %lang(uk) %{_mandir}/uk/man6/wesnothd.6*
273 %lang(vi) %{_mandir}/vi/man6/wesnothd.6*
274 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
275 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
276 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
277 %{systemdtmpfilesdir}/%{name}.conf
278 %endif
279
280 %files data
281 %defattr(644,root,root,755)
282 %{_datadir}/%{name}
This page took 0.092467 seconds and 4 git commands to generate.