]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
- up to 1.6a version
[packages/wesnoth.git] / wesnoth.spec
1 # TODO
2 # - rename language files sr@latin to sr@Latn and include them
3 # - use desktop file included with project (consider which one are better)
4 # - dont know what should I do with sr@latin and racv man pages
5 # Conditional build
6 # - put python files into pysite_dir
7 %bcond_without  server  # without server
8 %bcond_without  tools   # without tools
9 %bcond_without  fribidi # without Bidirectional language support
10 #
11 Summary:        Strategy game with a fantasy theme
12 Summary(hu.UTF-8):      Fantasy környezetben játszódó stratégiai játék
13 Summary(pl.UTF-8):      Strategiczna gra z motywem fantasy
14 Name:           wesnoth
15 Version:        1.6a
16 Release:        0.1
17 Epoch:          1
18 License:        GPL v2+
19 Group:          X11/Applications/Games/Strategy
20 Source0:        http://www.wesnoth.org/files/%{name}-%{version}.tar.bz2
21 # Source0-md5:  3c4618eb64d1e5aeb6a00ab3956d5080
22 Source1:        %{name}.desktop
23 Source2:        %{name}_editor.desktop
24 Source3:        %{name}d.init
25 Patch0:         %{name}-Makefile.patch
26 Patch1:         %{name}-locale_dir.patch
27 URL:            http://www.wesnoth.org/
28 BuildRequires:  SDL-devel >= 1.2.7
29 BuildRequires:  SDL_image-devel >= 1.2
30 BuildRequires:  SDL_mixer-devel >= 1.2
31 BuildRequires:  SDL_net-devel >= 1.2
32 BuildRequires:  SDL_ttf-devel >= 2.0.8
33 BuildRequires:  autoconf >= 2.59
34 BuildRequires:  automake >= 1:1.9
35 BuildRequires:  boost-devel >= 1.33
36 %{?with_fribidi:BuildRequires:  fribidi-devel}
37 BuildRequires:  gettext-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool >= 2:1.5
41 BuildRequires:  libvorbis-devel
42 BuildRequires:  pkg-config
43 BuildRequires:  python-devel
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(macros) >= 1.268
46 BuildRequires:  sed >= 4.0
47 BuildRequires:  zipios++-devel
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Battle for Wesnoth is a fantasy strategy game. Battle for control of
52 villages, using variety of units which have advantages and
53 disadvantages in different types of terrains and against different
54 types of attacks. Units gain experience and advance levels, and are
55 carried over from one scenario to the next campaign.
56
57 %description -l hu.UTF-8
58 Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben
59 játszódó stratégiai játék. Harc a falvak megszerzéséért,
60 különböző egységek felhasználásával, amelyeknek különböző
61 előnyeik és hátrányaik vannak a különféle terepeken és a
62 különböző támadási stílusok ellen. Az egységek tapasztalatot
63 gyűjtenek, és fejlődnek, amelyek átvihetők a következő
64 pályára.
65
66 %description -l pl.UTF-8
67 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę
68 nad wsiami przy pomocy różnego rodzaju oddziałów, które mają
69 przewagę lub jej brak w odmiennym ukształtowaniu terenu i przeciwko
70 różnym sposobom ataku. Oddziały zdobywają doświadczenie i poziomy
71 zaawansowania i są przenoszone z jednej scenerii do następnej
72 kampanii.
73
74 %package server
75 Summary:        Network server for Wesnoth
76 Summary(pl.UTF-8):      Sieciowy serwer dla Wesnoth
77 Group:          X11/Applications/Games/Strategy
78 Requires(post,preun):   /sbin/chkconfig
79 Requires(postun):       /usr/sbin/groupdel
80 Requires(postun):       /usr/sbin/userdel
81 Requires(pre):  /usr/sbin/groupadd
82 Requires(pre):  /usr/sbin/useradd
83 Requires:       rc-scripts >= 0.4.0.17
84
85 %description server
86 Server for playing networked games of Wesnoth.
87
88 %description server -l hu.UTF-8
89 Szerver a Wesnoth hálózati játékához.
90
91 %description server -l pl.UTF-8
92 Serwer do prowadzenia sieciowych gier Wesnoth.
93
94 %package tools
95 Summary:        Tools for Wesnoth
96 Summary(hu.UTF.8):      Eszközök a Wesnoth-hoz
97 Summary(pl.UTF-8):      Narzędzia dla Wesnoth
98 Group:          X11/Applications/Games/Strategy
99 Requires:       %{name} = %{epoch}:%{version}-%{release}
100
101 %description tools
102 Map editor and translations tools.
103
104 %description tools -l hu.UTF-8
105 Pályaszerkesztők és fordítási eszközök.
106
107 %description tools -l pl.UTF-8
108 Edytor map i narzędzia do tłumaczeń.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113 %patch1 -p1
114 %{__sed} -i 's,PYTHON_PREFIX"/lib,PYTHON_PREFIX"/%{_lib},g' configure.ac
115
116 %build
117 %{__gettextize}
118 %{__aclocal} -I m4
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122 %configure \
123         %{?with_server:--enable-server} \
124         %{?with_server:--enable-campaign-server} \
125         --enable-python-install \
126         %{?with_tools:--enable-editor} \
127         %{?with_tools:--enable-tools} \
128         --with%{!?with_fribidi:out}-fribidi \
129         --docdir=%{_docdir}/%{name}-%{version} \
130         --with-icondir=%{_pixmapsdir} \
131         --with-zipios
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 # install additional docs
142 install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
143 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
144
145 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
146 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
147 %if %{with server}
148 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
149 %endif
150
151 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{nb_NO,nb}
152
153 # unsupported(?)
154 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
155 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
156 rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
157
158 # the same as manuals from %{_mandir}/man?
159 rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
160
161 #%%py_comp $RPM_BUILD_ROOT%{py_sitedir}
162 #%%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
163 #%%py_postclean
164
165 %find_lang %{name} --all-name
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %pre server
171 %groupadd -P %{name}-server -g 178  wesnothd
172 %useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
173
174 %post server
175 /sbin/chkconfig --add wesnothd
176 %service wesnothd restart
177
178 %preun server
179 if [ "$1" = "0" ]; then
180         %service wesnothd stop
181         /sbin/chkconfig --del wesnothd
182         %userremove wesnothd
183         %groupremove wesnothd
184 fi
185
186 %files -f %{name}.lang
187 %defattr(644,root,root,755)
188 %doc %{_docdir}/%{name}-%{version}
189 %attr(755,root,root) %{_bindir}/wesnoth
190 %{_mandir}/man6/wesnoth.6*
191 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
192 #%%lang(da) %{_mandir}/da/man6/wesnoth.6*
193 %lang(de) %{_mandir}/de/man6/wesnoth.6*
194 %lang(es) %{_mandir}/es/man6/wesnoth.6*
195 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
196 #%%lang(fr) %{_mandir}/fr/man6/wesnoth.6*
197 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
198 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
199 %lang(it) %{_mandir}/it/man6/wesnoth.6*
200 #%%lang(ja) %{_mandir}/ja/man6/wesnoth.6*
201 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
202 #%%lang(nl) %{_mandir}/nl/man6/wesnoth.6*
203 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
204 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
205 #%%lang(sr) %{_mandir}/sr/man6/wesnoth.6*
206 #%%lang(sv) %{_mandir}/sv/man6/wesnoth.6*
207 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
208 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
209 #%%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
210 %{_datadir}/%{name}
211 %{_desktopdir}/%{name}.desktop
212 %{_pixmapsdir}/%{name}-icon.png
213
214 %if %{with server}
215 %files server
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_bindir}/campaignd
218 %attr(755,root,root) %{_bindir}/wesnothd
219 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
220 %{_mandir}/man6/wesnothd.6*
221 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
222 %lang(da) %{_mandir}/da/man6/wesnothd.6*
223 %lang(de) %{_mandir}/de/man6/wesnothd.6*
224 %lang(es) %{_mandir}/es/man6/wesnothd.6*
225 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
226 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
227 %lang(gl) %{_mandir}/gl/man6/wesnothd.6*
228 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
229 %lang(it) %{_mandir}/it/man6/wesnothd.6*
230 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
231 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
232 %lang(nl) %{_mandir}/nl/man6/wesnothd.6*
233 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
234 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
235 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
236 %lang(sv) %{_mandir}/sv/man6/wesnothd.6*
237 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
238 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
239 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
240 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
241 %endif
242
243 %if %{with tools}
244 %files tools
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_bindir}/cutter
247 %attr(755,root,root) %{_bindir}/exploder
248 %attr(755,root,root) %{_bindir}/wesnoth_addon_manager
249 #%%attr(755,root,root) %{_bindir}/wesnoth_editor
250 %attr(755,root,root) %{_bindir}/wmlindent
251 %attr(755,root,root) %{_bindir}/wmllint
252 %attr(755,root,root) %{_bindir}/wmlscope
253 #%%{_mandir}/man6/wesnoth_editor.6*
254 #%%lang(cs) %{_mandir}/cs/man6/wesnoth_editor.6*
255 #%%lang(da) %{_mandir}/da/man6/wesnoth_editor.6*
256 #%%lang(de) %{_mandir}/de/man6/wesnoth_editor.6*
257 #%%lang(es) %{_mandir}/es/man6/wesnoth_editor.6*
258 #%%lang(fr) %{_mandir}/fr/man6/wesnoth_editor.6*
259 #%%lang(gl) %{_mandir}/gl/man6/wesnoth_editor.6*
260 #%%lang(hu) %{_mandir}/hu/man6/wesnoth_editor.6*
261 #%%lang(it) %{_mandir}/it/man6/wesnoth_editor.6*
262 #%%lang(ja) %{_mandir}/ja/man6/wesnoth_editor.6*
263 #%%lang(lt) %{_mandir}/lt/man6/wesnoth_editor.6*
264 #%%lang(nl) %{_mandir}/nl/man6/wesnoth_editor.6*
265 #%%lang(pl) %{_mandir}/pl/man6/wesnoth_editor.6*
266 #%%lang(sk) %{_mandir}/sk/man6/wesnoth_editor.6*
267 #%%lang(sr) %{_mandir}/sr/man6/wesnoth_editor.6*
268 #%%lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
269 #%%lang(tr) %{_mandir}/tr/man6/wesnoth_editor.6*
270 #%%lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth_editor.6*
271 #%%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth_editor.6*
272 %{_desktopdir}/%{name}_editor.desktop
273 %{_pixmapsdir}/%{name}_editor-icon.png
274 #%%dir %{py_sitedir}/%{name}
275 #%%{py_sitedir}/%{name}/*.py[co]
276 %endif
This page took 0.061751 seconds and 4 git commands to generate.