]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
- bcond_with(out) is followed by one \t, then bcond's name.
[packages/wesnoth.git] / wesnoth.spec
1 #
2 # Conditional build
3 %bcond_without  server  # without server
4 %bcond_without  tools   # without tools
5 #
6 Summary:        Strategy game with a fantasy theme
7 Summary(pl):    Strategiczna gra z motywem fantasy
8 Name:           wesnoth
9 Version:        0.9.4
10 Release:        1
11 License:        GPL v2
12 Group:          X11/Applications/Games/Strategy
13 Icon:           wesnoth-icon.xpm
14 Source0:        http://www.wesnoth.org/files/%{name}-%{version}.tar.gz
15 # Source0-md5:  b27115df93298a8ee192a85499f26ef2
16 Source1:        %{name}.desktop
17 Source2:        %{name}d.init
18 Patch0:         %{name}-Makefile.patch
19 URL:            http://www.wesnoth.org/
20 BuildRequires:  SDL-devel >= 1.2.7
21 BuildRequires:  SDL_image-devel >= 1.2
22 BuildRequires:  SDL_mixer-devel >= 1.2
23 BuildRequires:  SDL_net-devel >= 1.2
24 BuildRequires:  SDL_ttf-devel >= 2.0
25 BuildRequires:  libstdc++-devel
26 Requires:       SDL_image >= 1.2
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Battle for Wesnoth is a fantasy strategy game. Battle for control of
31 villages, using variety of units which have advantages and
32 disadvantages in different types of terrains and against different
33 types of attacks. Units gain experience and advance levels, and are
34 carried over from one scenario to the next campaign.
35
36 %description -l pl
37 Battle for Wesnoth jest strategiczn± gr± fantasy. Batalia o kontrolê
38 nad wsiami przy pomocy ró¿nego rodzaju oddzia³ów, które maj± przewagê
39 lub jej brak w odmiennym ukszta³towaniu terenu i przeciwko ró¿nym
40 sposobom ataku. Oddzia³y zdobywaj± do¶wiadczenie i poziomy
41 zaawansowania i s± przenoszone z jednej scenerii do nastêpnej
42 kampanii.
43
44 %package server
45 Summary:        Network server for Wesnoth
46 Summary(pl):    Sieciowy serwer dla Wesnoth
47 Group:          X11/Applications/Games/Strategy
48 Requires(post,preun):   /sbin/chkconfig
49
50 %description server
51 Server for playing networked games of Wesnoth.
52
53 %description server -l pl
54 Serwer do prowadzenia sieciowych gier Wesnoth.
55
56 %package tools
57 Summary:        Tools for Wesnoth
58 Summary(pl):    Narzêdzia dla Wesnoth
59 Group:          X11/Applications/Games/Strategy
60 Requires:       %{name} = %{version}-%{release}
61
62 %description tools
63 Map editor and translations tools.
64
65 %description tools -l pl
66 Edytor map i narzêdzia do t³umaczeñ.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 %configure \
74         %{?with_server:--enable-server} \
75         %{?with_tools:--enable-editor} \
76         %{?with_tools:--enable-tools}
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
82 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 install images/wesnoth-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
88 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
89 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post server
95 /sbin/chkconfig --add wesnothd
96 if [ -f /var/lock/subsys/wesnothd ]; then
97         /etc/rc.d/init.d/wesnothd restart >&2
98 else
99         echo "Run \"/etc/rc.d/init.d/wesnothd start\" to start wesnothd." >&2
100 fi
101
102 %preun server
103 if [ "$1" = "0" ]; then
104         if [ -f /var/lock/subsys/wesnothd ]; then
105                 /etc/rc.d/init.d/wesnothd stop
106         fi
107         /sbin/chkconfig --del wesnothd
108 fi
109
110 %files
111 %defattr(644,root,root,755)
112 %doc changelog README MANUAL*
113 %attr(755,root,root) %{_bindir}/wesnoth
114 %attr(755,root,root) %{_bindir}/wmlxgettext
115 %{_mandir}/man6/wesnoth.6*
116 %lang(de) %{_mandir}/de/man6/wesnoth.6*
117 %lang(sv) %{_mandir}/sv/man6/wesnoth.6*
118 %{_datadir}/%{name}
119 %{_desktopdir}/%{name}.desktop
120 %{_pixmapsdir}/*
121
122 %if %{with server}
123 %files server
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/wesnothd
126 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
127 %{_mandir}/man6/wesnothd.6*
128 %lang(de) %{_mandir}/de/man6/wesnothd.6*
129 %lang(sv) %{_mandir}/sv/man6/wesnothd.6*
130 %endif
131
132 %if %{with tools}
133 %files tools
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/cutter
136 %attr(755,root,root) %{_bindir}/exploder
137 %attr(755,root,root) %{_bindir}/wesnoth_editor
138 %{_mandir}/man6/wesnoth_editor.6*
139 %lang(de) %{_mandir}/de/man6/wesnoth_editor.6*
140 %lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
141 %endif
This page took 0.035403 seconds and 4 git commands to generate.