]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
- up to 1.8.5
[packages/wesnoth.git] / wesnoth.spec
1 # TODO
2 # - unpackaged language files
3 # Conditional build
4 %bcond_without  server  # without server
5 %bcond_without  tools   # without tools
6 %bcond_without  fribidi # without Bidirectional language support
7 #
8 Summary:        Strategy game with a fantasy theme
9 Summary(hu.UTF-8):      Fantasy környezetben játszódó stratégiai játék
10 Summary(pl.UTF-8):      Strategiczna gra z motywem fantasy
11 Name:           wesnoth
12 Version:        1.8.5
13 Release:        0.9
14 Epoch:          1
15 License:        GPL v2+
16 Group:          X11/Applications/Games/Strategy
17 Source0:        http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
18 # Source0-md5:  a800285d1406690755dd0ea22b98b6df
19 Source1:        %{name}d.init
20 Patch0:         %{name}-libpng.patch
21 Patch1:         %{name}-desktop.patch
22 Patch2:         %{name}-locale_dir.patch
23 URL:            http://www.wesnoth.org/
24 BuildRequires:  SDL-devel >= 1.2.7
25 BuildRequires:  SDL_image-devel >= 1.2
26 BuildRequires:  SDL_mixer-devel >= 1.2
27 BuildRequires:  SDL_net-devel >= 1.2
28 BuildRequires:  SDL_ttf-devel >= 2.0.8
29 BuildRequires:  asciidoc
30 BuildRequires:  boost-devel >= 1.33
31 BuildRequires:  cmake >= 2.4
32 BuildRequires:  dbus-devel
33 %{?with_fribidi:BuildRequires:  fribidi-devel}
34 BuildRequires:  gettext-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libvorbis-devel
38 BuildRequires:  lua51-devel
39 BuildRequires:  pango-devel
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.268
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  zlib-devel
45 # sr@Latn vs. sr@latin
46 Conflicts:      glibc-misc < 6:2.7
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Battle for Wesnoth is a fantasy strategy game. Battle for control of
51 villages, using variety of units which have advantages and
52 disadvantages in different types of terrains and against different
53 types of attacks. Units gain experience and advance levels, and are
54 carried over from one scenario to the next campaign.
55
56 %description -l hu.UTF-8
57 Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben játszódó
58 stratégiai játék. Harc a falvak megszerzéséért, különböző egységek
59 felhasználásával, amelyeknek különböző előnyeik és hátrányaik vannak a
60 különféle terepeken és a különböző támadási stílusok ellen. Az
61 egységek tapasztalatot gyűjtenek, és fejlődnek, amelyek átvihetők a
62 következő pályára.
63
64 %description -l pl.UTF-8
65 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
66 wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
67 jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym sposobom
68 ataku. Oddziały zdobywają doświadczenie i poziomy zaawansowania i są
69 przenoszone z jednej scenerii do następnej kampanii.
70
71 %package server
72 Summary:        Network server for Wesnoth
73 Summary(hu.UTF-8):      Hálózati szerver Wesnoth-hoz
74 Summary(pl.UTF-8):      Sieciowy serwer dla Wesnoth
75 Group:          X11/Applications/Games/Strategy
76 Requires(post,preun):   /sbin/chkconfig
77 Requires(postun):       /usr/sbin/groupdel
78 Requires(postun):       /usr/sbin/userdel
79 Requires(pre):  /usr/sbin/groupadd
80 Requires(pre):  /usr/sbin/useradd
81 Requires:       rc-scripts >= 0.4.0.17
82 # sr@Latn vs. sr@latin
83 Conflicts:      glibc-misc < 6:2.7
84
85 %description server
86 Server for playing networked games of Wesnoth.
87
88 %description server -l hu.UTF-8
89 Szerver a Wesnoth hálózati játékához.
90
91 %description server -l pl.UTF-8
92 Serwer do prowadzenia sieciowych gier Wesnoth.
93
94 %package tools
95 Summary:        Tools for Wesnoth
96 Summary(hu.UTF.8):      Eszközök a Wesnoth-hoz
97 Summary(pl.UTF-8):      Narzędzia dla Wesnoth
98 Group:          X11/Applications/Games/Strategy
99 Requires:       %{name} = %{epoch}:%{version}-%{release}
100
101 %description tools
102 Map editor and translations tools.
103
104 %description tools -l hu.UTF-8
105 Pályaszerkesztők és fordítási eszközök.
106
107 %description tools -l pl.UTF-8
108 Edytor map i narzędzia do tłumaczeń.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113 %patch1 -p1
114 %patch2 -p1
115
116 # don't install locales in %{_datadir}/%{name}
117 %{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
118
119 # link using libpng instead of libpng12
120 %{__sed} -i 's,png12,png,' src/CMakeLists.txt
121
122 %build
123 install -d build
124 cd build
125 %cmake .. \
126         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
127         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
128         -DENABLE_STRICT_COMPILATION="off" \
129         -DBINDIR="%{_bindir}" \
130         -DMANDIR="%{_mandir}" \
131         -DLOCALEDIR="%{_datadir}/locale" \
132         %{!?with_server:-DENABLE_SERVER="off"} \
133         %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
134         %{!?with_tools:-DENABLE_EDITOR="off"} \
135         %{?with_tools:-DENABLE_TOOLS="on"} \
136         %{!?with_fribidi:-DENABLE_FRIBIDI="off"} \
137 %if "%{_lib}" == "lib64"
138         -DLIB_SUFFIX=64
139 %endif
140
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
146
147 %{__make} -C build install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 # install additional docs
151 install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
152 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
153
154 %if %{with server}
155 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
156 %endif
157
158 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
159 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/fur{_IT,}
160
161 # unsupported(?)
162 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
163 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
164 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/racv
165 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
166 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
167 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavianlatin
168 rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
169
170 # the same as manuals from %{_mandir}/man?
171 rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
172
173 %find_lang %{name} --all-name
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %pre server
179 %groupadd -P %{name}-server -g 178  wesnothd
180 %useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
181
182 %post server
183 /sbin/chkconfig --add wesnothd
184 %service wesnothd restart
185
186 %preun server
187 if [ "$1" = "0" ]; then
188         %service wesnothd stop
189         /sbin/chkconfig --del wesnothd
190         %userremove wesnothd
191         %groupremove wesnothd
192 fi
193
194 %files -f %{name}.lang
195 %defattr(644,root,root,755)
196 %doc %{_docdir}/%{name}-%{version}
197 %attr(755,root,root) %{_bindir}/wesnoth
198 %{_mandir}/man6/wesnoth.6*
199 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
200 %lang(de) %{_mandir}/de/man6/wesnoth.6*
201 %lang(es) %{_mandir}/es/man6/wesnoth.6*
202 %lang(et) %{_mandir}/et/man6/wesnoth.6*
203 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
204 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
205 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
206 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
207 %lang(id) %{_mandir}/id/man6/wesnoth.6*
208 %lang(it) %{_mandir}/it/man6/wesnoth.6*
209 %lang(ja) %{_mandir}/ja/man6/wesnoth.6*
210 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
211 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
212 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
213 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
214 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
215 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
216 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
217 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
218 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
219 %{_datadir}/%{name}
220 %{_desktopdir}/*.desktop
221 %{_pixmapsdir}/*-icon.png
222
223 %if %{with server}
224 %files server
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_bindir}/campaignd
227 %attr(755,root,root) %{_bindir}/wesnothd
228 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
229 %{_mandir}/man6/wesnothd.6*
230 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
231 %lang(de) %{_mandir}/de/man6/wesnothd.6*
232 %lang(es) %{_mandir}/es/man6/wesnothd.6*
233 %lang(et) %{_mandir}/et/man6/wesnothd.6*
234 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
235 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
236 %lang(gl) %{_mandir}/gl/man6/wesnothd.6*
237 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
238 %lang(id) %{_mandir}/id/man6/wesnothd.6*
239 %lang(it) %{_mandir}/it/man6/wesnothd.6*
240 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
241 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
242 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
243 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
244 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
245 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
246 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
247 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
248 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
249 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
250 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
251 %endif
252
253 %if %{with tools}
254 %files tools
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_bindir}/cutter
257 %attr(755,root,root) %{_bindir}/exploder
258 %endif
This page took 0.09738 seconds and 4 git commands to generate.