]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
- up to 1.4.4
[packages/wesnoth.git] / wesnoth.spec
1 # TODO
2 # - rename language files sr@latin to sr@Latn and include them
3 # - use desktop file included with project (consider which one are better)
4 # - dont know what should I do with sr@latin man pages
5 #
6 # Conditional build
7 %bcond_without  server  # without server
8 %bcond_without  tools   # without tools
9 %bcond_without  fribidi # without Bidirectional language support
10 #
11 Summary:        Strategy game with a fantasy theme
12 Summary(pl.UTF-8):      Strategiczna gra z motywem fantasy
13 Name:           wesnoth
14 Version:        1.4.4
15 Release:        1
16 Epoch:          1
17 License:        GPL v2+
18 Group:          X11/Applications/Games/Strategy
19 Source0:        http://www.wesnoth.org/files/%{name}-%{version}.tar.bz2
20 # Source0-md5:  b2260808e94eba12aa7ceaa40fa0ee4d
21 Source1:        %{name}.desktop
22 Source2:        %{name}_editor.desktop
23 Source3:        %{name}d.init
24 Patch0:         %{name}-Makefile.patch
25 Patch1:         %{name}-locale_dir.patch
26 URL:            http://www.wesnoth.org/
27 BuildRequires:  SDL-devel >= 1.2.7
28 BuildRequires:  SDL_image-devel >= 1.2
29 BuildRequires:  SDL_mixer-devel >= 1.2
30 BuildRequires:  SDL_net-devel >= 1.2
31 BuildRequires:  SDL_ttf-devel >= 2.0
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake >= 1:1.9
34 BuildRequires:  boost-devel >= 1.33
35 %{?with_fribidi:BuildRequires:  fribidi-devel}
36 BuildRequires:  gettext-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:1.5
40 BuildRequires:  python-devel
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.268
43 BuildRequires:  zipios++-devel
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Battle for Wesnoth is a fantasy strategy game. Battle for control of
48 villages, using variety of units which have advantages and
49 disadvantages in different types of terrains and against different
50 types of attacks. Units gain experience and advance levels, and are
51 carried over from one scenario to the next campaign.
52
53 %description -l pl.UTF-8
54 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
55 wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
56 jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym sposobom
57 ataku. Oddziały zdobywają doświadczenie i poziomy zaawansowania i są
58 przenoszone z jednej scenerii do następnej kampanii.
59
60 %package server
61 Summary:        Network server for Wesnoth
62 Summary(pl.UTF-8):      Sieciowy serwer dla Wesnoth
63 Group:          X11/Applications/Games/Strategy
64 Requires(post,preun):   /sbin/chkconfig
65 Requires(postun):       /usr/sbin/groupdel
66 Requires(postun):       /usr/sbin/userdel
67 Requires(pre):  /usr/sbin/groupadd
68 Requires(pre):  /usr/sbin/useradd
69 Requires:       rc-scripts >= 0.4.0.17
70
71 %description server
72 Server for playing networked games of Wesnoth.
73
74 %description server -l pl.UTF-8
75 Serwer do prowadzenia sieciowych gier Wesnoth.
76
77 %package tools
78 Summary:        Tools for Wesnoth
79 Summary(pl.UTF-8):      Narzędzia dla Wesnoth
80 Group:          X11/Applications/Games/Strategy
81 Requires:       %{name} = %{epoch}:%{version}-%{release}
82
83 %description tools
84 Map editor and translations tools.
85
86 %description tools -l pl.UTF-8
87 Edytor map i narzędzia do tłumaczeń.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93
94 %build
95 %{__gettextize}
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         %{?with_server:--enable-server} \
102         %{?with_tools:--enable-editor} \
103         %{?with_tools:--enable-tools} \
104         --with%{!?with_fribidi:out}-fribidi \
105         --docdir=%{_docdir}/%{name}-%{version} \
106         --with-icondir=%{_pixmapsdir} \
107         --with-zipios
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 # install additional docs
118 install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
119 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
120
121 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
122 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
123 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
124
125 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{gl_ES,gl}
126 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{nb_NO,nb}
127 mv -f $RPM_BUILD_ROOT%{_mandir}/{gl_ES,gl}
128
129 # unsupported(?)
130 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
131 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
132 rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
133
134 # the same as manuals from %{_mandir}/man?
135 rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
136
137 %find_lang %{name} --all-name
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %pre server
143 %groupadd -P %{name}-server -g 178  wesnothd
144 %useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
145
146 %post server
147 /sbin/chkconfig --add wesnothd
148 %service wesnothd restart
149
150 %preun server
151 if [ "$1" = "0" ]; then
152         %service wesnothd stop
153         /sbin/chkconfig --del wesnothd
154         %userremove wesnothd
155         %groupremove wesnothd
156 fi
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %doc %{_docdir}/%{name}-%{version}
161 %attr(755,root,root) %{_bindir}/wesnoth
162 %{_mandir}/man6/wesnoth.6*
163 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
164 %lang(da) %{_mandir}/da/man6/wesnoth.6*
165 %lang(de) %{_mandir}/de/man6/wesnoth.6*
166 %lang(es) %{_mandir}/es/man6/wesnoth.6*
167 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
168 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
169 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
170 %lang(it) %{_mandir}/it/man6/wesnoth.6*
171 %lang(ja) %{_mandir}/ja/man6/wesnoth.6*
172 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
173 %lang(nl) %{_mandir}/nl/man6/wesnoth.6*
174 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
175 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
176 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
177 %lang(sv) %{_mandir}/sv/man6/wesnoth.6*
178 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
179 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
180 %{_datadir}/%{name}
181 %{_desktopdir}/%{name}.desktop
182 %{_pixmapsdir}/%{name}-icon.png
183
184 %if %{with server}
185 %files server
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/wesnothd
188 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
189 %{_mandir}/man6/wesnothd.6*
190 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
191 %lang(da) %{_mandir}/da/man6/wesnothd.6*
192 %lang(de) %{_mandir}/de/man6/wesnothd.6*
193 %lang(es) %{_mandir}/es/man6/wesnothd.6*
194 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
195 %lang(gl) %{_mandir}/gl/man6/wesnothd.6*
196 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
197 %lang(it) %{_mandir}/it/man6/wesnothd.6*
198 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
199 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
200 %lang(nl) %{_mandir}/nl/man6/wesnothd.6*
201 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
202 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
203 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
204 %lang(sv) %{_mandir}/sv/man6/wesnothd.6*
205 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
206 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
207 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
208 %endif
209
210 %if %{with tools}
211 %files tools
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_bindir}/cutter
214 %attr(755,root,root) %{_bindir}/exploder
215 %attr(755,root,root) %{_bindir}/wesnoth_editor
216 %attr(755,root,root) %{_bindir}/wmlindent
217 %attr(755,root,root) %{_bindir}/wmllint
218 %attr(755,root,root) %{_bindir}/wmlscope
219 %{_mandir}/man6/wesnoth_editor.6*
220 %lang(cs) %{_mandir}/cs/man6/wesnoth_editor.6*
221 %lang(da) %{_mandir}/da/man6/wesnoth_editor.6*
222 %lang(de) %{_mandir}/de/man6/wesnoth_editor.6*
223 %lang(es) %{_mandir}/es/man6/wesnoth_editor.6*
224 %lang(fr) %{_mandir}/fr/man6/wesnoth_editor.6*
225 %lang(gl) %{_mandir}/gl/man6/wesnoth_editor.6*
226 %lang(hu) %{_mandir}/hu/man6/wesnoth_editor.6*
227 %lang(it) %{_mandir}/it/man6/wesnoth_editor.6*
228 %lang(ja) %{_mandir}/ja/man6/wesnoth_editor.6*
229 %lang(lt) %{_mandir}/lt/man6/wesnoth_editor.6*
230 %lang(nl) %{_mandir}/nl/man6/wesnoth_editor.6*
231 %lang(pl) %{_mandir}/pl/man6/wesnoth_editor.6*
232 %lang(sk) %{_mandir}/sk/man6/wesnoth_editor.6*
233 %lang(sr) %{_mandir}/sr/man6/wesnoth_editor.6*
234 %lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
235 %lang(tr) %{_mandir}/tr/man6/wesnoth_editor.6*
236 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth_editor.6*
237 %{_desktopdir}/%{name}_editor.desktop
238 %{_pixmapsdir}/%{name}_editor-icon.png
239 %endif
This page took 0.067204 seconds and 4 git commands to generate.