]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
- more man pages added
[packages/wesnoth.git] / wesnoth.spec
1 #
2 # Conditional build
3 %bcond_without  server  # without server
4 %bcond_without  tools   # without tools
5 #
6 Summary:        Strategy game with a fantasy theme
7 Summary(pl):    Strategiczna gra z motywem fantasy
8 Name:           wesnoth
9 Version:        1.2
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications/Games/Strategy
13 Source0:        http://www.wesnoth.org/files/%{name}-%{version}.tar.gz
14 # Source0-md5:  722a459282abe6d04dbe228d031c088e
15 Source1:        %{name}.desktop
16 Source2:        %{name}d.init
17 Patch0:         %{name}-Makefile.patch
18 Patch1:         %{name}-locale_dir.patch
19 URL:            http://www.wesnoth.org/
20 BuildRequires:  SDL-devel >= 1.2.7
21 BuildRequires:  SDL_image-devel >= 1.2
22 BuildRequires:  SDL_mixer-devel >= 1.2
23 BuildRequires:  SDL_net-devel >= 1.2
24 BuildRequires:  SDL_ttf-devel >= 2.0
25 BuildRequires:  autoconf >= 2.57
26 BuildRequires:  automake >= 1:1.9
27 BuildRequires:  gettext-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  zipios++-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Battle for Wesnoth is a fantasy strategy game. Battle for control of
35 villages, using variety of units which have advantages and
36 disadvantages in different types of terrains and against different
37 types of attacks. Units gain experience and advance levels, and are
38 carried over from one scenario to the next campaign.
39
40 %description -l pl
41 Battle for Wesnoth jest strategiczn± gr± fantasy. Batalia o kontrolê
42 nad wsiami przy pomocy ró¿nego rodzaju oddzia³ów, które maj± przewagê
43 lub jej brak w odmiennym ukszta³towaniu terenu i przeciwko ró¿nym
44 sposobom ataku. Oddzia³y zdobywaj± do¶wiadczenie i poziomy
45 zaawansowania i s± przenoszone z jednej scenerii do nastêpnej
46 kampanii.
47
48 %package server
49 Summary:        Network server for Wesnoth
50 Summary(pl):    Sieciowy serwer dla Wesnoth
51 Group:          X11/Applications/Games/Strategy
52 Requires(post,preun):   /sbin/chkconfig
53
54 %description server
55 Server for playing networked games of Wesnoth.
56
57 %description server -l pl
58 Serwer do prowadzenia sieciowych gier Wesnoth.
59
60 %package tools
61 Summary:        Tools for Wesnoth
62 Summary(pl):    Narzêdzia dla Wesnoth
63 Group:          X11/Applications/Games/Strategy
64 Requires:       %{name} = %{version}-%{release}
65
66 %description tools
67 Map editor and translations tools.
68
69 %description tools -l pl
70 Edytor map i narzêdzia do t³umaczeñ.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75 %patch1 -p1
76
77 %build
78 %{__gettextize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83 %configure \
84         %{?with_server:--enable-server} \
85         %{?with_tools:--enable-editor} \
86         %{?with_tools:--enable-tools}
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d}
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 install images/wesnoth-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
97 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
98 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
99
100 %find_lang %{name} --all-name
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post server
106 /sbin/chkconfig --add wesnothd
107 if [ -f /var/lock/subsys/wesnothd ]; then
108         /etc/rc.d/init.d/wesnothd restart >&2
109 else
110         echo "Run \"/etc/rc.d/init.d/wesnothd start\" to start wesnothd." >&2
111 fi
112
113 %preun server
114 if [ "$1" = "0" ]; then
115         if [ -f /var/lock/subsys/wesnothd ]; then
116                 /etc/rc.d/init.d/wesnothd stop
117         fi
118         /sbin/chkconfig --del wesnothd
119 fi
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %doc changelog README MANUAL*
124 %attr(755,root,root) %{_bindir}/wesnoth
125 %attr(755,root,root) %{_bindir}/wmlxgettext
126 %{_mandir}/man6/wesnoth.6*
127 %lang(de) %{_mandir}/de/man6/wesnoth.6*
128 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
129 %lang(en_GB) %{_mandir}/en_GB/man6/wesnoth.6*
130 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
131 %lang(ja) %{_mandir}/ja/man6/wesnoth.6*
132 %lang(nl) %{_mandir}/nl/man6/wesnoth.6*
133 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
134 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
135 %lang(sv) %{_mandir}/sv/man6/wesnoth.6*
136 %{_datadir}/%{name}
137 %{_desktopdir}/%{name}.desktop
138 %{_pixmapsdir}/*
139
140 %if %{with server}
141 %files server
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/wesnothd
144 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
145 %{_mandir}/man6/wesnothd.6*
146 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
147 %lang(de) %{_mandir}/de/man6/wesnothd.6*
148 %lang(en_GB) %{_mandir}/en_GB/man6/wesnothd.6*
149 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
150 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
151 %lang(nl) %{_mandir}/nl/man6/wesnothd.6*
152 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
153 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
154 %lang(sv) %{_mandir}/sv/man6/wesnothd.6*
155 %dir /var/run/wesnothd
156 %endif
157
158 %if %{with tools}
159 %files tools
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/cutter
162 %attr(755,root,root) %{_bindir}/exploder
163 %attr(755,root,root) %{_bindir}/wesnoth_editor
164 %{_mandir}/man6/wesnoth_editor.6*
165 %lang(cs) %{_mandir}/cs/man6/wesnoth_editor.6*
166 %lang(de) %{_mandir}/de/man6/wesnoth_editor.6*
167 %lang(en_GB) %{_mandir}/en_GB/man6/wesnoth_editor.6*
168 %lang(fr) %{_mandir}/fr/man6/wesnoth_editor.6*
169 %lang(it) %{_mandir}/it/man6/wesnoth_editor.6*
170 %lang(ja) %{_mandir}/ja/man6/wesnoth_editor.6*
171 %lang(nl) %{_mandir}/nl/man6/wesnoth_editor.6*
172 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth_editor.6*
173 %lang(sk) %{_mandir}/sk/man6/wesnoth_editor.6*
174 %lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
175 %endif
This page took 0.11048 seconds and 3 git commands to generate.