]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
cf5ddc953478d951488de103a049344602374319
[packages/wesnoth.git] / wesnoth.spec
1 # TODO
2 # - rename language files sr@latin to sr@Latn and include them
3 # - use desktop file included with project (consider which one are better)
4 # - dont know what should I do with sr@latin and racv man pages
5 # Conditional build
6 %bcond_without  server  # without server
7 %bcond_without  tools   # without tools
8 %bcond_without  fribidi # without Bidirectional language support
9 #
10 Summary:        Strategy game with a fantasy theme
11 Summary(hu.UTF-8):      Fantasy környezetben játszódó stratégiai játék
12 Summary(pl.UTF-8):      Strategiczna gra z motywem fantasy
13 Name:           wesnoth
14 Version:        1.6.2
15 Release:        1
16 Epoch:          1
17 License:        GPL v2+
18 Group:          X11/Applications/Games/Strategy
19 Source0:        http://dl.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
20 # Source0-md5:  d7de3cddcd832ebaaf8d00990ad14d01
21 Source1:        %{name}.desktop
22 Source2:        %{name}_editor.desktop
23 Source3:        %{name}d.init
24 Patch0:         %{name}-Makefile.patch
25 Patch1:         %{name}-locale_dir.patch
26 URL:            http://www.wesnoth.org/
27 BuildRequires:  SDL-devel >= 1.2.7
28 BuildRequires:  SDL_image-devel >= 1.2
29 BuildRequires:  SDL_mixer-devel >= 1.2
30 BuildRequires:  SDL_net-devel >= 1.2
31 BuildRequires:  SDL_ttf-devel >= 2.0.8
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake >= 1:1.9
34 BuildRequires:  boost-devel >= 1.33
35 %{?with_fribidi:BuildRequires:  fribidi-devel}
36 BuildRequires:  gettext-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:1.5
40 BuildRequires:  libvorbis-devel
41 BuildRequires:  pkg-config
42 BuildRequires:  python-devel
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.268
45 BuildRequires:  sed >= 4.0
46 BuildRequires:  zipios++-devel
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Battle for Wesnoth is a fantasy strategy game. Battle for control of
51 villages, using variety of units which have advantages and
52 disadvantages in different types of terrains and against different
53 types of attacks. Units gain experience and advance levels, and are
54 carried over from one scenario to the next campaign.
55
56 %description -l hu.UTF-8
57 Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben játszódó
58 stratégiai játék. Harc a falvak megszerzéséért, különböző egységek
59 felhasználásával, amelyeknek különböző előnyeik és hátrányaik vannak a
60 különféle terepeken és a különböző támadási stílusok ellen. Az
61 egységek tapasztalatot gyűjtenek, és fejlődnek, amelyek átvihetők a
62 következő pályára.
63
64 %description -l pl.UTF-8
65 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
66 wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
67 jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym sposobom
68 ataku. Oddziały zdobywają doświadczenie i poziomy zaawansowania i są
69 przenoszone z jednej scenerii do następnej kampanii.
70
71 %package server
72 Summary:        Network server for Wesnoth
73 Summary(hu.UTF-8):      Hálózati szerver Wesnoth-hoz
74 Summary(pl.UTF-8):      Sieciowy serwer dla Wesnoth
75 Group:          X11/Applications/Games/Strategy
76 Requires(post,preun):   /sbin/chkconfig
77 Requires(postun):       /usr/sbin/groupdel
78 Requires(postun):       /usr/sbin/userdel
79 Requires(pre):  /usr/sbin/groupadd
80 Requires(pre):  /usr/sbin/useradd
81 Requires:       rc-scripts >= 0.4.0.17
82
83 %description server
84 Server for playing networked games of Wesnoth.
85
86 %description server -l hu.UTF-8
87 Szerver a Wesnoth hálózati játékához.
88
89 %description server -l pl.UTF-8
90 Serwer do prowadzenia sieciowych gier Wesnoth.
91
92 %package tools
93 Summary:        Tools for Wesnoth
94 Summary(hu.UTF.8):      Eszközök a Wesnoth-hoz
95 Summary(pl.UTF-8):      Narzędzia dla Wesnoth
96 Group:          X11/Applications/Games/Strategy
97 Requires:       %{name} = %{epoch}:%{version}-%{release}
98
99 %description tools
100 Map editor and translations tools.
101
102 %description tools -l hu.UTF-8
103 Pályaszerkesztők és fordítási eszközök.
104
105 %description tools -l pl.UTF-8
106 Edytor map i narzędzia do tłumaczeń.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112 %{__sed} -i 's,$PYTHON_PREFIX"/lib/,"%{_libdir}/,g' configure.ac
113
114 %build
115 %{__gettextize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         PYTHON_VERSION=%{py_ver} \
122         %{?with_server:--enable-server} \
123         %{?with_server:--enable-campaign-server} \
124         --enable-python-install \
125         %{?with_tools:--enable-editor} \
126         %{?with_tools:--enable-tools} \
127         --with%{!?with_fribidi:out}-fribidi \
128         --docdir=%{_docdir}/%{name}-%{version} \
129         --with-icondir=%{_pixmapsdir} \
130         --with-zipios
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 # install additional docs
141 install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
142 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
143
144 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
145 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
146 %if %{with server}
147 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
148 %endif
149
150 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{nb_NO,nb}
151
152 # unsupported(?)
153 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
154 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/fur_IT
155 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
156 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/racv
157 rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
158
159 # the same as manuals from %{_mandir}/man?
160 rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
161
162 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
163 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
164 %py_postclean
165
166 %find_lang %{name} --all-name
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %pre server
172 %groupadd -P %{name}-server -g 178  wesnothd
173 %useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
174
175 %post server
176 /sbin/chkconfig --add wesnothd
177 %service wesnothd restart
178
179 %preun server
180 if [ "$1" = "0" ]; then
181         %service wesnothd stop
182         /sbin/chkconfig --del wesnothd
183         %userremove wesnothd
184         %groupremove wesnothd
185 fi
186
187 %files -f %{name}.lang
188 %defattr(644,root,root,755)
189 %doc %{_docdir}/%{name}-%{version}
190 %attr(755,root,root) %{_bindir}/wesnoth
191 %{_mandir}/man6/wesnoth.6*
192 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
193 #%%lang(da) %{_mandir}/da/man6/wesnoth.6*
194 %lang(de) %{_mandir}/de/man6/wesnoth.6*
195 %lang(es) %{_mandir}/es/man6/wesnoth.6*
196 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
197 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
198 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
199 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
200 %lang(it) %{_mandir}/it/man6/wesnoth.6*
201 #%%lang(ja) %{_mandir}/ja/man6/wesnoth.6*
202 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
203 #%%lang(nl) %{_mandir}/nl/man6/wesnoth.6*
204 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
205 #%%lang(ru) %{_mandir}/ru/man6/wesnoth.6*
206 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
207 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
208 %lang(sv) %{_mandir}/sv/man6/wesnoth.6*
209 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
210 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
211 #%%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
212 %{_datadir}/%{name}
213 %{_desktopdir}/%{name}.desktop
214 %{_pixmapsdir}/%{name}-icon.png
215
216 %if %{with server}
217 %files server
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_bindir}/campaignd
220 %attr(755,root,root) %{_bindir}/wesnothd
221 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
222 %{_mandir}/man6/wesnothd.6*
223 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
224 #%%lang(da) %{_mandir}/da/man6/wesnothd.6*
225 %lang(de) %{_mandir}/de/man6/wesnothd.6*
226 %lang(es) %{_mandir}/es/man6/wesnothd.6*
227 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
228 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
229 #%%lang(gl) %{_mandir}/gl/man6/wesnothd.6*
230 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
231 %lang(it) %{_mandir}/it/man6/wesnothd.6*
232 #%lang(ja) %{_mandir}/ja/man6/wesnothd.6*
233 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
234 #%%lang(nl) %{_mandir}/nl/man6/wesnothd.6*
235 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
236 #%%lang(sk) %{_mandir}/sk/man6/wesnothd.6*
237 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
238 %lang(sv) %{_mandir}/sv/man6/wesnothd.6*
239 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
240 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
241 #%%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
242 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
243 %endif
244
245 %if %{with tools}
246 %files tools
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{_bindir}/cutter
249 %attr(755,root,root) %{_bindir}/exploder
250 %attr(755,root,root) %{_bindir}/wesnoth_addon_manager
251 #%%attr(755,root,root) %{_bindir}/wesnoth_editor
252 %attr(755,root,root) %{_bindir}/wmlindent
253 %attr(755,root,root) %{_bindir}/wmllint
254 %attr(755,root,root) %{_bindir}/wmlscope
255 #%%{_mandir}/man6/wesnoth_editor.6*
256 #%%lang(cs) %{_mandir}/cs/man6/wesnoth_editor.6*
257 #%%lang(da) %{_mandir}/da/man6/wesnoth_editor.6*
258 #%%lang(de) %{_mandir}/de/man6/wesnoth_editor.6*
259 #%%lang(es) %{_mandir}/es/man6/wesnoth_editor.6*
260 #%%lang(fr) %{_mandir}/fr/man6/wesnoth_editor.6*
261 #%%lang(gl) %{_mandir}/gl/man6/wesnoth_editor.6*
262 #%%lang(hu) %{_mandir}/hu/man6/wesnoth_editor.6*
263 #%%lang(it) %{_mandir}/it/man6/wesnoth_editor.6*
264 #%%lang(ja) %{_mandir}/ja/man6/wesnoth_editor.6*
265 #%%lang(lt) %{_mandir}/lt/man6/wesnoth_editor.6*
266 #%%lang(nl) %{_mandir}/nl/man6/wesnoth_editor.6*
267 #%%lang(pl) %{_mandir}/pl/man6/wesnoth_editor.6*
268 #%%lang(sk) %{_mandir}/sk/man6/wesnoth_editor.6*
269 #%%lang(sr) %{_mandir}/sr/man6/wesnoth_editor.6*
270 #%%lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
271 #%%lang(tr) %{_mandir}/tr/man6/wesnoth_editor.6*
272 #%%lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth_editor.6*
273 #%%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth_editor.6*
274 %{_desktopdir}/%{name}_editor.desktop
275 %{_pixmapsdir}/%{name}_editor-icon.png
276 %dir %{py_sitedir}/%{name}
277 %{py_sitedir}/%{name}/*.py[co]
278 %endif
This page took 0.1059 seconds and 2 git commands to generate.