]> git.pld-linux.org Git - packages/wesnoth.git/blob - wesnoth.spec
9382fa0eecef2d4e1dd8f7c5f4502c3d9e403b95
[packages/wesnoth.git] / wesnoth.spec
1 # TODO
2 # - unpackaged language files
3 #
4 # Conditional build
5 %bcond_without  server  # without server
6 %bcond_without  tools   # without tools
7 %bcond_without  fribidi # without Bidirectional language support
8 #
9 Summary:        Strategy game with a fantasy theme
10 Summary(hu.UTF-8):      Fantasy környezetben játszódó stratégiai játék
11 Summary(pl.UTF-8):      Strategiczna gra z motywem fantasy
12 Name:           wesnoth
13 Version:        1.10
14 Release:        1
15 Epoch:          1
16 License:        GPL v2+
17 Group:          X11/Applications/Games/Strategy
18 Source0:        http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
19 # Source0-md5:  707daa13e2f5b3976d9b169aab62dc29
20 Source1:        %{name}d.init
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-locale_dir.patch
23 URL:            http://www.wesnoth.org/
24 BuildRequires:  SDL-devel >= 1.2.14-4
25 BuildRequires:  SDL_image-devel >= 1.2
26 BuildRequires:  SDL_mixer-devel >= 1.2
27 BuildRequires:  SDL_net-devel >= 1.2
28 BuildRequires:  SDL_ttf-devel >= 2.0.8
29 BuildRequires:  asciidoc
30 BuildRequires:  boost-devel >= 1.33
31 BuildRequires:  cmake >= 2.4
32 BuildRequires:  dbus-devel
33 %{?with_fribidi:BuildRequires:  fribidi-devel}
34 BuildRequires:  gettext-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libvorbis-devel
38 BuildRequires:  lua51-devel
39 BuildRequires:  pango-devel
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.600
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  zlib-devel
45 Requires:       SDL >= 1.2.14-4
46 # sr@Latn vs. sr@latin
47 Conflicts:      glibc-misc < 6:2.7
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Battle for Wesnoth is a fantasy strategy game. Battle for control of
52 villages, using variety of units which have advantages and
53 disadvantages in different types of terrains and against different
54 types of attacks. Units gain experience and advance levels, and are
55 carried over from one scenario to the next campaign.
56
57 %description -l hu.UTF-8
58 Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben játszódó
59 stratégiai játék. Harc a falvak megszerzéséért, különböző egységek
60 felhasználásával, amelyeknek különböző előnyeik és hátrányaik vannak a
61 különféle terepeken és a különböző támadási stílusok ellen. Az
62 egységek tapasztalatot gyűjtenek, és fejlődnek, amelyek átvihetők a
63 következő pályára.
64
65 %description -l pl.UTF-8
66 Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
67 wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
68 jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym sposobom
69 ataku. Oddziały zdobywają doświadczenie i poziomy zaawansowania i są
70 przenoszone z jednej scenerii do następnej kampanii.
71
72 %package server
73 Summary:        Network server for Wesnoth
74 Summary(hu.UTF-8):      Hálózati szerver Wesnoth-hoz
75 Summary(pl.UTF-8):      Sieciowy serwer dla Wesnoth
76 Group:          X11/Applications/Games/Strategy
77 Requires(post,preun):   /sbin/chkconfig
78 Requires(postun):       /usr/sbin/groupdel
79 Requires(postun):       /usr/sbin/userdel
80 Requires(pre):  /usr/sbin/groupadd
81 Requires(pre):  /usr/sbin/useradd
82 Requires:       rc-scripts >= 0.4.0.17
83 Provides:       group(wesnothd)
84 Provides:       user(wesnothd)
85 # sr@Latn vs. sr@latin
86 Conflicts:      glibc-misc < 6:2.7
87
88 %description server
89 Server for playing networked games of Wesnoth.
90
91 %description server -l hu.UTF-8
92 Szerver a Wesnoth hálózati játékához.
93
94 %description server -l pl.UTF-8
95 Serwer do prowadzenia sieciowych gier Wesnoth.
96
97 %package tools
98 Summary:        Tools for Wesnoth
99 Summary(hu.UTF.8):      Eszközök a Wesnoth-hoz
100 Summary(pl.UTF-8):      Narzędzia dla Wesnoth
101 Group:          X11/Applications/Games/Strategy
102 Requires:       %{name} = %{epoch}:%{version}-%{release}
103
104 %description tools
105 Map editor and translations tools.
106
107 %description tools -l hu.UTF-8
108 Pályaszerkesztők és fordítási eszközök.
109
110 %description tools -l pl.UTF-8
111 Edytor map i narzędzia do tłumaczeń.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 %patch1 -p1
117
118 # don't install locales in %{_datadir}/%{name}
119 %{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
120
121 %build
122 install -d build
123 cd build
124 %cmake \
125         .. \
126         -DENABLE_STRICT_COMPILATION="off" \
127         -DBINDIR="%{_bindir}" \
128         -DMANDIR="%{_mandir}" \
129         -DLOCALEDIR="%{_datadir}/locale" \
130         %{!?with_server:-DENABLE_SERVER="off"} \
131         %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
132         %{!?with_tools:-DENABLE_EDITOR="off"} \
133         %{?with_tools:-DENABLE_TOOLS="on"} \
134         %{!?with_fribidi:-DENABLE_FRIBIDI="off"}
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
141
142 %{__make} -C build install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 # install additional docs
146 install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
147 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
148
149 %if %{with server}
150 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
151 %endif
152
153 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
154 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/fur{_IT,}
155
156 # unsupported(?)
157 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ang@latin
158 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
159 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/la
160 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/racv
161 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
162 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
163 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavianlatin
164 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
165 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavian
166 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavianlatin
167
168 # the same as manuals from %{_mandir}/man?
169 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/en_GB
170
171 %find_lang %{name} --all-name
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %pre server
177 %groupadd -P %{name}-server -g 178  wesnothd
178 %useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
179
180 %post server
181 /sbin/chkconfig --add wesnothd
182 %service wesnothd restart
183
184 %preun server
185 if [ "$1" = "0" ]; then
186         %service wesnothd stop
187         /sbin/chkconfig --del wesnothd
188         %userremove wesnothd
189         %groupremove wesnothd
190 fi
191
192 %files -f %{name}.lang
193 %defattr(644,root,root,755)
194 %doc %{_docdir}/%{name}-%{version}
195 %attr(755,root,root) %{_bindir}/wesnoth
196 %{_mandir}/man6/wesnoth.6*
197 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
198 %lang(de) %{_mandir}/de/man6/wesnoth.6*
199 %lang(et) %{_mandir}/et/man6/wesnoth.6*
200 %lang(es) %{_mandir}/es/man6/wesnoth.6*
201 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
202 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
203 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
204 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
205 %lang(id) %{_mandir}/id/man6/wesnoth.6*
206 %lang(it) %{_mandir}/it/man6/wesnoth.6*
207 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
208 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
209 %lang(ru) %{_mandir}/ru/man6/wesnoth.6*
210 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
211 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
212 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
213 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
214 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
215 %{_datadir}/%{name}
216 %{_desktopdir}/*.desktop
217 %{_pixmapsdir}/*-icon.png
218
219 %if %{with server}
220 %files server
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_bindir}/campaignd
223 %attr(755,root,root) %{_bindir}/wesnothd
224 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
225 %{_mandir}/man6/wesnothd.6*
226 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
227 %lang(de) %{_mandir}/de/man6/wesnothd.6*
228 %lang(es) %{_mandir}/es/man6/wesnothd.6*
229 %lang(et) %{_mandir}/et/man6/wesnothd.6*
230 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
231 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
232 %lang(gl) %{_mandir}/gl/man6/wesnothd.6*
233 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
234 %lang(id) %{_mandir}/id/man6/wesnothd.6*
235 %lang(it) %{_mandir}/it/man6/wesnothd.6*
236 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
237 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
238 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
239 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
240 %lang(ru) %{_mandir}/ru/man6/wesnothd.6*
241 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
242 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
243 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
244 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
245 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
246 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
247 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
248 %endif
249
250 %if %{with tools}
251 %files tools
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/cutter
254 %attr(755,root,root) %{_bindir}/exploder
255 %endif
This page took 0.08465 seconds and 3 git commands to generate.