]> git.pld-linux.org Git - packages/waf.git/blob - waf.spec
- add path.patch so installed waf uses system waf
[packages/waf.git] / waf.spec
1 Summary:        The Waf build system
2 Name:           waf
3 Version:        1.0.1
4 Release:        0.4
5 License:        BSD
6 Group:          Development/Building
7 Source0:        http://freehackers.org/~tnagy/%{name}-%{version}.tar.bz2
8 # Source0-md5:  bc33d144ee927caec6279e0bf4b174ab
9 URL:            http://freehackers.org/~tnagy/bksys.html
10 Patch0:         %{name}-path.patch
11 BuildRequires:  python
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _libdir %{_prefix}/lib
16
17 %description
18 Waf is a general-purpose build system which was modelled from Scons.
19 Though it comes last in the arena of the build systems, we believe
20 that Waf is a vastly superior alternative to its competitors
21 (Autotools, Scons, Cmake, Ant, etc) for building software,
22
23 %prep
24 %setup -q
25 %patch0 -p1
26
27 %build
28 ./waf-light --make-waf
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 ./waf \
33         --prefix $RPM_BUILD_ROOT%{_prefix} \
34         --destdir $RPM_BUILD_ROOT \
35         --install
36
37 %py_comp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}
38 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}
39 %py_postclean %{_libdir}/%{name}-%{version}
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc README TODO
47 %attr(755,root,root) %{_bindir}/waf
48 %dir %{_libdir}/%{name}-%{version}
49 %dir %{_libdir}/%{name}-%{version}/wafadmin
50 %{_libdir}/%{name}-%{version}/wafadmin/*.py[co]
51 %dir %{_libdir}/%{name}-%{version}/wafadmin/Tools
52 %{_libdir}/%{name}-%{version}/wafadmin/Tools/*.py[co]
This page took 0.029919 seconds and 4 git commands to generate.