]> git.pld-linux.org Git - packages/waf.git/blob - waf.spec
- drop crazy paths
[packages/waf.git] / waf.spec
1 Summary:        The Waf build system
2 Summary(pl.UTF-8):      System budowania Waf
3 Name:           waf
4 Version:        1.4.4
5 Release:        1
6 License:        BSD
7 Group:          Development/Building
8 Source0:        http://waf.googlecode.com/files/%{name}-%{version}.tar.bz2
9 # Source0-md5:  6a809e446497b710592579772c8b22bd
10 URL:            http://code.google.com/p/waf/
11 BuildRequires:  python
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _libdir %{_prefix}/lib
16
17 %description
18 Waf is a general-purpose build system which was modelled from Scons.
19 Though it comes last in the arena of the build systems, we believe
20 that Waf is a vastly superior alternative to its competitors
21 (Autotools, Scons, Cmake, Ant, etc) for building software,
22
23 %description -l pl.UTF-8
24 Waf to system budowania ogólnego przeznaczenia opracowany na podstawie
25 Scons. Mimo że pojawił się jako ostatni na arenie systemów budowania,
26 autorzy wierzą, że przewyższa alternatywne narzędzia (Autotools,
27 Scons, Cmake, Ant itp.).
28
29 %prep
30 %setup -q
31
32 %build
33 ./waf-light configure \
34         --prefix=%{_prefix}
35 ./waf-light --make-waf
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 echo y | ./waf install \
40         --prefix %{_prefix} \
41         --destdir $RPM_BUILD_ROOT
42
43 %py_comp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}-*
44 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}-*
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc README TODO
52 %attr(755,root,root) %{_bindir}/waf
53 %dir %{_libdir}/%{name}-%{version}-*
54 %dir %{_libdir}/%{name}-%{version}-*/wafadmin
55 %{_libdir}/%{name}-%{version}-*/wafadmin/*.py[co]
56 %dir %{_libdir}/%{name}-%{version}-*/wafadmin/Tools
57 %{_libdir}/%{name}-%{version}-*/wafadmin/Tools/*.py[co]
This page took 0.052417 seconds and 3 git commands to generate.