]> git.pld-linux.org Git - packages/w3m.git/blob - w3m.spec
fix intermittent parallel build failures
[packages/w3m.git] / w3m.spec
1 # Conditional build:
2 %bcond_without  image   # build without image support
3
4 Summary:        Text based browser for the world wide web
5 Summary(de.UTF-8):      Text-Browser für das WWW
6 Summary(es.UTF-8):      w3m es un paginador, pero puede usarse también como un navegador WWW
7 Summary(fr.UTF-8):      Navigateur en mode texte pour le world wide web
8 Summary(pl.UTF-8):      Przeglądarka WWW pracująca w trybie tekstowym
9 Summary(pt_BR.UTF-8):   O w3m é um paginador, mas pode ser usado também como um navegador WWW
10 Summary(tr.UTF-8):      Metin ekranda WWW tarayıcı
11 Name:           w3m
12 Version:        0.5.3
13 Release:        10
14 Epoch:          1
15 License:        MIT-like
16 Group:          Applications/Networking
17 Source0:        http://downloads.sourceforge.net/w3m/%{name}-%{version}.tar.gz
18 # Source0-md5:  1b845a983a50b8dec0169ac48479eacc
19 Patch0:         %{name}-gzip_fallback.patch
20 Patch1:         %{name}-nolibs.patch
21 Patch2:         %{name}-0.5.3-parallel-make.patch
22 Patch3:         %{name}-0.5.2-fix_gcc_error.patch
23 Patch4:         %{name}-gc.patch
24 Patch5:         format-security.patch
25 Patch6:         ac-gettext.patch
26 Patch7:         openssl.patch
27 Patch8:         %{name}-configure.patch
28 Patch9:         %{name}-x11.patch
29 Patch10:        imlib2-pc.patch
30 Patch11:        parallel-build.patch
31 URL:            http://w3m.sourceforge.net/
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  gc-devel
35 BuildRequires:  gettext-tools
36 BuildRequires:  gpm-devel
37 %if %{with image}
38 BuildRequires:  imlib2-devel >= 1.1.0
39 BuildRequires:  xorg-lib-libX11-devel
40 %endif
41 BuildRequires:  ncurses-devel >= 5.0
42 BuildRequires:  openssl-devel >= 0.9.7d
43 BuildRequires:  pkgconfig
44 BuildRequires:  sed >= 4.0
45 Provides:       webclient
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 This a terminal based WWW browser. While it does not make any attempt
50 at displaying graphics, it has good support for HTML text formatting,
51 forms, and tables.
52
53 %description -l de.UTF-8
54 Dies ist ein WWW-Browser auf Terminal-Basis. Während kein Versuch
55 unternommen wird, Grafiken darzustellen, so bietet er doch guten
56 Support für HTML-Textformatierung, Formulare und Tabellen.
57
58 %description -l es.UTF-8
59 w3m es un paginador similar a las órdenes more y less. Este paquete
60 también puede utilizarse como un visualizador de páginas WWW en modo
61 texto.
62
63 %description -l fr.UTF-8
64 Navigateur WWW en mode texte. Bien qu'il n'affiche aucun graphique, il
65 sait bien gérer le formatage HTML du texte, les formulaires et les
66 tableaux.
67
68 %description -l pl.UTF-8
69 Przeglądarka WWW działającą w trybie tekstowym. Dobrze formatuje tekst
70 w HTML, ale nie pozwala na wyświetlanie grafiki.
71
72 %description -l pt_BR.UTF-8
73 O w3m é um paginador similar aos comandos more e less. Este pacote
74 pode ser ainda utilizado como um visualizador de páginas WWW em modo
75 texto.
76
77 %description -l tr.UTF-8
78 Metin ekranda çalışan bir WWW tarayıcıdır. Şekil gösteremese de,
79 formlar ve tablolar için desteği vardır.
80
81 %package imgdisplay
82 Summary:        Image display support for w3m
83 Summary(pl.UTF-8):      Wyświetlanie obrazków dla w3m
84 Group:          Applications/Networking
85 Requires:       %{name} = %{epoch}:%{version}-%{release}
86 Requires:       imlib2 >= 1.1.0
87
88 %description imgdisplay
89 Install this package if you want to display images in w3m run on xterm
90 or Linux framebuffer.
91
92 %description imgdisplay -l pl.UTF-8
93 Ten pakiet pozwala przeglądarce w3m wyświetlać obrazki w xtermie lub
94 na linuksowym framebufferze.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101 %patch3 -p1
102 %patch4 -p1
103 %patch5 -p1
104 %patch6 -p1
105 %patch7 -p1
106 %patch8 -p1
107 %patch9 -p1
108 %patch10 -p1
109 %patch11 -p1
110
111 %{__sed} '/^AC_PROG_CXX$/d' -i configure.ac
112
113 %build
114 cp -f /usr/share/automake/config.sub .
115 %{__gettextize}
116 %{__aclocal}
117 %{__autoconf}
118 %configure \
119         mkdir_p="mkdir -p" \
120         --enable-gopher \
121 %if %{with image}
122         --enable-image="x11,fb,fb+s" \
123         --with-imagelib="imlib2" \
124 %else
125         --disable-image \
126 %endif
127         --enable-keymap=lynx \
128         --with-editor=/bin/vi \
129         --with-mailer=/bin/mail \
130         --with-browser=%{_bindir}/mozilla \
131         --with-termlib=ncurses
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT%{_mandir}/man1
136
137 %{__make} install install-helpfile \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 # symlink instead of duplicated file
141 ln -sf w3mhelp-lynx_en.html $RPM_BUILD_ROOT%{_datadir}/w3m/w3mhelp.html
142
143 %find_lang %{name}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc doc/*.html doc/{README,keymap,menu}.* NEWS
151 %attr(755,root,root) %{_bindir}/w3m
152 %attr(755,root,root) %{_bindir}/w3mman
153 %dir %{_libexecdir}/w3m
154 %attr(755,root,root) %{_libexecdir}/w3m/inflate
155 %attr(755,root,root) %{_libexecdir}/w3m/xface2xpm
156 %dir %{_libexecdir}/w3m/cgi-bin
157 %attr(755,root,root) %{_libexecdir}/w3m/cgi-bin/*.cgi
158 %attr(755,root,root) %{_libexecdir}/w3m/cgi-bin/w3mbookmark
159 %attr(755,root,root) %{_libexecdir}/w3m/cgi-bin/w3mhelperpanel
160 %dir %{_datadir}/w3m
161 %{_datadir}/w3m/w3mhelp.html
162 %{_datadir}/w3m/w3mhelp*en.*
163 %lang(ja) %{_datadir}/w3m/w3mhelp*ja.*
164 %{_datadir}/w3m/w3mhelp-funcname.pl
165 %{_mandir}/man1/w3m.1*
166 %{_mandir}/man1/w3mman.1*
167 %lang(ja) %{_mandir}/ja/man1/w3m.1*
168
169 %if %{with image}
170 %files imgdisplay
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libexecdir}/w3m/w3mimgdisplay
173 %endif
This page took 0.095297 seconds and 4 git commands to generate.