]> git.pld-linux.org Git - packages/vtun.git/blob - vtun.spec
- massive change: BR openssl-devel >= 0.9.7d
[packages/vtun.git] / vtun.spec
1 #
2 # Conditional build:
3 %bcond_without  ssl     # build without encryption ability
4 #
5 Summary:        Virtual tunnel over TCP/IP networks
6 Summary(pl):    Wirtualne tunele poprzez sieci TCP/IP
7 Name:           vtun
8 Version:        2.6
9 Release:        2
10 Epoch:          2
11 License:        GPL
12 Group:          Networking/Daemons
13 Vendor:         Maxim Krasnyansky <max_mk@yahoo.com>
14 # Source0-md5:  309534fd03c5d13a19c43916f61f4bbf
15 Source0:        http://dl.sourceforge.net/vtun/%{name}-%{version}.tar.gz
16 Source1:        %{name}.init
17 Source2:        %{name}.sysconfig
18 Patch0:         %{name}-makefile.patch
19 Patch1:         %{name}-expect.patch
20 Patch2:         %{name}-autoheader.patch
21 Patch3:         %{name}-getpt.patch
22 Patch4:         %{name}-sslauth.patch
23 Patch5:         %{name}-ac.patch
24 URL:            http://vtun.sourceforge.net/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  bison
28 BuildRequires:  flex
29 BuildRequires:  lzo-devel
30 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
31 BuildRequires:  zlib-devel
32 PreReq:         rc-scripts
33 Requires(post,preun):   /sbin/chkconfig
34 Obsoletes:      vppp
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _localstatedir  /var
38
39 %description
40 VTun provides the method for creating Virtual Tunnels over TCP/IP
41 networks and allows to shape, compress, encrypt traffic in that
42 tunnels. Supported type of tunnels are: PPP, IP, Ethernet and most of
43 other serial protocols and programs. VTun is easily and highly
44 configurable, it can be used for various network task like VPN, Mobil
45 IP, Shaped Internet access, IP address saving, etc. It is completely
46 user space implementation and does not require modification to any
47 kernel parts. You need SSLeay-devel and lzo-devel to build it.
48
49 %description -l pl
50 VTun umo¿liwia tworzenie Wirtualnych Tunelu poprzez sieci TCP/IP wraz
51 z przydzielaniem pasma, kompresj±, szyfrowaniem danych w tunelach.
52 Wspierane typy tuneli to: PPP, IP, Ethernet i wiêkszo¶æ pozosta³ych
53 protoko³ów szeregowych.
54
55 %prep
56 %setup -q -n vtun
57 %patch2 -p1
58 %patch5 -p1
59 # must be ported
60 #%%patch4 -p1
61
62 %build
63 cp -f /usr/share/automake/config.* .
64 # aclocal.m4 is only local, don't try to rebuild
65 %{__autoheader}
66 %{__autoconf}
67 %configure \
68         %{?with_ssl:--with-crypto-headers=%{_includedir}/openssl} \
69         %{!?with_ssl:--disable-ssl} \
70         --enable-lzo
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
76         $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_localstatedir}/log/vtun}
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT \
80         INSTALL_OWNER=""
81
82 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/vtund
83 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/vtun
84 touch $RPM_BUILD_ROOT%{_sysconfdir}/vtund.conf
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 /sbin/chkconfig --add vtund
91 if [ -f /var/lock/subsys/vtund ]; then
92         /etc/rc.d/init.d/vtund restart >&2
93 else
94         echo "Run \"/etc/rc.d/init.d/vtund start\" to start vtun daemons."
95 fi
96
97 %preun
98 if [ "$1" = "0" ]; then
99         if [ -f /var/lock/subsys/vtund ]; then
100                 /etc/rc.d/init.d/vtund stop >&2
101         fi
102         /sbin/chkconfig --del vtund
103 fi
104
105 %files
106 %defattr(644,root,root,755)
107 %doc ChangeLog Credits README README.Setup README.Shaper FAQ TODO vtund.conf
108 %attr(754,root,root) /etc/rc.d/init.d/vtund
109 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/vtun
110 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vtund.conf
111 %attr(755,root,root) %{_sbindir}/vtund
112 %attr(755,root,root) %dir /var/log/vtund
113 %{_mandir}/man*/*
This page took 0.062855 seconds and 3 git commands to generate.