]> git.pld-linux.org Git - packages/vtun.git/blob - vtun.spec
- release 2: added rc-scripts to Prereq.
[packages/vtun.git] / vtun.spec
1 Summary:        Virtual tunnel over TCP/IP networks
2 Summary(pl):    Wirtualne tunele poprzez sieci TCP/IP
3 Name:           vtun
4 Version:        2.4
5 Release:        2
6 Epoch:          1
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Vendor:         Maxim Krasnyansky <max_mk@yahoo.com>
12 Source0:        http://vtun.sourceforge.net/%{name}-%{version}.tar.gz
13 Source1:        %{name}.init
14 Patch0:         %{name}-makefile.patch
15 URL:            http://vtun.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  autoconf
18 BuildRequires:  lzo-devel
19 BuildRequires:  openssl-devel
20 BuildRequires:  zlib-devel
21 Prereq:         rc-scripts
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 Obsoletes:      vppp
24
25 %define         _localstatedir  /var
26
27 %description
28 VTun provides the method for creating Virtual Tunnels over TCP/IP
29 networks and allows to shape, compress, encrypt traffic in that
30 tunnels. Supported type of tunnels are: PPP, IP, Ethernet and most of
31 other serial protocols and programs. VTun is easily and highly
32 configurable, it can be used for various network task like VPN, Mobil
33 IP, Shaped Internet access, IP address saving, etc. It is completely
34 user space implementation and does not require modification to any
35 kernel parts. You need SSLeay-devel and lzo-devel to build it.
36
37 %description -l pl
38 VTun umo¿liwia tworzenie Wirtualnych Tunelu poprzez sieci TCP/IP
39 wraz z przydzielaniem pasma, kompresj±, szyfrowaniem danych w tunelach.
40 Wspierane typy tuneli to: PPP, IP, Ethernet i wiêkszo¶æ pozosta³ych
41 protoko³ów szeregowych.
42
43 %prep
44 %setup -q
45 %patch -p1
46
47 %build
48 aclocal
49 autoconf
50 %configure \
51         --with-crypto-headers=%{_includedir}/openssl \
52         --enable-lzo
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
58         $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_localstatedir}/log/vtun}
59
60 %{__make} install DESTDIR=$RPM_BUILD_ROOT
61
62 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/vtund
63
64 gzip -9nf ChangeLog Credits README README.Setup README.Shaper FAQ TODO
65
66 %post
67 /sbin/chkconfig --add vtund
68 if [ -f /var/lock/subsys/vtund ]; then
69         /etc/rc.d/init.d/vtund restart >&2
70 else
71         echo "Run \"/etc/rc.d/init.d/vtund start\" to start vtun daemons."
72 fi
73
74 %preun
75 if [ "$1" = "0" ]; then
76         if [ -f /var/lock/subsys/vtund ]; then
77                 /etc/rc.d/init.d/vtund stop >&2
78         fi
79         /sbin/chkconfig --del vtund
80 fi
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc {ChangeLog,Credits,README,README.Setup,README.Shaper,FAQ,TODO}.gz
88 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/vtund
89 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vtund.conf
90 %attr(755,root,root) %{_sbindir}/vtund
91 %attr(755,root,root) %dir /var/log/vtund
92 %{_mandir}/man*/*
This page took 0.051652 seconds and 3 git commands to generate.