]> git.pld-linux.org Git - packages/vtun.git/blob - vtun.spec
- release 5: rebuild against openssl 0.9.6a.
[packages/vtun.git] / vtun.spec
1 Summary:        Virtual tunnel over TCP/IP networks
2 Summary(pl):    Wirtualne tunele poprzez sieci TCP/IP
3 Name:           vtun
4 Version:        2.4
5 Release:        5
6 Epoch:          1
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Vendor:         Maxim Krasnyansky <max_mk@yahoo.com>
12 Source0:        http://vtun.sourceforge.net/%{name}-%{version}.tar.gz
13 Source1:        %{name}.init
14 Source2:        %{name}.sysconfig
15 Patch0:         %{name}-makefile.patch
16 URL:            http://vtun.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  autoconf
19 BuildRequires:  lzo-devel
20 BuildRequires:  openssl-devel >= 0.9.6a
21 BuildRequires:  zlib-devel
22 Prereq:         rc-scripts
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24 Obsoletes:      vppp
25
26 %define         _localstatedir  /var
27
28 %description
29 VTun provides the method for creating Virtual Tunnels over TCP/IP
30 networks and allows to shape, compress, encrypt traffic in that
31 tunnels. Supported type of tunnels are: PPP, IP, Ethernet and most of
32 other serial protocols and programs. VTun is easily and highly
33 configurable, it can be used for various network task like VPN, Mobil
34 IP, Shaped Internet access, IP address saving, etc. It is completely
35 user space implementation and does not require modification to any
36 kernel parts. You need SSLeay-devel and lzo-devel to build it.
37
38 %description -l pl
39 VTun umo¿liwia tworzenie Wirtualnych Tunelu poprzez sieci TCP/IP
40 wraz z przydzielaniem pasma, kompresj±, szyfrowaniem danych w tunelach.
41 Wspierane typy tuneli to: PPP, IP, Ethernet i wiêkszo¶æ pozosta³ych
42 protoko³ów szeregowych.
43
44 %prep
45 %setup -q
46 %patch -p1
47
48 %build
49 aclocal
50 autoconf
51 %configure \
52         --with-crypto-headers=%{_includedir}/openssl \
53         --enable-lzo
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
59            $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_localstatedir}/log/vtun}
60
61 %{__make} install DESTDIR=$RPM_BUILD_ROOT
62
63 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/vtund
64 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/vtun
65
66 gzip -9nf ChangeLog Credits README README.Setup README.Shaper FAQ TODO
67
68 %post
69 /sbin/chkconfig --add vtund
70 if [ -f /var/lock/subsys/vtund ]; then
71         /etc/rc.d/init.d/vtund restart >&2
72 else
73         echo "Run \"/etc/rc.d/init.d/vtund start\" to start vtun daemons."
74 fi
75
76 %preun
77 if [ "$1" = "0" ]; then
78         if [ -f /var/lock/subsys/vtund ]; then
79                 /etc/rc.d/init.d/vtund stop >&2
80         fi
81         /sbin/chkconfig --del vtund
82 fi
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc *.gz
90 %attr(754,root,root) /etc/rc.d/init.d/vtund
91 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/vtun
92 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vtund.conf
93 %attr(755,root,root) %{_sbindir}/vtund
94 %attr(755,root,root) %dir /var/log/vtund
95 %{_mandir}/man*/*
This page took 0.071995 seconds and 3 git commands to generate.