]> git.pld-linux.org Git - packages/vtun.git/blob - vtun.spec
b68654ff30134d12f1e1fb7ae8f10fb6bcc375d4
[packages/vtun.git] / vtun.spec
1 Summary:        Virtual tunnel over TCP/IP networks
2 Name:           vtun
3 Version:        2.3
4 Release:        1
5 License:        GPL
6 Group:          Networking/Daemons
7 Group(de):      Netzwerkwesen/Server
8 Group(pl):      Sieciowe/Serwery
9 Vendor:         Maxim Krasnyansky <max_mk@yahoo.com>
10 Source0:        ftp://vtun.sourceforge.net/pub/vtun/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Patch0:         %{name}-makefile.patch
13 URL:            http://vtun.sourceforge.net/
14 BuildRequires:  lzo-devel
15 BuildRequires:  openssl-devel
16 BuildRequires:  zlib-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Obsoletes:      vppp
19
20 %define         _localstatedir  /var
21
22 %description
23 VTun provides the method for creating Virtual Tunnels over TCP/IP
24 networks and allows to shape, compress, encrypt traffic in that
25 tunnels. Supported type of tunnels are: PPP, IP, Ethernet and most of
26 other serial protocols and programs. VTun is easily and highly
27 configurable, it can be used for various network task like VPN, Mobil
28 IP, Shaped Internet access, IP address saving, etc. It is completely
29 user space implementation and does not require modification to any
30 kernel parts. You need SSLeay-devel and lzo-devel to build it.
31
32 %prep
33 %setup -q
34 %patch -p1
35 %build
36 %configure \
37         --with-crypto-headers=%{_includedir}/openssl \
38         --enable-lzo
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
44         $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_localstatedir}/log/vtun}
45
46 %{__make} install DESTDIR=$RPM_BUILD_ROOT
47
48 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/vtund
49
50 gzip -9nf ChangeLog Credits README README.Setup README.Shaper FAQ TODO
51
52 %post
53 /sbin/chkconfig --add vtund
54 if [ -f /var/lock/subsys/vtund ]; then
55         /etc/rc.d/init.d/vtund restart >&2
56 else
57         echo "Run \"/etc/rc.d/init.d/vtund start\" to start vtun daemons."
58 fi
59
60 %preun
61 if [ "$1" = "0" ]; then
62         if [ -f /var/lock/subsys/vtund ]; then
63                 /etc/rc.d/init.d/vtund stop >&2
64         fi
65         /sbin/chkconfig --del vtund
66 fi
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc {ChangeLog,Credits,README,README.Setup,README.Shaper,FAQ,TODO}.gz
74 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/vtund
75 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vtund.conf
76 %attr(755,root,root) %{_sbindir}/vtund
77 %attr(755,root,root) %dir /var/log/vtund
78 %{_mandir}/man*/*
This page took 0.02638 seconds and 2 git commands to generate.