]> git.pld-linux.org Git - packages/vtun.git/blob - vtun.spec
- finally enabled Arturcz Czechowski's patch allowing to ssl enabled vtun
[packages/vtun.git] / vtun.spec
1 # Conditional build:
2 # _without_ssl - build without encryption ability
3
4 Summary:        Virtual tunnel over TCP/IP networks
5 Summary(pl):    Wirtualne tunele poprzez sieci TCP/IP
6 Name:           vtun
7 Version:        2.5
8 Release:        3
9 Epoch:          2
10 License:        GPL
11 Group:          Networking/Daemons
12 Group(cs):      Sí»ové/Démoni
13 Group(da):      Netværks/Dæmoner
14 Group(de):      Netzwerkwesen/Server
15 Group(es):      Red/Servidores
16 Group(fr):      Réseau/Serveurs
17 Group(is):      Net/Púkar
18 Group(it):      Rete/Demoni
19 Group(no):      Nettverks/Daemoner
20 Group(pl):      Sieciowe/Serwery
21 Group(pt):      Rede/Servidores
22 Group(ru):      óÅÔØ/äÅÍÏÎÙ
23 Group(sl):      Omre¾ni/Stre¾niki
24 Group(sv):      Nätverk/Demoner
25 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
26 Vendor:         Maxim Krasnyansky <max_mk@yahoo.com>
27 Source0:        http://prdownloads.sourceforge.net/vtun/%{name}-%{version}.tar.gz
28 Source1:        %{name}.init
29 Source2:        %{name}.sysconfig
30 Patch0:         %{name}-makefile.patch
31 Patch1:         %{name}-expect.patch
32 Patch2:         %{name}-autoheader.patch
33 Patch3:         %{name}-getpt.patch
34 Patch4:         %{name}-sslauth.patch
35 URL:            http://vtun.sourceforge.net/
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 BuildRequires:  lzo-devel
39 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
40 BuildRequires:  zlib-devel
41 BuildRequires:  bison
42 BuildRequires:  flex
43 Prereq:         rc-scripts
44 Prereq:         /sbin/chkconfig
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46 Obsoletes:      vppp
47
48 %define         _localstatedir  /var
49
50 %description
51 VTun provides the method for creating Virtual Tunnels over TCP/IP
52 networks and allows to shape, compress, encrypt traffic in that
53 tunnels. Supported type of tunnels are: PPP, IP, Ethernet and most of
54 other serial protocols and programs. VTun is easily and highly
55 configurable, it can be used for various network task like VPN, Mobil
56 IP, Shaped Internet access, IP address saving, etc. It is completely
57 user space implementation and does not require modification to any
58 kernel parts. You need SSLeay-devel and lzo-devel to build it.
59
60 %description -l pl
61 VTun umo¿liwia tworzenie Wirtualnych Tunelu poprzez sieci TCP/IP wraz
62 z przydzielaniem pasma, kompresj±, szyfrowaniem danych w tunelach.
63 Wspierane typy tuneli to: PPP, IP, Ethernet i wiêkszo¶æ pozosta³ych
64 protoko³ów szeregowych.
65
66 %prep
67 %setup -q -n vtun
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71 %patch3 -p1
72 %patch4 -p1
73
74 %build
75 aclocal
76 autoheader
77 autoconf
78 %configure \
79         %{!?_without_ssl:--with-crypto-headers=%{_includedir}/openssl} \
80         %{?_without_ssl:--disable-ssl} \
81         --enable-lzo
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
87         $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_localstatedir}/log/vtun}
88
89 %{__make} install DESTDIR=$RPM_BUILD_ROOT
90
91 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/vtund
92 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/vtun
93
94 gzip -9nf ChangeLog Credits README README.Setup README.Shaper FAQ TODO
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 /sbin/chkconfig --add vtund
101 if [ -f /var/lock/subsys/vtund ]; then
102         /etc/rc.d/init.d/vtund restart >&2
103 else
104         echo "Run \"/etc/rc.d/init.d/vtund start\" to start vtun daemons."
105 fi
106
107 %preun
108 if [ "$1" = "0" ]; then
109         if [ -f /var/lock/subsys/vtund ]; then
110                 /etc/rc.d/init.d/vtund stop >&2
111         fi
112         /sbin/chkconfig --del vtund
113 fi
114
115 %files
116 %defattr(644,root,root,755)
117 %doc *.gz
118 %attr(754,root,root) /etc/rc.d/init.d/vtund
119 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/vtun
120 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vtund.conf
121 %attr(755,root,root) %{_sbindir}/vtund
122 %attr(755,root,root) %dir /var/log/vtund
123 %{_mandir}/man*/*
This page took 0.03041 seconds and 3 git commands to generate.