]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- release 1
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     glx     # drawing using GLX
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl.UTF-8):      Biblioteka z kontrolką terminala VTE
7 Name:           vte
8 Version:        0.16.0
9 Release:        1
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/vte/0.16/%{name}-%{version}.tar.bz2
13 # Source0-md5:  6b85967ba75ed574d0e5782697fbc79f
14 Patch0:         %{name}-keys.patch
15 Patch1:         %{name}-link.patch
16 %{?with_glx:BuildRequires:      OpenGL-GLU-devel}
17 %{?with_glx:BuildRequires:      OpenGL-GLX-devel}
18 BuildRequires:  autoconf >= 2.59-9
19 BuildRequires:  automake >= 1:1.6
20 BuildRequires:  gettext-devel
21 BuildRequires:  gtk+2-devel >= 2:2.10.9
22 BuildRequires:  gtk-doc >= 1.8
23 BuildRequires:  intltool >= 0.35.5
24 BuildRequires:  libtool
25 BuildRequires:  ncurses-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  python-pygtk-devel >= 2:2.10.4
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.197
30 Requires(pre):  utempter
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The vte package contains a terminal widget for GTK+. It's used by
35 gnome-terminal among other programs.
36
37 %description -l pl.UTF-8
38 Ten pakiet zawiera kontrolkę terminala dla GTK+. Jest używany przez
39 gnome-terminal oraz inne programy.
40
41 %package devel
42 Summary:        Headers for VTE
43 Summary(pl.UTF-8):      Pliki nagłówkowe VTE
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 %{?with_glx:Requires:   OpenGL-GLU-devel}
47 Requires:       gtk+2-devel >= 2:2.10.9
48 Requires:       ncurses-devel
49 Conflicts:      gnome-libs-devel < 1.4.1.2
50
51 %description devel
52 The vte package contains a terminal widget for GTK+. It's used by
53 gnome-terminal among other programs.
54
55 You should install the vte-devel package if you would like to compile
56 applications that use the vte terminal widget. You do not need to
57 install vte-devel if you just want to use precompiled applications.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe potrzebne do kompilowania programów używających vte.
61
62 %package static
63 Summary:        Static VTE library
64 Summary(pl.UTF-8):      Statyczna biblioteka VTE
65 Group:          X11/Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67 Conflicts:      gnome-libs-static < 1.4.1.2
68
69 %description static
70 Static version of VTE libraries.
71
72 %description static -l pl.UTF-8
73 Statyczna wersja bibliotek VTE.
74
75 %package -n python-vte
76 Summary:        Python VTE module
77 Summary(pl.UTF-8):      Moduł VTE dla pythona
78 Group:          Libraries
79 %pyrequires_eq  python-libs
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       python-pygtk-gtk >= 2:2.10.4
82
83 %description -n python-vte
84 Python VTE library.
85
86 %description -n python-vte -l pl.UTF-8
87 Biblioteka VTE dla pythona.
88
89 %package apidocs
90 Summary:        VTE API documentation
91 Summary(pl.UTF-8):      Dokumentacja API VTE
92 Group:          Documentation
93 Requires:       gtk-doc-common
94
95 %description apidocs
96 VTE API documentation.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API VTE.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105
106 %build
107 %{__glib_gettextize}
108 %{__intltoolize}
109 %{__libtoolize}
110 %{__aclocal}
111 %{__autoheader}
112 %{__automake}
113 %{__autoconf}
114 cd gnome-pty-helper
115 %{__libtoolize}
116 %{__aclocal}
117 %{__autoheader}
118 %{__automake}
119 %{__autoconf}
120 cd ..
121 %configure \
122         --enable-gtk-doc \
123         --with-default-emulation=xterm \
124         %{?with_glx:--with-glX} \
125         --with-html-dir=%{_gtkdocdir} \
126         --with-pangox \
127         --with-xft2
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
138
139 %find_lang vte
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files -f vte.lang
148 %defattr(644,root,root,755)
149 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
150 %attr(755,root,root) %{_bindir}/vte
151 %attr(755,root,root) %{_libdir}/libvte.so.*.*.*
152 %dir %{_libdir}/vte
153 %attr(755,root,root) %{_libdir}/vte/*
154 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
155 %{_datadir}/vte
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libvte.so
160 %{_libdir}/libvte.la
161 %{_includedir}/vte
162 %{_pkgconfigdir}/vte.pc
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libvte.a
167
168 %files apidocs
169 %defattr(644,root,root,755)
170 %{_gtkdocdir}/vte
171
172 %files -n python-vte
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{py_sitedir}/gtk-2.0/vtemodule.so
This page took 0.058894 seconds and 4 git commands to generate.