]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- python-vte subpackage
[packages/vte.git] / vte.spec
1 # TODO:
2 # - fix gtk-doc location
3 %define         gtk2_version            2.0.3
4 %define         glib2_version           2.0.3
5 %define         libart_lgpl_version     2.3.8
6
7 %include        /usr/lib/rpm/macros.python
8
9 Summary:        VTE terminal widget library
10 Summary(pl):    Biblioteka z widgetem terminala VTE
11 Name:           vte
12 Version:        0.10.4
13 Release:        0.1
14 License:        LGPL
15 Group:          X11/Libraries
16 Source0:        ftp://ftp.gnome.org/pub/gnome/sources/%{name}/0.10/%{name}-%{version}.tar.bz2
17 Patch0:         %{name}-Xft2.patch
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  glib2-devel >= %{glib2_version}
21 BuildRequires:  gtk+2-devel >= %{gtk2_version}
22 BuildRequires:  libart_lgpl-devel >= %{libart_lgpl_version}
23 BuildRequires:  libtool
24 BuildRequires:  gnome-common
25 BuildRequires:  python-pygtk-devel >= 1.99.13
26 Requires(pre):  utempter
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _prefix         /usr/X11R6
30 %define         _mandir         %{_prefix}/man
31
32 %description
33 The vte package contains a terminal widget for GTK+. It's used by
34 gnome-terminal among other programs.
35
36 %description -l pl
37 Ten pakiet zawiera widget terminala dla GTK+. Jest u¿ywany przez
38 gnome-terminal oraz inne programy.
39
40 %package devel
41 Summary:        Headers for vte
42 Summary(pl):    Pliki nag³ówkowe vte
43 Group:          X11/Development/Libraries
44 Requires:       %{name} = %{version}
45 Requires:       glib2-devel >= %{glib2_version}
46 Requires:       gtk+2-devel >= %{gtk2_version}
47 Requires:       libart_lgpl-devel >= %{libart_lgpl_version}
48 Conflicts:      gnome-libs-devel < 1.4.1.2
49
50 %description devel
51 The vte package contains a terminal widget for GTK+. It's used by
52 gnome-terminal among other programs.
53
54 You should install the vte-devel package if you would like to
55 compile applications that use the vte terminal widget. You do not need
56 to install vte-devel if you just want to use precompiled
57 applications.
58
59 %description devel -l pl
60 Pliki nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych
61 vte.
62
63 %package static
64 Summary:        Static vte library
65 Summary(pl):    Statyczna biblioteka vte
66 Group:          X11/Development/Libraries
67 Requires:       %{name}-devel = %{version}
68 Conflicts:      gnome-libs-static < 1.4.1.2
69
70 %description static
71 Static version of vte libraries.
72
73 %description static -l pl
74 Statyczna wersja bibliotek vte.
75
76 %package -n python-vte
77 Summary:        Python vte library
78 Summary(pl):    Biblioteka vte dla pythona
79 Group:          Libraries
80 Requires:       %{name} = %{version}
81
82 %description -n python-vte
83 Python vte library.
84
85 %description -n python-vte -l pl
86 Biblioteka vte dla pythona.
87
88 %prep
89 %setup  -q
90 %patch0 -p1
91
92 %build
93 #rm -f missing
94 #%{__libtoolize}
95 #%{__aclocal} -I %{_aclocaldir}/gnome2-macros
96 #%{__autoconf}
97 #%{__automake}
98 %configure
99 %{__make} pythonsiteexecdir=%{py_sitedir}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         pkgconfigdir=%{_pkgconfigdir} \
107         pythonsiteexecdir=%{py_sitedir}
108
109 %find_lang vte
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files -f vte.lang
118 %defattr(644,root,root,755)
119 %doc NEWS README AUTHORS
120 %attr(755,root,root) %{_bindir}/vte
121 %attr(755,root,root) %{_libdir}/lib*.so.*.*
122 %dir %{_libdir}/vte
123 %attr(755,root,root) %{_libdir}/vte/*
124 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
125
126 %files devel
127 %defattr(644,root,root,755)
128 %{_libdir}/lib*.so
129 %{_libdir}/lib*.la
130 %{_includedir}/*
131 %{_pkgconfigdir}/*
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/lib*.a
136
137 %files -n python-vte
138 %{py_sitedir}/*.so
This page took 0.062826 seconds and 4 git commands to generate.